Article ID: 212329 - View products that this article applies to.
This article was previously published under Q212329
Expand all | Collapse all

On This Page

SUMMARY

This step-by-step article describes what mail merge is and how to perform a basic mail merge to create a form letter in Microsoft Word.

For additional information about performing other types of mail merges, merging with other types of data, and problem solving, review the list of articles in the Related Articles section of this article.

For a description of the terms used in this article, see the Glossary section of this article.

What Is Mail Merge?

Mail merge is a feature in Word. With mail merge you can merge boilerplate information (such as a form letter) with variable information (such as a database of names and addresses of customers). This way, you can have documents that are almost exactly the same: the substance of the documents is the same for every customer, yet each document is customized to a particular individual in your database.

There are three main components to a mail merge:
  • The main document that contains the boilerplate information: text and graphics. The main document also determines the format of the resulting merged document; for example, form letter, envelopes, or labels.
  • The data source that contains the variable information: a list of names and addresses, for example.
  • The merged document that contains the combination of boilerplate text and variable information.
The main document contains the boilerplate text and graphics that you want in every version of the merged document. In the main document, you insert special instructions, called merge fields, to indicate where you want the variable information to appear. When you merge the information in the data source with the main document, the variable information replaces the merge fields with the individualized information. The result is the merged document that contains the combination of boilerplate text and variable information.

The data source contains the information (such as names, addresses, and phone numbers) that varies with each version of the document. Most of the time, you can store your data in a Word document; however, Word also recognizes other formats. For example, the data source can be a Microsoft Excel worksheet, a Microsoft Access database, or a comma-separated variable (CSV) file.

The data source is set up with a header row (also called a header record) and data records. The header row is the first item in the data source. It contains the field names that identify the variable information. The data records contain the individualized information. Each data record is made up of one or more fields, depending on how much variable information you have for each individual. This set of information makes up one data record.

The mail merge process has four main steps:
  1. Open or create the main document.
  2. Open or create the data source.
  3. Edit the main document.
  4. Perform the merge.
The following procedure demonstrates how to create a form letter, attach it to a data source, format it, and merge the documents. The procedure for creating merged envelopes or labels is similar. For additional information, see the appropriate article listed in the Related Articles section of this article.

Step 1: Open or Create the Main Document

  1. If you have a document that contains the boilerplate text that you want to use, open it. Or, if you want to create a new form letter and no blank document is currently displayed, click New on the Standard toolbar.
  2. On the Tools menu, click Mail Merge.
  3. In the Main Document area of the Mail Merge Helper dialog box, click Create.
  4. Click Form Letters.

    You are prompted to either use the active window for the main document or create a new main document. Click Active Window. The active document becomes the mail merge main document.

    Word returns to the Mail Merge Helper.
  5. Go to Step 2: Open or Create the Data Source.

Step 2: Open or Create the Data Source

When you open or create a data source by using the Mail Merge Helper, you are telling Word to use a specific set of variable information for your merge. Use either of the following methods to attach the main document to the data source.

Method 1: If You Are Typing the Names and Addresses for the First Time

To create a new database, follow these steps:
  1. In the Data Source area of the Mail Merge Helper dialog box, click Get Data.
  2. Click Create Data Source.

    The Create Data Source dialog box appears. In this dialog box, you can specify the field names to include in the data source. The Field Names in the Header Row box lists field names that are often used in form letters, mailing labels, and envelopes. You can remove the fields that you do not want by selecting them one at a time and then clicking Remove Field Name. If you want to create new field names, type the new field name in the Field Name box, and then click Add Field Name.

    When you finish creating new fields and removing fields that you do not want, click OK.
  3. The Save As dialog box appears. In the File Name box, type the name that you want to give your data source, and then click Save.
  4. When you are prompted to either edit the data source or set up the main document, click Edit Data Source.
  5. When the Data Form dialog box appears, type your information into the form. If there is no information for a particular field, leave the box blank. By default, Word skips blank fields, so the merge is not affected if blank entries are in the data form. The set of information in each form makes up one data record.
  6. After you type the information for a record, click Add New to move to the next record.
  7. After you add all of your data, click OK to return to the main document.

    Notice the Mail Merge toolbar.
  8. Save the main document.

    When you save the main document at this point, you are also saving the data source and attaching it to the main document.
  9. Go to Step 3: Edit the Main Document.

Method 2: If You Are Using an Existing Data Source

To use an existing data source, follow these steps:
  1. In the Mail Merge Helper dialog box, click Get Data.
  2. Click Open Data Source.
  3. In the Open Data Source dialog box, select the file that contains the variable information that you want to use, and then click Open.

    NOTE: If the data source is not listed in the list of files, choose the appropriate drive and folder. If necessary, select the appropriate option in the List Files of Type box. Select the file, and then click Open.

    Word prompts you with the following message:
    Word found no merge fields in your main document. Choose the Edit Main Document button to insert merge fields into your main document.
  4. Click Edit Main Document to return to the main document.

    Notice the Mail Merge toolbar.
  5. Save the main document. When you save the main document at this point, you are also saving the data source and attaching it to the main document.
  6. Go to Step 3: Edit the Main Document.

Step 3: Edit the Main Document

In step 1, you chose either to open an existing document or to create a new one. Use either of the following methods, based on the selection that you made in step 1.

Method 1: If You Are Using an Existing Document

  1. Click where you want to insert the information from your data source.
  2. On the Mail Merge toolbar, click Insert Merge Field, and then click the merge field that you want to use.

    NOTE: Make sure that you type any spaces or punctuation that you want between two merge fields or after a merge field. You can also format (apply bold or italic formatting to) the merge fields, just as you would with regular text.
  3. Repeat steps 1 and 2 for each merge field that you want to add to your document.
  4. When you finish editing the main document, click Save or Save As on the File menu. Name the file, and then click Save.
  5. Go to Step 4: Perform the Merge.

Method 2: If You Are Using a New Main Document

  1. Type or add any text and graphics that you want to include in your letter.
  2. Each time that you come to a place where you want to insert information from the data source, click Insert Merge Field on the Mail Merge toolbar, and then click the merge field that you want to use.

    NOTE: Make sure that you type any spaces or punctuation that you want between two merge fields or after a merge field. You can also format (apply bold or italic formatting to) the merge fields, just as you would with regular text.
  3. When you finish editing the main document, click Save or Save As on the File menu. Name the file, and then click Save.
  4. Go to Step 4: Perform the Merge.

Step 4: Perform the Merge

  1. On the Tools menu, click Mail Merge.
  2. Under Merge the Data with the Document, click Merge.
  3. In the Merge dialog box, click Merge To, and select New document to display the merged document on the screen. To print the merged document, click Print on the File menu.

    NOTE: In the Merge To box, select Printer if you want to send the merged document to the printer without first viewing it on your screen.
  4. Click Merge.

Glossary

Boilerplate. Generic information that is repeated in each form letter, mailing label, envelope, or catalog.

Data field. A category of information in a data source. A data field corresponds to one column of information in the data source. The name of each data field is listed in the first row (header row) of the data source. "PostalCode" and "LastName" are examples of data field names.

Data record. A complete set of related information in a data source. A data record corresponds to one row of information in the data source. All information about one client in a client mailing list is an example of a data record.

Data source. A data source is a file that contains the data that varies in each copy of a merged document. For example, a data source can include the name and address of each recipient of a form letter.

Delimited. A text file that has data fields separated (or delimited) by tab characters or commas, and data records delimited by paragraph marks.

Header row. The first row (or record) in a mail-merge data source. The header row contains the field names for the categories of information in the data source; for example, "Name" and "City." The header row can also be stored in a separate document called the header source.

Main document. In a mail-merge operation, the document that contains the text and graphics that remain the same for each version of the merged document; for example, the return address and body of a form letter.

Merge field. A placeholder that you insert in the main document. Merge fields direct Microsoft Word where to insert specific information from the data source. For example, insert the merge field "City" to have Word insert a city name, such as "Paris," that is stored in the City data field.

Merged document. The document that is created by merging the data from the data source into the main document.

REFERENCES

Additional Resources

Word Mail Merge Support Resources

For more information about mail merge, click Microsoft Word Help on the Help menu, type mail merge in the Office Assistant or the Answer Wizard, and then click Search to view the topics returned.

Related Articles

For additional informationabout mail merge, click the following article numbers to view the articles in the Microsoft Knowledge Base:
212322 HOW TO: Design and Set Up Mail Merge Data in Microsoft Word 2000
212017 HOW TO: Use Mail Merge to Create Envelopes in Word 2000
212034 HOW TO: Create Mailing Labels by Using Mail Merge in Word 2000
212029 HOW TO: Create a Custom Label or Modify an Existing Label in Word 2000
212012 WD2000: How to Force Text to Start at Same Line in Merged Letter
211363 WD: How to Specify Multiple Conditions with a Nested IF
212314 HOW TO: Use an Excel Data Source for Mail Merge in Word 2000
214183 HOW TO: Use Mail Merge with an Access Parameter Query in Word 2000
211190 HOW TO: Use Access 2000 Data in Word 2000
211206 HOW TO: Use the Outlook Express Address Book in a Mail Merge in Microsoft Word
212379 WD2000: How to Convert WordPerfect 6.x Data Files and Address Books
212334 WD2000: How to Convert Data in One Column to a Table
211702 WD2000: How to Convert WordPerfect Merge Data
214827 WD: How to Use Nested IF Fields in a Mail Merge Document
264722 WD2000: How to Suppress Blank Lines During a Mail Merge
211303 How To Use Mail Merge to Create a List Sorted by Category in Word 2000
211293 HOW TO: Change Delivery or Return Address Formatting in Word 2000
212078 HOW TO: Add a Graphic or Logo to Every Label in Word 2000
212358 WD2000: Merge Data Source Fails to Attach or Merge
212263 WD2000: Error Message: Word Could Not Open <File Name.doc> as a Data or Header Source Because It Is the Active Mail Merge Main Document
212125 WD2000: Error Message: 'Error! Reference Source Not Found' with Blank Ask or Fillin Field
211729 WD2000: ErrMsg: "Word could not merge the main document with the data source because the data records were empty or no data records matched your query options."
242339 WD2000: Misspelled Word Not Flagged When Checking the Spelling of Mail Merged Document
211437 WD2000: Mail Merge Main and Data Documents Not Saved in Background
240854 WD2000: Limitations of Converting WordPerfect 5.x Documents
211727 WD2000: Mail Merge Main Document Restored to Normal Word Document
189196 WD2000: Error Message: "<Main Document File Name> Is a Mail Merge Main Document" Using Outlook 97 or Schedule+
212354 WD2000: Character Formatting in Data Source Not Retained After Merge
212068 WD2000: Change Case Does Not Apply Formatting to Merge Fields
220250 WD2000: Error Message: Fields Are Nested Too Deeply in Mail Merge
211322 WD2000: Cannot Change Default Field Names in Mail Merge Helper
214157 WD2000: Cannot Replace All Occurrences of Invalid MERGEFIELD Field
211651 WD2000: Blank Space Appears If Field Is Blank in Mail Merge
264892 WD2000: Blank Line Is Not Suppressed in a Conditional Mail Merge
270623 OLEXP: How to Use the Outlook Express Address Book in a Mail Merge Procedure
192258 How to do a mail merge with your contact list in Outlook 2000

Properties

Article ID: 212329 - Last Review: May 7, 2007 - Revision: 4.1
APPLIES TO
  • Microsoft Word 2000 Standard Edition
Keywords: 
kbemail kbhowto kbfaq kbmerge KB212329

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com