XL: Создание колоколообразной диаграммы

Переводы статьи Переводы статьи
Код статьи: 213930 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

Аннотация

Колоколообразной кривой называется в статистике кривая нормального распределения набора данных. В данной статье описывается процедура создания колоколообразной диаграммы в Microsoft Excel.

Дополнительная информация

С помощью приведенного ниже примера вы сможете создать колоколообразную кривую данных, сгенерированных Excel с помощью генератора случайных чисел из пакета анализа. Посте того как Microsoft Excel сгенерирует множество случайных чисел, вы можете с помощью средства «Гистограмма» создать на основе этих случайных чисел гистограмму распределения. Затем на основе этой гистограммы можно создать колоколообразную диаграмму.

Чтобы создать колоколообразную кривую, выполняйте следующие действия:
  1. Запустите Excel.
  2. В новом листе введите следующие заголовки столбцов:
       A1:Исходное  B1:Среднее C1:Столбец  D1:Случайное  E1:Гистограмма  G1:Гистограмма
    					
  3. Введите в этот же лист следующие данные:
       A2: 23      B2:
       A3: 25      B3: СТАНДОТКЛОН
       A4: 12      B4:
       A5: 24
       A6: 27
       A7: 57
       A8: 45
       A9: 19
    					
  4. Введите в этот же лист следующие формулы:
       B2:  =СРЗНАЧ(A2:A9)
       B3:
       B4:  =СТАНДОТКЛОН(A2:A9)
    						
    Эти формулы сгенерируют среднее значение и стандартное отклонение исходного множества соответственно.
  5. Чтобы сгенерировать ширину столбца гистограммы, введите следующие формулы:
       C2: =$B$2-3*$B4
    						
    Это позволит сгенерировать нижний предел столбца гистограммы. Данное число представляет собой три стандартных отклонения, которые меньше среднего значения.
       C3: =C2+$B$4
    						
    Данная формула прибавляет одно стандартное отклонение к числу, вычисленному в расположенной выше ячейке.
  6. Выделите ячейку С3 и растяните формулу на ячейки до С8.
  7. Чтобы сгенерировать случайное множество, которое станет основой колоколообразной кривой, выполняйте следующие действия:
    1. В меню Сервис выберите команду Анализ данных.
    2. В поле Анализ данных выберите Генератор случайных чисел и нажмите OK.
    3. В поле Число переменных введите значение 1.
    4. В поле Число случайных чисел введите значение 2000.

      Примечание. Изменение этого числа повышает или снижает точность колоколообразной кривой.
    5. В меню Поле распределения выберите пункт Стандартное.
    6. В панели Параметры введите число, вычисленное в ячейке В2 (в нашем примере это 29) в поле Среднее.
    7. В поле Стандартное отклонение введите число, вычисленное в ячейке В4 (14,68722).
    8. В поле Случайное начальное число ничего не вводите.
    9. В панели Параметры вывода выберите Диапазон вывода.
    10. Введите D2 в поле Диапазон вывода.

      В результате сгенерируются 2000 случайных чисел, соответствующих закону нормального распределения.
    11. Нажмите кнопку ОК.
  8. Чтобы создать гистограмму случайного множества, выполняйте следующие действия:
    1. В меню Сервис выберите команду Анализ данных.
    2. В поле Анализ данных выберите Гистограмма и нажмите OK.
    3. В поле Исходный диапазон введите значение D2:D2001.
    4. В поле Столбец гистограммы введите C2:C8.
    5. В панели Параметры вывода выберите Диапазон вывода.
    6. Введите E2 в поле Диапазон вывода.
    7. Нажмите кнопку ОК.
  9. Чтобы создать гистограмму исходного множества, выполняйте следующие действия:
    1. В меню Сервис выберите команду Анализ данных.
    2. Выберите Гистограмма, затем нажмите OK.
    3. В поле Исходный диапазон введите значение A2:A9.
    4. В поле Столбец гистограммы введите C2:C8.
    5. В панели Параметры вывода выберите Диапазон вывода.
    6. Введите G2 в поле Диапазон вывода.
    7. Нажмите кнопку ОК.
  10. Создайте метки для легенды диаграммы, введя следующие символы:
       E14: =G1&"-"&G2
       E15: =E1&"-"&F2
       E16: =G1&"-"&H2
    					
  11. Выделите на листе диапазон клеток E2:H10.
  12. В меню Вставка выберите команду Диаграмма.
  13. В списке Тип выберите Точечная.
  14. В списке Вид в среднем ряду выберите диаграмму справа.

    Примечание. При этом под группой из пяти диаграмм появится надпись «Точечная диаграмма со значениями, соединенными сглаживающими линиями без маркеров».
  15. Нажмите кнопку Далее.
  16. Перейдите на вкладку Ряд.
  17. В поле Имя удалите ссылку на ячейку и выберите ячейку E15.
  18. В поле Значения X удалите ссылку на диапазон и выберите диапазон E3:E10.
  19. В поле Значения Y удалите ссылку на диапазон и выберите диапазон F3:F10.
  20. Нажмите кнопку Добавить, чтобы добавить еще один ряд.
  21. Выберите поле Имя и выделите ячейку E14.
  22. Выберите поле Значения X и выделите диапазон E3:E10.
  23. В поле Значения Y удалите значение и выберите диапазон G3:G10.
  24. Нажмите кнопку Добавить, чтобы добавить еще один ряд.
  25. Выберите поле Имя и выделите ячейку E16.
  26. Выберите поле Значения X и выделите диапазон E3:E10.
  27. В поле Значения Y удалите значение и выберите диапазон H3:H10.
  28. Нажмите кнопку Готово.

    На диаграмме вы увидите два искривленных ряда значений и прямой ряд значений по оси х.
  29. Дважды щелкните мышью второй ряд. В легенде должно стоять слово «Столбец».
  30. В диалоговом окне Формат ряда данных перейдите на вкладку Ось.
  31. Выберите По вспомогательной оси, затем нажмите ОК.
У вас получилась диаграмма, сравнивающая данное множество с колоколообразной кривой распределения.

Ссылки

Для получения дополнительных сведений о создании диаграмм выберите в меню Справка команду Справка: Microsoft Excel, введите в поле помощника Office или мастера ответов строку создать диаграмму и нажмите кнопку Поиск.

Свойства

Код статьи: 213930 - Последний отзыв: 10 марта 2006 г. - Revision: 2.0
Информация в данной статье применима к:
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
Ключевые слова: 
kbhowto KB213930

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com