Berechnen der Anzahl der Monate zwischen zwei Datumsangaben in Excel

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 214134 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Zusammenfassung

Dieser Artikel erläutert Schritt für Schritt, wie Sie die Anzahl der Monate zwischen zwei beliebigen Datumsangaben berechnen.

Wenden Sie eine der folgenden Methoden an, um die Anzahl der Monate zwischen zwei beliebigen Datumsangaben zu berechnen. Beachten Sie, dass beide Methoden die folgenden Informationen verwenden:
  • FDatum = Früheres Datum
  • SDatum = Späteres DatumHINWEIS: Wenn Sie "SDatum" oder "FDatum" nicht in die Zellbezüge, sondern direkt in diese Formel eingeben, müssen Sie die Angaben in Anführungszeichen einschließen (Beispiel: "7.9.00").

Aufrunden

Diese Methode verwendet in den Berechnungen nicht den Tag des Monats. Bei dem Anfangsdatum 31.10.2010 und dem Enddatum 02.11.2010 wird ein Monat zurückgegeben, obwohl nur zwei Tage vergangen sind.

Verwenden Sie für diese Methode die folgende Formel
=(JAHR(SDatum)-JAHR(FDatum))*12+MONAT(SDatum)-MONAT(FDatum)
wie im folgenden Beispiel ersichtlich:
  1. Geben Sie in die Zelle A1 das Datum 31.10.2010 ein.
  2. Geben Sie folgende Formel in Zelle A2 ein:
    =(JAHR(JETZT())-JAHR(A1))*12+MONAT(JETZT())-MONAT(A1)
    Die zurückgegebene Anzahl entspricht der Anzahl der Monate vom 31.10.2010 bis zum heutigen Datum, aufgerundet zur nächsten ganzen Zahl.

Abrunden

Diese Methode verwendet die Anzahl der Tage in den Berechnungen und rundet auf die nächste Anzahl ganzer Monate ab. Bei dem Anfangsdatum 30.10.2010 und dem Enddatum 30.11.2010 wird ein Monat zurückgegeben. Das Enddatum 29.11.2010 ergibt jedoch den Wert Null.

Verwenden Sie für diese Methode die folgende Formel
=WENN(TAG(SDatum)>=TAG(FDatum),0,-1)+(JAHR(SDatum)-JAHR(FDatum))
*12+MONAT(SDatum)-MONAT(FDatum)
wie im folgenden Beispiel ersichtlich:
  1. Geben Sie in die Zelle A1 das Datum 31.10.2010 ein.
  2. Geben Sie die folgende Formel in Zelle B1 ein:
    =WENN(TAG(JETZT())>=TAG(A1),0,-1)+(JAHR(JETZT())-JAHR(A1)) *12+MONAT(JETZT())-MONAT(A1)
    Hinweis: Stellen Sie sicher, dass die Zelle B1 das Format "Allgemein" besitzt. Die zurückgegebene Anzahl entspricht der Anzahl der Monate vom 31.10.2010 bis zum heutigen Datum, abgerundet zur nächsten Anzahl ganzer Monate.
Hinweis Dies ist ein Artikel, der im Schnellverfahren direkt von der Microsoft-Supportorganisation erstellt wurde. Die hierin enthaltenen Informationen werden als Reaktion auf neue Probleme wie besehen bereitgestellt. Da dieser Artikel im Schnellverfahren erstellt wurde, kann er Tippfehler enthalten und zu einem späteren Zeitpunkt ohne vorherige Ankündigung überarbeitet werden. Weitere zu berücksichtigende Informationen finden Sie in den Nutzungsbedingungen.

Eigenschaften

Artikel-ID: 214134 - Geändert am: Mittwoch, 22. Mai 2013 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Office Excel 2007
  • Microsoft Office Excel 2003
  • Microsoft Excel 2010
Keywords: 
kbdatetime kbformula kbinfo kbhowtomaster KB214134
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com