Symptoms
Consider the following scenario:
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You install an instance of Microsoft SQL Server on a computer that is running Windows Server 2003 or Windows Server 2008, Windows Vista, or a later version of Windows.
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You run an application on another computer. The application tries to retrieve the Performance Counter data for the instance of SQL Server remotely.
In this scenario, the Remote Registry service crashes on the computer that has SQL Server installed. Additionally, error messages that resemble the following are logged in the Application log on the computer that has the instance of SQL Server installed:
Faulting application name: svchost.exe_RemoteRegistry, version: 6. .7600. 6385, time stamp: 0x4a5bc3c
Faulting module name: perf-MSSQLSERVER-sqlctr 0. .275_unloaded, version: 0.0.0.0, time stamp: 0x4b48 09 Exception code: 0xc0000005 Fault offset: 0x00000000626bfe57 Faulting process id: 0x d 8 Faulting application start time: 0x0 cad723f5bfd536 Faulting application path: Drive:\Windows\system32\svchost.exe Faulting module path: perf-MSSQLSERVER-sqlctr 0. .275 Report Id: da45823c-4327- df-ad 9-00 7a477845a Faulting application name: svchost.exe_RemoteRegistry, version: 6.1.7600.16385, time stamp: 0x4a5bc3c1 Faulting module name: sqlctr90.dll_unloaded, version: 0.0.0.0, time stamp: 0x492b1b55 Exception code: 0xc0000005 Fault offset: 0x000000003353c171 Faulting process id: 0x2eec Faulting application start time: 0x01cad5a366dde911 Faulting application path: Drive:\Windows\system32\svchost.exe Faulting module path: sqlctr90.dll Report Id: d0a6f0d5-41b3-11df-ae47-0017a4778006Additionally, an error message that resembles the following is logged in the Windows System log on the computer that has the instance of SQL Server installed:
Date,Time PM,Error,ServerName,7034,Service Control Manager,N/A,N/A,"The Remote Registry service terminated unexpectedly. It has done this number time(s)."
Cause
This issue occurs because the SQL Server Performance Counter uses an incorrect method to call the RegQueryValueEx API to access a registry key. This behavior causes the Remote Registry service that loads the SQL Server Performance Counter to crash.
Resolution
Note To resolve this issue in SQL Server 2005 Service Pack 3 (SP3), apply Cumulative Update 13 for SQL Server 2005 SP3 on the computer where you have the SQL Server 2005 instance installed. Currently, this resolution only applies to SQL Server 2005 SP3.
Cumulative update information
The issue was first fixed in the following cumulative update of SQL Server.
Cumulative Update 17 for SQL Server 2008 SP3 /en-us/help/2958696
Cumulative Update 4 for SQL Server 2008 R2 SP1 /en-us/help/2633146
Cumulative Update 9 for SQL Server 2008 R2 /en-us/help/2567713
Cumulative Update 4 for SQL Server 2008 SP2 /en-us/help/2527180
Cumulative Update 13 for SQL Server 2005 SP3 /en-us/help/2438344
Cumulative Update 2 for SQL Server 2005 SP4 /en-us/help/2489409
Cumulative Update 13 for SQL Server 2008 SP1 /en-us/help/2497673
Each new cumulative update for SQL Server contains all the hotfixes and all the security fixes that were included with the previous cumulative update. Check out the latest cumulative updates for SQL Server:
Hotfix information of Windows Internal Database (Microsoft SQL Server Embedded Edition)
Note This fix only applies to the 2005 version of Windows Internal Database. A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
PrerequisitesTo apply this hotfix, you must have Windows Internal Database installed on the computer.
Restart requirementYou do not have to restart the computer after you apply this hotfix.
File information The global hotfix version of this has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.