FIX: The Remote Registry service crashes when an application tries to retrieve performance counter data from an instance of SQL Server on another computer

Article translations Article translations
Article ID: 2159286 - View products that this article applies to.
Expand all | Collapse all

On This Page

Symptoms

Consider the following scenario:
  • You install an instance of Microsoft SQL Server on a computer that is running Windows Server 2003 or Windows Server 2008, Windows Vista, or a later version of Windows.
  • You run an application on another computer. The application tries to retrieve the Performance Counter data for the instance of SQL Server remotely.
In this scenario, the Remote Registry service crashes on the computer that has SQL Server installed. Additionally, error messages that resemble the following are logged in the Application log on the computer that has the instance of SQL Server installed:
Faulting application name: svchost.exe_RemoteRegistry, version: 6. .7600. 6385, time stamp: 0x4a5bc3c
Faulting module name: perf-MSSQLSERVER-sqlctr 0. .275_unloaded, version: 0.0.0.0, time stamp: 0x4b48 09 Exception code: 0xc0000005
Fault offset: 0x00000000626bfe57
Faulting process id: 0x d 8
Faulting application start time: 0x0 cad723f5bfd536
Faulting application path: Drive:\Windows\system32\svchost.exe
Faulting module path: perf-MSSQLSERVER-sqlctr 0. .275
Report Id: da45823c-4327- df-ad 9-00 7a477845a

Faulting application name: svchost.exe_RemoteRegistry, version: 6.1.7600.16385, time stamp: 0x4a5bc3c1
Faulting module name: sqlctr90.dll_unloaded, version: 0.0.0.0, time stamp: 0x492b1b55
Exception code: 0xc0000005
Fault offset: 0x000000003353c171
Faulting process id: 0x2eec
Faulting application start time: 0x01cad5a366dde911
Faulting application path: Drive:\Windows\system32\svchost.exe
Faulting module path: sqlctr90.dll
Report Id: d0a6f0d5-41b3-11df-ae47-0017a4778006

Additionally, an error message that resembles the following is logged in the Windows System log on the computer that has the instance of SQL Server installed:
Date,Time PM,Error,ServerName,7034,Service Control Manager,N/A,N/A,"The Remote Registry service terminated unexpectedly. It has done this number time(s)."

Cause

This issue occurs because the SQL Server Performance Counter uses an incorrect method to call the RegQueryValueEx API to access a registry key. This behavior causes the Remote Registry service that loads the SQL Server Performance Counter to crash.

Resolution

Note To resolve this issue in SQL Server 2005 Service Pack 3 (SP3), apply Cumulative Update 13 for SQL Server 2005 SP3 on the computer where you have the SQL Server 2005 instance installed. Currently, this resolution only applies to SQL Server 2005 SP3.

Cumulative update information

The issue was first fixed in the following cumulative update of SQL Server.

Cumulative Update 17 for SQL Server 2008 SP3

Cumulative Update 4 for SQL Server 2008 R2 SP1

Cumulative Update 9 for SQL Server 2008 R2

Cumulative Update 4 for SQL Server 2008 SP2

Cumulative Update 13 for SQL Server 2005 SP3

Cumulative Update 2 for SQL Server 2005 SP4

Cumulative Update 13 for SQL Server 2008 SP1

About cumulative updates for SQL Server

Collapse this imageExpand this image
assets folding start collapsed
Each new cumulative update for SQL Server contains all the hotfixes and all the security fixes that were included with the previous cumulative update. Check out the latest cumulative updates for SQL Server:
Collapse this imageExpand this image
assets folding end collapsed

Hotfix information of Windows Internal Database (Microsoft SQL Server Embedded Edition)

Note This fix only applies to the 2005 version of Windows Internal Database.
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Internal Database installed on the computer.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

File information

The global hotfix version of this has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this imageExpand this image
assets folding start collapsed
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Sqlctr90.dll2005.90.5324.088,68025-Aug-201204:43x64
Sqlctr90.dll2005.90.5324.065,64025-Aug-201205:13x86
Sqlctr90.dll2005.90.5324.0129,64025-Aug-201204:32IA-64
Collapse this imageExpand this image
assets folding end collapsed

Workaround

We have determined that this problem occurs only when you start Performance Monitoring tools (for example, Windows System Monitor or Logman) remotely and try to connect to a Windows 2008 R2-based server that has SQL Server instances installed. Therefore, we recommend that you do not use Performance Monitoring tools that are installed on a Windows 2003-based server to monitor performance counters that are installed on a Windows 2008 R2-based server. However, if you must use this monitoring environment, make sure that the first connection is made from another Windows 2008 R2-based server. If you do this, all subsequent connections from Windows Server 2003 client computers will be successful.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 2159286 - Last Review: May 20, 2014 - Revision: 21.0
Applies to
  • Microsoft SQL Server 2008 Service Pack 1, when used with:
    • Microsoft SQL Server 2008 Enterprise
    • Microsoft SQL Server 2008 Developer
    • Microsoft SQL Server 2008 Standard
  • Microsoft SQL Server 2005 Service Pack 4, when used with:
    • Microsoft SQL Server 2005 Enterprise Edition
    • Microsoft SQL Server 2005 Developer Edition
    • Microsoft SQL Server 2005 Standard Edition
  • Microsoft SQL Server 2005 Service Pack 3, when used with:
    • Microsoft SQL Server 2005 Developer Edition
    • Microsoft SQL Server 2005 Enterprise Edition
    • Microsoft SQL Server 2005 Standard Edition
  • Microsoft SQL Server 2008 Service Pack 2, when used with:
    • Microsoft SQL Server 2008 Developer
    • Microsoft SQL Server 2008 Enterprise
    • Microsoft SQL Server 2008 Standard
  • Microsoft SQL Server 2008 R2 Developer
  • Microsoft SQL Server 2008 R2 Enterprise
  • Microsoft SQL Server 2008 R2 Standard
  • Microsoft SQL Server 2008 Service Pack 3, when used with:
    • Microsoft SQL Server 2008 Developer
    • Microsoft SQL Server 2008 Enterprise
    • Microsoft SQL Server 2008 Standard
Keywords: 
kbqfe kbfix kbsurveynew kbexpertiseadvanced KB2159286

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com