โปรแกรมประยุกต์ที่ใช้การเข้ารหัสลับ DES สำหรับการรับรองความถูกต้อง Kerberos ไม่สามารถเรียกใช้บนคอมพิวเตอร์ที่ใช้ในการใช้ Windows XP ไคลเอนต์ในโดเมน Windows Server 2008

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 2274102 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

พิจารณาสถานการณ์สมมติต่อไปนี้:
  • คุณได้กำหนดค่าคอมพิวเตอร์ที่กำลังเรียกใช้ Windows Server 2008 R2 เป็นตัวควบคุมโดเมนในโดเมนอยู่
  • เปิดการใช้งานการเข้ารหัสลับข้อมูลการเข้ารหัสลับมาตรฐาน (DES) สำหรับการรับรองความถูกต้อง Kerberos บนตัวควบคุมโดเมน
  • คุณได้กำหนดค่าระดับโดเมนการทำงานกับ Windows Server 2008 ในโดเมน
  • คุณเชื่อมต่อคอมพิวเตอร์แบบไคลเอ็นต์ที่ใช้ Windows XP ไปยังโดเมน
  • คุณรันโปรแกรมประยุกต์บนคอมพิวเตอร์ไคลเอนต์ที่ใช้ Windows XP โปรแกรมประยุกต์ใช้การเข้ารหัส DES เท่านั้นสำหรับการรับรองความถูกต้อง Kerberos
ในสถานการณ์สมมตินี้ การรับรองความถูกต้อง Kerberos ไม่สำเร็จ ดังนั้น แอพลิเคชันไม่ได้รัน

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจากมีข้อผิดพลาดในบริการศูนย์การแจกจ่ายคีย์ของ Kerberos (KDC) ที่อยู่บนตัวควบคุมโดเมนที่ใช้ Windows Server 2008 R2 โดยค่าเริ่มต้น บริการ KDC เลือกอัลกอริทึมการ RC4 เป็นชนิดการเข้ารหัสลับในการมอบหมายบัตร (TGT) อนุญาตให้บัตรหากด้านเซิร์ฟเวอร์ Kerberos และฝั่งไคลเอ็นต์ Kerberos สนับสนุนอัลกอริทึมการ RC4 ปัญหานี้เกิดขึ้นแม้ว่ามีการกำหนดค่าการเข้ารหัสลับ DES เป็นวิธีที่ต้องการเข้ารหัสลับ

การแก้ไข

ข้อมูลโปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนที่ได้รับการสนับสนุนจาก Microsoft พร้อมใช้งานอยู่ อย่างไรก็ตาม โปรแกรมแก้ไขด่วนนี้มีเป้าหมายเพื่อการแก้ไขปัญหาที่อธิบายไว้ในบทความนี้เท่านั้น นำโปรแกรมแก้ไขด่วนนี้ไปใช้กับระบบที่พบปัญหาที่อธิบายไว้ในบทความนี้เท่านั้น โปรแกรมแก้ไขด่วนนี้อาจได้รับการทดสอบเพิ่มเติม ดังนั้น ถ้าคุณไม่ได้รับอย่างจากจากปัญหานี้ เราขอแนะนำให้ คุณรอการปรับปรุงซอฟต์แวร์ถัดไปที่ประกอบด้วยโปรแกรมแก้ไขด่วนนี้

หากโปรแกรมแก้ไขด่วนพร้อมสำหรับการดาวน์โหลด จะส่วน "โปรแกรมแก้ไขด่วนพร้อมดาวน์โหลด" ที่ด้านบนของบทความฐานความรู้นี้ หากส่วนนี้ไม่ปรากฏขึ้น โปรดติดต่อฝ่ายบริการสนับสนุนลูกค้าของ Microsoft เพื่อขอรับโปรแกรมแก้ไขด่วน

หมายเหตุถ้าเติมปัญหาเกิดขึ้น หรือถ้าการแก้ไขปัญหาที่จำเป็น คุณอาจต้องสร้างการร้องขอบริการแยกต่างหาก ค่าใช้จ่ายในการสนับสนุนปกติจะเกิดขึ้นเมื่อมีคำถามและประเด็นการสนับสนุนอื่นๆ ซึ่งไม่จัดอยู่ในโปรแกรมแก้ไขด่วนเฉพาะที่กล่าวถึงนี้ สำหรับรายการทั้งหมดของ Microsoft ฝ่ายบริการสนับสนุนลูกค้าหมายเลขโทรศัพท์ หรือการสร้างการร้องขอบริการแยกต่างหาก แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
http://support.microsoft.com/contactus/?ws=support
หมายเหตุฟอร์ม "โปรแกรมแก้ไขด่วนพร้อมดาวน์โหลด" แสดงภาษาในโปรแกรมแก้ไขด่วนมีอยู่ ถ้าคุณไม่เห็นภาษาของคุณ อาจเป็น เพราะโปรแกรมแก้ไขด่วนจะไม่พร้อมใช้งานสำหรับภาษานั้น

ข้อกำหนดเบื้องต้น

ไปใช้โปรแกรมแก้ไขด่วนนี้ คุณต้องใช้งาน Windows Server 2008 R2 กับบทบาทบริการโดเมน active Directory ที่ใช้งานอยู่ติดตั้ง

ข้อมูลรีจิสทรี

เมื่อต้องการใช้โปรแกรมแก้ไขด่วนในแพคเกจนี้ คุณไม่จำเป็นต้องทำการเปลี่ยนแปลงไปยังรีจิสทรี

ความต้องการเริ่มระบบใหม่

คุณอาจต้องรีสตาร์ทคอมพิวเตอร์หลังจากที่คุณใช้โปรแกรมแก้ไขด่วนนี้

ข้อมูลการแทนที่โปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนนี้ไม่แทนนำออกใช้ก่อนหน้านี้แล้วโปรแกรมแก้ไขด่วน

แฟ้มข้อมูล

แฟ้มที่มีแอตทริบิวต์ที่ระบุไว้ในตารางต่อไปนี้ การติดตั้งโปรแกรมแก้ไขด่วนนี้รุ่น ในอังกฤษ (สหรัฐอเมริกา) วันที่และเวลาของแฟ้มเหล่านี้จะปรากฏในรูปแบบ Coordinated Universal Time (UTC) วันที่และเวลาสำหรับแฟ้มเหล่านี้ในคอมพิวเตอร์จะปรากฏตามเวลาท้องถิ่น โดยมีการปรับเวลาตามฤดูกาล (DST) นอกจากนี้ วันและเวลาอาจเปลี่ยนแปลงเมื่อคุณทำการดำเนินการบางอย่างบนแฟ้ม
หมายเหตุข้อมูลแฟ้มของ windows Server 2008 R2
สิ่งสำคัญโปรแกรมแก้ไขด่วน Windows 7 และโปรแกรมแก้ไขด่วนของ Windows Server 2008 R2 จะรวมอยู่ในแพคเกจโปรแกรมเดียวกัน อย่างไรก็ตาม โปรแกรมแก้ไขด่วนบนหน้าการร้องขอโปรแกรมแก้ไขด่วนจะแสดงรายการภายใต้ระบบปฏิบัติการทั้งสอง เมื่อต้องการร้องขอการแพคเกจโปรแกรมแก้ไขด่วนที่ใช้กับระบบปฏิบัติการหนึ่ง หรือทั้งสอง เลือกโปรแกรมแก้ไขด่วนที่แสดงภายใต้ "Windows 7/Windows Server 2008 R2" บนหน้า โปรดดูส่วน "นำไปใช้กับ" ในบทความเพื่อดูว่าระบบปฏิบัติการเกิดขึ้นจริงที่ใช้ในแต่ละโปรแกรมแก้ไขด่วนเสมอ
  • แสดงรายการในแฟ้ม (.manifest) และ MUM แฟ้ม (.mum) ที่มีการติดตั้งสำหรับแต่ละสภาพแวดล้อมได้แสดงรายการแยกต่างหากในส่วน "แฟ้มเพิ่มเติม สำหรับ Windows Server 2008 R2 และ Windows 7 ข้อมูล" MUM และแฟ้มที่รายการ และ แฟ้มแค็ตตาล็อก (.cat) การรักษาความปลอดภัยที่เกี่ยวข้อง เป็นสิ่งสำคัญอย่างยิ่งสำหรับการบำรุงรักษาสถานะของคอมโพเนนต์ที่ปรับปรุง ลงชื่อเข้ากับ Microsoft ดิจิทัลลายเซ็นการรักษาความปลอดภัยแฟ้มแค็ตตาล็อก ที่แอตทริบิวต์ไม่อยู่ในรายการ
สำหรับทั้งหมดที่ได้รับการสนับสนุน x 64-รุ่นที่ใช้ Windows Server 2008 R2
ยุบตารางนี้ขยายตารางนี้
ชื่อแฟ้มรุ่นของแฟ้มขนาดแฟ้มวันเวลาแพลตฟอร์ม
Kdcsvc.dll6.1.7600.20756429,56816-ก.ค.-201010:สีกันx64
Kdcsvc.mofไม่เกี่ยวข้อง5,30010 2009 Jun21:01ไม่เกี่ยวข้อง

สถานะ

Microsoft ได้ยืนยันว่า นี่เป็นปัญหาในผลิตภัณฑ์ของ Microsoft ที่อยู่ในส่วน "นำไปใช้กับ"

ข้อมูลเพิ่มเติม

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับคำศัพท์เฉพาะทางการปรับปรุงซอฟต์แวร์ คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
824684คำอธิบายของคำศัพท์มาตรฐานที่ใช้เพื่ออธิบายการปรับปรุงซอฟต์แวร์ของ Microsoft

ข้อมูลเพิ่มเติมของแฟ้ม

ข้อมูลแฟ้มเพิ่มเติมสำหรับ Windows Server 2008 R2

แฟ้มเพิ่มเติมสำหรับทั้งหมดที่ได้รับการสนับสนุน x 64-รุ่นที่ใช้ Windows Server 2008 R2
ยุบตารางนี้ขยายตารางนี้
ชื่อแฟ้มAmd64_d4d79987f90c80cc0e20a7efbb067f27_31bf3856ad364e35_6.1.7600.20756_none_61d52da6328f350d.manifest
รุ่นของแฟ้มไม่เกี่ยวข้อง
ขนาดแฟ้ม724
วัน (UTC)16-ก.ค.-2010
เวลา (UTC)21:07
แพลตฟอร์มไม่เกี่ยวข้อง
ชื่อแฟ้ม Amd64_microsoft หน้าต่าง k ..ชื่อการแจกจ่าย-center_31bf3856ad364e35_6.1.7600.20756_none_e857cc82c6f64656.manifest
รุ่นของแฟ้มไม่เกี่ยวข้อง
ขนาดแฟ้ม35,825
วัน (UTC)16-Jul-2010
เวลา (UTC)11:44
แพลตฟอร์มไม่เกี่ยวข้อง
ชื่อแฟ้มUpdate.mum
รุ่นของแฟ้มไม่เกี่ยวข้อง
ขนาดแฟ้ม1,706
วัน (UTC)16-Jul-2010
เวลา (UTC)21:07
แพลตฟอร์มไม่เกี่ยวข้อง

คุณสมบัติ

หมายเลขบทความ (Article ID): 2274102 - รีวิวครั้งสุดท้าย: 13 สิงหาคม 2553 - Revision: 1.0
ใช้กับ
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter kbmt KB2274102 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:2274102

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com