Quando você tenta buscar caracteres árabes especiais de colunas de DB2 usando SQL Server Reporting Services, caracteres ilegíveis são exibidos no Host Integration Server de 2009

Traduções deste artigo Traduções deste artigo
ID do artigo: 2278243 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sintomas

Em um ambiente Microsoft Host Integration Server 2009, quando você tenta buscar colunas de uma tabela DB2 usando o provedor OLE DB para DB2, Microsoft SQL Server Reporting Services pode exibir caracteres ilegíveis nas colunas.

Esse problema ocorre se as colunas contêm os seguintes caracteres especiais árabe:
  • Dhad: ?
  • Saad: ?
  • Sheen: ?
  • Visto: ?

Causa

Esse problema ocorre porque os caracteres que são mencionados na seção "Sintomas" são representados como dois caracteres EBCDIC. No entanto, esses caracteres são representados como apenas um caractere ANSI. Porque o buffer de dados for inicializado usando NULLs, o buffer de dados tem caracteres adicionais do NULL quando o buffer de dados de busca de colunas de DB2 que contêm esses caracteres arábicos. Portanto, o SQL Server Reporting Services exibe caracteres ilegíveis.

Resolução

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplica esta correcção apenas em sistemas que apresentarem o problema descrito neste artigo. Este hotfix pode receber testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção de "Download de Hotfix disponível" na parte superior deste artigo da Base de dados de Conhecimento. Se essa seção não for exibido, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação:Se ocorrerem problemas adicionais ou qualquer solução de problemas é necessária, talvez seja necessário criar uma solicitação de serviço separada. Os custos de suporte normais se aplicarão a perguntas de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa dos números de telefone de suporte e atendimento ao cliente da Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Observação:O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

A versão em português (Brasil) deste hotfix usa um pacote do Microsoft Windows Installer para instalar o hotfix. As datas e as horas destes ficheiros são listadas na hora universal coordenada (UTC) na tabela a seguir. Quando você visualiza as informações do arquivo, a data é convertida para a hora local. Para saber a diferença entre o UTC e a hora local, use aFuso horárioguia no item data e hora no painel de controle.

Microsoft Host Integration Server 2009, edição de 32 bits
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
trnsbidi.dll8.0.3763.261,26407-Jul-201013: 53x86
Microsoft Host Integration Server 2009, 64-bit edition
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
trnsbidi.dll8.0.3763.267,40807-Jul-201013: 59x64

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Propriedades

ID do artigo: 2278243 - Última revisão: sexta-feira, 5 de novembro de 2010 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Microsoft Host Integration Server 2009
Palavras-chave: 
kbautohotfix kbqfe kbHotfixServer kbfix kbexpertiseadvanced kbsurveynew kbfont kbmt KB2278243 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 2278243

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com