The RemoteApp program není ukončena po vypršení časového limitu nečinné relace v počítači se systémem Windows Server 2008 R2

Překlady článku Překlady článku
ID článku: 2287493 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Zvažte následující scénář:
  • Máte počítač se systémem Windows Server 2008 R2.
  • Můžete připojit počítač k doméně.
  • Při instalaci role služby služeb vzdálené plochy v počítači.
  • Povolíte následující nastavení zásad skupiny v doméně:
    Počítač uživatele\Šablony pro správu\Součásti systému Components\Remote Desktop Services\Remote plochy relace Host\Session čas Limits\Set časový limit aktivních ale nečinných relací službou vzdálené plochy

    Počítač uživatele\Šablony pro správu\Součásti systému Components\Remote Desktop Services\Remote plochy relace Host\Session čas Limits\Terminate relace při vypršení časového limitu
  • NastavíteLimit nečinných relacínastavení na hodnotu, která je větší než nebo rovna 5 minut. Nastavení limitu nečinné relace je vNastavit časový limit aktivních ale nečinných relací službou vzdálené plochyNastavení zásad skupiny.
  • Použití nastavení zásad skupiny pro počítač.
  • Spuštění aplikace RemoteApp spustit relaci vzdálené plochy služby v počítači.
  • Relace je nečinný po dobu, která je delší než časový limit nečinnosti relace.
  • v relaci služby vzdálené plochy po dobu delší než časový limit nečinnosti relace je nečinné relace se zobrazí následující zpráva:
    Nečinnost relace překročila časový limit. To bude ukončena za 2 minuty. Stisknutím libovolné klávesy nyní pokračovat v relaci.

V tomto případě aplikace RemoteApp není ukončena po zůstává relace nečinná pro další dvě minuty.

Příčina

k tomuto problému dochází, protože vzdálené plochy služba nesprávně zpracovává některé automaticky generované události a zprávy jako vstup uživatele. Proto službou vzdálené plochy aplikace RemoteApp neukončuje. 

Poznámka:Tyto události generovány automaticky a zprávy jsou z nástroje připojení ke vzdálené ploše.

Řešení

Informace o opravě hotfix

Podporovaná oprava hotfix je k dispozici od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku.. Tuto opravu hotfix instalujte pouze do systémů, ve kterých dochází k potížím popsaným v tomto článku.. Tato oprava hotfix může být dále testována.. Proto pokud není vážně tento problém, doporučujeme počkat na další aktualizaci softwaru, který obsahuje tuto opravu hotfix.

v případě, že je oprava hotfix k dispozici ke stažení, je sekce "Oprava Hotfix k dispozici stahování" na začátku tohoto článku znalostní báze Knowledge Base. Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix..

Poznámka:-Li další dojít k potížím nebo je-li řešení potíží, je nutné, budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix.. Úplný seznam služby Microsoft a podporu telefonního čísla nebo chcete-li vytvořit zvláštní požadavek na službu, navštivte následující web společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka:Ve formuláři "Oprava Hotfix k dispozici stahování" zobrazí jazyky, pro které je k dispozici je oprava hotfix. Pokud váš jazyk není zobrazen, je protože oprava hotfix není k dispozici pro tento jazyk.

Požadavky

Chcete-li nainstalovat tuto opravu hotfix, musí být spuštěn systém Windows Server 2008 R2. Kromě toho musí být nainstalována role služby služeb vzdálené plochy. 

Informace o registru

Pro použití v tomto balíčku opravy hotfix není nutné změny do registru.

Požadavek na restartování

Bude pravděpodobně třeba restartovat počítač po instalaci této opravy hotfix.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje dříve vydanou opravu hotfix.

Informace o souborech

Verze the Angličtina (Spojené státy) této opravy hotfix se nainstaluje soubory, jejichž atributy, které jsou uvedeny v následujících tabulkách. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaný světový čas (UTC). Kalendářní data a časy těchto souborů v místním počítači jsou zobrazeny podle místního času společně podle aktuálního letní čas (DST). Navíc data a časy mohou změnit při provedení určité operace soubory.
Poznámky k informacím o soubor systému Windows Server 2008 R2
DůležitéSystému Windows 7 opravy hotfix a opravy hotfix pro systém Windows Server 2008 R2 jsou součástí stejné balíčků. Nicméně opravy hotfix na stránce žádost o opravě Hotfix jsou uvedeny v obou operačních systémů. Požádat o balíčku oprav hotfix, která se vztahuje k jedné nebo obou operačních systémů, vyberte opravu hotfix, která je uvedena v části "Windows 7 a Windows Server 2008 R2" na stránce. Vždy naleznete v části "Platí pro" v článcích určit každou opravu hotfix, která se vztahuje na aktuální operační systém.
  • Soubory MANIFEST (.manifest) a soubory MUM (.mum) instalované pro každé prostředí jsouuvedeny samostatněv části "Další informace o souborech pro systém Windows Server 2008 R2". MUM a MANIFEST soubory a soubory CAT katalogu zabezpečení, jsou velmi důležité pro udržení stavu aktualizované součásti. Soubory katalogu zabezpečení, pro které nejsou uvedeny atributy, jsou podepsány pomocí společnosti Microsoft digitálního podpisu.
Pro všechny podporované 64bitové verze systému Windows Server 2008 R2 x
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Termsrv.dll6.1.7600.20757711,68017. Července-201008: 06x 64

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části "Platí pro".

Další informace

Další informace o terminologii aktualizace softwaru, klepněte na následující číslo článku databáze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Další informace o souborech

Další informace o souborech pro systém Windows Server 2008 R2

Další soubory pro všechny podporované 64bitové verze systému Windows Server 2008 R2 x
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruAmd64_microsoft-windows-t...teconnectionmanager_31bf3856ad364e35_6.1.7600.20757_none_eb40464486f89423.manifest
Verze souboruNení k dispozici
Velikost souboru29,203
Datum (UTC)17. Července-2010
Čas (UTC)08: 52
PlatformaNení k dispozici
Název souboruUpdate.mum
Verze souboruNení k dispozici
Velikost souboru24,725
Datum (UTC)17. Července-2010
Čas (UTC)14: 45
PlatformaNení k dispozici
Název souboruWow64_microsoft-windows-t...teconnectionmanager_31bf3856ad364e35_6.1.7600.20757_none_f594f096bb59561e.manifest
Verze souboruNení k dispozici
Velikost souboru10,688
Datum (UTC)17. Července-2010
Čas (UTC)07: 59
PlatformaNení k dispozici

Vlastnosti

ID článku: 2287493 - Poslední aktualizace: 12. srpna 2010 - Revize: 1.0
Informace v tomto článku jsou určeny pro produkt:
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
Klíčová slova: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced kbmt KB2287493 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:2287493

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com