You are unexpectedly prompted to enter your credentials when you try to access a WebDAV resource in a corporate network by using a DirectAccess connection in Windows 7 or in Windows Server 2008 R2

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Article ID: 2288297 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • You deploy Forefront Unified Access Gateway (UAG) DirectAccess in a domain environment.
  • You have a computer that is running Windows 7 or Windows Server 2008 R2 in a remote network.
  • You join this computer to the domain, and then you use DirectAccess to connect this computer to a corporate network.
  • You try to access a Web Distributed Authoring and Versioning (WebDAV) resource in the corporate network by using a fully qualified domain name (FQDN) address from this computer. For example, you try to open or edit a Microsoft Word document in the following SharePoint Document library:
http://www.contoso.com/sites/contoso/Shared%20Documents


In this scenario, you expect to access the resource directly. However, you are prompted to enter your credentials to access the resource.

CAUSE

This issue occurs because the automatic logon level for Windows HTTP Services (WinHTTP) is set to Medium. This behavior causes the user credentials not to be sent to the Internet server. Therefore, the FQDN address is regarded as an Internet server when you try to access the WebDAV resource and you are prompted to enter your credentials.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for applying this hotfix.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces the previously released hotfix 956943. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
956943You are prompted unexpectedly to enter your credentials when you access a SharePoint Server site from a Windows Vista-based or Windows Server 2008-based client computer that has a proxy server configured

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Webclnt.dll6.1.7600.20787202,24021-Aug-201006:52x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Webclnt.dll6.1.7600.20787253,95221-Aug-201007:24x64
Webclnt.dll6.1.7600.20787202,24021-Aug-201006:52x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the DirectAccess deployment guide, visit the following Microsoft website: 
General information about DirectAccess deployment guide
For more information about the DirectAccess connection process, visit the following Microsoft website:
General information about the DirectAccess connection process
For more information about DirectAccess, visit the following Microsoft website:
General information about DirectAccess
For more information about UAG DirectAccess deployment, click the following article number to view the article in the Microsoft Knowledge Base:
982886 UAG Direct Access deployment
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameUpdate.mum
File versionNot applicable
File size1,632
Date (UTC)21-Aug-2010
Time (UTC)12:36
PlatformNot applicable
File nameX86_ff3937f90796ede684e56dddff98ffd9_31bf3856ad364e35_6.1.7600.20787_none_c67099c0f777cf66.manifest
File versionNot applicable
File size709
Date (UTC)21-Aug-2010
Time (UTC)12:36
PlatformNot applicable
File nameX86_microsoft-windows-webdavredir-webclient_31bf3856ad364e35_6.1.7600.20787_none_5587c2f12e2102df.manifest
File versionNot applicable
File size2,413
Date (UTC)21-Aug-2010
Time (UTC)07:23
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_60f6d47886571248ba4e76114a1d2171_31bf3856ad364e35_6.1.7600.20787_none_98431fd6cb85bd4b.manifest
File versionNot applicable
File size713
Date (UTC)21-Aug-2010
Time (UTC)12:36
PlatformNot applicable
File nameAmd64_8837aae61032f3d21a594fccc01da830_31bf3856ad364e35_6.1.7600.20787_none_bd097125c297989b.manifest
File versionNot applicable
File size1,066
Date (UTC)21-Aug-2010
Time (UTC)12:36
PlatformNot applicable
File nameAmd64_ff3937f90796ede684e56dddff98ffd9_31bf3856ad364e35_6.1.7600.20787_none_228f3544afd5409c.manifest
File versionNot applicable
File size711
Date (UTC)21-Aug-2010
Time (UTC)12:36
PlatformNot applicable
File nameAmd64_microsoft-windows-webdavredir-webclient_31bf3856ad364e35_6.1.7600.20787_none_b1a65e74e67e7415.manifest
File versionNot applicable
File size2,417
Date (UTC)21-Aug-2010
Time (UTC)08:32
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,057
Date (UTC)21-Aug-2010
Time (UTC)12:36
PlatformNot applicable
File nameX86_microsoft-windows-webdavredir-webclient_31bf3856ad364e35_6.1.7600.20787_none_5587c2f12e2102df.manifest
File versionNot applicable
File size2,413
Date (UTC)21-Aug-2010
Time (UTC)07:23
PlatformNot applicable

Properties

Article ID: 2288297 - Last Review: October 13, 2010 - Revision: 1.0
APPLIES TO
  • Windows 7 Enterprise
  • Windows 7 Ultimate
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbexpertiseinter kbsurveynew kbexpertiseadvanced KB2288297

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