ИСПРАВИТЬ: Некоторые проблемы при использовании адаптера BizTalk EnterpriseOne Эдвардса JD или адаптер BizTalk для JD XE OneWorld Эдвардса в BizTalk Server 2006 R2 или BizTalk Server 2009 г.

Переводы статьи Переводы статьи
Код статьи: 2291479 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

Рассмотрим следующий сценарий:
  • У вас есть компьютер, на котором выполняется Microsoft BizTalk Server 2006 R2 или Microsoft BizTalk Server 2009 г.
  • Используйте один из следующих адаптеров для обмена Бизнес-функции сообщения между BizTalk Server и EnterpriseOne Эдвардса JD системы:
    • Microsoft BizTalk адаптер для EnterpriseOne Эдвардса JD
    • Microsoft BizTalk адаптер для OneWorld JD Эдвардса XE
В этом случае может возникнуть одна или несколько из следующих проблем.

Выпуск 1

При попытке отправить сообщение с помощью адаптера, адаптер после простоя для некоторое время, а затем попробуйте отправить сообщение. В этом случае адаптер не отправляет первое сообщение. Тем не менее адаптер отправляет второе сообщение. Кроме того в журнале приложений регистрируется событие, аналогичное следующему:

Тип события: ошибка
Источник события: Адаптеров Biztalk корпорации Майкрософт для разработки корпоративных приложений
Категория события: нет
КОД события: 0
Описание:
Ошибка выполнения: Не удалось установить соединение, поскольку конечный компьютер отверг 127.0.0.1:15000

Проблема 2

При установке Максимальное количество одновременных звонков для передачи свойство в значение, превышающее 1, для адаптера, многие сообщения экземпляров dehydrate и не обрабатываются.

Проблема 3

Периодически сообщения приостанавливаются. Кроме того некоторые события, подобные указанным ниже регистрируется в журнале приложений.

События 1

Тип события: ошибка
Источник события: Адаптеров BizTalk корпорации Майкрософт для разработки корпоративных приложений
Категория события: нет
КОД события: 0
Описание:
Недопустимый конечный: X0010GetNextNumber@JDE://CALLBSFN/

События 2

Тип события: ошибка
Источник события: Адаптеров Biztalk корпорации Майкрософт для разработки корпоративных приложений
Категория события: нет
КОД события: 0
Описание: Передающий сообщение:<soap-env:fault></soap-env:fault>
ПЕР = "http://schemas.xmlsoap.org/SOAP/Envelope/

"><faultcode>SOAP-ENV:Client</faultcode><faultstring>код запроса: неизвестный</faultstring>

Тип исключения: Метод не существует
Сведения об исключениях:
Исключение:
Недопустимый конечный. X0010GetNextNumber@JDE://CALLBSFN/X0010>

События 3

Тип события: предупреждение
Источник события: BizTalk Server 2009
Категория события: BizTalk Server 2009
КОД события: 5743
Описание: Адаптеру не удалось передать сообщения для отправки порт «<send port="">» в URL-адрес «<url>». Он будет повторно после интервала повтора для данного порта отправки. Подробности: "передающий сообщение об ошибке: <soap-env:fault xmlns:soap-env=" xmlns:soap-env=""></soap-env:fault xmlns:soap-env="></url></send>http://schemas.xmlsoap.org/SOAP/Envelope/

"><faultcode>SOAP-ENV:Client</faultcode><faultstring>код запроса: неизвестный</faultstring>

Тип исключения: Метод не существует
Сведения об исключениях:
Исключение:
Недопустимый конечный. X0010GetNextNumber@JDE://CALLBSFN/X0010>".

Причина

Эти проблемы возникают из-за ошибки в адаптеров BizTalk для корпоративных приложений.

Решение

Сведения об исправлении

Корпорация Майкрософт выпустила исправление. Однако данное исправление предназначено для устранения проблемы, описанной в этой статье. Это исправление необходимо применяйте только в тех системах, в которых наблюдается проблема, описанная в данной статье. Это исправление может проходить дополнительное тестирование. Таким образом Если не представляет особой важности, эта проблема, рекомендуется отложить ее решение до выхода ближайшего пакета обновления, содержащего это исправление.

Если исправление доступно для загрузки, имеется раздел «Исправление доступно для загрузки» в верхней части статьи базы знаний. Если этот раздел не отображается, обратитесь к технической поддержки и службу поддержки для получения исправления.

Примечание Если возникают другие проблемы или необходимо устранить неполадки, возможно создать отдельный запрос на обслуживание. Затраты на обычные службы поддержки будет применяться к дополнительные вопросы и проблемы, не связанные с данным исправлением, оплачиваются. Для получения полного списка телефонов службы поддержки и обслуживания клиентов корпорации Майкрософт или создать отдельный запрос посетите следующий веб-узел корпорации Майкрософт:
http://support.Microsoft.com/contactus/?ws=Support
Примечание В форме «Исправление доступно для загрузки» отображаются языки, для которых доступно исправление. Если язык не отображается, это потому, что исправление для данного языка отсутствует.

Необходимые условия

Данное исправление необходимо иметь адаптеров BizTalk для корпоративных приложений (также известный как бизнес-адаптеров BizTalk) установлен. Кроме того компьютер должен работать под управлением BizTalk Server 2006 R2 с пакетом обновления 1 (SP1) или BizTalk Server 2009.

Необходимость перезагрузки

После установки данного исправления перезагружать компьютер не нужно.

Сведения о замене исправлений

Это исправление не заменяет других исправлений.

Сведения о файле

Английская версия исправления содержит атрибуты файла (или более поздними), приведенные в следующей таблице. Дата и время для файлов указаны в формате общего скоординированного времени (UTC). При просмотре сведений о файле, он преобразуется в локальное время. Чтобы узнать разницу между временем UTC и местным временем, следует использовать Часовой пояс на вкладке Дата и время элемент панели управления.
Для BizTalk Server 2006 R2 SP1
Свернуть эту таблицуРазвернуть эту таблицу
Имя файлаВерсия файлаРазмер файлаДатаВремяПлатформа
Microsoft.BizTalk.Adapters.bizutil.dll1.0.5022.13164,23208-Авг-201116: 47X86
Для BizTalk Server 2009 г.
Свернуть эту таблицуРазвернуть эту таблицу
Имя файлаВерсия файлаРазмер файлаДатаВремяПлатформа
Microsoft.BizTalk.Adapters.bizutil.dll1.0.5102.2156,04028 Июля 2010 г.10: 30X86

Применение исправления

Это исправление после установки, выполните следующее:
  1. Вручную Зарегистрируйте файл Microsoft.BizTalk.Adapters.BizUtil.dll в глобальный кэш сборок (GAC). Чтобы сделать это, выполните следующие действия.

    1. Открыть Visual Studio командной строки -или- Командная строка пакета SDK окно. Измените текущий каталог на следующие:
      %ProgramFiles%\Common Files\Microsoft адаптеров BizTalk для Applications\Bin предприятия
      Важные Чтобы открыть Visual Studio командной строки окно, необходимо иметь Visual Studio 2008 Microsoft или Microsoft 2005 Visual Studio установки. Чтобы открыть Командная строка пакета SDK окно, необходимо наличие Microsoft.NET Framework 2.0 SDK установлен.
    2. В Visual Studio командной строки -или- Командная строка пакета SDK окно, введите следующую команду и нажмите клавишу ВВОД:
      Gacutil /i Microsoft.BizTalk.Adapters.BizUtil.dll
  2. Создайте новый раздел в реестре. Чтобы сделать это, выполните следующие действия.

    Предупреждение Неправильное изменение реестра с помощью редактора реестра или иным способом могут возникнуть серьезные проблемы. Эти проблемы могут привести к необходимости переустановки операционной системы. Корпорация Майкрософт не гарантирует, что эти проблемы можно разрешить. Изменение реестра на свой страх и риск.
    1. Нажмите кнопку Начало, выберите пункт выполнить, введите regedit, а затем нажмите кнопку ОК.
    2. Найдите и выделите следующий раздел реестра:
      Для 32-разрядной операционной системы
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalkAdapters
      Для 64-разрядной операционной системы
      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\BizTalkAdapters
    3. На Редактирование Выберите пункт Новый, а затем нажмите кнопку Значение типа DWORD.
    4. Тип AgentOutboundTimeout, а затем нажмите клавишу ВВОД.
    5. На Редактирование меню, нажмите кнопку Изменить.
    6. Выберите Десятичное, тип 60000, а затем нажмите кнопку ОК.
    В AgentOutboundTimeout значение используется для перезапуска RunTimeAgent процессы по истечении определенного периода времени бездействия. Рекомендуется установить значение, таким образом, чтобы он больше, чем время, необходимое для выполнения операции для выполнения на сервере Oracle. По умолчанию значение равно 60 000 миллисекунд (1 минута).

Статус

Корпорация Майкрософт подтверждает, что это проблема в продуктах Майкрософт, перечисленных в разделе «Относится к».

Дополнительная информация

Для получения дополнительных сведений о адаптер BizTalk для JD Эдвардса EnterpriseOne посетите следующий веб-узел Microsoft Developer Network (MSDN):
Общие сведения о адаптер BizTalk для EnterpriseOne Эдвардса JD
Для получения дополнительных сведений о адаптер BizTalk для JD Эдвардса OneWorld XE посетите следующий веб-узел MSDN:
Общие сведения о адаптер BizTalk для JD Эдвардса OneWorld XE
Для получения дополнительных сведений о Visual Studio командной строки окна, посетите следующий веб-узел MSDN:
Общие сведения о "Visual Studio" Командная
Для получения дополнительных сведений об исправлениях, BizTalk Server обратитесь к следующей статье Microsoft Knowledge Base:
2003907 Сведения об исправлениях, BizTalk Server

Свойства

Код статьи: 2291479 - Последний отзыв: 19 августа 2011 г. - Revision: 3.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft BizTalk Server 2009 Branch
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2009 Standard
  • Microsoft BizTalk Server 2006 R2 Service Pack 1 на следующих платформах
    • Microsoft BizTalk Server 2006 R2 Branch
    • Microsoft BizTalk Server 2006 R2 Developer Edition
    • Microsoft BizTalk Server 2006 R2 Enterprise Edition
    • Microsoft BizTalk Server 2006 R2 Standard Edition
Ключевые слова: 
kbautohotfix kbqfe kbhotfixserver kbexpertiseadvanced kbsurveynew kbbiztalk2009presp1fix kbbtsadapters kbmt KB2291479 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:2291479

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com