Article ID: 2297543 - Last Review: April 28, 2011 - Revision: 10.0

Performance problems when you try to access folders in a secondary mailbox in Outlook 2010

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Symptoms

When you try to access folders in a secondary Microsoft Exchange Server mailbox that was added to your Microsoft Outlook 2010 profile, you may experience random performance problems or errors.

For example, you may find errors that resemble the following in the synchronization log messages in the \Sync Issues folder:

13:22:28 Synchronizer Version 12.0.6529
13:22:28 Synchronizing Mailbox 'TeamShared'
13:22:28 Synchronizing Hierarchy
13:22:28 Error Synchronizing Hierarchy for Mailbox 'TeamShared'
13:22:28 [80040305-54A-4DE-1900]
13:22:28 Your server administrator has limited the number of items you can open simultaneously. Try closing messages you have opened or removing attachments and images from unsent messages you are composing.
13:22:28 Microsoft Exchange Information Store
13:22:28 For more information on this failure, click the URL below:
13:22:28 http://www.microsoft.com/support/prodredirect/outlook2000_us.asp?err=80040305-54a-4de-1900
13:22:28 Error synchronizing folder

13:22:31 Synchronizing local changes in folder 'TeamShared - Level1'
13:22:31 Error synchronizing folder
13:22:31 [80040305-54A-4DE-421]
13:22:31 Your server administrator has limited the number of items you can open simultaneously. Try closing messages you have opened or removing attachments and images from unsent messages you are composing.
13:22:31 Microsoft Exchange Information Store
13:22:31 For more information on this failure, click the URL below:
13:22:31 http://www.microsoft.com/support/prodredirect/outlook2000_us.asp?err=80040305-54a-4de-421

Note You must select the Folder List module on the Navigation pane to see the \Sync Issues folder in your mailbox.

Cause

This problem may occur if the following conditions are true:

  • The secondary mailbox that you are trying to access is added to your Outlook profile so that it appears in the Navigation pane.

    Note You add secondary mailboxes to your profile through the Advanced tab in the Microsoft Exchange dialog box.


  • This secondary mailbox contains many folders.
  • Your profile is configured in Cached Exchange Mode.
  • The default option to Download shared folders is enabled in your profile.

This problem occurs because Outlook 2010 locally caches (in your Outlook data file [.ost]) all folders to which you have access in the secondary mailbox. This is a change from earlier versions of Outlook. Outlook 2003 does not cache any shared folders, and by default, Outlook 2007 caches only those shared folders that do not contain email (such as Calendar, Contacts, and Tasks).

Resolution

To resolve this problem, use one of the following workarounds.

Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 How to back up and restore the registry in Windows XP and Windows Vista

Method 1: Disable caching of email folders

To have us disable the caching of email folders for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me

To fix this problem automatically, click the Fix this problem link. Then click Run in the File Download dialog box, and follow the steps in this wizard.

Fix this problem
Microsoft Fix it 50622



Note This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.

Note If you are not on the computer that has the problem, you can save the automatic fix to a flash drive or to a CD so that you can run it on the computer that has the problem.

Let me fix it myself

To disable the caching of email folders but to still allow for the caching of non-email folders, follow these steps:

  1. Exit Outlook 2010.
  2. Start Registry Editor.

    In Windows Vista and in Windows 7:

    Click Start, type regedit in the Start Search box, and then press ENTER.

     If you are prompted for an administrator password or for confirmation, type the password, or click Allow.

    In Windows XP

    Click Start, click Run, type regedit, and then click OK
  3. Locate and then click the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Cached Mode

    Note If the Cached Mode key does not exist, create this key by following these steps:

    a.  Select the Outlook key. 
    b.  On the Edit menu, point to New, and then click Key
    c.  Type Cached Mode, and then press ENTER. 
    d.  Select the Cached Mode key, and then go to step 4.
      
  4. On the Edit menu, point to New, and then click DWORD Value.  
  5. Type CacheOthersMail, and then press ENTER.  
  6. On the Edit menu, click Modify.  
  7. Type 0, and then click OK.  
  8. Exit Registry Editor.  
  9. Start Outlook 2010.

After you make this change, Outlook 2010 functionality will match the default functionality in Outlook 2007. If you are working offline, only non-email folders in the secondary mailbox will be available to you.

Method 2: Disable caching of all shared folders

To disable the caching of all shared folders, follow these steps:

  1. On the File tab, click Account Settings in the Account Settings list.
  2. In the Account Settings dialog box, click the E-mail tab and then double-click your Microsoft Exchange Server account.
  3. In the Change Account dialog box, click More Settings.
  4. In the Microsoft Exchange dialog box, click the Advanced tab.
  5. Click to clear the Download shared folders check box.


  6. Click OK two times.
  7. Click Next, click Finish, and then click Close.
  8. Restart Outlook.

After you make this change, none of the shared folders in the secondary mailbox will be available to you in Outlook when you are working offline. However, all folders in the primary mailbox will still be available to you when you are working offline.

Method 3: Change the configuration of the secondary Exchange mailbox to a second Exchange account in your profile

If you want to cache all folders in the secondary Exchange mailbox, follow these steps to modify your Outlook profile so that the secondary mailbox is added as a second Exchange account.

Note To follow these steps, you must either know the password for the account of the secondary mailbox or you must have full mailbox permissions to the account for the secondary mailbox. See your Exchange Server administrator for this information or permissions.

  1. On the File tab, click Account Settings in the Account Settings list.
  2. In the Account Settings dialog box, click the E-mail tab, and then double-click your Microsoft Exchange Server account.
  3. In the Change Account dialog box, click More Settings.
  4. In the Microsoft Exchange dialog box, click the Advanced tab.
  5. Click the Advanced tab. In the Mailboxes section, select the secondary mailbox, and then click Remove.
  6. Click Yes when you are prompted to confirm the removal of the mailbox.
  7. Click OK, click Next, click Finish, and then click Close.

    At this point, the secondary Exchange mailbox is no longer associated with your Outlook profile.
  8. Exit Outlook.
  9. Open the Mail item in Control Panel.
  10. Select your profile, and then click Properties.
  11. Click E-mail Accounts.
  12. On the E-mail tab of the Account Settings dialog box, click New.
  13. In the Choose Service section of the Add New Account dialog box, click E-mail Account, and then click Next.

    If you know the password for the secondary mailbox account, go to step 14.

    If you do not know the password for the secondary mailbox account, but your account has full mailbox permissions to this secondary mailbox, go to step 18.

  14. In the Auto Account Setup section of the Add New Account dialog box, enter the following account information for the secondary mailbox, and then click Next.

       Name
       Email address
       Password



  15. After the account has successfully been configured, click Finish.
  16. Click Close, click Close, and then click OK.
  17. Go to step 22.
  18. In the Auto Account Setup section of the Add New Account dialog box, click Manually configure server settings or additional server types, and then click Next.
  19. In the Choose Service section of the Add New Account dialog box, click Microsoft Exchange or compatible service, and then click Next.
  20. In the Server Settings section of the Add New Account dialog box, enter the following information for the secondary mailbox, and then click Next.

       Server (this is the Exchange server name)
       Use Cached Exchange Mode (enabled to allow the secondary mailbox to be cached locally in your .ost file)
       User name


  21. Click Finish, click Close, click Close, and then click OK.
  22. Start Outlook.

Note If your account does not have full mailbox permissions to the secondary mailbox, you will be prompted for the account credentials to the secondary mailbox.

More Information

You may experience the following specific issues when you use Outlook 2010 after you make the configuration changes that are specified in Method 3 in the "Resolution" section.

  • New email alerts are displayed for both Exchange mailboxes.


  • Messages that are marked as private can be viewed in the second Exchange mailbox even though the account of the first Exchange mailbox is not specifically configured to allow for the viewing of private messages.


APPLIES TO
  • Microsoft Outlook 2010
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