Удаление метаданных в документах Microsoft Word 2000

Переводы статьи Переводы статьи
Код статьи: 237361 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Аннотация

В этой статье описываются различные методы, которые можно использовать для уменьшения объема метаданных в документах Word.

При каждом создании, открыть или сохранить документ в Microsoft Word 2000 документ может содержать содержимое, которое не нужно использовать совместно с другими пользователями при распространением документа в электронном виде. Эта информация называется «метаданные». Метаданные используются для различных целей для улучшения редактирования просмотра, хранения и извлечения документов Microsoft Office.

Некоторые метаданные легко получить через интерфейс пользователя Microsoft Word; другие метаданные доступны только через чрезвычайных средств, таких как Открытие документа в Редактор низкого уровня двоичный файл. Ниже приведены некоторые примеры метаданных, которые могут быть хранящиеся в документах:
  • Ваше имя
  • Инициалы
  • Название вашей компании или организации
  • Имя вашего компьютера
  • Имя сетевого сервера или жестком диске, где сохранен Документ
  • Другие свойства и сводные сведения о файлах
  • Невидимые элементы внедренных объектов OLE
  • Имена авторов предыдущего документа
  • Изменения документа
  • Версии документа
  • Сведения о шаблоне
  • Скрытый текст
  • Комментарии
Метаданные создаются различными способами в документах Word. Как в результате отсутствует единый метод для удаления такого содержимого из вашего документы. В следующих разделах описаны области, где могут храниться метаданные в Документы Word.

Удаление имени пользователя из документов

Чтобы просмотреть или изменить имя пользователя, выполните следующие действия:
  1. Нажмите кнопку Параметры В меню Сервис меню. Выберите Сведения О пользователе Вкладка.

    Отображаются следующие поля:
    Имя
    Краткое название
    Почтовый адрес
  2. Если не хотите, эта информация появится в Введите документы, содержащие идентификационной строки и пробелы в соответствующие изменения поля, а затем нажмите кнопку ОК Чтобы принять изменения.
ПРИМЕЧАНИЕ: Эта информация будет включаться все новые документы, создаваемые вместо значения по умолчанию, введенных при установке Microsoft Office. Тем не менее, существующие документы уже может содержать эту информацию.

Удаление кратких личных сведений

При создании или сохранении документа в Microsoft Word, сведения могут быть сохранены в документе. Существует несколько методов, которые можно использовать для доступа Эта информация:

  • Откройте документ. На Файл меню, нажмите кнопку Свойства. В Сводка, Статистика, Содержание, и Настройка вкладки могут быть заданы различные свойства, такие как имя, ваш имя руководителя и название организации.
  • В проводнике Windows щелкните правой кнопкой мыши документ, а затем Нажмите кнопку Свойства в контекстном меню. Вкладки Свойства диалоговое окно может содержать данные.
  • Можно использовать Visual Basic для приложений макроса или другой программный код для чтения свойства, показанные в Свойства диалоговое окно.
Чтобы удалить суммарную информацию из существующего документа или шаблон, выполните следующие действия:
  1. Откройте документ или шаблон.
  2. На Файл меню, нажмите кнопку Свойства.
  3. На Сводка Вкладка, очистить Автор, Руководитель, Компания, и любые другие поля, которые вы не хотите ввода распространение.
  4. На Настройка Вкладка, удалите все свойства, которые содержат сведения, которые можно сделать желательно не распространять.
  5. Закончив, нажмите кнопку ОК. Нажмите кнопку Сохранить В меню Файл меню, а затем нажмите кнопку Закрыть В меню Файл меню.
После выполнения этих действий документ не следует содержит итоговые свойства.

Удаление кратких личных сведений при подключении к сети

Если вы вошли в сеть, сетевое имя пользователя может отображаются в Автор поле редактирования на Сводка вкладки и в Автор на Статистика вкладки, при сохранении документа. Это может произойти даже в том случае, если у вас есть удалить все личные сведения с компьютера.

Для удаления Сводные данные из документа при работе в сети:
  1. Если документ хранится на сетевом сервере, скопируйте его в локальный жесткий диск.
  2. Запустите компьютер, но не входите в сеть. Когда появится диалоговое окно входа в сеть, нажмите кнопку Отмена или нажмите клавишу ESCAPE.

    ПРИМЕЧАНИЕ: Если не удается запустить Windows путем (например, нажатие клавиши ESCAPE компьютер работает под управлением Windows NT), невозможно продолжить эти действия.
  3. Откройте документ.
  4. На Файл меню, нажмите кнопку Свойства.
  5. На Сводка Вкладка, очистить Автор, Руководитель, Компания, и любые другие изменения полей, содержащих сведения, не требуется распределить.
  6. На Настройка Вкладка, удалите все свойства, которые содержат сведения, которые можно сделать желательно не распространять.
  7. Закончив, нажмите кнопку ОК. Нажмите кнопку Сохранить В меню Файл меню. Нажмите кнопку Закрыть В меню Файл меню.
При входе в сеть не открывайте файл. В противном случае сетевое имя пользователя может быть записан в файл. Тем не менее можно использовать проводник Windows, чтобы скопировать файл в любой сети сервер или на дискете.

Удаление примечаний в документах

Microsoft Word предлагает возможность добавления комментариев к документам. Обычно примечания содержат имя их автора, таким образом, можно сказать, кто написал их.

Примечания обычно отображаются как выделенный текст; щелкнуть правой кнопкой мыши внутри комментария, а затем Нажмите кнопку Удалить комментарий в контекстном меню.

Все новые комментарии, созданные не должен содержать ваше имя пользователя, так как удалено из вашего Параметры диалоговое окно «», как было показано ранее.

Удаление колонтитулов из документов

Верхние и нижние колонтитулы в документы могут содержать определение сведения. Чтобы удалить сведения из верхних и нижних колонтитулов.
  1. На Представление меню, нажмите кнопку Верхний и нижний колонтитулы.
  2. Верхний и нижний колонтитулы отображаются в верхней и нижней части каждого страница в документе; измените их, как требуется.
  3. Закончив, нажмите кнопку Закрыть В меню Верхний и нижний колонтитулы панель инструментов.

Удаление записи исправлений

Документы могут содержать записанные исправления, в которых для узнать, кто внес изменения в документ. Когда вы принимаете или отклоняете пометки исправлений текст сохраняется в документе и версия пометки были удалены.

Чтобы принять или отклонить исправления:
  1. На Сервис Выберите пункт Отслеживание изменений и выберите команду Принятие или отклонение Изменения.
  2. В Принять или отклонить изменения диалоговое окно Используйте два Найти кнопки для поиска конкретного исправления по отдельности принимать или Щелкните или отклонить Принять все -или- Отменить все.
  3. Закончив, нажмите кнопку Закройте.

Отключение быстрого сохранения

Функция быстрого сохранения ускоряет процесс сохранения документа Сохранение только изменения, внесенные в документ.

Из-за Дизайн функция быстрого сохранения, может текст, который необходимо удалить из документа даже после сохранения документа, остаются в документе. Если пользователь опасается о удаленный текст, оставшихся в документах, необходимо выполнить следующие шаги:

  1. На Сервис меню, нажмите кнопку Параметры.
  2. Выберите Сохранить Вкладка.
  3. Снимите флажок Разрешить быстрое сохранение. загрузке поле. Нажмите кнопку ОК.
Для получения дополнительных сведений о быстрое сохранение см следующие статьи базы знаний Майкрософт:
211209 Wd2000: Открытие документа Word в текстовом редакторе отображаются удаленный текст
197978 Wd2000: Часто задаваемые вопросы О «Разрешить быстрое сохранение»

Поиск и удаление текста, отформатированный как скрытый

В документах Microsoft Word имеется возможность форматировать текст как скрытые. Так как скрытый текст может содержать сведения, не рекомендуется распространять, вы можно отобразить и удалите его. Чтобы удалить весь текст в документе, форматируется как скрытый, выполните следующие действия:

  1. На Сервис меню, нажмите кнопку Параметры. Выберите Представление Вкладка.
  2. Выберите Скрытый текст флажок, и выберите команду ОК.
  3. На Редактирование меню, нажмите кнопку Замена.
  4. Нажмите кнопку Более кнопку, чтобы развернуть диалоговое окно.
  5. Щелкните в поле ввода рядом с Найти что.
  6. Нажмите кнопку Формат Кнопка, а затем нажмите кнопку Шрифт. Выберите Скрытые флажок, а затем Нажмите кнопку ОК.
  7. Нажмите кнопку Заменить все.
Весь скрытый текст будет удален из документа. Чтобы отключить Отображение скрытого текста, выполните следующие действия:
  1. На Сервис меню, нажмите кнопку Параметры. Выберите Представление Вкладка.
  2. Снимите флажок Скрытый текст флажок. Нажмите кнопку ОК.

Удаление гиперссылок из документов

Документы могут содержать гиперссылки на другие документы или веб-страниц в интрасети или Интернете. Гиперссылки обычно отображаются как синий подчеркнутый текстовые строки.

Чтобы вручную удалить из документа одну гиперссылку Щелкните правой кнопкой мыши гиперссылку и выберите последовательно пункты Гиперссылка в контекстном меню, а затем нажмите Удаление гиперссылки.

Если вы хотите удалить все гиперссылки в документе для этого можно использовать Visual Basic для приложений макроса. Ниже пример Visual Basic для приложений макроса удаляет все гиперссылки документ.

ПРИМЕЧАНИЕ: В приведенный ниже макрос удаляется только ссылка. В текст гиперссылки остается в документе.

Sub RemoveHyperlinks()

Dim oDoc As Document
Dim oStory As Range
Dim oHlink As Hyperlink

For Each oStory In ActiveDocument.StoryRanges
    For Each oHlink In oStory.Hyperlinks
        oHlink.Delete
    Next
Next

End Sub
				
Чтобы удалить все следы гиперссылки и текст гиперссылки из документа, которые можно использовать приведенный ниже макрос.
Sub RemoveAllHyperlinks()

Dim oDoc As Document
Dim oStory As Range
Dim oHlink As Hyperlink

For Each oStory In ActiveDocument.StoryRanges
    For Each oHlink In oStory.Hyperlinks
        oHlink.Range.Delete
    Next
Next

End Sub
				
Для получения дополнительных сведений о способах использования образца кода в этой статье щелкните следующий номер статьи базы знаний Майкрософт Основание:
212536OFF2000: Как запуск кода примера из статей базы знаний

Удаление стилей из документов

Документы могут включать стили, содержащие метаданные. Вы можете удалить эти стили или переименовать их. Для этого:
  1. Откройте документ, содержащий стили.
  2. На Формат меню, нажмите кнопку Стиль.
  3. Выберите стиль, который нужно удалить или переименовать. Нажмите кнопку Удалить Чтобы удалить стиль, или нажмите кнопку Изменить Чтобы переименовать его.

Удаление старых версий файлов из документов

Microsoft Word включает в себя компонент версии файла, который позволяет сохранить несколько версий одного документа в одном файле. Требуется удалить более ранние версии документа, прежде чем использовать его совместно с другими пользователями.

Для Удаление одного или нескольких версий документа, выполните следующие действия:
  1. На Файл меню, нажмите кнопку Версии.
  2. Выберите версию документа, которую требуется удалить. Можно выбрать более одной версии, нажав клавишу CTRL при выделении версии.
  3. Нажмите кнопку Удалить.
  4. Завершив удаление старых версий документ, нажмите кнопку Сохранить В меню Файл меню.

Удаление связей из кодов полей

Может содержать связанные изображения и другие объекты в документы Word информацию о связи, такие как путь к связанному изображению или объекту. Вы можете Удалите информацию о связи из документа, изменив поля коды.

Чтобы отобразить коды полей:

  1. На Сервис меню, нажмите кнопку Параметры. Выберите Представление Вкладка.
  2. Выберите Коды полей флажок. Нажмите кнопку ОК.
Когда коды полей будут видны, появится ли какая-либо из них Содержит идентификационные сведения.

Чтобы удалить информацию о связи из связанного изображения или другого объекта:
  1. Выберите связанное изображение или объект. Или выделите код поля для изображения или объекта, если коды полей отображаются.
  2. Нажмите сочетание клавиш CTRL + SHIFT + F9.
Рисунок или объект является теперь несвязанные. Обратите внимание, что отмена связи изображения или объекта может привести к его недоступный для редактирования.

Как удалить имя и расположение шаблона

Все документы, созданные в Microsoft Word на основе шаблона. По по умолчанию, это файл шаблона Normal.dot, расположенный в папке «Шаблоны». Тем не менее можно создать документ, основанный на основе другого шаблона другое место. Путь и имя этого шаблона, хранятся в Свойства документа.

Чтобы просмотреть имя и расположение шаблона, нажмите кнопку Свойства В меню Файл и выбрать пункт Сводка Вкладка.

Даже в том случае, если шаблон не отправлять документ, документ сохраняет имя и расположение шаблона. Для изменения имя и расположение шаблона для определение значений, выполните следующие действия:
  1. На Сервис меню, нажмите кнопку Шаблоны и надстройки.
  2. Нажмите кнопку Присоединение.
  3. Выберите шаблон, который имеет имя и местоположение, которые не являются конфиденциальные или уникальным. Например так как каждый компьютер с Microsoft Установлен Word имеется файл Normal.dot, может возникнуть необходимость выбрать Normal.dot.
  4. Нажмите кнопку Открыть. Нажмите кнопку ОК.
ПРИМЕЧАНИЕ: Шаблон может содержать макросы, элементы автотекста, настраиваемые стили и пользовательские панели инструментов. Изменение шаблонов может сделать некоторые из этих элементов недоступен для вашего документа.

Удаление сведений О маршруте

Если отправить документ по электронной почте, используя маршрут рассылки сведения о маршрутизации могут быть присоединены к документу. Чтобы удалить эту информацию из документа необходимо сохранить документ в формате, который не сохраняются сведений о маршруте.

В Microsoft Word сохраните документ в RTF (формат RTF) или в формате HTML. Закройте документ, а затем Откройте новый файл. Поскольку сведений о маршруте больше нет, Теперь можно сохранить документ в формате Microsoft Word.

Вы можете Кроме того, выполните следующие действия:
  1. Отключить Разрешить быстрое сохранение. с помощью инструкции этой статьи.
  2. На Файл Выберите пункт Отправить, а затем нажмите кнопку Другой адресат.
  3. Нажмите кнопку Очистить Чтобы удалить маршрут. Нажмите кнопку ОК.
  4. На Файл меню, нажмите кнопку Сохранить.
Документ будет сохранен без любой маршрут сведения.

Как удалить имена авторов предыдущих

Microsoft Word сохраняет имена последних 10 человек работали документ в документе. Это автоматическая функция, не может быть включен «отключить».

Тем не менее, можно удалить имена последних 10 авторов из документ путем сохранения документа в формате, который не содержит таких сведения. Например, если сохранить документ в любом формате RTF (Rich Text Формат) или формата HTML разработки информация будет потеряна. После этого можно закрыть и снова открыть RTF и HTML-документ и сохраните его в Microsoft Word формат.

Как удалить свое имя из кода Visual Basic

При записи макроса Visual Basic в приложении Word, записанного макроса начинается с заголовка, подобное следующему:

   ' Macro1 Macro
   ' Macro recorded 3/11/1999 by <User Name>
				
Чтобы удалить свое имя из записанных макросов:
  1. Откройте документ, содержащий макросы.
  2. На Сервис Выберите пункт Макрос, а затем нажмите кнопку Редактор Visual Basic. Или нажмите сочетание клавиш ALT + F11.
  3. В окне проекта дважды щелкните модуль, содержит макросы.
  4. Удаление имени из кода записанного макроса.
После удаления своего имени нажмите клавиши ALT + Q, чтобы вернуться в программу. Нажмите кнопку Сохранить В меню Файл меню.

Удаление ссылок Visual Basic на другие файлы

В редакторе Visual Basic, существует возможность создать ссылку в другой файл. Если пользователь открывает документ, содержащий ссылки на другую файлы, он может просматривать имена файлов, на которые имеются ссылки.

Для удаления Эти ссылки, выполните следующее:
  1. Откройте документ, содержащий ссылки.
  2. На Сервис Выберите пункт Макрос, а затем нажмите кнопку Редактор Visual Basic. Или нажмите сочетание клавиш ALT + F11.
  3. На Сервис меню, нажмите кнопку Ссылки.
  4. Снимите флажок рядом с указанного файла или файлы. Закончив, нажмите кнопку ОК.
  5. Нажмите клавиши ALT + Q.
  6. На Файл меню, нажмите кнопку Сохранить.
ПРИМЕЧАНИЕ: Удаление ссылки на другие файлы могут снизить возможность макросы в документе для правильного функционирования.

Удаление сведений О жестком диске или сети

При сохранении документа на локальном жестком диске или в сети сервер, сведения, идентифицирующие жесткий диск или сетевой сервер может записи в документ.

Чтобы удалить эту информацию из документ, выполните следующие действия:
  1. Откройте документ.
  2. На Файл меню, нажмите кнопку Сохранить как. Сохраните документ в дисковод гибких дисков (как правило, A:).
  3. На Файл меню, нажмите кнопку Закрыть.
  4. Выньте дискету с гибкого диска диск.
Теперь можно использовать проводник Windows для копирования документа из гибкий диск для любого жесткого диска или сетевого сервера.

ПРИМЕЧАНИЕ: Чтобы из-за ограниченности места на дискете (обычно 1,44 МБ), этот метод не может использоваться, если размер файла превышает объем свободного места на дискете.

Внедренные объекты в документы могут содержать метаданные

Если объект, внедренный в документ, он сохраняет собственные свойства, независимо от того, что сделать, чтобы документ. Например если внедрить в книгу Microsoft Excel в документ Word, документ и Каждая книга имеет собственные свойства.

Удалить метаданные из внедренный объект, активируя объект, удаляя все метаданные, как описано ранее, повторная активация документом-контейнером (для предыдущего примера это Представляет документ Word) и затем сохранение документом-контейнером.

ПРИМЕЧАНИЕ: При активации объекта, внедренного в документ, только часть внедренный объект, который отображается в документе. объект может содержать Дополнительную информацию, которая не отображается. Если требуется, чтобы документ содержал Вырезать только отображают внедренного объекта, а не фактическое содержимое Объект, а затем использовать Специальная команды Редактирование Чтобы вставить объект в документ, используя метафайл формат. После этого, больше не может редактировать внедренный объект; Тем не менее, он не будет содержать какие-либо метаданные.

Метаданные в переменных документа

Корпорация Майкрософт предлагает примеры программного кода только для иллюстрации Это включает, но не ограничивается, подразумеваемые гарантии товарности или пригодности для определенной цели. В данной статье предполагается, что вы знакомы с языком программирования предложенном и с помощью средств, которые используются для создания и отладки. Сотрудники службы поддержки Майкрософт могут пояснить конкретной процедуры, но они будут изменять примеры для реализации дополнительных возможностей или удовлетворения конкретных требований.
Для получения дополнительных сведений об использовании пример кода в данной статье, щелкните следующий номер статьи для просмотра статьи в Microsoft Knowledge Base:
212536OFF2000: Как запуск кода примера из статей базы знаний
Для удаления переменных документа, содержащегося в документе Word Используйте следующий пример макроса:
Sub DeleteDocVars()

Dim Response
Dim myVar As Variable

   For Each myVar In ActiveDocument.Variables
      Response = MsgBox("The document variable: " & myVar.Name & vbCr & _
         "Value: " & myVar.Value & vbCr & vbCr & _
         "Do you want to delete the variable from this document?", vbYesNo)
            
      If Response = "6" Then
         ' Delete the variable.
         myVar.Delete
      Else
         End
      End If
   Next myVar
            
   MsgBox "There are no variables in the document."
   
End Sub
				
Для получения дополнительных сведений о переменных в Visual Basic Редактор, нажмите кнопку Справка по Microsoft Visual Basic В меню Справка Тип меню Свойства переменных в поле помощника Office или мастера ответов и нажмите кнопку Поиск Чтобы просмотреть раздел.

Общие рекомендации по обеспечению безопасности

Ниже приведены некоторые общие предложения, которые можно использовать для увеличения уровень безопасности рабочей среды:
  • Каждый раз, когда вы не за компьютером, защитить его с защищенную паролем экранную заставку, пароля при включении питания или блокировки Windows NT функция.
  • Если на компьютере есть общие папки, убедитесь, что Применение паролей для их таким образом, чтобы доступ к ним только авторизованным пользователям. Усовершенствовании безопасности используйте управление доступом на уровне пользователей, таким образом, вы можете управлять точно кто имеет доступ к общим ресурсам на компьютере.
  • При удалении файла немедленно очистите корзину. Необходимо рассмотреть программу, которая полностью стирает или перезаписывает файлы когда они будут удалены.
  • При резервном копировании данных хранения резервной копии файлов безопасное расположение, такое как сейф, банковская ячейка или заблокированный CAB-файл. Храните одну копию в надежном расположении резервных копий в случае вашего первичным расположением является недоступным.
  • Важные документы должны быть защищена паролем, чтобы сделать Убедитесь, что только авторизованные пользователи могут открывать их. Следует сохранять пароли в безопасных отдельное расположение. Обратите внимание, если не удается вспомнить пароль Невозможно восстановить содержимое защищенной паролем документ.
  • Не распространяйте документы в электронной форме. Вместо этого распечатывайте их. Например, некоторые шрифты не используйте идентификационные элементы водяные знаки, логотипы или специальную бумагу, если не требуется (например, презентации).
  • Электронная почта не является анонимным. Не электронной почты документ, если вы беспокоятся о ваши личные никак документ.
  • Не пересылайте документы через Интернет, используя либо Протокол HTTP или FTP. Информация, передаваемая через эти протоколы отправляется в "Очистить текст", который означает, что технически возможно (Однако маловероятно), для того чтобы Допускается перехват.

Ссылки

Для получения дополнительных сведений

Для получения дополнительных сведений, связанных с тем, обсуждаемых в более ранней версии в этой статье обратитесь к следующим статьям Microsoft Knowledge Основание:
195007 Wd2000: Некоторые свойства документа заполняются автоматически
194606 Wd2000: Сводные сведения, свойства не шифруется
209638 WD: Не запроса пароля «Изменить» в почтовом клиенте

Свойства

Код статьи: 237361 - Последний отзыв: 18 сентября 2011 г. - Revision: 5.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Word 2000 Standard Edition
Ключевые слова: 
kbsavefile kbopenfile kbnewfile kbhowto kbmt KB237361 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:237361

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com