WD2000: Campo texto truncado al mezclar o Insertar base de datos

Seleccione idioma Seleccione idioma
Id. de artículo: 242072 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Al realizar una combinación de correspondencia con una base de datos (o insertar una base de datos) que contiene un NOTES MEMO o campo, sólo los primeros 255 caracteres de las notas o el campo MEMO se combinan (Insertar).

Nota : el nombre de la notas o MEMO campo puede ser diferente; sin embargo, cuando un campo contiene más de 255 caracteres, se truncará el texto del campo.

Causa

Este problema es una limitación de Word 2000 al adjuntar a o insertar archivos de base de datos mediante (Open Database CONNECTIVITY).

Solución

Para solucionar temporalmente este problema, conéctese a o insertar la base de datos utilizando intercambio dinámico de datos (DDE). Para ello, siga los pasos apropiados para su situación.

Realizar una combinación de correspondencia

  1. En el documento principal de combinación de correspondencia, haga clic en Combinar correspondencia en el menú Herramientas .
  2. En Combinar correspondencia , haga clic en crear y haga clic el tipo de combinación de correspondencia que desea realizar. Por ejemplo, haga clic en cartas .
  3. Haga clic en la ventana activa .
  4. En Combinar correspondencia , haga clic en Obtener datos y, a continuación, haga clic en Abrir origen de datos .
  5. En el cuadro de diálogo Abrir origen de datos , siga estos pasos:
    1. Cambie el cuadro tipo de archivo al tipo de la base de datos. Por ejemplo, si la base de datos es una base de datos, cambiar el cuadro Tipo de bases de datos de Microsoft Access (*.mdb, *.mde) .
    2. Active la casilla de verificación Seleccionar método .
    3. Cambie el cuadro Buscar en la carpeta que contiene el archivo de base de datos. Por ejemplo, cambie el cuadro Buscar en para la carpeta C:\Archivos de programa\Microsoft Office\Office\Samples .
    4. Haga clic en el archivo de base de datos. Por ejemplo, haga clic en la base de datos Neptuno.mdb .
    5. Haga clic en Abrir .
  6. En el cuadro de diálogo Confirmar origen de datos , haga clic en Bases de datos de MS Access con DDE (*.mdb, *.mde) y, a continuación, haga clic en Aceptar .
Continúe la combinación de correspondencia como habitual.

Insertar una base de datos

  1. En el documento de Word, elija barras de herramientas en el menú Ver y a continuación, haga clic en la base de datos .
  2. En la barra de herramientas base de datos , haga clic en Insertar base de datos .
  3. Haga clic en obtener datos .
  4. En el cuadro de diálogo Abrir origen de datos , siga estos pasos:
    1. Cambie el tipo de archivo al tipo de la base de datos. Por ejemplo, si la base de datos es una base de datos, cambiar el cuadro Tipo de bases de datos de Microsoft Access (*.mdb, *.mde) .
    2. Active la casilla de verificación Seleccionar método .
    3. Cambie el cuadro Buscar en la carpeta que contiene el archivo de base de datos. Por ejemplo, cambie el cuadro Buscar en para la carpeta C:\Archivos de programa\Microsoft Office\Office\Samples .
    4. Haga clic en el archivo de base de datos. Por ejemplo, haga clic en la base de datos Neptuno.mdb .
    5. Haga clic en Abrir .
  5. En el cuadro de diálogo Confirmar origen de datos , haga clic en Bases de datos de MS Access con DDE (*.mdb, *.mde) y, a continuación, haga clic en Aceptar .

    Nota : quizás tenga que seleccionar una tabla en el cuadro de diálogo Seleccionar tabla .
  6. En el cuadro de diálogo base de datos , haga clic en Insertar datos .
  7. En el cuadro de diálogo Insertar datos , seleccione el rango de registros que desee; por ejemplo, haga clic en All y, a continuación, haga clic en Aceptar .

Solución

Para aumentar la limitación de carácter ODBC de campos al insertar una base de datos o cuando se utiliza una base de datos en una combinación de correspondencia de Word, utilice uno de las siguientes revisiones:

Corregir 1: Aumentar la limitación de caracteres de campo ODBC a 50.000

Para resolver este problema, consiga el Service Pack más reciente para Microsoft Office 2000. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
276367OFF2000: Cómo obtener el Service Pack más reciente de Office 2000
La versión en inglés de esta revisión tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.:
   Date         Time   Version  Size       File name     
   ---------------------------------------------------------
   11-JUN-2002  03:35  n/a      4,001,944  Winword.msp
   11-JUN-2002  05:09  n/a      4,681,888  Winword_admin.msp
				
después instala la revisión, los archivos siguientes tendrán los atributos enumerados o posterior:
   Date         Time   Version     Size        File name     
   -------------------------------------------------------
   07-JUN-2002  14:37  9.0.0.6604  8,818,740   Winword.exe 
				

Nota importante : la limitación al adjuntar a o insertar archivos de base de datos mediante (Open Database CONNECTIVITY) ha aumentado a 50.000 caracteres en un campo de Microsoft Office 2000 Service Release 1 (SR-1). Sin embargo, cuando un campo contiene más de 50.000 caracteres, el texto del campo todavía se truncarán.

Corregir 2: Aumentar la limitación de caracteres de campo ODBC para 2,550

Para resolver este problema, consiga el Service Pack más reciente para Microsoft Office 2000. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
276367OFF2000: Cómo obtener el Service Pack más reciente de Office 2000

Antes de instalar Microsoft Office 2000 Service Pack 3 (SP-3), debe tener Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a) se instaló primero. Para obtener Office 2000 Service Release 1/1a (SR-1/SR-1a), haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
245025OFF2000: Cómo obtener e instalar Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a)

importante : la limitación al adjuntar a o insertar archivos de base de datos mediante (Open Database CONNECTIVITY) ha aumentado a 2,550 caracteres en un campo de Microsoft Office 2000 Service Release 1 (SR-1). Sin embargo, cuando un campo contiene más de 2,550 caracteres, el texto del campo todavía se truncarán.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:" de este artículo. Este problema se corrigió por primera vez en Microsoft Office 2000 Service Pack 3 (SP-3).
El ODBC limitación del NOTES y MEMO de campos al insertar una base de datos o al utilizar una base de datos en una combinación de correspondencia de Word se ha aumentado según a las revisiones descritas en la sección Solución de este artículo.

Más información

Para obtener información adicional acerca de la combinación de correspondencia, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
211190Cómo: Utilizar datos de Access 2000 en Word 2000
212322WD2000: Cómo diseñar y configurar datos de correspondencia
212034WD2000: Cómo crear mediante la correspondencia de etiquetas postales
212017WD2000: Cómo crear sobres mediante combinación de correspondencia

Propiedades

Id. de artículo: 242072 - Última revisión: viernes, 07 de abril de 2006 - Versión: 4.0
La información de este artículo se refiere a:
  • Microsoft Word 2000 Standard Edition
Palabras clave: 
kbmt kbqfe kbhotfixserver kboffice2000sp3fix kbbug kbfix KB242072 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 242072

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com