FIX: "Invalid Date" error occurs when you use the EDI pipeline to receive EDI interchanges in BizTalk Server 2006 R2 or in BizTalk Server 2009 if a data element contains a leap date value

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Article ID: 2435900 - View products that this article applies to.
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SYMPTOMS

When you use the Electronic Data Interchange (EDI) pipeline to receive EDI interchanges in Microsoft BizTalk Server 2006 R2 or Microsoft BizTalk Server 2009, you may receive the following error message in the Application log:

Event Type: Error
Event Source: BizTalk Server 2009 EDI
Event Category: None
Event ID: 8114
Description:
Error encountered during parsing. The X12 transaction set with id '<n>' contained in functional group with id '<n>', in interchange with id '<n>', with sender id '<sender id> ', receiver id '<receiver id>' is being suspended with following errors:
Error: 1 (Field level error)
SegmentID: DTM
Position in TS: 42
Data Element ID: DTM02
Position in Segment: 2
Data Value: leapdate
8: Invalid Date

This issue only occurs when you receive EDI X12 (including HIPAA) interchanges. This issue does not occur when you use EDI EDIFACT interchanges.

EDI Type (Data Element) Validation
http://msdn.microsoft.com/en-us/library/bb226537(BTS.20).aspx


Notes
  • The Event Source is "BizTalk Server 2006 EDI" if you are using BizTalk Server 2006 R2.
  • The placeholder leapdate represents a leap date that is contained in the EDI interchange.

CAUSE

This issue occurs because the EDI interchange cannot validate a data element that contains a leap date value. For example, this issue occurs if the EDI interchange contains the "20120229" date value.

RESOLUTION

Cumulative update information

BizTalk Server 2009

The hotfix that resolves this issue is included in cumulative update package 1 for BizTalk Server 2009.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2429050 Cumulative update package 1 for BizTalk Server 2009

BizTalk Server 2006 R2


The hotfix that resolves this issue is included in cumulative update package 4 for BizTalk Server 2006 R2 SP1.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:

2682056Cumulative update package 4 for BizTalk Server 2006 R2 SP1

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have BizTalk Server 2006 R2 Service Pack 1andCumulative update package 3 for BizTalk Server 2006 R2 Service Pack 1 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

File information

File information for all supported versions of BizTalk Server 2006 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.edi.messagecore.dll3.6.2230.12350,08828-Jan-201118:14x86
Microsoft.biztalk.edi.pipelinecomponents.dll3.6.2230.12190,35228-Jan-201118:14x86
Microsoft.biztalk.edi.reporting.common.dll3.6.2230.1225,48828-Jan-201118:14x86
Microsoft.biztalk.edi.reporting.dll3.6.2230.1255,16828-Jan-201118:14x86
Microsoft.biztalk.edi.schemaeditorextension.dll3.6.2230.12202,64828-Jan-201118:14x86
Microsoft.biztalk.edi.shared.dll3.6.2230.12161,65628-Jan-201118:14x86
Microsoft.biztalk.ediint.reporting.dll3.6.2230.1234,69628-Jan-201118:14x86
Microsoft.biztalk.messaging.dll3.6.2230.1292,02428-Jan-201118:14x86
Microsoft.biztalk.pipeline.components.dll3.6.2230.12292,75228-Jan-201118:14x86
Microsoft.biztalk.pipeline.dll3.6.2230.12292,72828-Jan-201118:14x86
Microsoft.biztalk.streaming.dll3.6.2230.1251,06428-Jan-201118:14x86
Microsoft.biztalk.xpathreader.dll3.6.2230.1279,74428-Jan-201118:14x86
Microsoft.xlangs.basetypes.dll3.6.2230.12104,31228-Jan-201118:14x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
2003907 Information about BizTalk Server hotfixes

Properties

Article ID: 2435900 - Last Review: April 12, 2012 - Revision: 9.0
APPLIES TO
  • Microsoft BizTalk Server 2009 Standard
  • Microsoft BizTalk Server 2009 Branch
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2006 R2 Branch Edition
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Standard Edition
Keywords: 
kbexpertiseadvanced kbqfe kbfix kbsurveynew kbbtsmessaging kbbtspipeline kbautohotfix KB2435900

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