Article ID: 2438651 - Last Review: February 7, 2012 - Revision: 19.0

How to troubleshoot problems when you install or uninstall programs on a Windows-based computer

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Introduction

When you install or uninstall programs on a Windows-based computer, you may experience issues in which the programs may not install or uninstall correctly. 

An automated troubleshooter is available that diagnoses problems that can prevent you from installing and uninstalling programs on a Windows-based computer. This troubleshooter can help with programs that do not uninstall correctly and with issues in which programs may be blocking the installation of other programs. 
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Important The Windows Installer Cleanup utility (MSICUU2.exe) that was previously referred to in this article was discontinued. Although the Windows Installer Cleanup utility resolved some installation problems, it sometimes damaged other components that were installed on the computer. Because of this, the tool was removed from the Microsoft Download Center. The Program Install and Uninstall troubleshooter (http://support.microsoft.com/mats/Program_Install_and_Uninstall) is a replacement for that utility.

If the Program Install and Uninstall troubleshooter does not resolve your issue, you can use the additional steps that follow to resolve the problem.  

If you have to uninstall Microsoft Office, click the link that matches your version of Office:

How to uninstall or remove Microsoft Office 2010 suites (http://support.microsoft.com/kb/290301/)
How to uninstall or remove Microsoft Office 2007 suites (http://support.microsoft.com/kb/928218/)
How to uninstall or remove Microsoft Office 2003 suites (http://support.microsoft.com/kb/2639197/)

If you have to uninstall Microsoft Security Essentials, see the following Microsoft Knowledge Base article:
2435760  (http://support.microsoft.com/kb/2435760/ ) How to manually uninstall Microsoft Security Essentials if you cannot uninstall it by using the Add or Remove Programs item

SYMPTOMS

When you install, uninstall, or update a program on a Windows-based computer, you may receive one of the following error messages:

Error message 1
The Windows Installer Service could not be accessed.
Error message 2
Windows Installer Service couldn’t be started.
Error message 3
Could not start the Windows Installer service on Local Computer. Error 5: Access is denied.

CAUSE

The installation or uninstallation process of a program can fail for several reasons. This article discusses the following issues (Click each issue for related resolution):

RESOLUTION

To resolve these types of issues, follow the steps listed below:

Important You must log on to the computer by using an administrator account. To perform many of the steps in this article, you have to be logged on to a computer that has an account that has administrator rights. To determine whether you are using an account that has administrator rights, follow these steps:
  • In Windows XP or in Windows Server 2003

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  • In Windows Vista or in Windows 7

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Windows Installer issues

The Windows Installer Engine could be corrupted, installed incorrectly, or disabled. This may cause installation issues.

Note The Windows Installer Engine manages the installation of software, manages the additions and deletions of software components, monitors file resiliency, and maintains basic failure recovery by using rollbacks.

Use these methods to identify any Microsoft Installer issues that may be causing problems when you install, uninstall, or update programs. Start with method 1, follow the steps in that method, and then go to the next method if your issue is not resolved.

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Installing or updating programs in Windows may not have completed successfully

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Uninstalling programs in Windows may not have completed successfully

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For more help for your install, uninstall, or update issue

If you followed these steps and the issue is still not resolved you may have to contact Microsoft Support for additional assistance. For information about how to contact Microsoft Support, visit the following Microsoft website. Some charges may apply.
Microsoft Support (http://support.microsoft.com)
You may also want to visit a Microsoft community website where you can ask questions and receive answers from other users for free. Microsoft Answers is a support forum for consumer customers. To visit Microsoft Answers, visit the following Microsoft website:
Microsoft Answers ( http://answers.microsoft.com)

Advanced users

Note The following steps are appropriate for advanced users only.

Manually uninstalling the program

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Check for file or folder names longer than 260 characters

For more about the maximum path length limitation, visit the following Microsoft Developer Network (MSDN) website:

Enable MSI logging, and then read the MSI verbose logs

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REFERENCES

For general information about how to install or to uninstall a program, visit the following Microsoft websites:

Install a program (http://windows.microsoft.com/en-US/windows7/Install-a-program)
Uninstall or change a program (http://windows.microsoft.com/en-US/windows7/Uninstall-or-change-a-program)
Installing programs: frequently asked questions (http://windows.microsoft.com/en-US/windows7/Installing-programs-frequently-asked-questions)



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