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Symptoms

When you install, uninstall, or update a program on a Windows-based computer, you may receive one of the following error messages:

Error message 1
The Windows Installer Service could not be accessed.
Error message 2
Windows Installer Service couldn’t be started.
Error message 3
Could not start the Windows Installer service on Local Computer. Error 5: Access is denied.

Cause

The installation or uninstallation process of a program can fail for several reasons. This article discusses the following issues (Click each issue for related resolution):
  • Windows Installer issues
  • Installing or updating programs in Windows may not have completed successfully
  • Uninstalling programs in Windows may not have completed successfully

Resolution

Fix the problem automatically

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Start the Program Install and Uninstall troubleshooter

Fix the problem manually

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To resolve these kinds of issues, follow the steps listed below:

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Important You must log on to the computer by using an administrator account. To perform many of the steps in this article, you have to be logged on to a computer that has an account that has administrator rights. To determine whether you are using an account that has administrator rights, follow these steps:
In Windows XP or in Windows Server 2003
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  1. Open the Date and Time dialog box.
    1. Click Start, and then click Run.
    2. Type the following command in the Run dialog box, and then press OK:
      timedate.cpl (The screen shot for this step is listed below).
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      The screen shot for this step
  2. Use one of the appropriate steps, depending on the result.
    • If the Date and Time Properties dialog box appears, you are already logged on as an administrator. Click Cancel to close the Date and TimeProperties dialog box. (The screen shot for this step is listed below).
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      The screen shot for this step
    • The following message appears if you are not logged on as an administrator.
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      The screen shot showing the message appears if you are not logged on as an administrator
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In Windows Vista or in Windows 7
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  1. Open the Date and Time dialog box.
    1. Click Start.
    2. Type the following command in the Start Search box or in the Search programs and files box, and then press ENTER:
      timedate.cpl
      The Date and Time dialog box opens. (The screen shot for this step is listed below).
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      The screen shot for this step
  2. Click Change date and time in the Date and Time dialog box. When the User Account Control dialog box opens, click Continue.(The screen shot for this step is listed below).
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    The screen shot for this step
  3. Now, do one of the following, depending on what happens when you click Continue:
    • If your computer does not prompt you for a password
      You are already logged on with an administrator account. Click Cancel two times to close the Date and Time dialog box, and then you are ready to continue with this task.
    • If your computer prompts you for a password
      You are not logged on with an administrator account.
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Windows Installer issues

The Windows Installer Engine could be corrupted, installed incorrectly, or disabled. This may cause installation issues.

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Note The Windows Installer Engine manages the installation of software, manages the additions and deletions of software components, monitors file resiliency, and maintains basic failure recovery by using rollbacks.

Use these methods to identify any Microsoft Installer issues that may be causing problems when you install, uninstall, or update programs. Start with method 1, follow the steps in that method, and then go to the next method if your issue is not resolved.

Click here to view or hide detailed information
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Method 1: Determine whether the Windows Installer engine is functioning

  1. Click Start
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    Start button
    , type cmd in the Search box or click Run then type cmd in the dialog (Windows XP or Windows Server 2003), and then press Enter to open a Command Prompt window.
  2. At the command prompt, type MSIExec, and then press Enter.
  3. If the MSI engine is working, there should be no error messages. If you receive an error message, note the error. If you are proficient in how to use search engines, you can use the error message to help locate additional content to troubleshoot the issue.
  4. Try to install or to uninstall again.

If the problem persists, go to method 2.


Method 2: Make sure that the Windows Installer service is not set to Disabled

  1. Click Start
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    Start button
    , type services.msc in the Search box or click Run then type services.msc in the dialog (Windows XP or Windows Server 2003), and then press Enter to open Services.
  2. Right-click the Windows Installer service, and then click Properties.
  3. If the Startup type box is set to Disabled, change it to Manual.
  4. Click OK to close the Properties window.
  5. Right-click the Windows Installer service, and then click Start. The service should start without errors.
  6. Try to install or to uninstall again.

If the problem persists, go to method 3.

Method 3: Check your version of Windows Installer, and upgrade to the latest version if it is needed

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Important This method applies to Windows XP, to Windows Vista, to Windows Server 2003, to Windows Server 2003 R2, and to Windows Server 2008 only.
  1. Click Start
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    Start button
    , type cmd in the Search box or click Run then type services.msc in the dialog (Windows XP or Windows Server 2003), and then press Enter to open a Command Prompt window.
  2. At the Command Prompt window, type MSIExec, and then press Enter. If the MSI engine is working, there should be no error messages, and a separate dialog box should open. This shows the MSI version.
  3. If the installer version is not version 4.5, see the following article in the Microsoft Knowledge Base for information and for a link to download Windows installer 4.5:
  4. Try to install or to uninstall again.

If the problem persists, go to method 4.


Method 4: Reregister the installer engine

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Important This method applies to Windows XP and to Windows Server 2000 only.
  1. Click Start, click Run then type cmd in the dialog, and then click Command Prompt.
  2. At the command prompt, type the following, and then press Enter after each line:
    MSIExec /unregister

    MSIExec /regserver
  3. Try to install or to uninstall again.
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Installing or updating programs in Windows may not have completed successfully

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The method that is used to install or to update the program may not have completed successfully

There are several methods that can be used to install, to uninstall, or to update a program. Additionally, the method or methods that are used may not have started or completed successfully. The following are common methods that are used to install software:
  • Insert the CD or DVD media, and then let the installation auto-start.
  • Browse to the CD, DVD, removable media, or other location where the programs installation files are stored, and then double-click the Setup program. The setup file is typically one of the following:
    • Autorun or Autorun.exe
    • Setup or Setup.exe
    • Install or Install.exe
  • Click Run when you download the program from an Internet website.

The installation media may be unreadable

Installation media such as CD and DVD media may be dirty or scratched and may be unreadable by the CD or DVD reader and cause installation, removal, or updating issues.

Method 1: Clean the CD or DVD that you are using to install (This applies only if you have to use a CD or DVD.)

Clean the CD or DVD media. To do this, use a CD or DVD disc-cleaning kit. Or, gently wipe the silver side of the disc by using a soft, lint-free cotton cloth. Do not use paper cloth. This can scratch the plastic or leave streaks. When you clean the disc, wipe from the center of the disc outward. Do not use a circular motion. If the problem continues to occur, clean the disc by using a damp cloth or a commercial CD or DVD disc-cleaning solution. Dry the disc thoroughly before you insert the disc into the drive.

Method 2: Copy the installation files to your computer

Copy the installation files to a local hard disk on your computer or to other, removable media. Note the location, and then run the installation from that location. The installation file is typically called Autorun.exe or Setup.exe. But this can vary. If you are not sure, check the Readme file in the folder for instructions about how to run the installation. If an executable file (.exe) is available, we do not recommend that you run .msi files directly without specific instructions from the vendor.

Method 3: Obtain a fresh version of the installation package

If you tried to install from a CD or DVD, take the following actions:
  • Check the software manufacturer’s website for a more recent version of the software package. Download and install the new version.
  • If you already have the latest version, try to download the program from the manufacturer's website and then run the installation.

Advanced Users If multiple CDs or DVDs are required, we recommend that you copy all the disks to the same folder, in reverse order (higher disk numbers first). Be prepared to approve files to be overwritten if you are prompted, and then install from that location.


Downloaded or copied installation files may be corrupted

Method 1: Copy the installation files to your computer

Copy the installation files to a local hard disk on your computer or other, removable media. Note the location, and then run the installation from that location. The installation file is typically named Autorun.exe or Setup.exe. But this can vary. If you are not sure, check the Readme file in the folder for instructions on how to run the installation. If an executable file (.exe) is available, we do not recommend that you run .msi files directly without specific instructions from the vendor.
  • If you are installing a program from the Internet, re-download the file (select Save instead of Run in the download dialog box), save the file toa folder on a local hard disk on your computer or other, removable media, and run the installation from that location.
  • If your installation files are on a network (for example, a commercial or corporate environment), copy all the files to a folder on a local hard disk on your computer, and then run the installation from that location.

Method 2: Obtain a fresh version of the installation package

If some time has elapsed between when you downloaded the package and when you tried to install it, do the following:
  • Check the software manufacturer’s website for a more recent version of the software package. Download and install the new version.
  • If you already have the latest version, try to download the program again and then run the installation.

Programs that are currently running on your computer may be interfering with the installation process

Disable programs that might be interfering with the installation process. To do this, follow these steps:
  1. Click Start
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    Start button
    , type msconfig in the Search box, and then click msconfig.exe.

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    User Account Control permission
    If you are prompted for an administrator password or confirmation, type the password, or provide confirmation.
  2. On the General tab, click Selective startup, and then click to clear the Load startup items check box.
  3. Click Services, click Hide all Microsoft services, and then click Disable all.
  4. Click OK, and then click Restart.
  5. Try running your software program installation.
  6. When you are finished troubleshooting the problem, restart the computer in Normal Startup mode. To do this, follow these steps:
    1. Click Start
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      Start button
      , type msconfig in the Search box, and then click msconfig.exe.

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      User Account Control permission
      If you are prompted for an administrator password or confirmation, type the password, or provide confirmation.
    2. On the General tab, click Normal startup, click OK, and then click Restart.
For more information about how to use MSConfig, click the following article number to view the article in the Microsoft Knowledge Base:
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Uninstalling programs in Windows may not have completed successfully

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Try installing, uninstalling, or updating programs by using a different method in Windows

There are typically several ways to uninstall any program. Try the following methods. If one method does not resolve the issue, try the next method.

Method 1: Use the programs uninstall option (if available)
  1. Click Start
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    Start button
    , and then click All Programs.
  2. Select the folder for the program that you are trying to uninstall, and then open the folder.
  3. If there is an uninstall option, try to use it to uninstall the program.

If your issue is not resolved, go to method 2.

Method 2: Use Control Panel options
  1. Click Start
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    Start button
    , click Control Panel, click Add and Remove Programs or click Programs and Features, and then click Uninstall a program.
  2. Select the program, and then click Uninstall. Follow the prompts to uninstall the program.
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For more help for your install, uninstall, or update issue

If you followed these steps and the issue is still not resolved you may have to contact Microsoft Support for additional assistance. For information about how to contact Microsoft Support, visit the following Microsoft website. Some charges may apply.
Microsoft Support
You may also want to visit a Microsoft Community website where you can ask questions and receive answers from other users for free. Microsoft Community is a support forum for consumer customers. To visit Microsoft Community, visit the following Microsoft website:
Microsoft Community

Advanced users

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Note The following steps are appropriate for advanced users only.

Manually uninstalling the program

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You may be able to manually uninstall some parts of the program through the Windows interface. For example, you may be able to manually delete program files and folders. Because the steps to do this can be very different, depending on the version of Windows that you have and the program that you are trying to uninstall, no prescriptive steps are provided in this article to do this. If you are not familiar enough with the program that you are trying to uninstall to positively identify the files and folders for that program, we do not recommend that you try this method. Generally, when you begin to manually delete program files and folders, you run the risk of damaging your operating system. This step should be followed at your own risk.

If you are considering manually uninstalling the program, the following are some things that you should remember:
  • You should make every effort to uninstall the application through traditional means before you follow this step. For example, use Add or Remove Programs in Control Panel.
  • Before you follow this step, you should create a system restore point.
  • Before you get started, move any personal data or documents that may have ended up in the application’s install folder. For example, move them to the Documents folder.
  • If you cannot manually delete a program file, this could mean that the file is being used or that some other program is accessing the file and not letting you delete it. For example, an antivirus software may be accessing the file. When an antivirus software is accessing a program file and making it impossible to delete a file, it is likely that this same antivirus software was keeping you from uninstalling the program by using more traditional means.
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Check for file or folder names longer than 260 characters

For more about the maximum path length limitation, visit the following Microsoft Developer Network (MSDN) website:
Files, Paths, and Namespaces

Enable MSI logging, and then read the MSI verbose logs

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Most programs will create an installation log. If no log can be located, you can enable verbose MSI logging. For more information about how to enable Windows Installer logging, click the following article number to view the article in the Microsoft Knowledge Base: 223300 How to enable Windows Installer logging

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Note If you are running the .msi without the bootstrapping application (.exe), you can add parameters for verbose logging. For example:
Msiexec path\your_msi.msi /L*v path\your_msi_log.txt
For a list of msiexec command-line parameters, visit the following Microsoft Developer Network (MSDN) website:
Command-Line Options
A failed installation will typically log Return Value 3 where the problem occurred and the installation rollback begins. The description of the failure will appear immediately before the Return Value 3 log entry.

The Wilogutl.exe tool can be useful in the analysis of log files from a Windows Installer installation. Additionally, the tool can suggest solutions to errors that are found in a log file. The Wilogutil.exe tool is available in the latest Microsoft Windows Software Development Kit.

The following is an example of how to use the Wilogutl.exe tool:
wilogutl /q /l c:\mymsilog.log /o c\outputdir\
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References

For general information about how to install or to uninstall a program, visit the following Microsoft websites:

Install a program
Uninstall or change a program
Installing programs: frequently asked questions

Properties

Article ID: 2438651 - Last Review: November 11, 2013 - Revision: 30.0
Applies to
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Starter Edition
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Enterprise Edition
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Standard Edition
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