Procédure de résolution des problèmes lors de l'installation ou de la désinstallation de programmes sur un ordinateur exécutant Windows

Numéro d'article: 2438651 - Voir les produits auxquels s'applique cet article
Si vous êtes un client de PME, recherchez des ressources d'apprentissage et de dépannage supplémentaires sur le site du Support pour les PME.
Agrandir tout | Réduire tout

Sommaire

Réduire cette imageAgrandir cette image
Important L'utilitaire Windows Installer Cleanup (MSICUU2.exe) auquel il a précédemment été fait référence dans cet article a été abandonné. Bien que l'utilitaire Windows Installer Cleanup permît de résoudre certains problèmes d'installation, il endommageait parfois d'autres composants installés sur l'ordinateur. Par conséquent, l'outil a été supprimé du Centre de téléchargement Microsoft. L'utilitaire de résolution des problèmes d'installation et de désinstallation des programmes remplace cet utilitaire.

Si l'utilitaire de résolution des problèmes d'installation et de désinstallation de programmes ne résout pas votre problème, la procédure supplémentaire suivante peut peut-être vous y aider.

Si vous devez désinstaller Microsoft Office, cliquez sur le lien correspondant à votre version d'Office :


Si vous devez désinstaller Microsoft Security Essentials, reportez-vous à l'article suivant de la Base de connaissances Microsoft :
2435760 Comment désinstaller manuellement Microsoft Security Essentials si vous ne parvenez pas à le désinstaller à l'aide de la fonction « Ajout/Suppression de programmes »

Symptômes

Quand vous installez, désinstallez ou mettez à jour un programme sur un ordinateur exécutant Windows, l'un des messages d'erreur suivants peut s'afficher :

Message d'erreur 1
Impossible d'accéder au service Windows Installer.
Message d'erreur 2
Le service Windows Installer n'a pas pu démarrer.
Message d'erreur 3
Impossible de démarrer le service Windows Installer sur l'ordinateur local. Erreur 5 : Accès refusé.

Cause

Les processus d'installation ou de désinstallation d'un programme peuvent échouer pour diverses raisons. Cet article décrit les problèmes suivants (cliquez sur chaque problème pour découvrir la résolution associée) :

Résolution

Résolution automatique du problème

L'utilitaire de résolution de problèmes Diagnostiquer et résoudre automatiquement les problèmes d'installation et de désinstallation peut résoudre automatiquement le problème décrit dans cet article.
Cet utilitaire résout de nombreux problèmes.En savoir plusExécuter maintenant

Résolution manuelle du problème

Pour résoudre ce genre de problème, suivez les étapes ci-dessous :

Réduire cette imageAgrandir cette image
Important Vous devez ouvrir une session sur l'ordinateur en utilisant un compte administrateur. Pour exécuter plusieurs des étapes de cet article, vous devez avoir ouvert une session au moyen d'un compte disposant de droits d'administrateur. Pour déterminer si vous utilisez un compte disposant de droits d'administrateur, procédez comme suit :
  • Sous Windows XP ou Windows Server 2003 :

    Click here to view or hide step-by-step instructions with pictures
  • Sous Windows Vista ou Windows 7

    Click here to view or hide step-by-step instructions with pictures

Problèmes Windows Installer

Le moteur de Windows Installer peut être endommagé, installé de façon incorrecte ou désactivé. Ceci peut causer des problèmes d'installation.

Réduire cette imageAgrandir cette image
Remarque Le moteur Windows Installer gère l'installation de logiciels, l'ajout et la suppression de composants logiciels, la résistance des fichiers et assure la récupération de défaillance au moyen de restaurations.

Suivez ces méthodes pour identifier tout problème de Microsoft Installer pouvant causer des problèmes lors de l'installation, de la désinstallation ou de la mise à jour de programmes. Commencez par la méthode 1, suivez-en les différentes étapes, puis passez à la méthode suivante si votre problème n'est pas résolu.

Click here to view or hide detailed information

L'installation ou la mise à jour de programmes dans Windows n'a peut-être pas été exécutée correctement

Click here to view or hide detailed information

La désinstallation de programmes dans Windows n'a peut-être pas été exécutée correctement

Click here to view or hide detailed information

Pour plus d'informations sur votre problème d'installation, de désinstallation ou de mise à jour

Si vous avez suivi ces étapes et que le problème n'est toujours pas résolu, vous devrez peut-être contacter le support technique Microsoft pour obtenir de l'aide supplémentaire. Pour savoir comment contacter le support technique Microsoft, visitez le site Web de Microsoft suivant. Des frais peuvent découler de ce service.
Support technique Microsoft
Vous désirerez peut-être visiter un site Web de Microsoft Community où vous pouvez gratuitement poser des questions et recevoir des réponses d'autres utilisateurs. Microsoft Community est un forum d'assistance pour les clients. Pour visiter Microsoft Community, rendez-vous sur le site Web de Microsoft suivant :
Microsoft Community

Utilisateurs expérimentés

Réduire cette imageAgrandir cette image
Remarque Les étapes suivantes s'adressent uniquement aux utilisateurs expérimentés.

Désinstallation manuelle du programme

Click here to view or hide detailed information

Recherche des noms de fichier ou de dossier contenant plus de 260 caractères

Pour plus d'informations sur la limitation de la longueur maximale des chemins d'accès, reportez-vous au site Web MSDN (Microsoft Developer Network) à l'adresse suivante :

Activation de la journalisation MSI, puis lecture les journaux détaillés MSI

Click here to view or hide detailed information

Références

Pour des informations d'ordre général sur l'installation ou la désinstallation d'un programme, visitez les sites Web Microsoft suivants :

Installer un programme
Désinstaller ou modifier un programme
Installation de programmes : forum aux questions
.

Propriétés

Numéro d'article: 2438651 - Dernière mise à jour: mardi 29 janvier 2013 - Version: 16.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Windows 7 Entreprise
  • Windows 7 Édition Familiale Basique
  • Windows 7 Édition Familiale Premium
  • Windows 7 Professionnel
  • Windows 7 Édition Starter
  • Windows 7 Édition Integrale
  • Windows Vista Professionnel
  • Windows Vista Entreprise
  • Windows Vista Édition Familiale Basique
  • Windows Vista Édition Familiale Premium
  • Windows Vista Starter
  • Windows Vista Édition Intégrale
  • Microsoft Windows XP Édition familiale
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Starter Edition
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Édition Enterprise
  • Microsoft Windows 2000 Professionnel
  • Microsoft Windows 2000 Standard
Mots-clés : 
kbsurveynew kbexpertiseinter kbinfo kbcip KB2438651
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires