文書番号: 2438651 - 対象製品
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目次

現象

インストール、アンインストール、または Windows ベースのコンピューター上のプログラムを更新するときに、次のエラー メッセージのいずれかが表示されます。

エラー メッセージ 1
Windows インストーラー サービスにアクセスできませんでした。
エラー メッセージ 2
Windows インストーラー サービスを起動できませんでした。
エラー メッセージ 3
ローカル コンピューター上に Windows インストーラー サービスを開始できませんでした。エラー 5: アクセスが拒否されました。

原因

いくつかの理由は、プログラムのインストールまたはアンインストールの処理は失敗します。この資料には (各問題を関連の解決] をクリック)、次の問題について説明します。
  • Windows インストーラーの問題
  • インストールまたは Windows でのプログラムを更新する可能性がありますいないが正常に完了
  • Windows の [プログラムのアンインストールが完了していない正常に

解決方法

この問題を自動的に修復します。

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プログラムのインストールとアンインストールのトラブルシューティング ツールを開始します。

この問題を手動で修正します。

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この種の問題を解決するのに、以下の手順に従います。

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重要管理者アカウントを使用してコンピューターにログオンする必要があります。この資料の手順の多くを実行、管理者権限を持つアカウントを持つコンピューターにログオンするがあります。管理者権限を持つアカウントを使用しているかどうかを確認するのに以下の手順を実行します。
Windows XP または Windows Server 2003 で
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  1. 日付と時刻] ダイアログ ボックスを開きます。
    1. 開始]をクリックし、[実行] をクリックします。
    2. 実行] ダイアログ ボックスで、次のコマンドを入力し、 OKキーを押します。
      timedate.cpl (下のスクリーン ショットここは表示されます)。
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      ここのスクリーン ショット
  2. 結果の適切な手順の 1 つを使用します。
    • [日付と時刻のプロパティ] ダイアログ ボックスが表示されたら、する場合は、管理者としてログオンして既に。日付と時刻プロパティ] ダイアログ ボックスを閉じるにキャンセルをクリックします。(スクリーン ショットここは下記参照)。
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      ここのスクリーン ショット
    • 管理者としてログオンしていない場合は、次のメッセージが表示されます。
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      管理者としてログオンしていない場合は、メッセージを示すスクリーン ショットが表示されます。
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Windows vista または Windows 7 の
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  1. 日付と時刻] ダイアログ ボックスを開きます。
    1. [スタート] をクリックします。
    2. または、[検索の開始] ボックスで、次のコマンドを入力、プログラムとファイルの検索 ボックス、およびENTERキーを押します。
      timedate.cpl
      [日付と時刻] ダイアログ ボックスが表示されます。(スクリーン ショットここは下記参照)。
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      ここのスクリーン ショット
  2. 変更の日付と時刻日付と時刻] ダイアログ ボックスでをクリックします。ユーザー アカウント制御] ダイアログ ボックスが開いたら、[続行] をクリックします。(スクリーン ショットここは下記参照)。
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    ここのスクリーン ショット
  3. これをクリックした場合、次のいずれかの操作を行います続行:
    • 場合は、コンピューター表示しません、パスワードを
      既に管理者アカウントでログオンしています。このタスクを続行する準備ができたら [キャンセル] をクリック 2 回を閉じるには、[日付し、時刻] ダイアログ ボックス.
    • 場合は、コンピューターを求めるパスワード
      管理者アカウントでログオンしていません。
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Windows インストーラーの問題

Windows インストーラー エンジンは、壊れている、正しく、インストールされていないか無効になっている。インストールの問題があります。

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メモ Windows インストーラー エンジンは、ソフトウェアのインストールを管理する、ソフトウェア コンポーネントの削除の追加と管理、ファイルの回復力を監視およびロールバックによる基本的な障害回復を維持します。

原因と考えられる問題をインストール、アンインストール、またはプログラムを更新するときに、Microsoft インストーラーの問題を識別するために、これらのメソッドを使用します。方法 1 から始まる、手順を実行するメソッドでは、問題が解決しない場合は、次の方法に進みます。

詳細情報を表示または非表示にするのにはここをクリック
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方法 1: Windows インストーラー エンジンが機能しているかどうかの判断します。

  1. 開始] をクリックします。
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    [スタート] ボタン
    ] cmd [検索] ボックスまたは [実行する] をクリックし、入力 cmd (Windows XP または Windows Server 2003) は、ダイアログでコマンド プロンプトウィンドウを開くにはEnterキーを押します。
  2. コマンド プロンプトで次のように入力します。 MSIExec、し、 Enterキーを押します。
  3. MSI エンジンが動作している場合があるなしのエラー メッセージです。エラー メッセージを表示する場合は、エラーに注意してください。検索エンジンを使用する方法に精通している場合は、エラー メッセージを使用して、問題を解決する追加のコンテンツを見つけやすくことができます。
  4. インストールまたはアンインストールを実行してください。

問題が解決しない場合は、方法 2 に進みます。


方法 2: Windows インストーラー サービスが無効に設定されていないことを確認します。

  1. 開始] をクリックします。
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    [スタート] ボタン
    ] services.msc [検索] ボックスまたは [実行する] をクリックし、入力 services.msc (Windows XP または Windows Server 2003) は、ダイアログでキーを押します 入力してください。サービスを開きます。
  2. Windows インストーラーのサービスを右クリックし、[プロパティ] をクリックします。
  3. 場合は、[スタートアップの種類] ボックスが無効に設定を手動に変更します。
  4. [プロパティ] ウィンドウを閉じるに[ok]をクリックします。
  5. Windows インストーラーサービスを右クリックし、[開始] をクリックします。エラーのないサービスを開始する必要があります。
  6. インストールまたはアンインストールを実行してください。

問題が解決しない場合は、方法 3 に進みます。

方法 3: Windows インストーラーのバージョンを確認し、最新バージョンにアップグレードが必要な場合

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重要このメソッドはのみを Windows XP を Windows Vista を Windows Server 2003、Windows Server 2003 R2、および Windows Server 2008 に適用されます。
  1. 開始] をクリックします。
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    [スタート] ボタン
    ] cmd [検索] ボックスにまたは実行] をクリックし、(Windows XP または Windows Server 2003) ダイアログ ボックスでservices.mscと入力しキーを押します 入力してください。コマンド プロンプトウィンドウを開きます。
  2. コマンド プロンプトウィンドウで、次のように入力します。 MSIExec、し、キーを押します。 入力してください。.MSI エンジンが動作している場合は、エラー メッセージがないことし、別のダイアログ ボックスを開く必要があります。これは、MSI のバージョンを示します。
  3. インストーラーのバージョンがバージョン 4.5 でない場合は、次の資料で、マイクロソフト サポート技術情報とリンクについてを Windows インストーラー 4.5 をダウンロードするを参照してください。
  4. インストールまたはアンインストールを実行してください。

問題が解決しない場合は、方法 4 に進みます。


方法 4: インストーラーのエンジンを再登録します。

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重要このメソッドはのみ Windows xp と Windows Server 2000 に適用されます。
  1. [スタート] ボタンをクリックし、入力 cmd ダイアログ ボックスで、[コマンド プロンプト] をクリックするとします。
  2. コマンド プロンプトで、次を入力し、各行の後 Enter キーを押します。
    MSIExec の登録を解除すると

    MSIExec/regserver
  3. インストールまたはアンインストールを実行してください。
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インストールまたは Windows でのプログラムを更新する可能性がありますいないが正常に完了

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インストールまたは更新プログラムを使用するメソッドは正常に完了しなかった可能性があります。

インストール、アンインストール、または更新プログラムを使用することができますいくつかの方法があります。さらに、メソッドまたは使用されている方法がないが開始またはが正常に完了。ソフトウェアをインストールするのに使用される共通のメソッドを次に示します。
  • CD または DVD のメディアを挿入して、インストールが自動的に起動し。
  • CD、DVD、リムーバブル メディア、またはその他の場所は、プログラムのインストール ファイルが格納をし、セットアップ プログラムをダブルクリックします。セットアップ ファイルは、通常、次のいずれか。
    • 自動実行または Autorun.exe
    • セットアップまたは Setup.exe
    • インストールまたは Install.exe
  • インターネットの web サイトからプログラムをダウンロードするときに、[実行] をクリックします。

インストール メディアには、読み取ることができません。

インストール CD メディアや DVD メディアが汚れているか、傷が付いている可能性があります、CD または DVD の読み取りを読み取ることができないし、インストール、削除、または更新の問題が発生します。

方法 1: クリーン、CD または DVD をインストールするには、使用している (この当てはまりますを CD または DVD を使用している場合にのみ)。

CD または DVD メディアをクリーニングします。これを行うには、CD または DVD ディスク クリーニング キットを使用します。またはを柔らかくて埃の出ない綿の布を使用して、ディスクの銀色の面を軽く拭きます。紙の布は使わないでください。プラスチックに傷やすじが。ディスクをクリーニングするときは、ディスクの中央から外向きにふきます。円を描くを使わないでください。問題が引き続き発生する場合は、ディスクを湿った布か商用 CD または DVD ディスク クリーニング ソリューションを使用してにクリーニングします。ディスクを完全に乾かして、ディスクをドライブに挿入します。

方法 2: インストール ファイルをコンピューターにコピーします。

コンピューター上のローカルのハード ディスクまたはその他のリムーバブル メディアには、インストール ファイルをコピーします。場所を確認してとし、その場所からインストールを実行します。インストール ファイルは、通常 Autorun.exe または Setup.exe と呼ばれます。しかし、これは異なることができます。確認しない場合は、インストールを実行する方法については、フォルダー内の Readme ファイルを確認します。実行可能ファイル (.exe) を使用できる場合は推奨されません、仕入先から指示を特定せずに、直接 .msi ファイルを実行することです。

方法 3: インストール パッケージの最新バージョンを入手します。

CD または DVD からインストールしようとする場合は、次の操作を実行します。
  • ソフトウェア パッケージの最新バージョンのソフトウェア製造元の web サイトを確認してください。ダウンロードして、新しいバージョンをインストールします。
  • 最新バージョンが既に存在する場合に、製造元の web サイトからプログラムをダウンロードし、インストールを実行してください。

上級ユーザーお勧めことコピーするすべてのディスクと同じフォルダーに逆の順序で複数の Cd または Dvd が必要な場合 (最初に高いディスクを番号)。ファイルを上書きする場合は、承認するための準備し、し、その場所からインストールします。


ダウンロードまたはコピーしたインストール ファイルが破損している可能性があります。

方法 1: インストール ファイルをコンピューターにコピーします。

コンピューターまたはその他のリムーバブル メディアには、ローカルのハード_ディスクにインストール ファイルをコピーします。場所を確認してとし、その場所からインストールを実行します。Autorun.exe または Setup.exe インストール ファイルの名前が通常です。しかし、これは異なることができます。確認しない場合は、フォルダーにインストールを実行する方法の詳細についての Readme ファイルを確認します。実行可能ファイル (.exe) を使用できる場合は推奨されません、仕入先から指示を特定せずに、直接 .msi ファイルを実行することです。
  • インターネットからプログラムをインストールする場合 (選択保存のダウンロード] ダイアログ ボックスでの実行ではなく) ファイルを再度ダウンロード toa のファイル フォルダーのコンピューターまたは他のリムーバブル メディアでは、ローカル ハード ディスク上に保存、その場所からインストールを実行します。
  • ネットワーク (たとえば、市販または社内環境) では、インストール ファイルと、コンピューター上のローカルのハード ディスク上のフォルダーにすべてのファイルをコピーし、その場所からインストールを実行します。

方法 2: インストール パッケージの最新バージョンを入手します。

パッケージをダウンロードしたときにそれをインストールしようとするといくつかの時間が経過した場合は、以下行います。
  • ソフトウェア パッケージの最新バージョンのソフトウェア製造元の web サイトを確認してください。ダウンロードして、新しいバージョンをインストールします。
  • ある場合、最新バージョン、もう一度プログラムをダウンロードしようとし、インストールを実行します。

コンピューターで現在実行中のプログラムをインストール プロセスを妨げている可能性が

インストール プロセスに干渉している可能性がありますのプログラムを無効にします。これを行うには、次の手順を実行します。
  1. 開始] をクリックします。
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    [スタート] ボタン
    ] msconfig検索ボックス、および [ msconfig.exe] をクリックします。

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    ユーザー アカウント制御の許可
    管理者のパスワードまたは確認のメッセージが表示されたら、パスワードを入力または確認を提供します。
  2. [全般] タブで、スタートアップのオプションを選択をクリック、スタートアップ項目を読み込む] チェック ボックスをオフにします。
  3. サービス] をクリックして、 Microsoft サービスを全て隠すを [すべて無効にする] をクリックします。
  4. [OK] をクリックし、[再起動] をクリックします。
  5. ソフトウェア プログラムのインストールを実行してください。
  6. 問題のトラブルシューティングが完了したら、通常スタートアップ モードでコンピューターを再起動します。これを行うには、次の手順を実行します。
    1. 開始] をクリックします。
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      [スタート] ボタン
      で、[検索] ボックスにmsconfigと入力し、[ msconfig.exe] をクリックします。

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      ユーザー アカウント制御の許可
      管理者のパスワードまたは確認のメッセージが表示されたら、パスワードを入力または確認を提供します。
    2. [全般] タブで、[通常スタートアップ] をクリックして、 [ok]をクリックしておよび [再起動] をクリックします。
MSConfig を使用する方法の詳細については、次のマイクロソフト サポート技術資料を参照する次の文書番号をクリックしてください。
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Windows の [プログラムのアンインストールが完了していない正常に

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Windows で別のメソッドを使用して、インストール、アンインストール、または更新プログラムを実行してください。

通常、任意のプログラムをアンインストールするには、いくつかの方法です。次の方法を試してください。1 つの方法は、問題が解決しない場合は、次の方法にしてください。

方法 1: (該当する場合)、プログラムのアンインストール オプションを使用してください。
  1. 開始] をクリックします。
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    [スタート] ボタン
    、し、[すべてのプログラム] をクリックします。
  2. プログラムをアンインストールしようとしているフォルダーを選択し、フォルダーを開きます。
  3. アンインストール オプションがある場合、プログラムをアンインストールすることを使用してください。

問題が解決しない場合は、方法 2 に進みます。

方法 2: コントロール パネルを使用するオプション
  1. 開始] をクリックします。
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    [スタート] ボタン
    、[コントロール パネル] をクリックして追加とプログラムの削除] をクリックしてまたはプログラムと機能、をクリックし、[プログラムのアンインストール] をクリックします。
  2. プログラムを選択し、[アンインストール] をクリックします。プログラムをアンインストールする画面の指示に従います。
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インストールの詳細についてをアンインストール、または更新の問題

次の手順に従うし、問題が解決しない場合は、詳細について Microsoft サポートに連絡する必要があります。マイクロソフトのサポートへの問い合わせ方法については、次のマイクロソフト web サイトを参照してください。いくつかの料金が適用されます。
マイクロソフトのサポート
また質問し、無料で他のユーザーから回答を得ることができます、マイクロソフト コミュニティ web サイトを参照してくださいする可能性があります。マイクロソフト コミュニティは、個人のお客様向けのサポート フォーラムです。マイクロソフトのコミュニティを訪問するには、次のマイクロソフト web サイトを参照してください。
マイクロソフト コミュニティ

高度なユーザー

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メモ 次の手順は、上級ユーザーのみに適しています。

手動でプログラムをアンインストールします。

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Windows のインターフェイスからプログラムの一部を手動でアンインストールすることができます。たとえば、プログラム ファイルとフォルダーを手動で削除することができます。これを行うには、手順は、プログラムをアンインストールしようとしているしている Windows のバージョンによって大きく異なることができます、ためこれを行うにはこの資料には規範となる手順は表示されません。アンインストールするプログラムのフォルダーとファイルを識別するのにしようとしているプログラムで十分理解していない場合は、推奨されませんこの方法を試すことです。一般的には、プログラムのファイルとフォルダーを手動で削除することを開始するときに、オペレーティング システムの損傷のリスクが実行します。この手順はユーザー自身の責任に従う必要があります。

手動でプログラムのアンインストールを検討している場合は、次に注意すべき点。
  • この手順を実行する前に、従来の方法を使用して、アプリケーションをアンインストールする努力をする必要があります。コントロール パネルの [プログラム追加と削除を使用、します。
  • この手順を実行する前にシステムの復元ポイントを作成してください。
  • を開始する前に、個人データやドキュメントをアプリケーションのインストール フォルダー終了した可能性がありますに移動します。たとえば、ドキュメント フォルダーに移動します。
  • プログラム ファイルを手動で削除できない場合は、この可能性、ファイルが使用されているまたは他のプログラムは、ファイルへのアクセスをいない削除することができます。たとえば、するウイルス対策ソフトウェア ファイルにアクセスしている可能性があります。ウイルス対策ソフトウェアは、プログラム ファイルへのアクセス、ファイルを削除できないようにする場合にこの同じウイルス対策ソフトウェアが従来の手段を使用して、プログラムをアンインストールすることを維持すること。
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260 文字より長いファイルまたはフォルダーの名前を探します。

詳細については、パスの最大長の制限は、次の Microsoft Developer Network (MSDN) web サイトを参照してください。
ファイル、パス、および名前空間

MSI ログを有効にして、詳細な MSI ログを参照して

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ほとんどのプログラムは、インストール ログを作成します。ログがない場合に、詳細な MSI ログを有効にできます。Windows インストーラーのロギングを有効にする方法の詳細については、次のマイクロソフト サポート技術資料を参照する次の文書番号をクリックしてください。 223300 Windows インストーラーのログを有効にする方法

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メモ ブートス トラップ アプリケーション (.exe) なしで .msi を実行している場合は、詳細ログのパラメーターを追加できます。例を示します。
Msiexec パス\your_msi.msi /L * v パス\your_msi_log.txt
Msiexec コマンド ライン パラメーターの一覧は、次の Microsoft Developer Network (MSDN) web サイトを参照してください。
コマンド ライン オプション
インストールが失敗した場所、問題が発生し、インストールのロールバックを開始の値 3 を返す通常記録します。エラーの説明は、値 3 を返しますログ エントリの前にすぐに表示されます。

Wilogutl.exe ツールは、Windows インストーラーのログ ファイルの分析に役立つことができます。また、ツールはエラー ログ ファイルに存在するソリューションを提案します。Wilogutil.exe ツールは、最新の利用可能です Microsoft Windows ソフトウェア開発キットです。

Wilogutl.exe ツールを使用する方法の例を次に示します。
wilogutl/q/l c:\mymsilog.log /o c\outputdir\
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関連情報

インストールする、または、プログラムをアンインストールする方法については、次のマイクロソフト web サイトを参照してください。

プログラムをインストールします。
アンインストール、またはプログラムを変更します。
プログラムのインストール: よく寄せられる質問

プロパティ

文書番号: 2438651 - 最終更新日: 2013年11月16日 - リビジョン: 21.0
この資料は以下の製品について記述したものです。
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Starter Edition
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Enterprise Edition
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Standard Edition
キーワード:?
kbsurveynew kbexpertiseinter kbinfo kbcip kbmt KB2438651 KbMtja
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英語版 KB:2438651
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