Windows ベースのコンピューターでプログラムをインストールまたはアンインストールする際の問題のトラブルシューティング方法

文書番号: 2438651 - 対象製品
中小企業のお客様は、中小企業向けサポート サイトで問題解決や学習に関する他のリソースを参照できます。
すべて展開する | すべて折りたたむ

目次

元に戻す画像を拡大する
重要 この資料に以前に記載されていた Windows Installer Cleanup ユーティリティ (MSICUU2.exe) の提供は終了しました。Windows Installer Cleanup ユーティリティは一部のインストールの問題を解決しましたが、場合によってはコンピューターにインストールされていた他のコンポーネントを破損させることがありました。このため、このツールは Microsoft ダウンロード センターから削除されました。プログラムのインストールとアンインストールのトラブルシューティング ツールは、このユーティリティに代わるものです。

プログラムのインストールとアンインストールのトラブルシューティング ツールで問題が解決されない場合は、以下に示す追加の手順を使用して問題を解決することができます。

Microsoft Office をアンインストールする必要がある場合は、使用している Office のバージョンに対応するリンクをクリックしてください。


Microsoft Security Essentials をアンインストールする必要がある場合は、次のサポート技術情報を参照してください。
2435760 [プログラムの追加と削除] 項目を使用しても Microsoft Security Essentials をアンインストールできない場合に手動でアンインストールする方法

現象

Windows ベースのコンピューターでプログラムをインストール、アンインストール、またはアップグレードするときに、次のいずれかのエラー メッセージが表示されることがあります。

エラー メッセージ 1
Windows インストーラー サービスにアクセスできませんでした。
エラー メッセージ 2
Windows インストーラー サービスを開始できませんでした。
エラー メッセージ 3
ローカル コンピューターの Windows インストーラー サービスを開始できませんでした。エラー 5アクセスが拒否されました。

原因

プログラムのインストールまたはアンインストール処理は、いくつかの理由により失敗することがあります。この資料では次の問題について説明します (各問題をクリックすると関連する解決策を参照できます)。

解決方法

この問題を自動的に解決する

自動的にプログラムのインストールおよびアンインストールの問題を診断および修復するトラブルシューティング ツールで、この資料で説明されている問題が自動的に解決できる可能性があります。
このトラブルシューティング ツールは、多くの問題を解決します。詳細情報今すぐ実行

この問題を手動で解決する

これらの種類の問題を解決するには、次の手順に従います。

元に戻す画像を拡大する
重要 管理者アカウントを使用してコンピューターにログオンする必要があります。この資料の多くの手順を実行するには、管理者権限のアカウントを使用してコンピューターにログオンする必要があります。管理者権限のあるアカウントを使用しているかどうかを確認するには、次の手順を実行します。
  • Windows XP または Windows Server 2003 の場合

    Click here to view or hide step-by-step instructions with pictures
  • Windows Vista または Windows 7 の場合:

    Click here to view or hide step-by-step instructions with pictures

Windows インストーラーの問題

Windows インストーラー エンジンが破損しているか、正しくインストールされていないか、または無効になっている可能性があります。これにより、インストールの問題が発生することがあります。

元に戻す画像を拡大する
注: Windows インストーラー エンジンは、ソフトウェアのインストールの管理、ソフトウェア コンポーネントの追加と削除の管理、ファイルの復元の監視を行い、さらにロールバックを使用した基本的な障害回復機能を備えています。

プログラムのインストール、アンインストール、または更新時の問題の原因になっている可能性がある Microsoft インストーラーの問題を特定するには、以下の方法を使用します。方法 1 から開始してその手順に従い、問題が解決しない場合は次の方法に進みます。

Click here to view or hide detailed information

Windows でプログラムのインストールまたは更新が正常に完了していない可能性がある

Click here to view or hide detailed information

Windows でプログラムのアンインストールが正常に完了していない可能性がある

Click here to view or hide detailed information

インストール、アンインストール、または更新の問題のサポートについて

以上の手順に従っても問題が解決しない場合は、マイクロソフト サポートに問い合わせることもできます。マイクロソフト サポートへの問い合わせ方法の詳細については、以下のマイクロソフト Web サイトを参照してください。料金がかかる場合があります。
マイクロソフト サポート
質問を投稿して他のユーザーから無料の回答を得ることができるマイクロソフト コミュニティ Web サイトを参照することもできます。マイクロソフト コミュニティはコンシューマー カスタマー向けのサポート フォーラムです。マイクロソフト コミュニティを参照するには、次のマイクロソフト Web サイトを参照してください。
マイクロソフト コミュニティ

上級ユーザー向け

元に戻す画像を拡大する
注: 以下の手順は、上級レベルのユーザーを対象にしています。

手動でプログラムをアンインストールする

Click here to view or hide detailed information

260 文字を超える長さのファイル名やフォルダー名の確認

パスの最大長の制限については、次の MSDN (Microsoft Developer Network) Web サイトを参照してください。

MSI ログを有効にして、MSI 詳細ログを読み取る

Click here to view or hide detailed information

関連情報

プログラムをインストール、再インストール、またはアンインストールする方法の一般情報については、次のマイクロソフト Web サイトを参照してください。

プログラムのインストール
プログラムの削除と変更
プログラムのインストール: よく寄せられる質問


プロパティ

文書番号: 2438651 - 最終更新日: 2013年1月29日 - リビジョン: 19.0
この資料は以下の製品について記述したものです。
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Starter Edition
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Enterprise Edition
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Standard Edition
キーワード:?
kbsurveynew kbexpertiseinter kbinfo kbcip KB2438651
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック