หมายเลขบทความ (Article ID): 2438651 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

เมื่อคุณติดตั้ง ถอนการติดตั้ง หรือปรับปรุงโปรแกรมบนคอมพิวเตอร์ที่ใช้ Windows คุณอาจได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้:

ข้อความแสดงข้อผิดพลาด 1
Windows Installer Service ไม่สามารถเข้าถึง
ข้อความแสดงข้อผิดพลาด 2
Windows Installer Service ไม่สามารถเริ่มต้น
ข้อความแสดงข้อผิดพลาด 3
ไม่สามารถเริ่มต้นบริการ Windows Installer บนคอมพิวเตอร์เฉพาะที่ ข้อผิดพลาด 5: ถูกปฏิเสธการเข้าถึง

สาเหตุ

กระบวนการติดตั้งหรือถอนการติดตั้งของโปรแกรมสามารถล้มเหลวด้วยเหตุผลหลายประการ บทความนี้กล่าวถึงปัญหาต่อไปนี้ (คลิกที่แต่ละประเด็นสำหรับการแก้ปัญหาที่เกี่ยวข้อง):
  • ปัญหาการติดตั้ง Windows
  • การติดตั้ง หรือปรับปรุงโปรแกรมใน Windows อาจไม่เสร็จสมบูรณ์
  • ถอนการติดตั้งโปรแกรมใน Windows อาจไม่เสร็จสมบูรณ์

การแก้ไข

แก้ไขปัญหาโดยอัตโนมัติ

ยุบรูปภาพนี้ขยายรูปภาพนี้
2863010
เริ่มตัวแก้ไขปัญหาการติดตั้งโปรแกรมและการถอนการติดตั้ง

แก้ไขปัญหาด้วยตนเอง

ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding start collapsed
เมื่อต้องการแก้ไขปัญหาต่าง ๆ เหล่านี้ ให้ทำตามขั้นตอนที่แสดงด้านล่าง:

ยุบรูปภาพนี้ขยายรูปภาพนี้
2684263
สิ่งสำคัญ คุณต้องเข้าสู่ระบบคอมพิวเตอร์ โดยใช้แอคเคาท์ผู้ดูแลระบบ ทำตามขั้นตอนในบทความนี้ คุณต้องเข้าสู่ระบบคอมพิวเตอร์ที่มีบัญชีผู้ใช้ที่มีสิทธิ์ระดับผู้ดูแลระบบ เพื่อตรวจสอบว่า คุณกำลังใช้บัญชีผู้ใช้ที่มีสิทธิ์ระดับผู้ดูแลระบบ ให้ทำตามขั้นตอนเหล่านี้:
ใน Windows XP หรือ ใน Windows Server 2003
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding start collapsed
  1. เปิดกล่องโต้ตอบวันและเวลา
    1. คลิกเริ่มและจากนั้น คลิกเรียกใช้
    2. พิมพ์คำสั่งต่อไปนี้ในกล่องโต้ตอบเรียกใช้และจากนั้น ให้กด'ตกลง':
      timedate.cpl (จอสำหรับขั้นตอนนี้จะแสดงรายการด้านล่าง)
      ยุบรูปภาพนี้ขยายรูปภาพนี้
      จอสำหรับขั้นตอนนี้
  2. ใช้หนึ่งในขั้นตอนที่เหมาะสม ขึ้นอยู่กับผลลัพธ์
    • หากปรากฏกล่องโต้ตอบวันและเวลาที่คุณสมบัติจะเรียบร้อยแล้วว่าคุณล็อกออนเป็นผู้ดูแลระบบ คลิกยกเลิกเพื่อปิดกล่องโต้ตอบคุณสมบัติวันและเวลา (จอสำหรับขั้นตอนนี้จะแสดงที่ด้านล่าง)
      ยุบรูปภาพนี้ขยายรูปภาพนี้
      จอสำหรับขั้นตอนนี้
    • ข้อความต่อไปนี้ปรากฏขึ้นถ้าคุณไม่ได้ล็อกออนเป็นผู้ดูแลระบบ
      ยุบรูปภาพนี้ขยายรูปภาพนี้
      ภาพหน้าจอที่แสดงข้อความที่ปรากฏขึ้นถ้าคุณไม่ได้ล็อกออนเป็นผู้ดูแลระบบ
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding end collapsed

ใน Windows Vista หรือ Windows 7
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding start collapsed
  1. เปิดกล่องโต้ตอบวันและเวลา
    1. คลิก เริ่ม
    2. พิมพ์คำสั่งต่อไปนี้ ในกล่องเริ่มการค้นหาหรือในการค้นหาโปรแกรมและแฟ้ม กล่อง จากนั้น กดENTER:
      timedate.cpl
      เปิดกล่องโต้ตอบวันและเวลา (จอสำหรับขั้นตอนนี้จะแสดงที่ด้านล่าง)
      ยุบรูปภาพนี้ขยายรูปภาพนี้
      จอสำหรับขั้นตอนนี้
  2. คลิกเปลี่ยนวันและเวลาในกล่องโต้ตอบวันและเวลา เมื่อคุณเปิดกล่องโต้ตอบ'การควบคุมบัญชีผู้ใช้คลิกทำต่อไป(จอสำหรับขั้นตอนนี้จะแสดงที่ด้านล่าง)
    ยุบรูปภาพนี้ขยายรูปภาพนี้
    จอสำหรับขั้นตอนนี้
  3. ขณะนี้ ทำวิธีใดวิธีหนึ่งต่อไปนี้ ขึ้นอยู่กับสิ่งที่เกิดขึ้นเมื่อคุณคลิต่อเนื่อง:
    • ถ้าคอมพิวเตอร์ของคุณไม่พร้อมท์ให้คุณใส่รหัสผ่าน
      แล้วคุณเข้าสู่ระบบ ด้วยบัญชีผู้ดูแล คลิกยกเลิกสองครั้งเพื่อปิดกล่องโต้ตอบวัน และเวลาและจากนั้น คุณก็พร้อมที่จะดำเนินงานนี้
    • ถ้าคอมพิวเตอร์พร้อมท์ให้คุณใส่รหัสผ่าน
      ไม่คุณจะเข้าสู่ระบบ ด้วยบัญชีผู้ดูแล
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding end collapsed
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding end collapsed

ปัญหาการติดตั้ง Windows

โปรแกรมติดตั้ง Windows อาจจะเสียหาย ติดตั้งอย่างไม่ถูกต้อง หรือปิดใช้งาน ซึ่งอาจทำให้เกิดปัญหาการติดตั้ง

ยุบรูปภาพนี้ขยายรูปภาพนี้
2683283
หมายเหตุ โปรแกรมติดตั้ง Windows จัดการการติดตั้งซอฟต์แวร์ จัดการและลบคอมโพเนนต์ของซอฟต์แวร์เพิ่มเติม มีความยืดหยุ่นในแฟ้มการตรวจสอบ และรักษาพื้นฐานความล้มเหลวในการกู้คืน โดยใช้ rollbacks

ใช้วิธีการเหล่านี้เพื่อระบุปัญหาใด ๆ โปรแกรมติดตั้ง Microsoft ที่อาจนั้นทำให้เกิดปัญหาเมื่อคุณติดตั้ง ถอนการติดตั้ง หรือโปรแกรมปรับปรุง Start ด้วยวิธีที่ 1 ให้ทำตามขั้นตอนในวิธีที่ แล้ว ไปวิธีถัดไปถ้าไม่ได้รับการแก้ไขปัญหาของคุณ

คลิกที่นี่เพื่อดู หรือซ่อนข้อมูลรายละเอียด
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding start collapsed

วิธีที่ 1: ตรวจสอบว่า โปรแกรม Windows Installer ทำงาน

  1. คลิกStart
    ยุบรูปภาพนี้ขยายรูปภาพนี้
    ปุ่ม'เริ่ม'
    ชนิด คำสั่ง ในการค้นหาในกล่อง หรือคลิกเรียกใช้แล้ว พิมพ์ คำสั่ง ในการโต้ตอบ (Windows XP หรือ Windows Server 2003), แล้วกดEnterเพื่อเปิดหน้าต่างพร้อมรับคำสั่ง
  2. ที่พรอมต์คำสั่ง พิมพ์ MSIExecแล้ว กดEnter
  3. ถ้าโปรแกรม MSI ทำงาน ควรจะมีข้อความแสดงข้อผิดพลาด ถ้าคุณได้รับข้อผิดพลาด หมายเหตุข้อผิดพลาด ถ้าคุณคือ proficient ในวิธีการใช้โปรแกรมค้นหา คุณสามารถใช้ข้อความข้อผิดพลาดเพื่อช่วยค้นหาเนื้อหาเพิ่มเติมเพื่อแก้ไขปัญหา
  4. พยายามติดตั้ง หรือถอนการติดตั้งอีกครั้ง

ถ้าปัญหายังคงมีอยู่ ไปที่วิธีที่ 2


วิธีที่ 2: ตรวจสอบให้แน่ใจว่า Windows Installer Service ไม่ได้ถูกตั้งค่าเป็นปิดใช้งาน

  1. คลิกStart
    ยุบรูปภาพนี้ขยายรูปภาพนี้
    ปุ่ม'เริ่ม'
    ชนิด services.msc ในการค้นหาในกล่อง หรือคลิกเรียกใช้แล้ว พิมพ์ services.msc ในกล่องโต้ตอบ (Windows XP หรือ Windows Server 2003), แล้วกด ป้อน เมื่อต้องการเปิดบริการ
  2. คลิกขวาบริการWindows Installerและจากนั้น คลิกคุณสมบัติ
  3. ถ้ากล่องชนิดการเริ่มต้นถูกตั้งค่าให้ปิดการใช้งานเปลี่ยนแปลงด้วยตนเอง
  4. คลิกตกลงเพื่อปิดหน้าต่างคุณสมบัติ
  5. คลิกขวาบริการWindows Installerและจากนั้น คลิกเริ่ม บริการควรเริ่มต้น โดยไม่มีข้อผิดพลาด
  6. พยายามติดตั้ง หรือถอนการติดตั้งอีกครั้ง

ถ้าปัญหายังคงมีอยู่ ไปที่วิธีที่ 3

วิธีที่ 3: ตรวจสอบรุ่นของ Windows Installer และการปรับรุ่นเป็นรุ่นล่าสุดถ้าจำเป็น

ยุบรูปภาพนี้ขยายรูปภาพนี้
2684263
สิ่งสำคัญ วิธีนี้ใช้ กับ Windows XP, Windows Vista กับ Windows Server 2003 กับ Windows Server 2003 R2 และ Windows Server 2008 เท่านั้น
  1. คลิกStart
    ยุบรูปภาพนี้ขยายรูปภาพนี้
    ปุ่ม'เริ่ม'
    ชนิด คำสั่ง ในการค้นหาในกล่อง หรือคลิกเรียกใช้จาก นั้นพิมพ์services.mscในกล่องโต้ตอบ (Windows XP หรือ Windows Server 2003), จากนั้น กด ป้อน เมื่อต้องการเปิดหน้าต่างพร้อมรับคำสั่ง
  2. ในหน้าต่างพร้อมรับคำสั่งพิมพ์ MSIExecแล้ว กด ป้อน. ถ้าโปรแกรม MSI ทำงาน ควรจะมีข้อความแสดงข้อผิดพลาด และควรเปิดกล่องโต้ตอบที่แยกต่างหาก ฟิลด์นี้แสดงรุ่นของ MSI
  3. ถ้าติดตั้งรุ่นไม่ใช่รุ่น 4.5 ดูบทความใน Microsoft Knowledge Base สำหรับข้อมูล และ สำหรับการเชื่อมโยงการดาวน์โหลด Windows installer 4.5 ดังต่อไปนี้:
  4. พยายามติดตั้ง หรือถอนการติดตั้งอีกครั้ง

ถ้าปัญหายังคงมีอยู่ ไปที่วิธีที่ 4


วิธีที่ 4: ลองลงทะเบียนโปรแกรมติดตั้ง

ยุบรูปภาพนี้ขยายรูปภาพนี้
2684263
สิ่งสำคัญ วิธีนี้ใช้ กับ Windows XP และ Windows Server 2000 เท่านั้น
  1. คลิกเริ่มคลิกเรียกใช้แล้ว พิมพ์ คำสั่ง ในกล่องโต้ตอบ แล้ว คลิกพรอมต์คำสั่ง
  2. พิมพ์ต่อไปนี้ที่พรอมต์คำสั่ง และจากนั้น กด Enter หลังจากแต่ละบรรทัด:
    MSIExec / ถอนการลงทะเบียน

    MSIExec /regserver
  3. พยายามติดตั้ง หรือถอนการติดตั้งอีกครั้ง
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding end collapsed

การติดตั้ง หรือปรับปรุงโปรแกรมใน Windows อาจไม่เสร็จสมบูรณ์

ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding start collapsed

วิธีการที่จะใช้ใน การติดตั้ง หรือ การปรับปรุงโปรแกรม อาจไม่เสร็จสมบูรณ์

มีหลายวิธีที่สามารถใช้ใน การติดตั้ง ถอนการติดตั้ง หรือ การปรับปรุงโปรแกรม นอกจากนี้ วิธีการหรือวิธีการที่ใช้อาจไม่เริ่มต้น หรือเสร็จสมบูรณ์แล้ว ต่อไปนี้คือ วิธีการทั่วไปที่จะใช้ในการติดตั้งซอฟต์แวร์:
  • ใส่สื่อแบบซีดีหรือดีวีดี แล้ว ให้ติดตั้งเริ่มอัตโนมัติ
  • เรียกดูซีดี ดีวีดี สื่อแบบถอดได้ หรือสถานอื่น ๆ ที่จัดเก็บแฟ้มการติดตั้งโปรแกรม และจากนั้น คลิกสองครั้งที่โปรแกรมติดตั้ง แฟ้มการติดตั้งอยู่โดยทั่วไปต่อไปนี้:
    • ทำงานอัตโนมัติหรือ Autorun.exe
    • ตั้งค่าหรือ Setup.exe
    • ติดตั้งหรือ Install.exe
  • คลิกเรียกใช้เมื่อคุณดาวน์โหลดโปรแกรมจากเว็บไซต์อินเทอร์เน็ต

สื่อการติดตั้งอาจไม่สามารถอ่านได้

สื่อการติดตั้งเช่นซีดีและดีวีดีอาจมีรอยขีดข่วน หรือสกปรก และอาจไม่สามารถอ่านได้ โดยเครื่องอ่านซีดีหรือดีวีดี และทำให้การติดตั้ง ลบ หรือการปรับปรุงการตัดสินค้าจากคลัง

วิธีที่ 1: การทำความสะอาดซีดีหรือดีวีดีที่คุณกำลังใช้การติดตั้ง (ดำเนินการนี้ใช้เฉพาะเมื่อคุณจำเป็นต้องใช้ซีดีหรือดีวีดี)

ทำความสะอาดซีดีหรือดีวีดีสื่อ เมื่อต้องการทำเช่นนี้ ใช้ซีดีหรือดีวีดีแผ่นดิสก์ทำความสะอาดชุด หรือ เช็ดแผ่นดิสก์ด้านสีเงิน โดยใช้ผ้าฝ้ายนุ่ม อย่างไม่ อย่าใช้กระดาษเพราะ ซึ่งสามารถลบทิ้งแบบพลาสติก หรือปล่อย streaks เมื่อคุณล้างแผ่นดิสก์ คลี่จากศูนย์กลางของแผ่นดิสก์ออกด้านนอก อย่าใช้ภาพเคลื่อนไหวแบบวงกลม ถ้าปัญหายังคงเกิดขึ้น ล้างแผ่นดิสก์ โดยใช้ผ้าชื้นหรือเชิงพาณิชย์ซีดีหรือดีวีดีความสะอาดดิสก์โซลูชัน Dry ดิสก์อย่างถี่ถ้วนก่อนที่คุณใส่แผ่นดิสก์ลงในไดรฟ์

วิธีที่ 2: คัดลอกแฟ้มการติดตั้งลงในคอมพิวเตอร์ของคุณ

คัดลอกแฟ้มการติดตั้งลงบนฮาร์ดดิสก์ภายในเครื่องบนคอมพิวเตอร์ของคุณ หรือไป ยังสื่อแบบถอดได้อื่น ๆ หมายเหตุที่ตั้ง และจากนั้น เรียกใช้การติดตั้งจากตำแหน่งที่ตั้ง โดยทั่วไปจะเรียกว่าแฟ้มการติดตั้ง Autorun.exe หรือ Setup.exe แต่นี่อาจแตกต่างกัน ถ้าคุณไม่แน่ใจ ตรวจสอบแฟ้ม Readme ในโฟลเดอร์สำหรับคำแนะนำเกี่ยวกับวิธีการเรียกใช้การติดตั้ง ถ้ามีแฟ้มปฏิบัติการ (.exe) จะพร้อมใช้งาน เราไม่แนะนำให้ คุณเรียกใช้แฟ้ม.msi โดยตรง โดยไม่มีคำแนะนำเฉพาะจากผู้จัดจำหน่าย

วิธีที่ 3: ขอรับแพคเกจการติดตั้งรุ่นใหม่

ถ้าคุณพยายามที่จะติดตั้งจากซีดีหรือดีวีดี ดำเนินการต่อไปนี้:
  • ตรวจสอบเว็บไซต์ของผู้ผลิตซอฟต์แวร์สำหรับแพคเกจซอฟต์แวร์รุ่นล่าสุดหรือไม่ ดาวน์โหลด และติดตั้งเวอร์ชันใหม่
  • ถ้าคุณมีรุ่นล่าสุด ลองดาวน์โหลดโปรแกรมจากเว็บไซต์ของผู้ผลิต จากนั้น เรียกใช้การติดตั้ง

ผู้ใช้ขั้นสูง ถ้าซีดีหรือดีวีดีหลายจำเป็น เราขอแนะนำให้ คุณคัดลอกดิสก์ทั้งหมดไปยังโฟลเดอร์เดียวกัน ในลำดับย้อนกลับ (ดิสก์สูงเลขแรก) โปรดเตรียมให้พร้อมเพื่ออนุมัติแฟ้มจะถูกเขียนทับถ้าคุณได้รับพร้อมท์ และติดตั้งจากตำแหน่งที่ตั้ง


ติดตั้งดาวน์โหลด หรือคัดลอกแฟ้มอาจเสียหาย

วิธีที่ 1: คัดลอกแฟ้มการติดตั้งลงในคอมพิวเตอร์ของคุณ

คัดลอกแฟ้มการติดตั้งลงบนคอมพิวเตอร์ของคุณหรือสื่ออื่น ๆ ถอดฮาร์ดดิสก์ภายในเครื่อง หมายเหตุที่ตั้ง และจากนั้น เรียกใช้การติดตั้งจากตำแหน่งที่ตั้ง โดยทั่วไปจะตั้งชื่อแฟ้มการติดตั้ง Autorun.exe หรือ Setup.exe แต่นี่อาจแตกต่างกัน ถ้าคุณไม่แน่ใจ ตรวจสอบแฟ้ม Readme ในโฟลเดอร์สำหรับคำแนะนำเกี่ยวกับวิธีการเรียกใช้การติดตั้ง ถ้ามีแฟ้มปฏิบัติการ (.exe) จะพร้อมใช้งาน เราไม่แนะนำให้ คุณเรียกใช้แฟ้ม.msi โดยตรง โดยไม่มีคำแนะนำเฉพาะจากผู้จัดจำหน่าย
  • ถ้าคุณกำลังติดตั้งโปรแกรมจากอินเทอร์เน็ต การดาวน์โหลดไฟล์ (เลือกบันทึกแทนที่จะเรียกใช้ในกล่องโต้ตอบดาวน์โหลด), บันทึก toa โฟลเดอร์แฟ้มบนฮาร์ดดิสก์ภายในเครื่องบนคอมพิวเตอร์ของคุณหรือสื่ออื่น ๆ แบบถอดได้ และเรียกใช้การติดตั้งจากตำแหน่งที่ตั้ง
  • ถ้าแฟ้มของคุณติดตั้งอยู่บนเครือข่าย (ตัวอย่างเช่น ทางการค้า หรือองค์กรล้อม), คัดลอกไฟล์ทั้งหมดไปยังโฟลเดอร์บนฮาร์ดดิสก์ภายในเครื่องบนคอมพิวเตอร์ของคุณ และจากนั้น เรียกใช้การติดตั้งจากตำแหน่งที่ตั้ง

วิธีที่ 2: ขอรับแพคเกจการติดตั้งรุ่นใหม่

ถ้าเลยเวลาระหว่างเมื่อคุณดาวน์โหลดแพคเกจและเมื่อคุณพยายามติดตั้ง ทำสิ่งต่อไปนี้:
  • ตรวจสอบเว็บไซต์ของผู้ผลิตซอฟต์แวร์สำหรับแพคเกจซอฟต์แวร์รุ่นล่าสุดหรือไม่ ดาวน์โหลด และติดตั้งเวอร์ชันใหม่
  • ถ้าคุณมีรุ่นล่าสุด ให้ลองดาวน์โหลดโปรแกรมอีกครั้งแล้วเรียกใช้การติดตั้งอยู่แล้ว

โปรแกรมที่กำลังทำงานอยู่บนคอมพิวเตอร์ของคุณอาจจะรบกวนกระบวนการติดตั้ง

ปิดการใช้งานของโปรแกรมที่อาจจะรบกวนกระบวนการติดตั้ง ในการดำเนินการดังกล่าว ให้ทำตามขั้นตอนต่อไปนี้
  1. คลิกStart
    ยุบรูปภาพนี้ขยายรูปภาพนี้
    ปุ่ม'เริ่ม'
    ชนิด msconfig ในการค้นหาในกล่อง และจากนั้น คลิกmsconfig.exe

    ยุบรูปภาพนี้ขยายรูปภาพนี้
    สิทธิ์ในการควบคุมบัญชีผู้ใช้
    หากคุณได้รับพร้อมท์สำหรับรหัสผ่านของผู้ดูแลระบบหรือการยืนยัน ให้พิมพ์รหัสผ่าน หรือทำการยืนยัน
  2. บนแท็บทั่วไปคลิกเริ่มต้นที่เลือกและจากนั้น คลิกเพื่อยกเลิกเลือกกล่องกาเครื่องหมายโหลดรายการเริ่มต้นระบบ
  3. คลิกการบริการคลิกซ่อนบริการของ Microsoft ทั้งหมดและจากนั้น คลิกปิดใช้งานทั้งหมด
  4. คลิกตกลงและจากนั้น คลิกเริ่มใหม่
  5. ลองทำการติดตั้งโปรแกรมซอฟต์แวร์ของคุณ
  6. เมื่อคุณเสร็จสิ้นการแก้ไขปัญหา รีสตาร์ทคอมพิวเตอร์ในโหมดการเริ่มต้นปกติ ในการดำเนินการดังกล่าว ให้ทำตามขั้นตอนต่อไปนี้
    1. คลิกStart
      ยุบรูปภาพนี้ขยายรูปภาพนี้
      ปุ่ม'เริ่ม'
      พิมพ์msconfigลงในกล่องค้นหาและจากนั้น คลิกmsconfig.exe

      ยุบรูปภาพนี้ขยายรูปภาพนี้
      สิทธิ์ในการควบคุมบัญชีผู้ใช้
      หากคุณได้รับพร้อมท์สำหรับรหัสผ่านของผู้ดูแลระบบหรือการยืนยัน ให้พิมพ์รหัสผ่าน หรือทำการยืนยัน
    2. บนแท็บทั่วไปคลิกเริ่มต้นปกติคลิกตกลงและจากนั้น คลิกเริ่มใหม่
สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการใช้ MSConfig ให้คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding end collapsed

ถอนการติดตั้งโปรแกรมใน Windows อาจไม่เสร็จสมบูรณ์

ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding start collapsed

ลองติดตั้ง ถอนการติดตั้ง หรือการปรับปรุงโปรแกรม โดยใช้วิธีการต่าง ๆ ใน Windows

โดยทั่วไปมีหลายวิธีในการถอนการติดตั้งโปรแกรมใด ๆ ลองใช้วิธีต่อไปนี้ ถ้าวิธีหนึ่งไม่สามารถแก้ปัญหา ลองใช้วิธีถัดไป

วิธีที่ 1: ใช้ตัวเลือกการถอนการติดตั้งโปรแกรม (ถ้ามี)
  1. คลิกStart
    ยุบรูปภาพนี้ขยายรูปภาพนี้
    ปุ่ม'เริ่ม'
    แล้ว คลิกโปรแกรมทั้งหมด
  2. เลือกโฟลเดอร์ของโปรแกรมที่คุณกำลังพยายามถอนการติดตั้ง และจากนั้น เปิดโฟลเดอร์
  3. ถ้าไม่มีตัวเลือกถอนการติดตั้ง พยายามที่จะใช้ในการถอนการติดตั้งโปรแกรม

ถ้าไม่มีแก้ไขปัญหาของคุณ ไปที่วิธีที่ 2

วิธีที่ 2: ตัวเลือกแผงควบคุมใช้
  1. คลิกStart
    ยุบรูปภาพนี้ขยายรูปภาพนี้
    ปุ่ม'เริ่ม'
    , 'แผงควบคุม'คลิก คลิกเพิ่มและเอาโปรแกรมออกหรือคลิกโปรแกรมและคุณลักษณะและคลิก การถอนการติดตั้งโปรแกรม
  2. เลือกโปรแกรม และจากนั้น คลิกถอนการติดตั้ง ทำตามพร้อมท์เพื่อถอนการติดตั้งโปรแกรม
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding end collapsed

สำหรับวิธีใช้เพิ่มเติมสำหรับการติดตั้ง ถอนการติดตั้ง หรืออัพเดตการตัดสินค้าจากคลัง

ถ้าคุณตามขั้นตอนเหล่านี้ และยังไม่สามารถแก้ไข คุณอาจต้องติดต่อฝ่ายสนับสนุนของ Microsoft สำหรับความช่วยเหลือเพิ่มเติม สำหรับข้อมูลเกี่ยวกับวิธีการติดต่อฝ่ายสนับสนุนของ Microsoft แวะไปที่เว็บไซต์ของ Microsoft ต่อไปนี้ ค่าธรรมเนียมบางอย่างอาจนำไปใช้คุณอาจต้องการเยี่ยมชมเว็บไซต์ชุมชนของ Microsoft ที่คุณสามารถถามคำถาม และได้รับคำตอบจากผู้ใช้รายอื่น ๆ ฟรี ชุมชน Microsoft คือ ศูนย์ข้อมูลการสนับสนุนสำหรับลูกค้าผู้บริโภค การเยี่ยมชมชุมชน Microsoft แวะไปที่เว็บไซต์ของ Microsoft ต่อไปนี้:
ชุมชน Microsoft

ผู้ใช้ขั้นสูง

ยุบรูปภาพนี้ขยายรูปภาพนี้
2683283
หมายเหตุ ขั้นตอนต่อไปนี้มีความเหมาะสมสำหรับผู้ใช้ขั้นสูงเท่านั้น

ด้วยตนเองถอนการติดตั้งโปรแกรม

ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding start collapsed
คุณอาจสามารถถอนบางส่วนของโปรแกรมผ่านอินเทอร์เฟซของ Windows ด้วยตนเอง ตัวอย่างเช่น คุณอาจจะลบโปรแกรมแฟ้มและโฟลเดอร์ด้วยตนเอง เนื่องจากขั้นตอนการดำเนินการนี้จะแตกต่างกัน ขึ้นอยู่กับรุ่นของ Windows ที่คุณมีและโปรแกรมที่คุณกำลังพยายามถอนการติดตั้ง ไม่มีขั้นตอนต่าง ๆ ที่เหมาะกับไว้ในบทความนี้เพื่อทำสิ่งนี้ให้ หากคุณไม่คุ้นเคยเพียงพอกับโปรแกรมที่คุณกำลังพยายามถอนการติดตั้งเพื่อระบุแฟ้มและโฟลเดอร์สำหรับโปรแกรมนั้น เราไม่แนะนำให้ คุณลองใช้วิธีนี้ โดยทั่วไปแล้ว คุณสามารถลบโปรแกรมแฟ้มและโฟลเดอร์ด้วยตนเอง คุณเสี่ยงต่อการทำลายระบบปฏิบัติการของคุณ ขั้นตอนนี้ควรมีความรับผิดชอบของคุณเอง

ถ้าคุณกำลังพิจารณาด้วยตนเองถอนการติดตั้งโปรแกรม ต่อไปนี้คือ บางสิ่งที่คุณควรจำไว้ว่า:
  • คุณควรทำทุกความพยายามถอนการติดตั้งแอพลิเคชัน โดยวิธีแบบดั้งเดิมก่อนที่คุณทำตามขั้นตอนนี้ ตัวอย่างเช่น ใช้เพิ่มหรือเอาโปรแกรมออกในแผงควบคุม
  • ก่อนที่คุณทำตามขั้นตอนนี้ คุณควรสร้างจุดคืนค่าระบบ
  • ก่อนที่คุณจะเริ่ม ย้ายข้อมูลส่วนบุคคลหรือเอกสารที่อาจสิ้นสุดขึ้นในโฟลเดอร์การติดตั้งของโปรแกรมประยุกต์ ตัวอย่างเช่น ย้ายไปยังโฟลเดอร์เอกสาร
  • ถ้าคุณไม่สามารถลบแฟ้มโปรแกรมด้วยตนเอง นี่อาจหมายความ ว่า แฟ้มกำลังถูกใช้ หรือว่า โปรแกรมอื่นเข้าถึงแฟ้ม และไม่อนุญาตให้คุณลบเอกสารนั้น ตัวอย่างเช่น ซอฟต์แวร์ป้องกันไวรัสอาจเข้าถึงแฟ้ม เมื่อซอฟต์แวร์ป้องกันไวรัสมีการเข้าถึงแฟ้มโปรแกรม และทำให้ไม่สามารถลบแฟ้ม เป็นไปได้ว่า ซอฟต์แวร์ป้องกันไวรัสนี้เดียวกันถูกรักษาคุณจากการถอนการติดตั้งโปรแกรมโดยใช้วิธีแบบดั้งเดิม
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding end collapsed

กาเครื่องหมายสำหรับแฟ้มหรือโฟลเดอร์ชื่อยาวเกิน 260 อักขระ

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับข้อจำกัดความยาวเส้นทางสูงสุด แวะไปที่เว็บไซต์ Microsoft Developer Network (MSDN) ต่อไปนี้:
แฟ้ม เส้นทาง และ Namespaces

เปิดใช้งานการบันทึก MSI และอ่าน MSI verbose ล็อกแล้ว

ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding start collapsed
โปรแกรมส่วนใหญ่จะสร้างแฟ้มบันทึกการติดตั้ง ถ้าไม่มีแฟ้มบันทึกจะอยู่ คุณสามารถเปิดใช้งานการบันทึก MSI verbose สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการเปิดใช้การบันทึกของ Windows Installer คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft: 223300 วิธีการเปิดใช้การบันทึกของ Windows Installer

ยุบรูปภาพนี้ขยายรูปภาพนี้
2683283
หมายเหตุ ถ้าคุณกำลังเรียกใช้.msi ไม่ มีโปรแกรมประยุกต์ bootstrapping (.exe), คุณสามารถเพิ่มพารามิเตอร์สำหรับการบันทึก verbose ตัวอย่าง:
Msiexec เส้นทาง\your_msi.msi / L * v เส้นทาง\your_msi_log.txt
สำหรับรายการของพารามิเตอร์บรรทัดคำสั่ง msiexec แวะไปเว็บไซต์ Microsoft Developer Network (MSDN) ต่อไปนี้:
ตัวเลือกบรรทัดคำสั่ง
การติดตั้งล้มเหลวจะเข้าสู่การส่งกลับค่า 3 ซึ่งเกิดปัญหา และการย้อนกลับการติดตั้งเริ่มต้นโดยทั่วไป คำอธิบายของความล้มเหลวจะปรากฏขึ้นทันทีก่อนรายการล็อก 3 ค่าที่ส่งคืน

ที่ Wilogutl.exe เครื่องมืออาจเป็นประโยชน์ในการวิเคราะห์ไฟล์บันทึกจากการติดตั้ง Windows Installer นอกจากนี้ เครื่องมือสามารถแนะนำวิธีแก้ไขข้อผิดพลาดที่พบในแฟ้มบันทึก เครื่องมือ Wilogutil.exe ไม่มีอยู่ในล่าสุด ชุดพัฒนาซอฟต์แวร์ของ Microsoft Windows

ต่อไปนี้เป็นตัวอย่างของวิธีการใช้เครื่องมือ Wilogutl.exe:
wilogutl /q /l c:\mymsilog.log /o c\outputdir\
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding end collapsed


ข้อมูลอ้างอิง

สำหรับข้อมูลทั่วไปเกี่ยวกับวิธีการติดตั้ง หรือถอนการติดตั้งโปรแกรม แวะไปที่เว็บไซต์ของ Microsoft ต่อไปนี้:

ติดตั้งโปรแกรม
ถอนการติดตั้ง หรือเปลี่ยนโปรแกรม
ติดตั้งโปรแกรม: คำถามที่ถามบ่อย

คุณสมบัติ

หมายเลขบทความ (Article ID): 2438651 - รีวิวครั้งสุดท้าย: 17 พฤศจิกายน 2556 - Revision: 16.0
ใช้กับ
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Starter Edition
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter Edition (64-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise Edition (64-Bit x86)
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Standard Edition (64-Bit x86)
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Enterprise Edition
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Standard Edition
Keywords: 
kbsurveynew kbexpertiseinter kbinfo kbcip kbmt KB2438651 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:2438651

ให้ข้อเสนอแนะ