ID článku: 244435 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

Aplikace Microsoft Excel ukládá pouze tu část listu, která je používána, tj. část obsahující data a formátování. Poslední buňka listu někdy může být mimo oblast skutečně používaných dat. Tento problém může vést k větší než potřebné velikosti souboru, k tisku nadbytečných stránek, zobrazení chybových zpráv „Nedostatek paměti“ nebo k jinému nezvyklému chování. Tyto problémy můžete vyřešit odstraněním nadbytečných řádků a sloupců a novým nastavením poslední buňky.

Poznámka: Poslední buňku aktivního listu najdete stisknutím kombinace kláves CTRL+SHIFT+END.

Další informace

Nejběžnější příčinou nastavení poslední buňky mimo aktuálně používanou oblast listu je nadbytečné formátování. Formátujete-li celé řádky nebo sloupce mohou některé typy formátování vést k nastavení poslední buňky daleko dolů nebo vpravo mimo skutečně používanou oblast.

Tento problém se rovněž může projevit, když do aplikace Excel importujete soubor aplikace Lotus 1-2-3. Při uložení souboru aplikace Lotus do formátu sešit aplikace Excel, nemůže aplikace Excel v listu aplikace Lotus 1-2-3 určit poslední buňku. Proto nastaví jako aktivní celý list. Chcete-li nově nastavit adresu poslední buňky, můžete jednou z následujících metod odstranit z nevyužívaných sloupců a řádků listu nepotřebné informace (data a formátování). Po odebrání nadbytečných informací list uložte, aby aplikace Excel znovu vytvořila tabulku aktivních buněk.

Poznámka: Použijete-li jednu z následujících metod, může se zobrazit chybová zpráva „Nedostatek paměti“ nebo podobná chybová zpráva. Aplikace Excel se totiž pokouší odstranit vybranou oblast. Pokud se zobrazí tato chybová zpráva, použijte při odstraňování dat menší oblasti řádků nebo sloupců.

Metoda 1: Ruční odstranění nadbytečných řádků a sloupců

Chcete-li poslední buňku nově nastavit ručním odstraněním nadbytečných řádků a sloupců, postupujte takto:
  1. Výběrem záhlaví příslušných sloupců vyberte sloupce vpravo od posledního sloupce, který obsahuje data.

    Tip: Jedním ze způsobů, jak to provést, je stisknout klávesu F5 a zadat příslušný odkaz. V případě sloupců například zadejte F:IV, v případě řádků 5:65536.
  2. V nabídce Úpravy klepněte na příkaz Vymazat vše.

    Poznámka: Pokud tento krok nevymaže veškeré nadbytečné formátování, bude zřejmě nutné klepnout pravým tlačítkem myši na sloupce a pak klepnout na příkaz Odstranit, aby se buňky zcela odstranily. Pokud odstraníte buňky, na které odkazuje nějaký vzorec, odkaz ve vzorci se změní na #REF!. Proto doporučujeme před provedením tohoto postupu zazálohovat původní soubor a po provedení postupu zkontrolovat, zda se v nějakém vzorci neobjevilo #REF!.
  3. Pro řádky, které jsou pod posledním řádkem obsahujícím data, opakujte kroky 1 a 2.
  4. Uložte soubor.
  5. Chcete-li pokračovat v práci v souboru, zavřete jej a znovu otevřete.

Metoda 2: Použití doplňku aplikace Excel

Poznámka: Následující doplněk aplikace Excel se týká pouze anglické verze aplikace Excel, nikoli neanglické verze aplikace Excel. Před použitím tohoto doplňku aplikace Excel možná bude nutné v této aplikaci změnit jazyk.

Nyní je možné stáhnout doplněk aplikace Excel, který odebere nadbytečné formátování a znovu nastaví poslední buňku. Lze jej stáhnout z následujícího webu společnosti Microsoft:
http://www.microsoft.com/downloads/details.aspx?FamilyId=ECFD076C-B873-48CC-B842-DA999C848C82&displaylang=en
  1. Na stránce pro stažení, klepněte na tlačítko Stáhnout. Po zobrazení výzvy klepněte na tlačítko Otevřít nebo Spustit.
  2. Když se zobrazí licenční smlouva, klepněte na tlačítko Ano.
  3. Když se zobrazí výzva programu WinZip Self-Extractor, klepněte na tlačítko Procházet a vyberte umístění, do kterého chcete doplněk extrahovat.

    Poznámka: Soubor můžete uložit do umístění pro doplňky aplikace Excel, takže se v aplikaci Excel automaticky zobrazí v dialogovém okně Doplňky. Toto umístění je složka Library v instalačním umístění systému Office. Toto umístění je obvykle ve složce C:\Program Files\Microsoft Office\Office\Library.

    Po výběru požadovaného umístění pro stahovaný soubor v dialogovém okně Procházet klepněte v dialogovém okně programu WinZip na tlačítko UnZip. V potvrzení úspěšného stažení klepněte na tlačítko OK a v dialogovém okně programu WinZip klepněte na tlačítko Zavřít.
  4. Spusťte aplikaci Excel a použijte jeden z následujících postupů (podle používané verze aplikace Excel).

    Microsoft Office Excel 2007

    1. Klepněte na Tlačítko Office a potom na tlačítko Možnosti aplikace Excel.
    2. Klepněte na možnost Doplňky, v dialogovém okně Správa klepněte na možnost Doplňky aplikace Excel a pak klepněte na tlačítko Přejít.
    3. Pokud jste soubor neuložili do složky Library, klepněte na tlačítko Procházet, vyhledejte soubor a vyberte jej v okně Procházet.
    4. Klepněte na možnost Excess Format Cleaner 1.1 a poté na tlačítko OK.

    Microsoft Office Excel 2003 a starší verze aplikace Excel

    1. V nabídce Nástroje klepněte na příkaz Doplňky.
    2. Pokud jste soubor neuložili do složky Library, klepněte na tlačítko Procházet, vyhledejte soubor a vyberte jej v okně Procházet.
    3. Klepněte na možnost Excess Format Cleaner 1.1 a poté na tlačítko OK.
  5. V aplikaci Excel 2007 klepněte na kartu Doplňky a pak ve skupině Příkazy nabídky klepněte na možnost Clear Excess Formats in XSFormatCleaner.xla.

    V aplikaci Excel 2003 a ve starších verzích aplikace Excel otevřete sešit, který chcete vyčistit, a pak v nabídce Soubor klepněte na příkaz Clear Excess Formatting in sešit. Makro pak ze všech listů v souboru odstraní nadbytečné formátování.

    Po dokončení makra se zobrazí zpráva, že změny budou trvalé až po uložení sešitu.
  6. Soubor uložte, zavřete a znovu jej otevřete.

Vlastnosti

ID článku: 244435 - Poslední aktualizace: 21. května 2008 - Revize: 6.1
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Office Excel 2007
  • Microsoft Office Excel 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
Klíčová slova: 
kbexpertisebeginner kbcode kbdtacode kbhowto kbinfo kbprogramming KB244435

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com