Artikkelin tunnus: 244435 - Näytä tuotteet, joita tämä artikkeli koskee.
Laajenna kaikki | Kutista kaikki

Tällä sivulla

Yhteenveto

Microsoft Excel tallentaa vain osan jokaisesta käytössä olevasta laskentataulukosta eli dataa tai muotoilutietoja sisältävän osan. Joskus laskentataulukon viimeinen solu voi olla todellisten käytettyjen tietojen alueen ulkopuolella. Tämä ongelma saattaa saada aikaan sen, että tiedoston koko on tarvittavaa suurempi, ylimääräisiä sivuja saatetaan tulostaa, näyttöön saattaa tulla Muisti ei riitä -virhesanomia tai saattaa ilmetä muuta epätavallista toimintaa. Ylimääräisten rivien ja sarakkeiden tyhjentäminen, jotta viimeinen solu nollataan, voi ratkaista kyseiset ongelmat.

Huomautus Voit paikantaa aktiivisen laskentataulukon viimeisen solun painamalla CTRL+VAIHTO+END.

Enemmän tietoa

Yleisin syy siihen, että viimeinen solu on määritetty laskentataulukon alueen ulkopuolelle, on liiallisen muotoilun käyttäminen. Kun muotoilet kokonaisia rivejä ja sarakkeita, jotkin muotoilutyypit saattavat aiheuttaa sen, että viimeinen solu määritetään paljon todellisen käytössä olevan alueen alapuolelle tai oikealle puolelle.

Tämä ongelma voi ilmetä myös, kun Lotus 1-2-3 -tiedosto tuodaan Exceliin. Kun tallennat Lotus-tiedoston Excelin työkirjamuotoon, Excel ei pysty selvittämään Lotus 1-2-3 -laskentataulukon viimeistä solua. Tämän vuoksi se tekee koko laskentataulukosta aktiivisen. Jos haluat nollata viimeisen soluosoitteen, voit tyhjentää tarpeettomat tiedot (datan ja muotoilun) laskentataulukon käyttämättömistä sarakkeista ja riveistä jommallakummalla seuraavista tavoista. Kun olet poistanut ylimääräiset tiedot, tallenna laskentataulukko, jotta Excel pakotetaan muodostamaan aktiivinen solutaulukko uudelleen.

Huomautus Kun käytät jompaakumpaa seuraavista tavoista, näyttöön saattaa tulla Muisti ei riitä -virhesanoma tai vastaava virhesanoma. Tämä johtuu siitä, että Excel yrittää poistaa valitun alueen. Jos tämä virhesanoma tulee näyttöön, käytä tietoja tyhjentäessäsi pienempiä rivi- tai sarakealueita.

Tapa 1: Poista ylimääräiset rivit ja sarakkeet manuaalisesti

Jos haluat nollata viimeisen solun poistamalla ylimääräiset rivit ja sarakkeet manuaalisesti, toimi seuraavasti:
  1. Valitse kaikki sarakkeet viimeisen tietoja sisältävän sarakkeen oikealta puolelta valitsemalla asianmukaiset sarakeotsikot.

    Vihje Yksi tapa tehdä tämä on painaa F5-näppäintä ja kirjoittaa asianmukaiset viittaustiedot. Kirjoita esimerkiksi sarakkeille F:IV tai riveille 5:65536.
  2. Valitse Muokkaa-valikosta Tyhjennä kaikki.

    Huomautus: Jos tämä vaihe ei poista kaikkea ylimääräistä muotoilua, voit poistaa solut kokonaan napsauttamalla sarakkeita hiiren kakkospainikkeella ja valitsemalla sitten Poista. Jos poistamiisi soluihin viitataan kaavoissa, viittauksen muodoksi vaihtuu #REF!. Tästä syystä suosittelemme alkuperäisen tiedoston varmuuskopioimista ja kaavojen toimivuuden tarkistamista (ettei niissä ole #REF!.-viittauksia) näiden toimien suorittamisen jälkeen.
  3. Toista vaiheita 1 ja 2 tietoja sisältävän viimeisen rivin alapuolella oleville riveille.
  4. Tallenna tiedosto.
  5. Jos haluat jatkaa tiedoston käsittelemistä, sulje tiedosto ja avaa se sitten uudelleen.

Tapa 2: käytä Excel-apuohjelmaa

Excel-malliapuohjelma, joka poistaa ylimääräisen muotoilun ja nollaa viimeisen solun, on nyt ladattavissa. Voit ladata tämän apuohjelman seuraavasta Microsoftin verkkosivustosta:
XSFormatCleaner.xla.
Lataa XSFormatCleaner.xla sivun latausosiosta ja tallenna se tietokoneeseesi. Kun olet ladannut xla:n, voit poistaa ylimääräiset muotoilut työkirjastasi suorittamalla koodin apuohjelmassa seuraavien ohjeiden mukaisesti.
  1. Käynnistä Excel ja tee sitten seuraavat Excel-versiosi mukaiset toimet.

    Microsoft Office Excel 2007, 2010 ja 2013

    1. Napsauta Microsoft Office -painiketta ja valitse sitten Excel Options.
    2. Valitse Add-Ins, valitse Manage-ruudussa Excel Add-ins ja valitse sitten Go.
    3. Jos et tallentanut tiedostoa Library-kansioon, valitse Selaa, etsi tiedosto ja valitse tiedosto sitten Selaa-valintaikkunassa.
    4. Valitse Excess Format Cleaner 1.1 ja valitse sitten OK.

    Microsoft Office Excel 2003 ja Excelin aiemmat versiot (englanninkieliset)

    1. Valitse Tools-valikosta Add-Ins.
    2. Jos et tallentanut tiedostoa Library-kansioon, valitse Selaa, etsi tiedosto ja valitse tiedosto sitten Selaa-valintaikkunassa.
    3. Valitse Excess Format Cleaner 1.1 ja valitse sitten OK.
  2. Valitse Excel 2007:ssä Add-Ins-välilehti ja valitse sitten Menu Commands -ryhmästä Clear Excess Formats in XSFormatCleaner.xla.

    Avaa siivottava työkirja Excel 2003:ssa tai Excelin aiemmissa versioissa ja valitse sitten File-valikosta Clear Excess Formatting in työkirja. Makro tyhjentää ylimääräisen muotoilun kaikista tiedoston laskentataulukoista.

    Kun makron suorittaminen on päättynyt, näyttöön tulee sanoma siitä, että työkirja on tallennettava, jotta muutokset ovat pysyvät.
  3. Tallenna tiedosto, sulje se ja avaa se sitten uudelleen.
Huomautus Tämä on niin sanottu nopeasti julkaistava (?fast publish?) artikkeli, joka on laadittu suoraan Microsoftin tukiorganisaatiossa. Tässä olevat tiedot toimitetaan sellaisenaan vastauksena esiin tulleisiin ongelmiin. Koska aineisto on tuotu saataville nopeasti, se saattaa sisältää painovirheitä ja tietoja saatetaan muokata milloin tahansa ilman erillistä ilmoitusta. Lue muut huomioon otettavat seikat käyttöehdoista.

Ominaisuudet

Artikkelin tunnus: 244435 - Viimeisin tarkistus: 31. tammikuuta 2014 - Versio: 1.0
Artikkelin tiedot koskevat seuraavia tuotteita:
  • Microsoft Excel 2013
  • Microsoft Excel 2010
  • Microsoft Office Excel 2003
  • Microsoft Office Excel 2007
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
Hakusanat: 
kbexpertisebeginner kbcode kbdtacode kbhowto kbinfo kbprogramming KB244435

Anna palautetta

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com