Update: Eine SNA-Anwendung reagiert möglicherweise nicht mehr, nachdem es 512 Transaktionen in einer 64-Bit-Version von Host Integration Server 2009 oder Host Integration Server 2010

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 2459642 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Stellen Sie sich das folgende Szenario vor:
  • Sie haben einen Clientcomputer, auf dem eine 64-Bit-Version von Microsoft Host Integration Server 2009 oder Microsoft Host Integration Server 2010 ausgeführt wird.
  • Sie verbinden den Clientcomputer zu einem Server, auf dem eine 32-Bit-Version von Host Integration Server 2009 oder Host Integration Server 2010 ausgeführt wird.
  • Sie haben eine 64-Bit-SNA-Anwendung (z. B. APPC, CPI-C, LUA oder 3270) auf dem Clientcomputer installiert.
  • Sie starten den SnaBase-Prozess auf dem Server.
  • Sie starten die SNA-Anwendung auf dem Clientcomputer mindestens fünf Minuten nach dem Starten des Prozesses SnaBase.
  • Die SNA-Anwendung wird 512 Transaktion Anforderungen an den Server gesendet.
In diesem Szenario die SNA-Anwendung reagiert möglicherweise nicht mehr.

Ursache

Dieses Problem tritt auf, wenn der Host Integration Server-Client eine Antwort vom Host Integration Server-32-Bit-System erhält. In diesem Fall gibt der SnaBase Prozess auf dem Host Integration Server-Client nicht Einträge in ein Array frei, auf dem den 64-Bit-Zeiger 32-Bit-Index-Zuordnungen gespeichert. Wenn die Anzahl der Einträge im Array der maximal 512 erreicht, kann die SNA-Anwendung weitere Anforderungen nicht verarbeiten.

Lösung

Hotfix-Informationen


Ein unterstützter Hotfix ist von Microsoft erhältlich. Der Hotfix ist jedoch nur das Problem zu beheben, das in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systeme an, bei die das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix wird möglicherweise zusätzliche Tests angezeigt. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft, für das nächste Update warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, ist ein Abschnitt "Hotfix Download verfügbar" am Anfang dieses Knowledge Base-Artikels. Wenn dieser Abschnitt nicht angezeigt wird, wenden Sie sich an Microsoft Customer Service und Support, um den Hotfix zu erhalten.

Hinweis:Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Normale Servicegebühren werden jedoch für weitere Fragen und Problemen, die für diesen bestimmten Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf den folgenden Microsoft-Website:
http://support.Microsoft.com/contactus/?ws=Support
Hinweis:Das Formular "Hotfix Download verfügbar" zeigt die Sprachen an, für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen:

Um diesen Hotfix anwenden zu können, muss Microsoft Host Integration Server 2009 oder Microsoft Host Integration Server 2010 installiert sein.

Informationen zum Neustart

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix anwenden.

Dateiinformationen

Die englische Version dieses Updates besitzt die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) aufgeführt. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln, verwenden dieDie ZeitzoneRegisterkarte derDatum und UhrzeitElement in der Systemsteuerung.

Dateiinformationen für Host Integration Server 2009 und Host Integration Server 2010

Für alle unterstützten x 86-basierten Versionen von Host Integration Server 2009
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Snabase.exe8.0.3787.2252,24011-Nov 201018: 03X 86
Für alle unterstützten x 64-basierten Versionen von Host Integration Server 2009
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Snabase.exe8.0.3787.2293,71211-Nov 201018: 08X 64
Für alle unterstützten x 86-basierten Versionen von Host Integration Server 2010
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Snabase.exe8.5.4250.2264,01613-Nov 201001: 52X 86
Für alle unterstützten x 64-basierten Versionen von Host Integration Server 2010
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Snabase.exe8.5.4250.2296,27213-Nov 201001: 56X 64
Hinweis:Aufgrund von Dateiabhängigkeiten kann das neueste Update, das diese Dateien enthält, auch weitere Dateien enthalten.

Status

Microsoft hat bestätigt, dass es sich um ein Problem bei den Microsoft-Produkten handelt, die im Abschnitt "Beziehen sich auf" aufgeführt sind.

Eigenschaften

Artikel-ID: 2459642 - Geändert am: Mittwoch, 29. Dezember 2010 - Version: 2.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Host Integration Server 2009
  • Microsoft Host Integration Server 2010
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbexpertiseadvanced kbsurveynew kbmt KB2459642 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 2459642
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com