Artigo: 2464297 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Sintomas

Quando faz duplo clique num destes tipos de ficheiro:
  • Documento do Word (.doc ou .docx)
  • Excel (.xls ou .xlsx)
  • PowerPoint (.ppt ou .pptx)
Poderá deparar-se com qualquer um destes problemas:
  1. O ícone do ficheiro está em branco ou apresenta uma imagem incorrecta.
  2. O ficheiro não abre.
  3. Recebe este erro:

    Este ficheiro não tem um programa associado para executar esta acção. Crie uma associação em Opções de Pastas no painel de controlo.
  4. Recebe este erro:

    <nome de ficheiro> não é uma Aplicação Win32 válida

Causa

Estes problemas ocorrem quando falta a associação entre o ficheiro e a aplicação correspondente.

Resolução

Antes de continuar com qualquer um dos métodos nesta secção, recomendamos que verifique se existem várias instalações do Office no seu computador. Para o fazer, siga estes passos:
  1. Clique em Iniciar.
    • No Windows XP, clique em Executar e, em seguida, clique na caixa Abrir.
    • No Windows Vista, clique na caixa Iniciar Procura.
    • No Windows 7, clique na caixa Procurar programas e ficheiros.
  2. Escreva appwiz.cpl e, em seguida, clique em OK.
  3. Verifique se existem várias instalações do conjunto de aplicações Microsoft Office na lista dos programas instalados actualmente.
Caso existam várias instalações do Microsoft Office no computador, recomendamos que siga os passos listados no Método 2 desta secção. Caso exista apenas uma instalação do Microsoft Office no computador, siga os passos listados no Método 1 desta secção. Siga os passos listados no Método 3 apenas no caso de ainda se deparar com problemas após ter tentado os dois primeiros métodos ou se tiver instalado o conjunto de aplicações de avaliação do Microsoft Office.

Método 1

Caso exista apenas uma instalação do Microsoft Office 2010 no computador, siga estes passos para reparar o Microsoft Office:
  1. Clique em Iniciar.
    • No Windows XP, clique em Executar e, em seguida, clique na caixa Abrir.
    • No Windows Vista, clique na caixa Iniciar procura.
    • No Windows 7, clique na caixa Procurar programas e ficheiros.
  2. Escreva appwiz.cpl e, em seguida, clique em OK.
  3. Seleccione o conjunto de aplicações do Microsoft Office 2010 que pretende reparar e, em seguida, clique em Alterar.
    Reduzir esta imagemExpandir esta imagem
    2906721
  4. Clique em Reparar e, em seguida, clique em Continuar. Poderá ter de reiniciar o computador após a reparação estar concluída.
Método 2
Reduzir esta imagemExpandir esta imagem
assets folding start collapsed
Caso tenha mais do que uma instalação de um conjunto de aplicações do Microsoft Office 2010 no computador, recomendamos que desinstale os conjuntos de aplicações baseados em Clique-e-Use para evitar problemas na associação do tipo de ficheiros. Terá de desinstalar o Microsoft Office Starter, Microsoft Office Clique-e-Use ou o conjunto de aplicações Microsoft Office 2010, Versão de Avaliação e reparar a instalação baseada em MSI (pacote Microsoft Installer) tradicional do Microsoft Office 2010:
  1. Clique em Iniciar.
    • No Windows XP, clique em Executar e, em seguida, clique na caixa Abrir.
    • No Windows Vista, clique na caixa Iniciar procura.
    • No Windows 7, clique na caixa Procurar programas e ficheiros.
  2. Escreva appwiz.cpl e, em seguida, clique em OK.
  3. Na lista de programas actualmente instalados, seleccione Microsoft Office Clique-e-Use 2010 e clique em Remover (no Windows XP) ou Desinstalar (no Windows Vista e no Windows 7).
  4. Será visualizado um pedido a solicitar que desinstale a selecção. Clique em Sim.
  5. Siga as instruções de desinstalação e reinicie o computador.
  6. Clique em Iniciar.
    • No Windows XP, clique em Executar e, em seguida, clique na caixa Abrir.
    • No Windows Vista, clique na caixa Iniciar procura.
    • No Windows 7, clique na caixa Procurar programas e ficheiros.
  7. Escreva appwiz.cpl e clique em OK.
  8. Seleccione o conjunto de aplicações do Office 2010 baseado em MSI que pretende reparar e, em seguida, clique em Alterar.
  9. Seleccione Reparar e clique em Continuar. Poderá ter de reiniciar o computador após a reparação estar concluída.
Reduzir esta imagemExpandir esta imagem
assets folding end collapsed
Método 3
Reduzir esta imagemExpandir esta imagem
assets folding start collapsed
Nota: Este método pode não ser uma correcção permanente do problema de associação do tipo de ficheiro que está a ocorrer. Recomendamos que siga primeiro os métodos anteriores e tente estes passos apenas se o problema continuar a ocorrer.

Caso apenas tenha um Microsoft Office Starter, Microsoft Office 2010, Versão de Avaliação ou Microsoft Office Clique-e-Use 2010 instalado no computador, siga estes passos para voltar a associar o ficheiro manualmente:
  1. Clique com o botão direito do rato no ficheiro do Microsoft Office que pretende abrir. No Windows XP, poderá ser necessário premir SHIFT e clicar com o botão direito do rato no ficheiro.
  2. Seleccione Abrir com e, em seguida, clique em Escolher programa predefinido... (no Windows 7 ou no Windows Vista) ou Escolher Programa (no Windows XP).
  3. Na lista de Programas Recomendados, seleccione Processador de Virtualização de Cliente do Microsoft Office.
  4. Clique para seleccionar a caixa de verificação Utilizar sempre o programa seleccionado para abrir este tipo de ficheiro e, em seguida, clique em OK.

Se tiver apenas um conjunto de aplicações do Microsoft Office 2010 baseado em MSI (pacote Microsoft Installer) instalado no computador, siga estes passos para voltar a associar o ficheiro manualmente:
  1. Clique com o botão direito do rato no ficheiro do Microsoft Office que pretende abrir. No Windows XP poderá ser necessário premir SHIFT e clicar com o botão direito do rato no ficheiro.
  2. Seleccione Abrir com e, em seguida, clique em Escolher programa predefinido... (no Windows 7 ou no Windows Vista) ou Escolher Programa (no Windows XP).
  3. Na lista de Programas Recomendados, seleccione o programa adequado para associar ao ficheiro.
  4. Clique para seleccionar a caixa de verificação Utilizar sempre o programa seleccionado para abrir este tipo de ficheiro e, em seguida, clique em OK.
O ícone do seu ficheiro apresenta agora a imagem correcta e deverá abrir no programa Microsoft Office correcto.
Reduzir esta imagemExpandir esta imagem
assets folding end collapsed


Mais Informação

As versões Clique-e-Use e MSI (pacote Microsoft Installer) do Microsoft Office 2010 não foram concebidas para serem utilizadas no mesmo computador. Recomendamos que seleccione uma versão para executar no computador, evitando problemas como os indicados neste artigo.

Para obter mais informações acerca do Microsoft Office Clique-e-Use e associações de ficheiros, clique no número de artigo que se segue para visualizar o artigo na Base de Dados de Conhecimento Microsoft:

982434 Descrição geral do Microsoft Office Clique-e-Use para Office 2010


Se tiver seguido os passos neste artigo e ainda recebe as mesmas mensagens de erro listadas na secção Sintomas deste artigo, poderá ter problemas de permissões com o seu registo.
Uma vez que pode não ser possível saber o que provocou ou levou aos problemas das permissões, sugerimos que considere restaurar o Windows para um estado anterior.

Restaurar ficheiros e definições do sistema (Windows 7)
http://windows.microsoft.com/pt-pt/windows7/Restore-system-files-and-settings

Como reparar o sistema operativo e como restaurar a configuração do sistema operativo para um ponto anterior no tempo do Windows Vista
http://support.microsoft.com/kb/936212/pt

Como restaurar o Windows XP para um estado anterior
http://support.microsoft.com/kb/306084/pt


Se os seus ficheiros Excel ainda não estiverem a abrir, mas o erro tiver parado após ter seguido estes passos, poderá ter mais um problema a resolver.

Sugerimos que verifique também o conteúdo fornecido neste artigo:
http://support.microsoft.com/kb/211494/pt


Propriedades

Artigo: 2464297 - Última revisão: 31 de outubro de 2013 - Revisão: 7.0
A informação contida neste artigo aplica-se a:
  • Microsoft Excel 2013
  • Microsoft Word 2013
  • Microsoft PowerPoint 2013
  • Microsoft Excel 2010
  • Microsoft Word 2010
  • Microsoft PowerPoint 2010
  • Microsoft Office Starter 2010
  • Microsoft Office Standard 2010
  • Microsoft Office Home and Student 2010
  • Microsoft Office Home and Business 2010
  • Microsoft Office Professional 2010
  • Microsoft Office Professional Plus 2010
Palavras-chave: 
KB2464297

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com