Stránkovaný dotaz LDAP selže na druhé stránce a stránky, postupujte v systému Windows Server 2008 R2

Překlady článku Překlady článku
ID článku: 2468316 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Zvažte následující scénář:
  • Máte server Lightweight Directory Access Protocol (LDAP) nebo řadiče domény se systémem Windows Server 2008 R2.
  • Provedení stránkovaného dotaz LDAP řadiči domény.
  • PomocícreateTimeStampnebomodifyTimeStampAtribut filtru dotazu.
  • Výsledek dotazu zahrnuje více stránek.
V tomto scénáři stránkovaného dotaz LDAP selže na druhé stránce a druhé stránce na následujících stránkách.

Následuje příklad scénáře:
  • Nasazení řadiče domény se systémem Windows Server 2008 R2.
  • Nasazení serveru Microsoft Exchange Server 2007 v počítači a potom povolte aplikace Microsoft Office Outlook Web Access.
  • Můžete nakonfigurovat dostatek informací uživatele Chcete-li povolit více než jednu stránku výsledků hledání seznamu (GAL) globální adresy.
  • Zadejte hledaný termín, který vrací více než jednu stránku výsledků.
  • Pokusíte se posouvat zpět vícestránkové výsledky hledání globálního seznamu adres.
V tomto případě nelze se posouvat zpět výsledky a zobrazí následující chybová zpráva:

Nelze se připojit k adresářovému serveru. Pokud problém přetrvává, obraťte se na technickou podporu organizaci.

Příčina

K tomuto problému dochází, protože některé filtry hledání nesprávně změněna v dotazech LDAP stránkovat.

Řešení

Informace o opravě hotfix

Podporovaná oprava hotfix je k dispozici od společnosti Microsoft. Tato oprava hotfix je však určena pouze problém popsaný v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k popsanému problému popsaného v tomto článku. Tato oprava hotfix může být dále testována. Proto pokud není vážně ovlivněn tento problém, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix je k dispozici ke stažení, je sekce "Hotfix stažení k dispozici" v horní části tohoto článku. Pokud tento oddíl není uveden, obraťte se na odbornou pomoc a služby zákazníkům společnosti, jak získat opravu hotfix.

Poznámka:Pokud nastanou další problémy nebo řešení potíží je vyžadován, budete muset vytvořit samostatnou žádost. Výdaje na technickou podporu projeví dalších otázek a problémů, které nelze vyřešit určitou konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu navštivte následující web společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka:"Hotfix stažení k dispozici" formulář zobrazí jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, je oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Tuto opravu hotfix, spuštěn operační systém, který zní:

  • Systém Windows Server 2008 R2
  • Aktualizace Service Pack 1 (SP1) pro systém Windows Server 2008 R2

Informace o registru

Použít opravu hotfix, není nutné změnit registr.

Požadavek na restartování

Po instalaci této opravy hotfix je nutné restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje žádné dříve vydané opravy hotfix.

Informace o souborech

Globální verze této opravy hotfix nainstaluje soubory s atributy, které jsou uvedeny v následujících tabulkách. Kalendářní data a časy jednotlivých souborů jsou uvedeny ve koordinovaný světový čas (UTC). Kalendářní data a časy těchto souborů v místním počítači jsou zobrazeny podle místního času společně podle aktuálního letní čas (DST). Navíc data a časy mohou změnit při provádění některých operací se soubory.
Poznámky k informacím o soubor systému Windows Server 2008 R2
DůležitéOpravy hotfix pro systém Windows 7 a Windows Server 2008 R2 opravy hotfix jsou zahrnuty ve stejném balení. Avšak na stránce žádost o opravu Hotfix opravách v obou operačních systémech. O balíčku oprav hotfix, která se vztahuje k jedné nebo obou operačních systémů, vyberte opravu hotfix, která je uvedena v části "Windows 7 a Windows Server 2008 R2" na stránce. Vždy naleznete v části "Platí pro" v článcích určit skutečný operační systém, který se vztahuje každá oprava hotfix.
  • Soubory týkající se konkrétního produktu, SR_Level (RTM, SPn), a služby (LDR, GDR) lze identifikovat porovnáním čísel verzí souborů podle následující tabulky.
    Zmenšit tuto tabulkuRozšířit tuto tabulku
    VerzeProduktSR_LevelSložka služby
    6.1.7600.20xxxSystém Windows Server 2008 R2RTMVĚTVE LDR
    6.1.7601.21xxxSystém Windows Server 2008 R2AKTUALIZACE SP1VĚTVE LDR
  • Soubory MANIFEST (.manifest) a soubory MUM (.mum) instalované pro každé prostředí jsouuvedeny samostatněv části "Další informace o souborech pro systémy Windows Server 2008 R2". MUM a MANIFEST a soubory soubory CAT katalogu zabezpečení, jsou velmi důležité pro udržení stavu aktualizované součásti. Soubory katalogu zabezpečení, které nejsou uvedeny atributy, jsou podepsané digitálním podpisem společnosti Microsoft.
Pro všechny podporované 64bitové verze systému Windows Server 2008 R2 x
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
NTDSA.MOFNení k dispozici227,76510. Června 200920: 34Není k dispozici
Ntdsai.dll6.1.7600.208612,723,32818. Prosince 201006: 09x 64
NTDSA.MOFNení k dispozici227,76505. Listopadu 201001: 54Není k dispozici
Ntdsai.dll6.1.7601.216242,723,32818. Prosince 201008: 51x 64

Jak potíže obejít

DůležitéTento oddíl, metoda nebo úkol obsahuje kroky, které informace o úpravě registru. Však mohou nastat závažné problémy při nesprávných úpravách registru. Proto se ujistěte, opatrně postupujte takto. Pro zvýšení ochrany zálohovat registr před úpravami je nutné. Pak můžete obnovit registr v případě problému. Další informace o zálohování a obnovení registru získáte článku znalostní báze Microsoft Knowledge Base:
322756Postup při zálohování a obnovení registru v systému Windows

Chcete-li tento problém vyřešit, je nutné vytvořit podklíč registru na serveru LDAP. Chcete-li to provést, postupujte takto:
  1. Klepněte na tlačítkoStart
    Zmenšit tento obrázekZvětšit tento obrázek
    tlačítko Start
    , typregeditvProhledat programy a souborypole a stiskněte klávesu ENTER.
    Zmenšit tento obrázekZvětšit tento obrázek
    NÁSTROJ ŘÍZENÍ UŽIVATELSKÝCH ÚČTŮ
    Pokud se zobrazí výzva k zadání hesla správce, zadejte heslo. Pokud se zobrazí výzva k potvrzení, poskytnout potvrzení.
  2. Vyhledejte a vyberte následující podklíč registru:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NTDS\Parameters
  3. VÚpravapříkazNovéa klepněte na tlačítkoŘetězcová hodnota.
  4. TypHeuristika DSA, a pak stiskněte klávesu ENTER.
  5. Klepněte pravým tlačítkem myšiHeuristika DSAa klepněte na tlačítkoÚprava.
  6. VÚdaj hodnotypole Typ000000000001a klepněte na tlačítkoOK.
  7. Ukončete Editor registru.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části "Platí pro".

Další informace

Další informace o terminologii aktualizace softwaru získáte článku znalostní báze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Další informace o souborech

Další informace o souborech pro systémy Windows Server 2008 R2

Další soubory pro všechny podporované 64bitové verze systému Windows Server 2008 R2 x
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruAmd64_149ee8c9e20c2afd3347ba6c7b8f3a51_31bf3856ad364e35_6.1.7601.21624_none_e08641138148d4a0.manifest
Verze souboruNení k dispozici
Velikost souboru716
Datum (UTC)21. Prosince 2010
Čas (UTC)00: 14
PlatformaNení k dispozici
Název souboruAmd64_ffed5210101de2b65fbc8adf4e82aac4_31bf3856ad364e35_6.1.7600.20861_none_bb751eb51b570fad.manifest
Verze souboruNení k dispozici
Velikost souboru716
Datum (UTC)21. Prosince 2010
Čas (UTC)00: 14
PlatformaNení k dispozici
Název souboruAmd64_microsoft-windows-d...toryservices-ntdsai_31bf3856ad364e35_6.1.7600.20861_none_4d5676a6ebe4c26e.manifest
Verze souboruNení k dispozici
Velikost souboru3,531
Datum (UTC)18. Prosince 2010
Čas (UTC)06: 54
PlatformaNení k dispozici
Název souboruAmd64_microsoft-windows-d...toryservices-ntdsai_31bf3856ad364e35_6.1.7601.21624_none_4f6b143ae8e80a9b.manifest
Verze souboruNení k dispozici
Velikost souboru3,531
Datum (UTC)18. Prosince 2010
Čas (UTC)09: 27
PlatformaNení k dispozici

Vlastnosti

ID článku: 2468316 - Poslední aktualizace: 10. února 2011 - Revize: 1.0
Informace v tomto článku jsou určeny pro produkt:
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
Klíčová slova: 
kbautohotfix kbqfe kbhotfixserver kbfix kbexpertiseadvanced kbsurveynew kbmt KB2468316 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:2468316

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com