Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Consider the following scenario:

  • You install Microsoft Customer Care Framework (CCF) 2009 on a computer.

  • You call the Microsoft.Ccf.Csr.WebSerices.ContactCenter/NonHostedApplication::GetNonHostedApplications method to retrieve the list of the non-hosted applications that are defined in CCF 2009.

In this scenario, the GetNonHostedApplications method returns truncated results.

Note This issue also occurs in CCF 2008. However, the hotfix package for CCF 2008 is currently not available.

Cause

This issue occurs because the results that are returned by the GetNonHostedApplications method exceed 2033 characters. 

When the GetNonHostedApplications method uses the following query to retrieve the application list from the CCFInfrastructure database, the Raw command returns data in blobs of 2033 characters:

Select * from NonHostedApplications for xml raw

However, the GetNonHostedApplications method discards anything past the first line of 2033 characters. Therefore, the results are truncated.

Resolution

Hotfix information


A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites


To apply this hotfix, you must have Microsoft Customer Care Framework (CCF) 2009 Service Pack 1 (SP1) installed. 

Restart requirement


You do not have to restart the computer after you apply this hotfix if the affected files are not being used.  

Hotfix replacement information


This hotfix does not replace a previously released hotfix.  

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File name

File version

File size

Date

Time

Platform

Microsoft.ccf.csr.webservices.providers.dll

4.1.10326.1

210,832

23-Nov-2010

16:13

x86

Workaround

To work around this issue, call the GetShortDetails method in an AdminConsole\NonHostedAppWS web service.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×