Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Consider the following scenario:

  • The Active Directory domain NetBIOS name contains an ampersand (&) character in a Microsoft Exchange Server 2010 environment.

  • You try to install Exchange Server 2010 Service Pack 1 (SP1) on a server in the environment.

In this scenario, the installation fails. Additionally, you receive the following error message:

An error occurred while parsing EntityName. Line7, position 12.

Cause

This issue occurs because the ampersand character is a reserved character in XML. Therefore, the character causes the parsing for current logon user to fail.

Resolution

To resolve this issue, follow these steps.

Note This issue is resolved in Update Rollup 4 for Exchange Server 2010 Service Pack 1. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

2579150 Description of Update Rollup 4 for Exchange Server 2010 Service Pack 1

  1. Copy all the installation files from the CD to a hard disk, and then open the ManageScheduledTask.ps1 file in the scripts folder.

  2. Locate the following lines:

    function Get-CurrentUserName 
    {
    [System.Security.Principal.WindowsIdentity]$id = [System.Security.Principal.WindowsIdentity]::GetCurrent()
    $id.Name
    }
  3. Change the lines as follows:

    function Get-CurrentUserName
    {
    [System.Security.Principal.WindowsIdentity]$id = [System.Security.Principal.WindowsIdentity]::GetCurrent()
    [System.String]$fixedName = $id.Name.Replace('&','`&')
    return $fixedName
    }
  4. Save the file, and then try to install Exchange Server 2010 SP1 from the hard disk.

  5. Install the following update:

    2579150 Description of Update Rollup 4 for Exchange Server 2010 Service Pack 1

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×