Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Considerare lo scenario descritto di seguito:

  • Il nome NetBIOS di dominio Active Directory contiene una e commerciale (&) in un ambiente Microsoft Exchange Server 2010.

  • Si tenta di installare Exchange Server 2010 Service Pack 1 (SP1) su un server nell'ambiente.

In questo scenario, l'installazione non riesce. Inoltre, viene visualizzato il seguente messaggio di errore:

Si è verificato un errore durante l'analisi di EntityName. Line7, posizionare 12.

Causa

Questo problema si verifica perché il carattere e commerciale è un carattere riservato in XML. Pertanto, il carattere fa sì che l'analisi per utente di accesso corrente l'esito negativo.

Risoluzione

Per risolvere il problema, attenersi alla seguente procedura.Nota Questo problema viene risolto nell'aggiornamento cumulativo 4 per Exchange Server 2010 Service Pack 1. Per ulteriori informazioni, fare clic sul numero dell'articolo seguente per visualizzare l'articolo nella Microsoft Knowledge Base:

2579150 Descrizione dell'aggiornamento cumulativo 4 per Exchange Server 2010 Service Pack 1

  1. Copiare tutti i file di installazione dal CD al disco e quindi aprire il file ManageScheduledTask.ps1 nella cartella scripts.

  2. Individuare le seguenti righe:

    function Get-CurrentUserName { [System.Security.Principal.WindowsIdentity]$id = [System.Security.Principal.WindowsIdentity]::GetCurrent() $id.Name }
  3. Modificare le righe come segue:

    function Get-CurrentUserName{ [System.Security.Principal.WindowsIdentity]$id = [System.Security.Principal.WindowsIdentity]::GetCurrent() [System.String]$fixedName = $id.Name.Replace('&','`&') return $fixedName }
  4. Salvare il file e quindi si tenta di installare Exchange Server 2010 SP1 dal disco rigido.

  5. Installare l'aggiornamento seguente:

    2579150 Descrizione dell'aggiornamento cumulativo 4 per Exchange Server 2010 Service Pack 1

Stato

Microsoft ha confermato che questo problema si verifica nei prodotti elencati nella sezione "Si applica a".

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×