FIX: "Fehler: Ungültige Adler32-Prüfsumme ist aufgetreten" Fehlermeldung, wenn Sie eine komprimierte AS2-Nachricht in BizTalk Server erhalten

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 2492615 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Wenn Sie Microsoft BizTalk Server verwenden, um eine komprimierte Applicability Statement 2 (AS2) angezeigt wird, möglicherweise eine Fehlermeldung, die der folgenden ähnelt im Anwendungsprotokoll protokolliert:

Ereignistyp: Fehler
Quelle: BizTalk Server 2009 EDI
Ereigniskategorie: keine
Ereignis-ID: 8133
Beschreibung:
Die AS2-Decoder hat eine Ausnahmebedingung während der Verarbeitung. Informationen über die Meldung und Ausnahme sind wie folgt: AS2-aus: "<AS2-From party=""></AS2-From>"AS2-an:"<AS2-To party=""></AS2-To>"MessageID:"<Message id=""></Message>"MessageType:"Unbekannt"Ausnahme:" Dekomprimierung fehlgeschlagen beim Verarbeiten einer komprimierten AS2-Nachricht. Fehler: Ungültige Adler32-Prüfsumme ist aufgetreten. "
Hinweis Der Ereignis Quelle-Wert kann variieren, je nachdem, welche Version von BizTalk Server, die Sie verwenden.

Ursache

Dieses Problem tritt auf, weil die Adler32 Prüfsummenwert ist separat in zwei Blöcken gespeichert, wenn Sie eine komprimierte AS2-Nachricht erhalten. Aus diesem Grund lesen BizTalk Server den Wert nicht korrekt.

Lösung

Kumulatives Update-Informationen

BizTalk Server 2006 R2
Kumulatives Updatepaket 4 für BizTalk Server 2006 R2 SP1 gehört der Hotfix, der dieses Problem behebt.

Weitere Informationen dazu, wie Sie das kumulative Updatepaket zu erhalten, klicken in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:

2682056Kumulatives Updatepaket 4 für BizTalk Server 2006 R2 SP1

BizTalk Server 2010
Weitere Informationen dazu, wie Sie das kumulative Updatepaket zu erhalten, klicken in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
2497789 Kumulatives Updatepaket 1 für BizTalk 2010

BizTalk Server 2009
Kumulatives Updatepaket 2 für BizTalk Server 2009 gehört der Hotfix, der dieses Problem behebt.

Weitere Informationen dazu, wie Sie das kumulative Updatepaket zu erhalten, klicken in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
2497794 Kumulatives Updatepaket 2 für BizTalk Server 2009

Status

Microsoft hat bestätigt, dass dieses Problem auf die im Abschnitt "Gilt für" aufgeführten Microsoft-Produkte zutrifft.

Informationsquellen

Weitere Informationen zu Hotfixes für BizTalk Server finden Sie in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
2003907Informationen zu Hotfixes für BizTalk Server
Weitere Informationen über die Fehlermeldung "Ungültige Adler32-Prüfsumme ist aufgetreten" finden Sie auf die folgende MSDN-Website:
Allgemeine Informationen über die Fehlermeldung "Ungültige Adler32-Prüfsumme ist aufgetreten"

Eigenschaften

Artikel-ID: 2492615 - Geändert am: Donnerstag, 12. April 2012 - Version: 3.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft BizTalk Server 2009 Standard
  • Microsoft BizTalk Server 2009 Branch
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server Branch 2010
  • Microsoft BizTalk Server Developer 2010
  • Microsoft BizTalk Server Enterprise 2010
  • Microsoft BizTalk Server Standard 2010
  • Microsoft BizTalk Server 2006 R2 Branch
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Service Pack 1
  • Microsoft BizTalk Server 2006 R2 Standard Edition
Keywords: 
kbqfe kbfix kbsurveynew kbexpertiseadvanced kbbiztalk2006r2presp2fix kbmt KB2492615 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 2492615
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com