Služby spravovania virtuálny stroj Hyper-V prestane reagovať, prerušovane, keď je služba zastavená v systéme Windows Server 2008 R2

Preklady článku Preklady článku
ID článku: 2496089 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

PRIZNAKY

Uvažujme o nasledujúcom prípade:
  • V počítači je spustený systém Windows Server 2008 R2 nainštalujete rolu Hyper-V.
  • Zastaviť a potom spustite službu správy virtuálny stroj Hyper-V často na počítači.
V tomto scenári služby spravovania virtuálny stroj Hyper-V nereaguje prerušovane po zastavení služby.

PRICINA

Tento problém sa vyskytuje z dôvodu rasy stave v služby spravovania virtuálny stroj Hyper-V. Keď dôjde k race podmienka, vlákno, ktoré vykonáva služby čistenie nie ukončiť svoje správy vedenie, ako sa očakávalo. Preto sa vyskytnúť problém, ktorý je popísaný v časti „príznaky".

RIESENIE

Informácie o rýchlej oprave

Podporovaná rýchla oprava je k dispozícii od spoločnosti Microsoft. Táto rýchla oprava je však určená iba problém, ktorý je popísaný v tomto článku. Táto rýchla oprava sa vzťahujú len na systémy, ktoré sa vyskytuje problém popísaný v tomto článku. Táto rýchla oprava obdržať dodatočné testy. Preto, ak ste nie sú vážne ovplyvnené týmto problémom, odporúčame vám počkať na ďalšiu aktualizáciu softvéru, ktorá obsahuje túto rýchlu opravu.

Ak je rýchla oprava k dispozícii na prevzatie, je tu "Prevzatie dostupnej rýchlej opravy" sekcia na začiatku tohto článku databázy Knowledge Base. Ak sa táto sekcia nezobrazuje, obráťte sa na Microsoft zákaznícky servis a podpora získať rýchlu opravu.

Poznámka Ak sa vyskytnú ďalšie problémy alebo ak sa riešenie problémov vyžaduje, možno budete musieť vytvoriť samostatnú servisnú požiadavku. Obvyklé podporné náklady budú vzťahovať na dodatočnú podporu otázkach a problémoch, ktoré nespĺňajú kritériá pre tento špecifický rýchlu opravu. Úplný zoznam telefónnych čísel, Microsoft zákaznícky servis a podpora alebo vytvorte samostatnú servisnú požiadavku, navštívte nasledujúce webovú lokalitu spoločnosti Microsoft:
http://support.Microsoft.com/contactus/?ws=support
Poznámka „Prevzatie dostupnej rýchlej opravy"formulári zobrazujú jazyky, pre ktoré je rýchla oprava k dispozícii. Ak váš jazyk nie je zobrazený, je to preto rýchla oprava nie je k dispozícii pre daný jazyk.

Predpoklady

Ak chcete použiť túto rýchlu opravu, musíte mať program Windows Server 2008 R2. Okrem toho musíte mať rolu Hyper-V nainštalované v počítači.

Reštartujte požiadavka

Po použití tejto rýchlej opravy je potrebné reštartovať počítač.

Informácie o nahradení pre rýchlu opravu

Táto rýchla oprava nenahrádza predtým uvoľnenej rýchlu opravu.

Informácie o súbore

Globálna verzia tejto rýchlej opravy nainštaluje súbory, ktoré majú atribúty, ktoré sú uvedené v nasledovných tabuľkách. Dátumy a časy jednotlivých súborov sú uvedené v Coordinated Universal Time (UTC). Dátumy a časy pre tieto súbory na lokálnom počítači sú zobrazené v váš miestny čas spolu s vašej aktuálnej zaujatosti letný čas (letný čas). Navyše, dátumy a časy sa môže zmeniť, keď vykonať určité operácie so súbormi.
Windows Server 2008 R2 súbor informácií poznámky
Dôležité Windows 7 rýchlych a rýchlych opráv systému Windows Server 2008 R2 sú zahrnuté v rovnakom balení. Však rýchlych na stránke rýchla oprava žiadosť uvedených pod oba operačné systémy. Požiadať balík s rýchlou, ktorá sa vzťahuje na jednej alebo oboch operačných systémov, vyberte rýchlu opravu, ktorá je uvedený v časti „Windows 7 a Windows Server 2008 R2"na stránke. Vždy si pozrite časti „vzťahuje sa na"v článkoch určiť skutočný operačný systém, že každý rýchla oprava sa týka.
  • Súbory, ktoré sa vzťahujú na konkrétny produkt, SR_Level (RTM, SPn), služba pobočky (LDR, NDR) možno identifikovať skúmaním čísla verzií súboru, ako je uvedené v nasledujúcej tabuľke.
    Zbaliť túto tabuľkuRozbaliť túto tabuľku
    VerziaVýrobokSR_LevelSlužba pobočky
    6.1.760 0. 20XXXWindows Server 2008 R2RTMLDR
  • ZJAVNE súbory (.manifest) a MAMA súbory (.mum), ktoré sú nainštalované pre každý prostredie sú uvedené samostatne v sekcii "ďalší súbor informácie pre systém Windows Server 2008 R2". MAMA a ZJAVNE a súvisiace bezpečnostné katalógu (typu .cat) súbory, sú veľmi dôležité pre udržanie stavu aktualizované súčasti. Zabezpečenia katalóg súborov, pre ktoré nie sú uvedené atribúty, sú podpísané s digitálnym podpisom spoločnosti Microsoft.
Pre všetky podporované x 64-bitových verziách systému Windows Server 2008 R2
Zbaliť túto tabuľkuRozbaliť túto tabuľku
Názov súboruVerzia súboruVeľkosť súboruDátumČasPlatforma
Vmms.exe6.1.7600.208814,507,64815-Jan-201104: 10x 64

STAV

Spoločnosť Microsoft potvrdila, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v časti „vzťahuje sa na".

DALSIE INFORMACIE

Ďalšie informácie o softvér Aktualizácia terminológie, po kliknutí na nasledovné číslo článku databázy Microsoft Knowledge Base:
824684Popis štandardnej terminológie použitej na popis aktualizácií softvéru spoločnosti Microsoft

Ďalších informácií o súbore

Ďalší súbor informácií pre systém Windows Server 2008 R2

Ďalšie súbory pre všetky podporované x 64-bitových verziách systému Windows Server 2008 R2
Zbaliť túto tabuľkuRozbaliť túto tabuľku
Názov súboruAmd64_668581bd3bae6d2b4365c82641051e45_31bf3856ad364e35_6.1.7600.20881_none_51dae4ca18d92bb3.Manifest
Verzia súboruNie je uplatňované
Veľkosť súboru703
Dátum (UTC)21-Jan-2011
Čas (UTC)19: 57
PlatformaNie je uplatňované
Názov súboruAmd64_microsoft-hyper-v-vstack-vmms_31bf3856ad364e35_6.1.7600.20881_none_93109c8291beeb6d.manifest
Verzia súboruNie je uplatňované
Veľkosť súboru316,002
Dátum (UTC)15-Jan-2011
Čas (UTC)06: 59
PlatformaNie je uplatňované
Názov súboruUpdate.mum
Verzia súboruNie je uplatňované
Veľkosť súboru1,462
Dátum (UTC)21-Jan-2011
Čas (UTC)19: 57
PlatformaNie je uplatňované

Vlastnosti

ID článku: 2496089 - Posledná kontrola: 8. novembra 2011 - Revízia: 1.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
Kľúčové slová: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter kbmt KB2496089 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem:2496089

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com