文書番号: 2498452 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

Windows Update を使用して更新プログラムを確認すると、Windows 7 Service Pack 1 (SP1) をダウンロードするオプションが提示されない場合があります。

原因

特定の状況では、Windows 7 SP1 のインストールが成功しない場合があります。コンピューターで以下のいずれかの問題が該当する場合、これらの状況を回避できるように、Windows Update 経由では Windows 7 SP1 が提供されません。
  • Windows SP1 が既にインストールされているか、プレリリース版の Windows 7 SP1 がまだアンインストールされていません。
  • Windows 7 SP1 を入手する前に、別の更新プログラムをインストールする必要があります。
  • コンピューターに Windows 7 SP1 のインストールを妨げているプログラムがあります。
  • Windows 7 SP1 のインストールに必要なシステム ファイルがコンピューターにありません。

解決策

この問題を解決するには、方法 1 から始まる以下の方法の手順を実行します。方法 1 で問題が解決されない場合は方法 2 に進みます。

方法 1: Windows 7 SP1 がまだインストールされていないこと、およびプレリリース版の Windows 7 SP1 を搭載していないことを確認する

元に戻す画像を拡大する
assets folding start collapsed

これを行うには、次の手順を実行します。
  1. [スタート] ボタン
    元に戻す画像を拡大する
    [スタート] ボタン
    をクリックし、[コンピューター] を右クリックし、[プロパティ] をクリックします。
  2. [Windows エディション] セクションを確認します。
    1. [Service Pack 1] が一覧に表示される場合、Windows 7 SP1 はコンピューターに既にインストールされています。
    2. バージョン番号 (v.153 または v.720 など) が [Service Pack 1] の後に表示される場合は、プレリリース版の Windows 7 SP1 がお使いのコンピューターにインストールされています。これをアンインストールしない限り、Windows Update でリリース版 SP1 は提示されません。関連情報については、以下を参照してください。 Windows 7 SP1 のアンインストール方法
元に戻す画像を拡大する
assets folding end collapsed

方法 2: 保留中の更新プログラムを確認する

元に戻す画像を拡大する
assets folding start collapsed

お使いのコンピューターに更新プログラム 2454826、2534366、および 2533552 をインストールしないと Windows Update で Windows 7 SP1 が提示されないことがあります。

Windows Update を使用してこれらの更新プログラムをインストールするには、以下の手順を実行します。
  1. [スタート] ボタン
    元に戻す画像を拡大する
    [スタート] ボタン
    をクリックし、[すべてのプログラム]、[Windows Update] を順にクリックします。
  2. ナビゲーション ウィンドウで [更新プログラムの確認] をクリックし、Windows でコンピューター用の最新の更新プログラムの確認が行われている間待ちます。
  3. 重要な更新プログラムが表示されたら、[更新プログラムのインストール] をクリックします。
    元に戻す画像を拡大する
    ユーザー アカウント制御の許可
    管理者のパスワードを要求するダイアログ ボックスが表示された場合はパスワードを入力して [OK] をクリックし、確認を要求するダイアログ ボックスが表示された場合は [続行] をクリックします。
  4. インストールの完了時点で、再起動を求めるメッセージが表示されたら、コンピューターを再起動します。
  5. Windows Update を再度チェックし、Windows 7 SP1 が提示されるようになったかどうかを調べます。
更新プログラム 2454826、2534366、および 2533552 は、Microsoft ダウンロード センターからもダウンロードできます。これらの更新プログラムの詳細およびインストール方法については、以下のサポート技術情報番号をクリックしてください。
2534366 すべての言語パックがインストールされたコンピューターで Windows 7 SP1 をインストールすると失敗する (エラー 0xC0000009A)
2533552 Windows 7 SP1 または Windows Server 2008 R2 SP1 をインストールしたときに "0xC0000034" エラー メッセージが表示されるのを防ぐ更新プログラムを利用できます
2454826 Windows 7 および Windows Server 2008 R2 用のパフォーマンスと機能に関する更新プログラムについて
元に戻す画像を拡大する
assets folding end collapsed

方法 3: 互換性のないバージョンの SafeCentral がコンピューターにインストールされていないことを確認する

元に戻す画像を拡大する
assets folding start collapsed

お使いのコンピューターに特定のバージョンの SafeCentral がインストールされている場合、Windows SP1 は Windows Update に表示されないことがあります。SafeCentral は SafeCentral, Inc. が製造しているセキュリティ プログラムです。

コンピューターで SafeCentral バージョン 2.9.0.0 以前を実行している場合、Windows 7 SP1 をインストールする前に SafeCentral を更新する必要があります。

SafeCentral がインストールされているかどうかを判断するには、次の手順を実行します。
  1. [スタート] ボタン
    元に戻す画像を拡大する
    [スタート] ボタン
    をクリックし、[コントロール パネル] をクリックします。次に、[プログラム] の [プログラムと機能] をクリックします。
  2. プログラムの一覧から SafeCentral を検索します。SafeCentral バージョン 2.9.0.0 の以前のバージョンがインストールされている場合、詳細については、SafeCentral Web サイトを参照してください。
元に戻す画像を拡大する
assets folding end collapsed

方法 4: Intel 統合グラフィック ドライバー Igdkmd32.sys または Igdkmd64.sys を使用しているかどうか、およびドライバーをアップグレードしたかどうかを確認する

元に戻す画像を拡大する
assets folding start collapsed

次のいずれかのファイルがコンピューターにインストールされている場合、Windows 7 SP1 は Windows Update に表示されません。
  • Igdkmd32.sys (32 ビット版)、バージョン 8.15.10.2104 〜 8.15.10.2141
  • Igdkmd64.sys (64 ビット版)、バージョン 8.15.10.2104 〜 8.15.10.2141
これらのドライバーについては、D2D (Direct2D) を使用する特定のアプリケーションと問題が発生することが知られています。たとえば、特定の環境下でこれらのドライバーと Windows Live メールを一緒に使用すると、Windows Live メールがクラッシュする可能性があります。

Intel 統合グラフィック ドライバーおよびドライバーのバージョンをチェックするには、以下の手順を実行します。
  1. DirectX 診断ツールを起動します。これを行うには、[スタート]
    元に戻す画像を拡大する
    [スタート] ボタン
    をクリックし、[プログラムとファイルの検索] ボックスに「dxdiag」と入力し、Enter キーを押します。
  2. [ディスプレイ] タブをクリックします。
  3. ドライバーとドライバーのバージョンをメモします。
  4. Intel 統合グラフィック ドライバーとドライバーのバージョン 8.15.10.2104 〜 8.15.10.2141 がインストールされている場合、コンピューターの製造元の Web サイトを閲覧し、新しいバージョンのドライバーを入手できるかどうかを確認します。
更新プログラム 2454826 は、Microsoft ダウンロード センターからもダウンロードできます。この更新プログラムを適用すると、この問題に関するパフォーマンスと機能を改善できる場合があります。この更新プログラムの詳細およびインストール方法については、以下のサポート技術情報番号をクリックしてください。
2454826 Windows 7 および Windows Server 2008 R2 用のパフォーマンスと機能に関する更新プログラムについて
元に戻す画像を拡大する
assets folding end collapsed

方法 5: Windows 7 インストールのカスタマイズに vLite を使用しなかったことを確認する

元に戻す画像を拡大する
assets folding start collapsed

vLite は Windows 7 のインストールのカスタマイズに使用するサードパーティプログラムです。vLite は Windows システム コンポーネントの一部を削除することが知られています。Windows 7 のインストールのカスタマイズに vLite を使用した場合、Windows Update で Windows 7 SP1 をインストールするオプションは提示されないことがあります。

vLite を使用して Windows 7 SP1 をインストールしようとするときに発生する既知のエラーの詳細については、「Windows 7 SP1 のインストール時にシステム コンポーネントが不足していることを伝えるエラー メッセージが表示される 」トピックを参照してください。

スタンドアロン型の Windows 7 SP1 を入手する方法の詳細については、「Windows 7 Service Pack 1 (SP1) をインストール方法」を参照してください。.

vLite の問題を回避する手順

この資料に記載されているすべての手順を試行しても、Windows Update によって Windows 7 SP1 のインストール オプションが提示されない場合、 Microsoft ダウンロード センターから Windows 7 SP1 をインストールすると vLite の問題を回避できます。.

重要 Windows 7 SP1 のインストールでは、Windows Update を使用する方法が推奨されます。Windows Update を使用して Windows 7 SP1 をインストールする方法の詳細については、「 Windows 7 Service Pack 1 (SP1) をインストールする方法 」トピックを参照してください。Microsoft ダウンロード センターで Service Pack をインストールすることで問題を回避する場合、Microsoft ダウンロード センターの Windows 7 Service Pack 1 をインストールする前に実行する手順があります。 詳細については、以下のサポート技術情報番号をクリックしてください。
2505743 Microsoft ダウンロード センターで Windows 7 Service Pack 1 をインストールする前に実行する手順

重要: サポート技術情報 2505743 の手順を実行せずに、Microsoft ダウンロード センターから Service Pack をインストールする場合は、最適な状態でなくなる可能性があります。

この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示的か黙示的かにかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

他社テクニカル サポートのお問い合わせ窓口は、ユーザーの便宜のために提供されているものであり、将来予告なしに変更されることがあります。マイクロソフトは、掲載されている情報に対して、いかなる責任も負わないものとします。
元に戻す画像を拡大する
assets folding end collapsed

方法 6: Microsoft ダウンロード センターから Windows 7 SP1 をダウンロードする

元に戻す画像を拡大する
assets folding start collapsed
上記の方法をすべて試しても Windows Update で使用可能な Windows 7 SP1 が見つからない場合は、Microsoft ダウンロード センターから Windows 7 SP1 をダウンロードします。
Windows 7 および Windows Server 2008 R2 Service Pack 1 (KB976932)
元に戻す画像を拡大する
assets folding end collapsed

プロパティ

文書番号: 2498452 - 最終更新日: 2014年1月8日 - リビジョン: 9.0
この資料は以下の製品について記述したものです。
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
キーワード:?
kbcip KB2498452
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com