FIX: BizTalk Document Tracking may stop working after you install cumulative update package 1 for BizTalk Server

Article translations Article translations
Article ID: 2508913 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

After you install cumulative update package 1 for Microsoft BizTalk 2009 or Microsoft BizTalk 2010 on a computer, BizTalk Document Tracking may stop working. Additionally, an error message that resembles the following is logged in the Application log:
Event Type: Error
Event Source: BAM EventBus Service
Event Category: None
Event ID: 6
Description:
Execute event error. Error(s) occurred while executing events, see TDDS_FailedTrackingData table for more details. SQLServer: <SQL Server>, Database: BizTalkDTADb.

The TDDS_FailedTackingData table contain the following entries:

TDDS failed to execute event. Stored Procedure dtasp_ServiceInsert failed to run.Stored Procedure dtasp_ServiceInsert Parameter Count and IPersistQueryable Item count not the same, Expected Count: 0, IPersistQueryable Count: 14.

TDDS failed to execute event. Stored Procedure dtasp_MsgIn failed to run.Stored Procedure dtasp_MsgIn Parameter Count and IPersistQueryable Item count not the same, Expected Count: 0, IPersistQueryable Count: 14.

TDDS failed to execute event. Stored Procedure dtasp_MsgOut failed to run.Stored Procedure dtasp_MsgOut Parameter Count and IPersistQueryable Item count not the same, Expected Count: 0, IPersistQueryable Count: 14.

Additionally, the TDDS_FailedTrackingData table may grow very large in the BizTalkDTADb database.

CAUSE

This issue occurs because the BizTalk Application Users group loses the execute permissions for the following stored procedures after you install cumulative update package 1 for Microsoft BizTalk 2009:
  • [dbo].[dtasp_MsgIn]
  • [dbo].[dtasp_MsgOut]
  • [dbo].[dtasp_ServiceInsert]

RESOLUTION

Cumulative update information
 

BizTalk Server 2010

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2497789 Cumulative update package 1 for BizTalk 2010

The hotfix that resolves this issue is included in cumulative update package 2 for BizTalk Server 2009.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2497794 Cumulative update package 2 for BizTalk Server 2009

WORKAROUND

To work around this issue, follow these steps in BizTalk Administration Console:
  1. Click to select the Allow Host Tracking check box in another BizTalk Server host, and then click to clear this option in the current tracking host.
  2. Restart BizTalk Server host instances.
  3. Click to select the Allow Host Tracking check box in the original tracking host, and then click to clear this option in the other tracking host.
  4. Restart the host instances to correctly apply the permissions.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:

2003907 Information about BizTalk Server hotfixes

Properties

Article ID: 2508913 - Last Review: May 23, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft BizTalk Server 2009 Branch
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2009 Standard
Keywords: 
kbqfe kbexpertiseadvanced kbsurveynew kbfix kbbiztalk2009presp1fix kbbtsbam KB2508913

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com