Bei Microsoft anmelden
Melden Sie sich an, oder erstellen Sie ein Konto.
Hallo,
Wählen Sie ein anderes Konto aus.
Sie haben mehrere Konten.
Wählen Sie das Konto aus, mit dem Sie sich anmelden möchten.

Problembeschreibung

In Microsoft Commerce Server 2007 oder in Microsoft Commerce Server 2009 wählen Sie Ersetzen Importtyp eine Katalogimport ausführen. Wenn die Katalogdaten vorhanden ist, hat importieren langen Zeit abgeschlossen werden. Z. B. Wenn Sie einen neuen Katalog importieren, Minuten der Import über 10. Verwenden Sie Importtyp Ersetzen die gleichen Katalogdatei erneut nach dem ersten Import importieren, dauert der Import Stunde abgeschlossen werden.

Ursache

Das Problem tritt auf, weil Ctlg_RepairCatalogsAfterImport ineffizienten Abfrageplanes für den Import von Katalog ausgewählt.

Lösung

Informationen zum Hotfix

Ein unterstützter Hotfix ist von Microsoft erhältlich. Dieser Hotfix soll nur der Behebung des Problems dienen, das in diesem Artikel beschrieben wird. Wenden Sie dieses Hotfix nur auf Systeme an, bei denen das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix sollte weiteren Tests unterzogen werden. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir sie, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält. Wenn der Hotfix zum Download zur Verfügung steht, gibt es einen Abschnitt "Hotfixdownload available" ("Hotfixdownload verfügbar"), am oberen Rand dieses Knowledge Base-Artikel. Wenn dieser Abschnitt nicht angezeigt wird, wenden Sie sich an den Microsoft Customer Service and Support, um den Hotfix zu erhalten. Hinweis Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten für zusätzliche Supportfragen und Probleme, die nicht diesem speziellen Hotfix zugeordnet werden können. Für eine vollständige Liste der Telefonnummern von Microsoft Customer Service and Support oder für Erstellung eine separate Serviceanfrage, fahren Sie auf der folgenden Microsoft-Website fort:

http://support.microsoft.com/contactus/?ws=supportHinweis Das Formular "Hotfix download available" ("Hotfixdownload verfügbar") zeigt die Sprachen an, für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist dieser Hotfix für Ihre Sprache nicht verfügbar.

Voraussetzungen

Sie müssen einer der folgenden Versionen installiert sein:

  • Microsoft Commerce Server 2007 SP2

  • Microsoft Commerce Server 2009

Neustart

Sie müssen keinen Neustart des Computers. Jedoch müssen Sie Internet Information Services (IIS) und Commerce Server Catalog Import Host COM+-Anwendung starten, nachdem Sie diesen Hotfix anwenden. Neustart von IIS, Befehlszeile geben Sie folgenden Befehl ein und drücken Sie anschließend:

IISRESET /RESTART Hinweis Diese Option beendet und neu gestartet alle IIS-Dienste ausgeführt werden.

Ersetzte Updates

Dieser Hotfix ersetzt keine zuvor veröffentlichten Hotfix.

Dateiinformationen

Die internationale Version dieses Updates verwendet ein Microsoft Windows Installer-Paket Hotfix installieren. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) in der folgenden Tabelle aufgeführt. Wenn Sie die Dateiinformationen anzeigen, wird das Datum in Ortszeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu finden, verwenden Sie die Registerkarte Zeitzone unter Datum und Uhrzeit in der Systemsteuerung.

Für Microsoft Commerce Server 2007

Dateiname

Dateiversion

Dateigröße

Datum

Uhrzeit

Plattform

Catalogcreate.sql

Not applicable

1,153,421

25-Feb-2011

10:38

Not applicable

Für Microsoft Commerce Server 2009

Dateiname

Dateiversion

Dateigröße

Datum

Uhrzeit

Plattform

Catalogcreate.sql

Not applicable

1,157,103

25-Feb-2011

10:38

Not applicable

Cs2009hotfixhelper.exe

6.0.4171.40

13,080

28-Feb-2011

08:01

x86

Informationen zum Hotfix-installation

Nachdem Sie das Hotfix-Paket extrahieren, erhalten Sie die folgenden Dateien:

  • Für Commerce Server 2007:

    • CommerceServer2007SP2-KB2513798-ENU.exe

    • KB2513798.sql

    Installieren Sie die Datei CommerceServer2007SP2-KB2513798-ENU.exe zur Aktualisierung der Datei Catalogcreate.sql.

  • Für Commerce Server 2009:

    • CommerceServer2007SP3-KB2513798-ENU.exe

    • KB2513798.sql

    Installieren Sie die Datei CommerceServer2007SP3-KB2513798-ENU.exe zur Aktualisierung der Datei Catalogcreate.sql.

Sie haben entsprechende sicherstellen, dass dieses Problem für neue Katalogdatenbanken nicht installieren. Außerdem müssen Sie die KB2513798.sql-Datei vorhandenen Katalog Datenbanken aktualisieren ihre gespeicherten Prozeduren ausführen.

Weitere Informationen

Weitere Informationen zum Importieren von Katalogen in Commerce Server finden Sie auf folgender MSDN-Website:

Importieren ein Katalogs

Benötigen Sie weitere Hilfe?

Möchten Sie weitere Optionen?

Erkunden Sie die Abonnementvorteile, durchsuchen Sie Trainingskurse, erfahren Sie, wie Sie Ihr Gerät schützen und vieles mehr.

In den Communities können Sie Fragen stellen und beantworten, Feedback geben und von Experten mit umfassendem Wissen hören.

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Sprachqualität?
Was hat Ihre Erfahrung beeinflusst?
Wenn Sie auf "Absenden" klicken, wird Ihr Feedback zur Verbesserung von Produkten und Diensten von Microsoft verwendet. Ihr IT-Administrator kann diese Daten sammeln. Datenschutzbestimmungen.

Vielen Dank für Ihr Feedback!

×