Iniciar sessão com a Microsoft
Iniciar sessão ou criar uma conta.
Olá,
Selecione uma conta diferente.
Tem várias contas
Selecione a conta com a qual pretende iniciar sessão.

Sintomas

No Microsoft Commerce Server 2007 ou no Microsoft Commerce Server 2009, pode seleccionar o tipo de importação Substituir para efectuar uma importação de catálogo. Se os dados de catálogo não existirem, a importação demora muito tempo para ser concluída. Por exemplo, se importar um novo catálogo, a importação demora cerca de 10 minutos. Se utilizar o tipo de importação Substituir para importar o mesmo ficheiro de catálogo novamente depois da primeira importação, a importação demora uma hora a ser concluída.

Causa

O problema ocorre porque o ctlg_RepairCatalogsAfterImport selecciona um plano de consulta ineficazes para o processo de importação do catálogo.

Resolução

Informações sobre correção

Existe uma correção suportada pela Microsoft. No entanto, esta correção destina-se apenas a corrigir o problema descrito neste artigo. Aplique esta correção apenas em sistemas que tenham o problema descrito neste artigo. Esta correcção poderá ser submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afetado por este problema, recomendamos que aguarde pela próxima atualização de software que contenha esta correção. Se a correcção estiver disponível para transferência, existirá uma secção de "Transferência de correcção disponível" na parte superior deste artigo da Base de dados de conhecimento. Se esta secção não for apresentada, contacte o Suporte ao Cliente da Microsoft para obter a correção. Nota Caso ocorram problemas adicionais ou se for necessária a resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos de normais do suporte serão aplicados a questões de suporte adicional e problemas incluídos nesta correção específica. Para uma lista completa dos números de telefone de suporte e serviço de cliente da Microsoft ou para criar um pedido de assistência separado, visite o seguinte site da Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota O formulário "Transferência de correcção disponível" apresenta os idiomas nos quais a correcção está disponível. Se não visualizar o seu idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Tem de ter uma das seguintes versões instaladas:

  • Microsoft Commerce Server 2007 SP2

  • Microsoft Commerce Server 2009

Necessidade de reinício

Não é necessário reiniciar o computador. No entanto, tem de reiniciar o Internet Information Services (IIS) e a aplicação Commerce Server Catalog importação anfitrião COM+ depois de aplicar esta correcção. Para reiniciar o IIS, numa linha de comandos, escreva o seguinte comando e, em seguida, prima ENTER:

IISRESET /RESTART Nota Esta opção pára e, em seguida, reinicia todos os serviços do IIS que estão em execução.

Informações sobre a substituição

Esta correção não substitui uma correção disponibilizada anteriormente.

Informações de ficheiro

A versão global desta correcção utiliza um pacote do Microsoft Windows Installer para instalar a correcção. As datas e horas destes ficheiros são listadas na hora Universal Coordenada (UTC) na seguinte tabela. Quando visualiza as informações do ficheiro, a data é convertida para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador Fuso Horário no item Data e Hora no Painel de Controlo.

Para o Microsoft Commerce Server 2007

Nome do ficheiro

Versão do ficheiro

Tamanho do ficheiro

Data

Hora

Plataforma

Catalogcreate.sql

Não aplicável

1,153,421

25-Feb-2011

10:38

Não aplicável

Para Microsoft Commerce Server 2009

Nome do ficheiro

Versão do ficheiro

Tamanho do ficheiro

Data

Hora

Plataforma

Catalogcreate.sql

Não aplicável

1,157,103

25-Feb-2011

10:38

Não aplicável

Cs2009hotfixhelper.exe

6.0.4171.40

13,080

28-Feb-2011

08:01

x86

Informações de instalação da correcção

Depois de extrair o pacote de correcção, obtém os seguintes ficheiros:

  • Para o Commerce Server 2007:

    • CommerceServer2007SP2-KB2513798-ENU.exe

    • KB2513798.sql

    Instale o ficheiro CommerceServer2007SP2-KB2513798-ENU.exe para actualizar o ficheiro Catalogcreate.sql.

  • Para o Commerce Server 2009:

    • CommerceServer2007SP3-KB2513798-ENU.exe

    • KB2513798.sql

    Instale o ficheiro CommerceServer2007SP3-KB2513798-ENU.exe para actualizar o ficheiro Catalogcreate.sql.

Tem de instalar a correcção adequada para se certificar de que este problema não ocorre para novas bases de dados do catálogo. Além disso, tem de executar o ficheiro KB2513798.sql contra as bases de dados do catálogo existente para actualizar os procedimentos armazenados.

Mais Informações

Para mais informações sobre como importar catálogos do Commerce Server, visite a seguinte página Web da MSDN:

Como importar um catálogo

Precisa de mais ajuda?

Quer mais opções?

Explore os benefícios da subscrição, navegue em cursos de formação, saiba como proteger o seu dispositivo e muito mais.

As comunidades ajudam-no a colocar e a responder perguntas, a dar feedback e a ouvir especialistas com conhecimentos abrangentes.

Estas informações foram úteis?

Quão satisfeito está com a qualidade do idioma?
O que afetou a sua experiência?
Ao selecionar submeter, o seu feedback será utilizado para melhorar os produtos e serviços da Microsoft. O seu administrador de TI poderá recolher estes dados. Declaração de Privacidade.

Obrigado pelo seu feedback!

×