Extra.exe ไม่สามารถติดตามผู้ใช้คนเดียวที่มีแอตทริบิวต์ legacyExchangeDN ประกอบด้วยอักขระพิเศษได้อย่าง น้อยหนึ่งในสภาพแวดล้อมที่มี Exchange Server 2010

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 2514700 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

พิจารณาสถานการณ์สมมติต่อไปนี้:
  • คุณเปิดใช้งานลักษณะการทำงานใน Microsoft Exchange แก้ไขปัญหาเบื้องต้นช่วย (Extra.exe) เพื่อการสืบค้นกลับผู้ใช้ (ผู้ใช้ A) ในสภาพแวดล้อมของ Microsoft Exchange Server 2010 การสืบค้นกลับที่ถูกกรอง
  • ผู้ใช้มีแอททริบิวต์legacyExchangeDNที่ประกอบด้วยอักขระพิเศษดังต่อไปนี้อย่างน้อยหนึ่งอย่าง:
    • เครื่องหมายดอลลาร์ ($)
    • เครื่องหมายมหัพภาค (.)
    • เครื่องหมายจุลภาค ()
    • ตรงอัญประกาศเดี่ยว (')
    • เครื่องหมายรูปหมวก (^)
    • ()ในช่องว่าง
ในสถานการณ์นี้ Extra.exe การสืบค้นกลับผู้ใช้ทั้งหมดในสภาพแวดล้อมแทนเฉพาะผู้ใช้นอกจาก A. นี้ แอตทริบิวต์legacyExchangeDNของผู้ใช้ถูกแบ่งออกเป็นหลายส่วนในแฟ้ม EnabledTraces.config ตัวอย่างเช่น ผู้ใช้ของแอตทริบิวต์legacyExchangeDNในเครื่องมือการแก้ไข Active Directory บริการอินเทอร์เฟซ (ADSI) จะแสดงเป็นดังนี้:

/ o = CONTOSO, / ou = กลุ่มระดับผู้ดูแล Exchange (FYDIBOHF23SPDLT) / cn =ผู้ รับ/cn =ผู้ใช้

อย่างไรก็ตาม แอตทริบิวต์การUserDNแยกต่างหากต่อไปนี้จะแสดงอยู่ในแฟ้ม EnableTraces.config:

UserDN: / o = CONTOSO
UserDN: / ou = กลุ่มระดับผู้ดูแล Exchange (FYDIBOHF23SPDLT) / cn =ผู้ รับ/cn =ผู้ใช้

หมายเหตุ
โดยค่าเริ่มต้น แฟ้ม EnabledTraces.config ที่อยู่ในรากของไดรฟ์ c

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจากกฎการสืบค้นกลับสำหรับ Extra.exe ถือว่า อักขระพิเศษในแอตทริบิวต์เดี่ยวlegacyExchangeDNเป็นตัวคั่น ดังนั้น แอตทริบิวต์เดี่ยวlegacyExchangeDNถูกแบ่งออกเป็นแอตทริบิวต์UserDNสอง


การแก้ไข

เมื่อต้องแก้ไขปัญหานี้ ติดตั้งโปรแกรมปรับปรุงที่ต่อไปนี้:
2685289 คำอธิบายของโปรแกรมปรับปรุง 3 สำหรับ Exchange Server 2010 Service Pack 2

การหลีกเลี่ยงปัญหา

เมื่อต้องหลีกเลี่ยงปัญหานี้ รวมแอตทริบิวต์UserDNในบรรทัดที่หนึ่ง และด้วยตนเองรวมอักขระพิเศษลงในแฟ้ม EnableTraces.config ตัวอย่างเช่น เพิ่มเครื่องหมายจุลภาค () แอตทริบิวต์legacyExchangeDNดังที่แสดงในตัวอย่างต่อไปนี้

ต่อไปนี้เป็นตัวอย่างของแอตทริบิวต์legacyExchangeDNก่อนที่จะทำการแก้ปัญหา:
UserDN: / o = CONTOSO
UserDN: / ou = กลุ่มระดับผู้ดูแล Exchange (FYDIBOHF23SPDLT) / cn =ผู้ รับ/cn =ผู้ใช้

ต่อไปนี้เป็นตัวอย่างของแอตทริบิวต์legacyExchangeDNหลังจากทำการแก้ปัญหา:
UserDN: / o = CONTOSO, / ou = กลุ่มระดับผู้ดูแล Exchange (FYDIBOHF23SPDLT) / cn =ผู้ รับ/cn =ผู้ใช้

สถานะ

Microsoft ยืนยันว่า ปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ที่ระบุไว้ในส่วน"ใช้งาน"

ข้อมูลเพิ่มเติม

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับบทความ KB 967255 คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
967255 เฉพาะข้อมูลการติดตามของผู้ใช้ล่าสุดถูกบันทึกไว้เมื่อคุณตั้งค่าคอนฟิก Exchange Server 2007 เพื่อการสืบค้นกลับผู้ใช้หลายคนในเวลาเดียวกัน
สำหรับข้อมูลเพิ่มเติมเกี่ยวกับบทความ KB 971878 คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
971878 วิธีการแก้ไขปัญหาปฏิทินใน Microsoft Outlook, Microsoft Exchange Server 2007 และ Microsoft Exchange Server 2010


คุณสมบัติ

หมายเลขบทความ (Article ID): 2514700 - รีวิวครั้งสุดท้าย: 27 มิถุนายน 2555 - Revision: 2.0
ใช้กับ
  • Microsoft Exchange Server 2010 Service Pack 2 เมื่อใช้กับ:
    • Microsoft Exchange Server 2010 Enterprise
    • Microsoft Exchange Server 2010 Standard
Keywords: 
kbsurveynew kbexpertiseinter kbqfe kbfix kbmt KB2514700 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:2514700

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com