Article ID: 2519359 - Last Review: July 28, 2011 - Revision: 4.0

"Changes to the rule cannot be saved." error message when you try to create a reply rule by using Outlook in an Exchange Server 2010 environment

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SYMPTOMS

Consider the following scenario:
  • You have Owner permission and Send as permission on a public folder in a Microsoft Exchange Server 2010 environment.
  • You try to create a reply rule on the public folder by using Microsoft Office Outlook.
In this scenario, the operation fails, and you receive the following error message:

Changes to the rule cannot be saved.

CAUSE

This issue occurs because of an error in Store.exe which causes the permissions on the Public Folder not to be validated properly, which in turn causes the permissions check to fail.

RESOLUTION

To resolve this issue, install the following update rollup:
2579150  (http://support.microsoft.com/kb/2579150/ ) Description of Update Rollup 4 for Exchange Server 2010 Service Pack 1

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Exchange Server 2010 Service Pack 1, when used with:
    • Microsoft Exchange Server 2010 Enterprise
    • Microsoft Exchange Server 2010 Standard
Keywords: 
kbqfe kbfix kbsurveynew kbexpertiseinter kbhotfixrollup KB2519359