ข้ามไปที่เนื้อหาหลัก
การสนับสนุน
ลงชื่อเข้าใช้
ลงชื่อเข้าใช้ด้วย Microsoft
ลงชื่อเข้าใช้หรือสร้างบัญชี
สวัสดี
เลือกบัญชีอื่น
คุณมีหลายบัญชี
เลือกบัญชีที่คุณต้องการลงชื่อเข้าใช้

อาการ

แอปพลิเคชันไคลเอ็นต์ Microsoft Outlook บางตัวพบปัญหาการเชื่อมต่อเมื่อมีเธรดบริการการเข้าถึงไคลเอ็นต์ RPC ของ Microsoft Exchange หลายเธรดที่อยู่บนโฟลเดอร์สาธารณะที่รอการตอบกลับจากบริการความพร้อมใช้งาน ตัวอย่างเช่น ปัญหานี้เกิดขึ้นเมื่อมีเธรดมากกว่า 500 เธรดรอการตอบกลับในโฟลเดอร์สาธารณะ  

หมายเหตุ

  • ไม่มีตัวเลือกในการปิดใช้งานบริการความพร้อมใช้งานบนเซิร์ฟเวอร์ที่ใช้ Exchange Server 2010 Service Pack (SP1)

  • ถ้าคุณเริ่มบริการการเข้าถึงไคลเอ็นต์ Exchange RPC บนเซิร์ฟเวอร์โฟลเดอร์สาธารณะของ Exchange Server 2010 SP1 ใหม่ ปัญหานี้ได้รับการแก้ไขชั่วคราว

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจากฟีเจอร์ใหม่ใน Exchange Server 2010 SP1 ฟีเจอร์ใหม่นี้ใช้บริการการเข้าถึงไคลเอ็นต์ RPC ของ Microsoft Exchange เป็นพร็อกซีของบริการความพร้อมใช้งานเวอร์ชันก่อนหน้า (ข้อมูลว่าง/ไม่ว่าง) ดังนั้น ถ้าคุณมีโฟลเดอร์สาธารณะที่ติดตั้งบนเซิร์ฟเวอร์ Exchange Server 2010 SP1 บริการการเข้าถึงไคลเอ็นต์ RPC ของ Microsoft Exchange จะตัดการร้องขอข้อมูลว่าง/ไม่ว่าง

การแก้ไข

หากต้องการแก้ไขปัญหา โปรดใช้วิธีการอย่างใดอย่างหนึ่งต่อไปนี้:

วิธีที่ 1



อัปเกรดไคลเอ็นต์ทั้งหมดเป็น Outlook 2007 หรือเวอร์ชันที่ใหม่กว่าซึ่งใช้ Exchange Web Services (EWS) เพื่อติดต่อบริการความพร้อมใช้งานไปยังเซิร์ฟเวอร์ Exchange Client Access โดยตรง 

วิธีที่ 2

ติดตั้งการอัปเดตต่อไปนี้บนเซิร์ฟเวอร์กล่องจดหมาย Exchange Server 2010 SP1 ที่โฮสต์ฐานข้อมูลโฟลเดอร์สาธารณะ:

2497453 การแก้ไข: แอปพลิเคชันอาจหยุดตอบสนองหลังจากการร้องขอ HTTP หลายการร้องขอถูกยกเลิก ถ้าคุณใช้คลาส HttpWebRequest เพื่อส่งการร้องขอใน .NET Framework

วิธีที่ 3

สิ่งสําคัญ ส่วน วิธีการ หรืองานนี้มีขั้นตอนที่บอกวิธีการปรับเปลี่ยนรีจิสทรี อย่างไรก็ตาม ปัญหาร้ายแรงอาจเกิดขึ้นถ้าคุณปรับเปลี่ยนรีจิสทรีอย่างไม่ถูกต้อง ดังนั้น ตรวจสอบให้แน่ใจว่าคุณได้ปฏิบัติตามขั้นตอนเหล่านี้อย่างระมัดระวัง เมื่อต้องการป้องกันเพิ่มเติม ให้ย้อนกลับรีจิสทรีก่อนที่คุณจะปรับเปลี่ยน จากนั้นคุณสามารถคืนค่ารีจิสทรีถ้ามีปัญหาเกิดขึ้น For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 วิธีการย้อนกลับและคืนค่ารีจิสทรีในข้อควรระวังของ Windows
ปัญหาต่อไปนี้อาจเกิดขึ้นถ้าคุณใช้วิธีการนี้:

  • ในการปรับใช้ Exchange Server แบบไฮบริดของ Office 365 และภายในองค์กร หรือในองค์กรภายนอก ไคลเอ็นต์ดั้งเดิม เช่น Microsoft Office Outlook 2007 หรือ Microsoft Office Outlook 2003 จะไม่ได้รับข้อมูลว่าง/ไม่ว่างจากไซต์ระบบคลาวด์หรือจากองค์กรระยะไกลอีกต่อไป

  • ข้อมูลว่าง/ไม่ว่างในปัจจุบันจะไม่ถูกรายงานในไคลเอ็นต์ดั้งเดิม ข้อมูลอาจทันสมัยออกไปถึง 15 นาที

เมื่อต้องการแก้ไขปัญหานี้ ให้ปฏิบัติตามขั้นตอนเหล่านี้บนเซิร์ฟเวอร์กล่องจดหมายที่โฮสต์ฐานข้อมูลโฟลเดอร์สาธารณะ:

  1. คลิกหมายเลขบทความต่อไปนี้เพื่อไปยังบทความใน Microsoft Knowledge Base จากนั้นติดตั้งชุดการอัปเดตที่อธิบายไว้ในบทความ:

    2579150 อธิบายของ Rollup การอัปเดต 4 for Exchange Server 2010 Service Pack 1

  2. ปิดใช้งานบริการความพร้อมใช้งาน

    เมื่อต้องการให้เราปิดใช้งานบริการความพร้อมใช้งานให้คุณหลังจากที่คุณติดตั้ง Rollup การอัปเดต 2579150 ให้ไปที่ส่วน " แก้ไขปัญหาให้ฉัน" ถ้าคุณต้องการปิดใช้งานบริการความพร้อมใช้งานด้วยตนเอง ให้ไปที่ส่วน "ให้ฉันแก้ไขด้วยตนเอง"

    แก้ไข meTo ปิดใช้งานบริการความพร้อมใช้งานโดยอัตโนมัติ คลิกปุ่ม หรือลิงก์ แก้ไข จากนั้นคลิกเรียกใช้ในกล่องโต้ตอบดาวน์โหลดไฟล์แล้วปฏิบัติตามขั้นตอนในตัวช่วยสร้างแก้ไข




    หมายเหตุ

    • ตัวช่วยสร้างนี้อาจเป็นภาษาอังกฤษเท่านั้น อย่างไรก็ตาม การแก้ไขอัตโนมัติยังใช้งานได้กับ Windows เวอร์ชันภาษาอื่นด้วย

    • ถ้าคุณไม่ได้อยู่บนคอมพิวเตอร์ที่มีปัญหา ให้บันทึก แก้ไขปัญหา ลงในแฟลชไดรฟ์หรือซีดี แล้วเรียกใช้บนคอมพิวเตอร์ที่มีปัญหา


    จากนั้นไปที่ส่วน "วิธีนี้แก้ไขปัญหาได้หรือไม่"



    ให้ฉันแก้ไขด้วยตนเองหลังจากที่คุณติดตั้งการอัปเดต ให้ปฏิบัติตามขั้นตอนเหล่านี้เพื่อปิดใช้งานบริการความพร้อมใช้งาน:

    1. คลิกเริ่ม พิมพ์ regeditในกล่องเริ่มค้นหา แล้วคลิกregedit.exe

    2. ค้นหาแล้วคลิกที่คีย์ย่อยรีจิสทรีต่อไปนี้:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\

    3. บนเมนูแก้ไข ให้ชี้ไปที่สร้างแล้วคลิก คีย์

    4. พิมพ์ ParametersSystem แล้วกด Enter

    5. ค้นหาแล้วคลิกที่คีย์ย่อยรีจิสทรีต่อไปนี้:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\ParametersSystem

    6. บนเมนูแก้ไขให้ชี้ไปที่ใหม่แล้วคลิกค่า Dword

    7. พิมพ์ DisableAvailabilityServiceCalls แล้วกด Enter

    8. ในบานหน้าต่างรายละเอียด ให้คลิกขวาที่DisableAvailabilityServiceCallsแล้วคลิกปรับเปลี่ยน

    9. ในกล่อง ข้อมูล ค่า ให้พิมพ์ 1 แล้วคลิกตกลง

    10. ออกจาก Registry Editor


วิธีนี้ช่วยแก้ปัญหาหรือยัง

  • ตรวจสอบว่าปัญหานี้ได้รับการแก้ไขหรือไม่ หากแก้ไขปัญหาได้แล้ว คุณไม่ต้องดำเนินการใดๆ กับส่วนนี้อีก หากปัญหายังไม่ได้รับการแก้ไข คุณสามารถ ติดต่อฝ่ายสนับสนุน

  • เราขอขอบคุณที่ให้ข้อเสนอแนะของคุณ เมื่อต้องการให้ข้อคิดเห็นหรือรายงานปัญหาเกี่ยวกับโซลูชันนี้ โปรดใส่ข้อคิดเห็นบน "แก้ไขให้ฉัน" บล็อก หรือส่ง ข้อความอีเมล ถึงเรา

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "นำไปใช้กับ"

ข้อมูลเพิ่มเติม

For more information about the Availability service, visit the following Microsoft TechNet website:

บริการสถานะความพร้อมใน Exchange 2013

ต้องการความช่วยเหลือเพิ่มเติมหรือไม่

ต้องการตัวเลือกเพิ่มเติมหรือไม่

สํารวจสิทธิประโยชน์ของการสมัครใช้งาน เรียกดูหลักสูตรการฝึกอบรม เรียนรู้วิธีการรักษาความปลอดภัยอุปกรณ์ของคุณ และอื่นๆ

ชุมชนช่วยให้คุณถามและตอบคําถาม ให้คําติชม และรับฟังจากผู้เชี่ยวชาญที่มีความรู้มากมาย

ข้อมูลนี้เป็นประโยชน์หรือไม่

คุณพึงพอใจกับคุณภาพภาษาเพียงใด
สิ่งที่ส่งผลต่อประสบการณ์ใช้งานของคุณ
เมื่อกดส่ง คำติชมของคุณจะถูกใช้เพื่อปรับปรุงผลิตภัณฑ์และบริการของ Microsoft ผู้ดูแลระบบ IT ของคุณจะสามารถรวบรวมข้อมูลนี้ได้ นโยบายความเป็นส่วนตัว

ขอบคุณสำหรับคำติชมของคุณ!

×