แอพลิเคชันไคลเอนต์ outlook ไม่สามารถเชื่อมต่อไปยังโฟลเดอร์สาธารณะหลังจากที่คุณติดตั้ง Exchange Server 2010 SP1

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 2535105 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

บางแอพลิเคชันไคลเอนต์ Microsoft Outlook พบปัญหาในการเชื่อมต่อเมื่อ Microsoft Access ไคลเอ็นต์ RPC Exchange บริการเธรดอยู่มากซึ่งอยู่ในโฟลเดอร์'สาธารณะ'กำลังรอการตอบสนองจากบริการพร้อมใช้งาน ตัวอย่างเช่น ปัญหานี้เกิดขึ้นเมื่อเธรดมากกว่า 500 รอการตอบกลับในโฟลเดอร์สาธารณะ

หมายเหตุ
  • ไม่มีตัวเลือกที่มีอยู่เมื่อต้องการปิดใช้งานการบริการพร้อมใช้งานบนเซิร์ฟเวอร์ที่กำลังเรียกใช้ Exchange Server 2010 Service Pack (SP1)
  • ถ้าคุณเริ่มการบริการการเข้าถึงไคลเอ็นต์ RPC Exchange บนเซิร์ฟเวอร์โฟลเดอร์สาธารณะ Exchange Server 2010 SP1 คือแก้ไขปัญหานี้ชั่วคราว

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจากคุณลักษณะใหม่ใน Exchange Server 2010 SP1 คุณลักษณะใหม่นี้ใช้บริการการเข้าถึงไคลเอ็นต์ RPC Exchange Microsoft เป็นพร็อกซีสำหรับบริการพร้อมใช้งาน (ข้อมูลว่าง/ไม่ว่าง) รุ่นก่อนหน้า ดังนั้น ถ้าคุณมีโฟลเดอร์สาธารณะที่ถูกติดตั้งไว้บนเซิร์ฟเวอร์ Exchange Server 2010 SP1 การบริการการเข้าถึงไคลเอ็นต์ RPC Exchange Microsoft คเกอร์ดักคำขอข้อมูลว่าง/ไม่ว่าง

การแก้ไข

เมื่อต้องการแก้ไขปัญหานี้ ใช้หนึ่งในวิธีต่อไปนี้

วิธีที่ 1

ติดตั้งการปรับปรุงต่อไปนี้บนเซิร์ฟเวอร์ Exchange Server 2010 SP1:
2497453 การแก้ไข: โปรแกรมประยุกต์อาจหยุดการตอบสนองหลังจากถูกยกเลิกการร้องขอ HTTP หลายถ้าคุณใช้คลาส HttpWebRequest เพื่อส่งคำร้องขอใน.NET Framework

วิธีที่ 2

สิ่งสำคัญ ส่วน วิธีการ หรืองานนี้ประกอบด้วยขั้นตอนที่บอกให้คุณทราบวิธีการปรับเปลี่ยนรีจิสทรี อย่างไรก็ตาม ปัญหาร้ายแรงอาจเกิดขึ้นหากคุณปรับเปลี่ยนรีจิสทรีอย่างไม่ถูกต้อง ดังนั้น ตรวจสอบให้แน่ใจว่า คุณทำตามขั้นตอนเหล่านี้อย่างระมัดระวัง สำหรับการป้องกันเพิ่มเติม ให้สำรองข้อมูลรีจิสทรีก่อนที่คุณจะปรับเปลี่ยน จากนั้นคุณจะสามารถคืนค่ารีจิสทรีได้หากเกิดปัญหา สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการสำรอง และคืนค่ารีจิสทรี คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
322756 วิธีการสำรอง และคืนค่ารีจิสทรีใน Windows

ข้อควรระวังปัญหาต่อไปนี้อาจเกิดขึ้นถ้าคุณใช้วิธีนี้:
  • ใน anOffice 365 และการปรับใช้ไฮบริดสลี Exchange Server ในสถานที่ หรือ ในการติดต่อกับภายนอกองค์กร ไคลเอนต์แบบดั้งเดิมเช่น Microsoft Office Outlook 2007 หรือ Microsoft Office Outlook 2003 จะไม่ได้รับข้อมูลว่าง/ไม่ว่าง จาก cloud ไซต์ หรือ จากองค์กรระยะไกล
  • จะไม่มีรายงานข้อมูลว่าง/ไม่ว่างล่าสุดสำหรับไคลเอนต์แบบดั้งเดิม ข้อมูลอาจจะล้าสมัยนานถึง 15 นาที
เมื่อต้องแก้ไขปัญหานี้ ให้ทำตามขั้นตอนเหล่านี้:
  1. คลิกหมายเลขบทความต่อไปนี้เพื่อไปยังบทความในฐานความรู้ของ Microsoft และจากนั้น ให้ติดตั้ง update rollup ที่อธิบายไว้ในบทความนี้:
    2579150 คำอธิบายของ Update Rollup 4 สำหรับ Exchange Server 2010 Service Pack ที่ 1
  2. ปิดใช้งานการบริการพร้อมใช้งาน

    ต้องการให้เราปิดใช้งานการบริการพร้อมใช้งานสำหรับคุณหลังจากที่คุณติดตั้งการปรับปรุง 2579150 ค่าสะสม ไป "แก้ไขให้ฉัน"ส่วน หากคุณต้องการปิดใช้งานการบริการมีอยู่ของตัวคุณเอง ให้ไป "ให้ฉันแก้ไขด้วยตนเอง"ส่วน

    แก้ไขให้ฉัน

    เมื่อต้องการปิดใช้งานบริการมีพร้อมใช้งานโดยอัตโนมัติ การFix it ปุ่มหรือการเชื่อมโยง แล้วคลิกเรียกใช้ในกล่องโต้ตอบดาวน์โหลดแฟ้มและทำตามขั้นตอนในตัวช่วยสร้างFix it


    แก้ไขปัญหานี้
    Microsoft Fix it 50789


    หมายเหตุ
    • ตัวช่วยสร้างนี้อาจเป็นภาษาอังกฤษเท่านั้น อย่างไรก็ตาม การแก้ไขอัตโนมัติยังสามารถใช้ได้กับ Windows รุ่นภาษาอื่น
    • ถ้าคุณไม่ใช้คอมพิวเตอร์ที่มีปัญหา บันทึกวิธีแก้นั้นโซลูชันไปยังแฟลชไดรฟ์หรือซีดี แล้ว เรียกใช้บนคอมพิวเตอร์ที่มีปัญหา

    แล้ว ไป "วิธีนี้แก้ไขปัญหาหรือไม่"ส่วน



    ให้ฉันแก้ไขด้วยตนเอง

    หลังจากที่คุณติดตั้งการปรับปรุง ให้ทำตามขั้นตอนเหล่านี้เพื่อปิดใช้งานการบริการพร้อมใช้งาน:

    หมายเหตุ คุณอาจต้องทำตามขั้นตอนเหล่านี้บนเซิร์ฟเวอร์โฟลเดอร์สาธารณะ
    1. คลิกเริ่มชนิด regedit ในการเริ่มต้นค้นหากล่อง และจากนั้น คลิกregedit.exe
    2. ค้นหาและคลิกที่คีย์ย่อยของรีจิสทรีต่อไปนี้:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\
    3. ในการแก้ไข เมนู ชี้ไปที่สร้างและคลิกที่คีย์
    4. ชนิด ParametersSystemแล้ว กด Enter
    5. ค้นหาและคลิกที่คีย์ย่อยของรีจิสทรีต่อไปนี้:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\ParametersSystem
    6. ในการแก้ไข ชี้ไปที่สร้างและเมนูแล้ว คลิกDword Value
    7. ชนิด DisableAvailabilityServiceCallsแล้ว กด Enter
    8. ในบานหน้าต่างรายละเอียด คลิกขวาDisableAvailabilityServiceCallsและจากนั้น คลิกปรับเปลี่ยน
    9. ในการValue data กล่อง พิมพ์1แล้ว คลิกตกลง
    10. ออกจาก Registry Editor

วิธีนี้แก้ไขปัญหาหรือไม่

  • ตรวจสอบว่าปัญหาได้รับการแก้ไขแล้ว ถ้าปัญหาได้รับการแก้ไข แสดงว่าคุณเสร็จสิ้นส่วนนี้แล้ว ถ้าไม่มีแก้ไขปัญหานี้ คุณสามารถ โปรดติดต่อฝ่ายสนับสนุน.
  • เรายินดีรับทราบคำติชมของคุณ เมื่อต้อง การแสดงคำติชม หรือรายงานปัญหาใด ๆ เกี่ยวกับการแก้ไขนี้ โปรดทิ้งข้อคิดเห็น "แก้ไขให้ฉัน"บล็อก หรือส่งถึงเราผิด อีเมล .

สถานะ

Microsoft ยืนยันว่า ปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ที่ระบุไว้ในส่วน "นำไปใช้งาน"

ข้อมูลเพิ่มเติม

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับบริการการมีพร้อมใช้งาน แวะไปที่เว็บไซต์ของ Microsoft TechNet ดังต่อไปนี้:

คุณสมบัติ

หมายเลขบทความ (Article ID): 2535105 - รีวิวครั้งสุดท้าย: 17 พฤศจิกายน 2556 - Revision: 6.0
ใช้กับ
  • Microsoft Exchange Server 2010 Service Pack 1 เมื่อใช้กับ:
    • Microsoft Exchange Server 2010 Enterprise
    • Microsoft Exchange Server 2010 Standard
Keywords: 
kbqfe kbfix kbexpertiseinter kbsurveynew kbhotfixrollup kbfixme kbmsifixme kbmt KB2535105 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:2535105

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com