The Microsoft Exchange Information Store service crashes occasionally when a folder view is corrupted on an Exchange Server 2010 mailbox server

Article ID: 2548246 - View products that this article applies to.
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SYMPTOMS

When a folder view is corrupted on a Microsoft Exchange Server 2010 server that has the mailbox server role installed, the Microsoft Exchange Information Store service (Store.exe) crashes occasionally. When this issue occurs, event 4999 is logged in the Application log together with the following events:

Time: <time>
ID: 10030
Level: Warning
Provider: MSExchangeIS Mailbox Store
Machine: <computer>
Message: A mismatch was detected between a view of a folder and the actual contents of the folder. The mismatched item was ignored.

Time: <time>
ID: 10031
Level: Warning
Provider: MSExchangeIS Mailbox Store
Machine: <computer>
Message: A folder view which previously experienced consistency issues has been deleted and will be rebuilt the next time it is needed.


Note When this issue occurs, users cannot access their mailboxes.

CAUSE

This issue occurs because the Store.exe process creates a negative index in the corrupted view. Therefore, the Store.exe process crashes when it tries to clean the corrupted folder view.

RESOLUTION

To resolve this issue, install the following update rollup:
2608646 Description of Update Rollup 6 for Exchange Server 2010 Service Pack 1

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

WORKAROUND

To work around this issue, move the mailboxes that contain the corrupted folder view to a different database.

Properties

Article ID: 2548246 - Last Review: October 31, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Exchange Server 2010 Service Pack 1, when used with:
    • Microsoft Exchange Server 2010 Standard
    • Microsoft Exchange Server 2010 Enterprise
Keywords: 
kbqfe kbfix kbsurveynew kbexpertiseadvanced KB2548246

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