Smartcard-Authentifizierung funktioniert nicht bei Verwendung von VDI und RD-Gateway für RDC-Client in Windows 7 oder Windows Server 2008 R2

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Artikel-ID: 2548538 - Produkte anzeigen, auf die sich dieser Artikel bezieht
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Problembeschreibung

Auf einem Computer, auf der Windows 7 oder Windows Server 2008 R2 ausgeführt wird, verwenden Sie Virtual Desktop Infrastructure (VDI) und Remotedesktopgateway (Remote Desktop)-Client (Remote Desktop Connection, RDC). In diesem Szenario kann nicht der RDC-Client MyDesktop oder VMpool schließen mit Smartcard-Authentifizierung. Außerdem erhalten Sie eine Fehlermeldung, die folgenden Inhalts angezeigt:
Ihr Computer kann nicht mit dem Remotecomputer herstellen, da ein Benutzername und Kennwort erforderlich sind, um die Remotedesktop-Gatewayserver anstelle von Smartcard-Anmeldeinformationen zu authentifizieren.
Hinweis Dieses Problem tritt nur beim dem Versuch, auf dem remote-Server zum ersten Mal anmelden mithilfe des RDC-Clients.

Ursache

Dieses Problem tritt auf, weil der RDC-Broker die Option RDP-Datei nicht korrekt generieren. Aus diesem Grund kann die Smartcard-Authentifizierung ausgewählt werden.

Lösung

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Dieser Hotfix ist jedoch vorgesehen, um nur das Problem zu beheben, das in diesem Artikel beschrieben wird. Wenden Sie diesen Hotfix nur auf Systemen, bei die das Problem auftritt, das in diesem Artikel beschrieben wird. Dieser Hotfix wird möglicherweise zusätzliche Tests angezeigt. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, dass Sie auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, ist ein Abschnitt "Hotfixdownload available" (Hotfixdownload verfügbar"am oberen Rand dieses Knowledge Base-Artikel. Wenn dieser Abschnitt nicht vorhanden ist, wenden Sie sich an Microsoft Customer Service and Support, um den Hotfix zu erhalten.

Hinweis Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der Microsoft-Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf die folgende Microsoft-Website:
http://Support.Microsoft.com/contactus/?WS=Support
Hinweis Das Formular "Hotfixdownload available" (Hotfixdownload verfügbar"zeigt die Sprachen an, für die der Hotfix verfügbar ist. Wenn Sie Ihre Sprache nicht angezeigt werden, ist es da ein Hotfix nicht für diese Sprache verfügbar ist.

Voraussetzungen

Um diesen Hotfix installieren zu können, muss eine der folgenden Betriebssysteme ausgeführt werden:
  • Windows 7
  • Windows 7 mit Servicepack 1 (SP1)
  • WindowsServer 2008 R2
  • WindowsServer 2008 R2 mit Servicepack 1 (SP1)
Weitere Informationen dazu, wie Sie ein Servicepack von Windows 7 oder Windows Server 2008 R2 Servicepack zu erhalten finden Sie in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
976932 Informationen zum Servicepack 1 für Windows 7 und Windows Server 2008 R2

Registrierungsinformationen

Um den Hotfix in diesem Paket verwenden, müssen Sie keinen Änderungen an der Registrierung vornehmen.

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix anwenden.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfix.

Dateiinformationen

Die internationale Version dieses Hotfixes installiert Dateien mit die Attributen, die in den folgenden Tabellen aufgeführt sind. Die Datumsangaben und Uhrzeiten für diese Dateien werden in Coordinated Universal Time (UTC) aufgeführt. Die Datumsangaben und Uhrzeiten für diese Dateien auf Ihrem lokalen Computer werden in Ihrer lokalen Zeit zusammen mit Ihren aktuellen Daylight Saving Time (DST)-Bias angezeigt. Darüber hinaus können die Datumsangaben und Uhrzeiten ändern, wenn Sie bestimmte Operationen auf Dateien anwenden.
Hinweise zu den Dateiinformationen für Windows 7 und Windows Server 2008 R2
  • Die Dateien für bestimmte Produkte, Meilensteine (RTM, SP geltenn), und Servicebereiche (LDR, GDR) kann identifiziert werden, durch die Versionsnummern der Datei untersuchen, wie in der folgenden Tabelle dargestellt:
    Tabelle minimierenTabelle vergrößern
    VersionProduktMeilensteinServicebereiche
    6.1.760 0,20xxxWindows 7 und WindowsServer 2008 R2RTMLDR
    6.1.760 1.21xxxWindows 7 und WindowsServer 2008 R2SP1LDR
  • Die MANIFESTEN-Dateien (. manifest) und MUM-Dateien (.mum), die installiert werden für jede Umgebung sind separat aufgeführt im Abschnitt "Weitere Dateiinformationen für Windows Server 2008 R2 und Windows 7". MUM- und MANIFEST-Dateien sowie die zugeordneten (.cat) Sicherheitskatalogdateien, sind äußerst wichtig, um den Status der aktualisierten Komponenten beizubehalten. Die Sicherheitskatalogdateien, deren Attribute nicht aufgelistet sind, sind mit einer digitalen Microsoft-Signatur signiert.
Für alle unterstützten x 64-basierten Versionen von Windows 7 und Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumZeitPlattform
Sbmgr.dll6.1.7600.209711,667,07223-Mai-201105: 31X 86
Sbmgr.mscNicht zutreffend116,20010-Jun-200920: 32Nicht zutreffend
Sbmgr.dll6.1.7601.217321,712,12823-Mai-201105: 13X 86
Sbmgr.mscNicht zutreffend116,20010-Jun-200920: 32Nicht zutreffend

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Beziehen sich auf" aufgeführt sind.

Weitere Informationen

Weitere Informationen zum Bereitstellen von Remotedesktoplizenzierung finden Sie auf die folgende Microsoft TechNet-Website:
Eine schrittweise Anleitung zum Bereitstellen der Remotedesktoplizenzierung
Weitere Informationen zur Terminologie für Softwareupdates finden Sie in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
824684 Beschreibung der Standardterminologie, die zum Beschreiben von Softwareupdates von Microsoft verwendet wird

Weitere Dateiinformationen

Weitere Dateiinformationen für Windows 7 und Windows Server 2008 R2

Weitere Dateien für alle unterstützten x 64-basierten Versionen von Windows 7 und Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameAmd64_1f51a88ae61aa61d111a4410a4919dcd_31bf3856ad364e35_6.1.7601.21732_none_5ef5596cf5b8c6e7.Manifest
DateiversionNicht zutreffend
Dateigröße729
Datum (UTC)23-Mai-2011
Zeit (UTC)19: 39
PlattformNicht zutreffend
DateinameAmd64_f89809b35666d485fb904cdb329679c0_31bf3856ad364e35_6.1.7600.20971_none_b00a891d384a0dec.Manifest
DateiversionNicht zutreffend
Dateigröße729
Datum (UTC)23-Mai-2011
Zeit (UTC)19: 39
PlattformNicht zutreffend
DateinameAmd64_microsoft-Windows-t...Bmgr-Snap-in-nonmsil_31bf3856ad364e35_6.1.7600.20971_none_af40754e63599ff8.manifest
DateiversionNicht zutreffend
Dateigröße11,897
Datum (UTC)23-Mai-2011
Zeit (UTC)05: 56
PlattformNicht zutreffend
DateinameAmd64_microsoft-Windows-t...Bmgr-Snap-in-nonmsil_31bf3856ad364e35_6.1.7601.21732_none_b153124e605eb577.manifest
DateiversionNicht zutreffend
Dateigröße11,897
Datum (UTC)23-Mai-2011
Zeit (UTC)07: 15
PlattformNicht zutreffend
DateinameUpdate.mum
DateiversionNicht zutreffend
Dateigröße1,989
Datum (UTC)23-Mai-2011
Zeit (UTC)19: 39
PlattformNicht zutreffend

Eigenschaften

Artikel-ID: 2548538 - Geändert am: Mittwoch, 15. Juni 2011 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Windows 7 Enterprise
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter kbmt KB2548538 KbMtde
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 2548538
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