FIX: Memory usage of the W3wp.exe process increases when the CreateFromCache method of the DiscountItemCollection class displays discount information on a Commerce Server 2007 site or on a Commerce Server 2009 site

Article translations Article translations
Article ID: 2556002 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario:
  • You install Microsoft Commerce Server 2007 or Microsoft Commerce Server 2009 on a computer.
  • You create a Commerce Server site that calls the CreateFromCache method of the DiscountItemCollection class to display the discount information of a discount cache.

    Note For more information about how to display discounts for specific products, visit the following MSDN website:
    How to display discounts for specific products
  • The discount cache frequently refreshes.

    Note The frequency of the refresh operations depends on one or more of the following factors:
    • How frequently business users use Marketing Manager business user applications to refresh the site cache.
    • How frequently the SiteCacheRefresh.axd handler is called to refresh all the marketing caches or the discount cache.
    • The refreshInterval setting for the discount cache in the caches element of the Web.config file.
In this scenario, the memory usage for the W3wp.exe worker process of Internet Information Services (IIS) increases. When the memory usage increases to a high value, you have to manually recycle the IIS application pool that the Commerce Server site runs.

Note The rate that the memory increases depends on the frequency of the discount cache refreshes.

CAUSE

This issue occurs because the DiscountItemCollection component uses time stamps in the cache to determine when the component has to rebuild the list of discounts. 

When the cache is frequently refreshed, the list of discounts is created multiple times. Therefore, the memory usage increases.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Microsoft Commerce Server 2007 Service Pack 2 (SP2) or Microsoft Commerce Server 2009 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart Internet Information Services (IIS) and the Commerce Server Catalog Import Host COM+ application after you apply this hotfix.

To restart IIS, type the following command at a command prompt, and then press ENTER:
IISRESET /RESTART
Note This command stops and then restarts all IIS services that are running on a computer.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Commerce Server 2007 Service Pack 2 (SP2)
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.commerceserver.runtime.dll6.0.4109.64845,69625-May-201111:28x86
Commerce Server 2009 RTM for SharePoint 2007
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Cs2009hotfixhelper.exe6.0.4171.4912,13626-May-201110:21x86
Microsoft.catalogserver.dll6.0.4171.49763,76026-May-201110:21x86
Microsoft.commerceserver.runtime.dll6.0.4171.49849,79226-May-201110:21x86
Microsoft.commerceserver.catalog.dll6.0.4171.49960,38426-May-201110:05x86
Commerce Server 2009 Template Pack for Microsoft SharePoint 2010
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Cspatchhelper.exe6.0.4171.51516,22426-May-201110:52x86
Microsoft.catalogserver.dll6.0.4171.515763,76026-May-201110:52x86
Microsoft.commerceserver.runtime.dll6.0.4171.515849,79226-May-201110:52x86
Microsoft.commerceserver.catalog.dll6.0.4171.515960,38426-May-201110:39x86

MORE INFORMATION

A discount cache might be frequently refreshed in the following situations:
  • Random cache refreshes
    The following operations refresh the cache:
    • Manually refresh cache by using Commerce Server administration tools.
    • Incoming messages use line-of-business Commerce Server adapters that automatically start the cache refresh operation.

  • Periodic cache refreshes that are automatic
    The following operations automatically and periodically refresh the cache:
    • Configure the RefreshInterval settings in a standard Commerce Server installation.

      Note You can configure the RefreshInterval setting in the caches element of the Web.config file. For more information about the caches element, visits the following MSDN website:
      General information about the caches element
    • Use time interval configurations to trigger the Line-Of-Business Commerce Server adapters.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For more information about caching in Commerce Server, visit the following MSDN website:
General information about caching in Commerce Server
For more information about the CreateFromCache method, visit the following MSDN website:
General information about the CreateFromCache method

Properties

Article ID: 2556002 - Last Review: June 15, 2011 - Revision: 1.0
APPLIES TO
  • Microsoft Commerce Server 2007 Enterprise Edition
  • Microsoft Commerce Server 2007 Developer Edition
  • Microsoft Commerce Server 2007 Standard Edition
  • Microsoft Commerce Server 2009 Enterprise
  • Microsoft Commerce Server 2009 Standard
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbexpertiseadvanced kbsurveynew KB2556002

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com