Synchronization of an organizational forms library fails when you use Outlook in Cache mode in an Exchange Server 2010 environment

Article ID: 2572029 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

Consider the following scenario:
  • An administrator creates a public folder for an organizational forms library in a Microsoft Exchange Server 2010 environment.
  • A user publishes a form to the organizational forms library.
  • A user tries to sync their Microsoft Outlook Cached Mode profile with the Exchange server.
In this scenario, synchronization partially fails. Additionally, an event that resembles the following is logged in the Sync Issues folder: 
Time Synchronizer Version Version Number
Time Synchronizing Mailbox Mailbox
Time Synchronizing Hierarchy
Time Synchronizing Forms
Time Downloading from server Server
Time Error synchronizing folder
Time [80004005-501-4B9-560]
Time The client operation failed.
Time Microsoft Exchange Information Store
Time For more information on this failure, click the URL below:
TimeURL
Time Done
Note This issue affects all users in the organization, including users who do not use organizational forms.

CAUSE

The issue occurs because the Outlook client requests more properties than the database actually contains for the folder. When the RPCClientAccess service requests data from the store, the service finds that certain properties are missing, throws an exception, and then stops synchronizing the folder.

RESOLUTION

To resolve this issue, install the following update rollup:
2685289 Description of Update Rollup 3 for Exchange Server 2010 Service Pack 2

MORE INFORMATION

For more information about how to create an organizational forms library, go to the following Microsoft website:
How to create an organizational forms library

Properties

Article ID: 2572029 - Last Review: June 27, 2012 - Revision: 3.0
APPLIES TO
  • Microsoft Exchange Server 2010 Service Pack 2
  • Microsoft Exchange Server 2010 Standard
  • Microsoft Exchange Server 2010 Enterprise
Keywords: 
kbqfe kbsurveynew kbfix kbexpertiseinter KB2572029

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com