Symptoms
Consider the following scenario:
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A web proxy client establishes a secure socket layer (SSL) connection to an external web server by using a server that is running Microsoft Forefront Threat Management Gateway 2010.
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HTTPS inspection is not involved. Therefore, an end-to-end SSL tunnel between the client and the web server is established.
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Inside this established connection, the client uploads data to the web server.
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The connection and TCP flow to the web server are slow.
In this scenario, the upload does not finish correctly under certain circumstances.
Cause
This problem occurs after the client successfully sends all its data to the TMG proxy server The client does this even though the TMG proxy server has not yet sent all the data to the destination web server because of slow bandwidth between the TMG proxy server and the destination web server.
In this case, the TMG proxy server does not correctly handle the reminding buffer that is to be sent to the destination web server, and the TCP connection is prematurely closed.Resolution
To resolve this problem, install the service pack that is described in the following Microsoft Knowledge Base article:
2555840 Description of Service Pack 2 for Microsoft Forefront Threat Management Gateway 2010Note To enable this hotfix, you must run the setProxySocketSendBufSize.vbs script on the server that is running Forefront Threat Management Gateway 2010. To have us run the setProxySocketSendBufSize.vbs script for you, go to the "Fix it for me" section. If you prefer to create and run the script yourself, go to the "Let me fix it myself" section.
Fix it for me
To fix this problem automatically, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.
Notes
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This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
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If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.
Did this fix the problem?" section.
Then, go to the "Let me fix it myself
To create and run the script, follow these steps:
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Start Notepad. To do this, click Start, click Run, type notepad.exe in the Open box, and then click OK.
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Paste the following script into the new Notepad file:
Const SE_VPS_GUID = "{143F5698-103B-12D4-FF34-1F34767DEabc}"
Const SE_VPS_NAME = "ProxySocketSendBufSize" Const SE_VPS_VALUE = 8192 Sub SetValue() ' Create the root object. Dim root ' The FPCLib.FPC root object Set root = CreateObject("FPC.Root") 'Declare the other objects that are needed. Dim array ' An FPCArray object Dim VendorSets ' An FPCVendorParametersSets collection Dim VendorSet ' An FPCVendorParametersSet object ' Obtain references to the array object ' and the network rules collection. Set array = root.GetContainingArray Set VendorSets = array.VendorParametersSets On Error Resume Next Set VendorSet = VendorSets.Item( SE_VPS_GUID ) If Err.Number <> 0 Then Err.Clear ' Add the item Set VendorSet = VendorSets.Add( SE_VPS_GUID ) CheckError WScript.Echo "New VendorSet added... " & VendorSet.Name Else WScript.Echo "Existing VendorSet found... value- " & VendorSet.Value(SE_VPS_NAME) End If if VendorSet.Value(SE_VPS_NAME) <> SE_VPS_VALUE Then Err.Clear VendorSet.Value(SE_VPS_NAME) = SE_VPS_VALUE If Err.Number <> 0 Then CheckError Else VendorSets.Save false, true CheckError If Err.Number = 0 Then WScript.Echo "Done with " & SE_VPS_NAME & ", saved!" End If End If Else WScript.Echo "Done with " & SE_VPS_NAME & ", no change!" End If End Sub Sub CheckError() If Err.Number <> 0 Then WScript.Echo "An error occurred: 0x" & Hex(Err.Number) & " " & Err.Description Err.Clear End If End Sub SetValue -
On the File menu, click Save As, and then save the script as setProxySocketSendBufSize.vbs.
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On the File menu, click Exit to exit Notepad.
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Double-click the .vbs file that you saved in step 3.
Did this fix the problem?
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Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.
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We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email.
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
References
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates