Applies ToOutlook

Symptoms

When you use Microsoft Outlook to add or to remove a delegate, the delegate is not added or deleted. Additionally, you receive the following error message:

The Delegates settings were not saved correctly. Unable to activate send-on-behalf-of list. You do not have sufficient permission to perform this operation on this object.

Cause

When you add a delegate, Outlook also tries to grant "send on behalf of" permission to the delegate by default. This permission is written to the publicDelegates attribute of your user object in Active Directory.

The issue that is described in "Symptoms" can occur for either (or both) of the following reasons.

  • The global catalog (GC) server to which your Outlook client is connected is not local to your domain. If your Outlook client is connected to a GC that is not local to your domain, the publicDelegates attribute cannot be written to your user object in Active Directory.  

  • The SELF object does not have the Write Personal Information right on your Active Directory user object.

Resolution

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756  How to back up and restore the registry in Windows

Outlook can be configured to enable you to add delegates without requiring you to grant the "send on behalf of" permission. Follow these steps:

  1. Exit Outlook.

  2. Start Registry Editor. To do this, use one of the following procedures, as appropriate for your situation.  

    • Windows 10 or Windows 8: Press Windows Key + R to open a Run dialog box. Type regedit.exe and then press OK.

    • Windows 7 or Windows Vista: Click Start, type regedit.exe in the search box, and then press Enter.

    • Windows XP: Click Start, and click Run.  Type regedit.exe and then press OK.

  3. Locate and then click the following registry subkey:  

        HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\Preferences If you use policies, click the following subkey:  

        HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\x.0\Outlook\Preferences Note: x.0 in the above registry key represents your Outlook version. Please use one of the following values.Outlook 2016: 16.0Outlook 2013: 15.0 Outlook 2010: 14.0 Outlook 2007: 12.0 Outlook 2003: 11.0  

  4. After you select the subkey that is specified in step 3, click New on the Edit menu, and then click DWORD Value.

  5. Type IgnoreSOBError, and then press Enter.

  6. Right-click IgnoreSOBError, and then click Modify.

  7. In the Value data box, type 1, and then click OK.

  8. On the File menu, click Exit to exit Registry Editor.

After you add the registry value, you can add a delegate without having write permissions to your own user object on the global catalog server. When you do this, a message that resembles the following message is logged in the Windows Application log to help track the event:

Source: Outlook Category: None Event ID: 27 Type: Error User: N/A Computer: computer_name Description: SOB error ignored

More Information

The "send on behalf of" permission is not needed for meeting-related messages. Microsoft Exchange Server specifically does not require that you have "send on behalf of" permissions to send a meeting request on behalf of another user. Therefore, even without the "send on behalf of" permission, delegates can successfully send meeting requests on behalf of the calendar owner. However, when you use a delegate that does not have the "send on behalf of" permission to send a non-meeting-related message on behalf of the owner, the operation fails. For example, if a delegate tried to send an informational message "from the boss," that operation would fail. This is because the "send on behalf of" permission was not successfully granted.

If you want to grant another user the "send on behalf of" permission on your mailbox, you can do this on the Exchange Server.

In Exchange Server 2003, use the Delivery Restrictions button on the Exchange General tab of the Mailbox properties. For more information about the Exchange General tab, see http://technet.microsoft.com/en-us/library/aa997251.aspx.

For more information about how to grant "send on behalf of" permissions in Exchange Server 2007, see http://technet.microsoft.com/en-us/library/bb124406(EXCHG.80).aspx.

For information about how to grant "send on behalf of" permissions in Exchange Server 2010, see http://technet.microsoft.com/en-us/library/bb124255.aspx.  

For information about adding user permissions to mailbox folders, see http://technet.microsoft.com/en-us/library/dd298062.aspx.   

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