Jak rozwiązywać problemy, które mogą występować podczas uruchamiania programów Word 2000, Word 2002 i Word 2003 lub podczas pracy w tych programach

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 259413 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Ten artykuł został opublikowany wcześniej pod numerem PL259413
Ważne: W tym artykule zamieszczono informacje dotyczące sposobu modyfikowania rejestru. Przed zmodyfikowaniem rejestru należy wykonać jego kopię zapasową. Upewnij się, że wiesz, jak przywrócić rejestr w przypadku pojawienia się problemu. Aby uzyskać informacje dotyczące wykonywania kopii zapasowej, przywracania i modyfikowania rejestru, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
256986 Opis rejestru systemu Microsoft Windows

Ten artykuł jest konsolidacją następujących dostępnych wcześniej artykułów: 826840 i 289634
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Streszczenie

W przypadku programu Microsoft Word wiele problemów jest często skojarzonych z ustawieniami lub sterownikami, które nie należą do podstawowych plików programu Word. Ten artykuł zawiera listę wybranych ogólnych kroków, które można spróbować wykonać przed skontaktowaniem się z pomocą techniczną.

Więcej informacji

Upewnianie się, że drukarka została zainstalowana

W przypadku braku czcionek należy się upewnić, że drukarka została zainstalowana i nie jest to drukarka Typowa/Tylko tekst. Czcionki wyświetlane w programie Word na liście Czcionka są zależne od typu zainstalowanej drukarki. Jeżeli jako domyślny sterownik drukarki ustawiono sterownik drukarki Typowa/Tylko tekst, na liście Czcionka może zostać wyświetlona tylko jedna czcionka – Roman 10 znaków na cal (cpi). Jeżeli jako drukarkę domyślną ustawiono drukarkę inną niż Typowa, wszystkie czcionki TrueType zainstalowane na komputerze są wyświetlane na liście Czcionka.

Aby sprawdzić w programie Word, która drukarka jest używana, należy kliknąć polecenie Drukuj w menu Plik. Jeżeli pozycja Generic / Text Only jest wyświetlona w polu Nazwa, należy wybrać inną drukarkę. Jeżeli inna drukarka nie jest dostępna w polu Nazwa, należy zainstalować drukarkę, wykonując kroki odpowiednie dla danej sytuacji.
Uwaga: Ponieważ istnieje wiele wersji systemu Microsoft Windows, poniższe kroki mogą się różnić w zależności od komputera. W takim przypadku należy wykonać kroki opisane w dokumentacji produktu.

W systemie Windows 2000
  1. Zamknij wszystkie wystąpienia programu Word. Jeżeli używasz programu Word jako edytora poczty e-mail, upewnij się, że program Microsoft Outlook również został zamknięty.
  2. Kliknij przycisk Start, wskaż polecenie Ustawienia, a następnie kliknij polecenie Drukarki.
  3. Kliknij polecenie Dodaj drukarkę.
  4. W Kreatorze dodawania drukarki kliknij przycisk Dalej.
  5. Zaznacz opcję Drukarka lokalna lub Drukarka sieciowa, a następnie kliknij przycisk Dalej.
  6. Jeżeli zostanie wyświetlony komunikat proponujący ręczną instalację drukarki, kliknij przycisk Dalej.
  7. Wybierz port, którego chcesz użyć, a następnie kliknij przycisk Dalej.
  8. Na liście Producenci zaznacz odpowiedniego producenta drukarki. Na liście Drukarki kliknij żądany model drukarki. Kliknij przycisk Dalej.
  9. Zaznacz żądane opcje, a następnie kliknij przycisk Dalej. Powtarzaj tę procedurę w przypadku każdego panelu kreatora, aż do końca. Kliknij przycisk Zakończ.
  10. Ustaw tę drukarkę jako drukarkę domyślną.
W systemie Windows XP
  1. Zamknij wszystkie wystąpienia programu Word. Jeżeli używasz programu Word jako edytora poczty e-mail, upewnij się, że program Microsoft Outlook również został zamknięty.
  2. Kliknij przycisk Start, a następnie kliknij polecenie Drukarki i faksy.
  3. W menu Plik kliknij polecenie Dodaj drukarkę.
  4. W Kreatorze dodawania drukarki kliknij przycisk Dalej.
  5. Kliknij opcję Drukarka lokalna podłączona do tego komputera lub Drukarka sieciowa lub drukarka podłączona do innego komputera, a następnie kliknij przycisk Dalej.
  6. Jeżeli zostanie wyświetlony komunikat proponujący ręczną instalację drukarki, kliknij przycisk Dalej.
  7. Wybierz port, którego chcesz użyć, a następnie kliknij przycisk Dalej.
  8. Na liście Producentci zaznacz odpowiedniego producenta drukarki. Na liście Drukarki kliknij żądany model drukarki. Kliknij przycisk Dalej.
  9. Zaznacz żądane opcje, a następnie kliknij przycisk Dalej. Powtarzaj tę procedurę w przypadku każdego panelu kreatora, aż do końca. Kliknij przycisk Zakończ.
  10. Ustaw tę drukarkę jako drukarkę domyślną.

Ustalanie, czy określone zachowanie jest specyficzne dla dokumentu

Jeżeli występuje problem z określonym dokumentem, należy rozważyć następujące zagadnienia:
  • Czy to samo zachowanie występuje w przypadku nowego dokumentu?
  • Czy to samo zachowanie występuje w przypadku innych istniejących dokumentów?
Program Word kojarzy wiele rodzajów formatowania, zwłaszcza formatowanie sekcji i stylów, z ostatnim znakiem akapitu. Jeżeli wszystkie elementy oprócz ostatniego znaku akapitu zostaną skopiowane do nowego dokumentu, być może uszkodzone formatowanie nie zostanie przeniesione z oryginalnego dokumentu. W nowym dokumencie należy ponownie zastosować formatowanie sekcji lub stylów. Aby skopiować wszystkie elementy oprócz ostatniego znaku akapitu, wykonaj następujące kroki:
  1. Otwórz dokument w programie Word.
  2. Naciśnij klawisze CTRL+END.
  3. Naciśnij klawisze CTRL+SHIFT+HOME.
  4. W menu Edycja kliknij polecenie Kopiuj.
  5. W menu Plik kliknij polecenie Nowy.
  6. Kliknij łącze Pusty dokument.
  7. W menu Edycja kliknij polecenie Wklej.
UWAGA: Jeżeli dokument zawiera znaki podziału sekcji, należy skopiować tylko tekst znajdujący się między znakami podziału sekcji. Nie wolno kopiować i wklejać znaków podziału sekcji, ponieważ może to być przyczyną przeniesienia uszkodzonego formatowania do nowego dokumentu. Aby uzyskać więcej informacji dotyczących sposobu rozwiązywania problemów z uszkodzonymi dokumentami programu Word, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
826864 How to troubleshoot damaged Word documents

Upewnianie się, że konwerter odzyskiwania tekstu nie jest używany podczas otwierania pliku

Aby zapobiec odzyskaniu wyłącznie tekstu podczas otwierania pliku i otworzyć plik w formacie dokumentów programu Word, wykonaj następujące kroki:
  1. W menu Plik kliknij polecenie Otwórz.
  2. Na liście Pliki typu kliknij pozycję Wszystkie dokumenty programu Word lub kliknij pozycję Wszystkie pliki.
Aby uzyskać więcej informacji, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
291180 Formatting lost, symbols appear when you open document

Wstawianie dokumentu do innego pliku

Ostatni znak akapitu w dokumencie programu Word zawiera informacje dotyczące dokumentu. Jeżeli dokument jest uszkodzony, można pobrać tekst dokumentu pod warunkiem pominięcia ostatniego znaku akapitu.

Aby uzyskać dostęp do dokumentu, pomijając ostatni znak akapitu, wykonaj następujące kroki:
  1. W menu Plik kliknij polecenie Nowy. Wybierz łącze Pusty dokument i kliknij przycisk OK.
  2. W menu Wstaw kliknij polecenie Plik.
  3. Zaznacz plik, który chcesz otworzyć i wstawić, a następnie kliknij przycisk Wstaw.

Uzyskiwanie aktualnego skanera wirusów

Niektóre problemy mogą być związane z wirusem. Można zapobiec infekcji lub usunąć wirusa z komputera, uruchamiając oprogramowanie antywirusowe zawierające najnowszą aktualizację i często skanując system. Aby uzyskać więcej informacji, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
233396 ZZmniejszanie ryzyka infekcji przez wirusy makr w programie Word
49500 Lista dostawców oprogramowania antywirusowego

Uruchamianie programu Word z przełącznikiem /a

Przełącznik /a jest narzędziem do rozwiązywania problemów, umożliwiającym lokalizację problemu występującego podczas pracy z programem Microsoft Word. Jeżeli przełącznik /a jest używany do uruchamiania programu Word, dodatki i szablony globalne nie są ładowane automatycznie. Przełącznik /a powoduje również zablokowanie plików ustawień, tzn. niemożność odczytywania lub modyfikowania plików tego typu, jeżeli przełącznik ten jest użyty. Aby uruchomić program Word przy użyciu przełącznika /a, wykonaj następujące kroki:
  1. Kliknij przycisk Start, a następnie kliknij polecenie Uruchom.
  2. W oknie dialogowym Uruchamianie kliknij przycisk Przeglądaj.
  3. Otwórz jeden z następujących folderów, zależnie od wersji programu Word:

    Word 2003
    C:\Program Files\Microsoft Office\Office11
    Word 2002
    C:\Program Files\Microsoft Office\Office10
    Word 2000
    C:\Program Files\Microsoft Office\Office
    UWAGA: Jeżeli program Word został zainstalowany w innym folderze, należy użyć odpowiedniej ścieżki.

    Kliknij plik Winword.exe, a następnie kliknij przycisk Otwórz.
  4. W polu Otwórz powinna być widoczna ścieżka podobna do następującej:

    "C:\Program Files\Microsoft Office\Office\Winword.exe"
  5. Kliknij w polu Otwórz, a następnie przenieś punkt wstawiania za końcowy znak cudzysłowu na końcu ścieżki.
  6. Wpisz spację, a następnie wpisz przełącznik /a. Po wykonaniu powyższych czynności ścieżka powinna wyglądać podobnie do następującej:

    "C:\Program Files\Microsoft Office\Office\Winword.exe" /a

    UWAGA: Przełącznik /a musi być wpisany poza znakami cudzysłowu. Jeżeli zostanie wpisany między znakami cudzysłowu, podczas próby uruchomienia polecenia zostanie wyświetlony komunikat o błędzie podobny do następującego:
    Nie można odnaleźć pliku 'C:\Program Files\Microsoft Office\Office\Winword.exe /a' (lub jednego z jego składników). Upewnij się, że podana ścieżka i nazwa pliku są poprawne i że wszystkie wymagane biblioteki są dostępne.
  7. Kliknij przycisk OK, aby uruchomić program Word z przełącznikiem /a.
Aby uzyskać więcej informacji dotyczących zastosowań przełącznika /a, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
826857 Description of the "/a" startup switch in Word
Jeżeli dany problem nie występuje w przypadku uruchamiania programu Word przy użyciu przełącznika /a, należy wykonać sześć następnych procedur, aby ustalić źródło problemu (rezygnacja z uruchamiania makr automatycznych, opróżnienie folderu startowego, sprawdzenie dodatków COM, zmiana nazwy szablonu globalnego, zmiana nazwy klucza danych w rejestrze systemu Windows i zmiana nazwy klucza rejestru Options).

Rezygnacja z uruchamiania makr automatycznych

Niektóre makra, zwane makrami automatycznymi, są uruchamiane podczas uruchamiania programu Word. Następująca lista zawiera listę makr automatycznych. Aby uruchomić program Word bez wykonywania makr automatycznych, należy nacisnąć i przytrzymać klawisz SHIFT podczas uruchamiania programu Word.
Zwiń tę tabelęRozwiń tę tabelę
MakroLokalizacja przechowywaniaUruchamianie makra
AutoExecW szablonie Normal lub w dodatku globalnymPodczas uruchamiania programu Word
AutoNewW szabloniePodczas tworzenia nowego dokumentu na podstawie szablonu
AutoOpenW dokumencie lub szabloniePodczas otwierania dokumentu utworzonego na podstawie szablonu lub zawierającego to makro
AutoCloseW dokumencie lub szabloniePodczas zamykania dokumentu utworzonego na podstawie szablonu lub zawierającego to makro
AutoExitW szablonie Normal lub w dodatku globalnymPodczas zamykania programu Word
Program Word rozpoznaje makro o nazwie rozpoczynającej się od przedrostka „Auto” jako makro uruchamiane automatycznie podczas wystąpienia odpowiedniej dla niego sytuacji. Aby tymczasowo uniemożliwić uruchamianie makr automatycznych, należy nacisnąć i przytrzymać klawisz SHIFT podczas wykonywania akcji powodującej uruchomienie makra.

Jeżeli problem nie występuje wówczas, gdy klawisz SHIFT zostanie naciśnięty i przytrzymany podczas uruchamiania programu Word, oznacza to, że przyczyną problemu jest makro automatyczne. Aby zapobiec występowaniu tego problemu, wykonaj następujące kroki:
  1. Uruchom program Word.
  2. W menu Narzędzia wskaż polecenie Makro, a następnie polecenie Makra.
  3. W oknie dialogowym Makra może zostać wyświetlona lista makr. Jeżeli wyświetlona nazwa makra zaczyna się od tekstu „Auto”, konieczne może być usunięcie danego makra.
  4. Aby usunąć makro automatyczne, kliknij w celu zaznaczenia odpowiedniego makra, a następnie kliknij przycisk Usuń.

    Uwaga: Być może makro automatyczne zostało utworzone przez dodatek programu Word. Aby ustalić, który szablon zawiera makro automatyczne, należy wyświetlić makra dostępnych szablonów w oknie dialogowym Makra. Po zlokalizowaniu szablonu zawierającego makro automatyczne konieczne może być usunięcie tego szablonu z komputera. Jeżeli zostanie usunięty szablon zainstalowany przez dodatek programu Word, dodatek może nie działać.
  5. Kliknij przycisk Anuluj, aby zamknąć okno dialogowe Makra.
  6. W menu Plik kliknij polecenie Zakończ, aby zamknąć program Microsoft Word. Następnie należy ponownie uruchomić program Word.
Jeżeli problem nie występuje po ponownym uruchomieniu programu Word, oznacza to, że makro automatyczne było przyczyną problemu.

Opróżnianie folderu startowego

Podczas uruchamiania programu Word automatycznie ładowane są szablony i dodatki znajdujące się w folderach startowych. Błędy występujące w programie Word mogą być spowodowane przez konflikty lub problemy z dodatkiem. Aby ustalić, czy dany element z folderu startowego jest przyczyną problemu, można tymczasowo opróżnić ten folder.

Program Word ładuje elementy z folderów Startup pakietu Office oraz Word. Aby usunąć elementy z folderów Startup, wykonaj następujące kroki:
  1. Zamknij wszystkie wystąpienia programu Word. Jeżeli używasz programu Word jako edytora poczty e-mail, upewnij się, że program Microsoft Outlook również został zamknięty.
  2. Na pulpicie systemu Windows kliknij dwukrotnie ikonę Mój komputer, a następnie zlokalizuj folder Startup pakietu Office dla danej wersji programu Word. Lokalizacja domyślna jest następująca:

    Word 2003
    C:\Program Files\Microsoft Office\Office11\Startup
    Word 2002
    C:\Program Files\Microsoft Office\Office10\Startup
    Word 2000
    C:\Program Files\Microsoft Office\Office\Startup
  3. Przeciągnij poszczególne elementy z folderu Startup na pulpit. (Możesz również utworzyć folder na pulpicie i przeciągnąć poszczególne elementy do tego nowego folderu).

    UWAGA: Aby utworzyć nowy folder na pulpicie, kliknij prawym przyciskiem myszy pusty obszar pulpitu, wskaż polecenie Nowy, a następnie kliknij polecenie Folder.
  4. Znajdź folder Startup programu Word. Domyślna lokalizacja folderu Startup programu Word jest następująca:

    W systemie Windows XP lub Windows 2000:

    C:\Documents and Settings\nazwa użytkownika\Dane aplikacji\Microsoft\Word\Startup

    W systemie Windows 98 lub Windows Millennium Edition (Windows Me) bez włączonej obsługi profili:

    C:\windows\Dane aplikacji\Microsoft\Word\Startup

    W systemie Windows 98 lub Windows Millennium Edition (Windows Me) z włączoną obsługą profili:

    C:\windows\nazwa użytkownika\Dane aplikacji\Microsoft\Word\Startup

    Przeciągnij poszczególne elementy z folderu Startup na pulpit. (Możesz również utworzyć folder na pulpicie i przeciągnąć poszczególne elementy do tego nowego folderu).
  5. Uruchom program Word.
Jeżeli nie można odtworzyć problemu i usunięto wiele elementów z jednego lub kilku folderów Startup, można spróbować wyizolować problem, dodając kolejno pliki ponownie do odpowiedniego folderu Startup. Należy spróbować odtworzyć problem po dodaniu każdego pliku, aby ustalić, który plik jest przyczyną problemu.

Sprawdzanie dodatków COM

Są one instalowane przez programy współdziałające z programem Word. Dodatki COM mogą być zainstalowane w dowolnej lokalizacji. Aby wyświetlić listę zainstalowanych dodatków COM, wykonaj następujące kroki:
  1. W menu Narzędzia kliknij polecenie Dostosuj.
  2. Kliknij kartę Polecenia.
  3. Na liście Kategorie kliknij pozycję Narzędzia.
  4. Przeciągnij polecenie Dodatki COM do paska narzędzi.
  5. Kliknij przycisk Zamknij.
  6. Kliknij przycisk Dodatki COM na pasku narzędzi, aby wyświetlić listę dodatków COM załadowanych razem z programem Word.
Jeżeli w oknie dialogowym Dodatki COM są wyświetlane dodatki, należy je tymczasowo wyłączyć. Aby to zrobić, należy klikać pola wyboru obok poszczególnych dodatków COM na liście w celu ich wyczyszczenia, a następnie kliknąć przycisk OK. Podczas ponownego uruchamiania programu Word dodatki COM nie zostaną załadowane.

Jeżeli problem nie występuje po wyłączeniu dodatków COM, być może jeden z dodatków COM jest przyczyną problemu.
Jeżeli na liście widocznych jest kilka dodatków COM, należy ustalić, który dodatek COM jest przyczyną określonego problemu, wyłączając kolejno dodatki COM. Następnie należy ponownie uruchomić program Word.

Zmiana nazwy szablonu globalnego

Aby formatowanie, Autotekst i makra przechowywane w szablonie globalnym (Normal.dot) nie wpływały na zachowanie programu lub otwieranych dokumentów, należy zmienić nazwę pliku Normal.dot.

UWAGA: Zmiana nazwy szablonu Normal.dot pozwala szybko ustalić, czy szablon Normal jest przyczyną określonego problemu lub zachowania. Zmiana nazwy szablonu Normal.dot powoduje przywrócenie ustawień domyślnych wielu opcji, w tym stylów niestandardowych, niestandardowych pasków narzędzi, makr i wpisów Autotekstu. Z tego powodu firma Microsoft zdecydowanie zaleca zmianę nazwy pliku Normal.dot zamiast jego usunięcia.

Niektóre rodzaje konfiguracji mogą utworzyć więcej niż jeden plik Normal.dot. Dzieje się tak, gdy na tym samym komputerze jest uruchamianych wiele wersji programu Word lub istnieje wiele instalacji stacji roboczych. W takich sytuacjach należy się upewnić, że zmieniono nazwę wszystkich kopii pliku Normal.dot.

Aby zmienić nazwę szablonu globalnego (Normal.dot), wykonaj następujące czynności:

Uwaga: Ponieważ istnieje wiele wersji systemu Microsoft Windows, poniższe kroki mogą się różnić w zależności od komputera. W takim przypadku należy wykonać kroki opisane w dokumentacji produktu.
  1. Zamknij wszystkie wystąpienia programu Word, w tym programu Microsoft Outlook, jeśli edytorem wiadomości e-mail jest program Word.
  2. Kliknij przycisk Start, a następnie kliknij polecenie Wyszukaj.
  3. W oknie dialogowym Wyniki wyszukiwania, w obszarze Co chcesz wyszukać? kliknij łącze Wszystkie pliki i foldery.
  4. W polu Cała nazwa pliku lub jej część wpisz Normal.dot.
  5. W polu Szukaj w wybierz lokalny dysk twardy (lub alternatywną lokalizację szablonów użytkownika, jeżeli program Word jest uruchamiany z serwera sieciowego).
  6. Kliknij przycisk Wyszukaj, aby odszukać plik.
  7. Dla każdego wystąpienia pliku Normal.dot w oknie dialogowym Wyniki wyszukiwania kliknij je prawym przyciskiem myszy. Kliknij polecenie Zmień nazwę w menu skrótów. Wpisz nową nazwę pliku, taką jak OldNormal.dot lub Normal-1.dot, a następnie naciśnij klawisz ENTER.
  8. W menu Plik kliknij polecenie Zamknij, aby zamknąć program wyszukujący.
Jeżeli program Word uruchamia się prawidłowo, problem został rozwiązany. W tym przypadku problemem był uszkodzony szablon Normal.dot. Aby przywrócić ulubione opcje, konieczna będzie zmiana kilku ustawień.

Jeżeli plik Normal.dot, którego nazwa została zmieniona, zawiera dostosowania niemożliwe do odtworzenia w prosty sposób, takie jak style, makra lub pozycje Autotekstu, można je skopiować ze starego pliku Normal.dot do nowego pliku Normal.dot przy użyciu Organizatora. Aby uzyskać więcej informacji dotyczących sposobu korzystania z Organizatora, kliknij polecenie Microsoft Word — Pomoc w menu Pomoc, wpisz sposób korzystania z Organizatora w polu Wyszukaj w okienku Pomoc, a następnie kliknij przycisk Rozpocznij wyszukiwanie, aby wyświetlić listę znalezionych tematów.

Zmiana nazwy klucza danych w Rejestrze Windows

Ostrzeżenie: Niepoprawne zmodyfikowanie rejestru za pomocą Edytora rejestru lub innej metody może stać się przyczyną poważnych problemów. Mogą one wymagać ponownego zainstalowania systemu operacyjnego. Firma Microsoft nie może zagwarantować, że rozwiązanie problemów spowodowanych niepoprawnym zmodyfikowaniem rejestru będzie możliwe. Możesz modyfikować rejestr na własną odpowiedzialność.
UWAGA: Zmiana nazwy klucza danych powoduje przywrócenie ustawień domyślnych kilku opcji, w tym listy ostatnio używanych plików w menu Plik, a także wielu ustawień dostosowanych przez użytkownika po kliknięciu polecenia Opcje w menu Narzędzia. Podczas następnego uruchomienia program Word odbudowuje klucz danych, korzystając z ustawień domyślnych.

Aby zmienić nazwę klucza danych, wykonaj następujące czynności:
  1. Zamknij wszystkie programy systemu Windows.
  2. Kliknij przycisk Start, a następnie kliknij polecenie Uruchom.
  3. W polu Otwórz wpisz polecenie regedit, a następnie kliknij przycisk OK.
  4. Zlokalizuj następujący klucz, klikając dwukrotnie foldery odpowiednie dla używanej wersji programu Word:

    Word 2003
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Data
    Word 2002
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data
    Word 2000
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Data


    Zaznacz folder Dane, a następnie kliknij polecenie Zmień nazwę w menu Edycja.
  5. Wpisz nową nazwę folderu Dane (na przykład wpisz OldData, a następnie naciśnij klawisz ENTER.
  6. W menu Rejestr kliknij polecenie Zakończ, aby zamknąć Edytor rejestru. Uruchom ponownie program Word w zwykły sposób (nie używając przełącznika /a).
Jeżeli program Word uruchamia się prawidłowo, problem został rozwiązany. Przyczyną problemu jest uszkodzony klucz danych. Aby przywrócić ulubione opcje, konieczna będzie zmiana kilku ustawień.

Zmiana nazwy klucza rejestru Options

W tym kluczu są przechowywane opcje, które można konfigurować z programu Word.

UWAGA: Większość ustawień nie jest zapisywana w rejestrze aż do chwili, kiedy użytkownik wprowadzi zmiany w programie Word, a następnie zamknie program Word.

Aby zmienić nazwę klucza Options, wykonaj następujące czynności:
  1. Zamknij wszystkie programy systemu Windows.
  2. Kliknij przycisk Start, a następnie kliknij polecenie Uruchom.
  3. W polu Otwórz wpisz polecenie regedit, a następnie kliknij przycisk OK.
  4. Zlokalizuj następujący klucz, klikając dwukrotnie foldery odpowiednie dla używanej wersji programu Word:

    Word 2003
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Options
    Word 2002
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options
    Word 2000
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Options
    Zaznacz folder Options, a następnie kliknij polecenie Zmień nazwę w menu Edycja.
  5. Wpisz nową nazwę folderu Options (na przykład wpisz OldOptions), a następnie naciśnij klawisz ENTER.
  6. W menu Rejestr kliknij polecenie Zakończ, aby zamknąć Edytor rejestru.
Uruchom ponownie program Word w zwykły sposób (nie używając przełącznika /a).

Jeżeli program Word uruchamia się prawidłowo, problem został rozwiązany. Przyczyną problemu jest uszkodzony klucz Options. Konieczne może być ponowne zdefiniowanie niektórych ustawień w celu przywrócenia ulubionych opcji użytkownika. Aby uzyskać więcej informacji dotyczących przywracania domyślnych ustawień programu Word, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
822005 Jak zresetować opcje użytkownika i ustawienia rejestru w programach Microsoft Office Word 2003, Microsoft Word 2002 i Microsoft Word 2000

Sprawdzanie sterownika drukarki

Jeżeli komputer przestaje odpowiadać („zawiesza się”) lub występują inne problemy związane z drukowaniem, należy spróbować użyć sterownika drukarki Typowa/Tylko tekst. Aby zainstalować sterownik drukarki Typowa, należy wykonać następujące kroki.

UWAGA: Do zainstalowania tego sterownika drukarki może być niezbędny dysk CD-ROM z systemem Windows.
Uwaga: Ponieważ istnieje wiele wersji systemu Microsoft Windows, poniższe kroki mogą się różnić w zależności od komputera. W takim przypadku należy wykonać kroki opisane w dokumentacji produktu.

W systemach Windows XP lub Windows 2000:
  1. Zamknij program Word.
  2. Kliknij przycisk Start, wskaż polecenie Ustawienia, a następnie kliknij polecenie Drukarki.

    UWAGA: W systemie Windows XP kliknij polecenie Drukarki i faksy w menu Start.

    • Jeżeli widoczna jest ikona sterownika drukarki Typowa, kliknij prawym przyciskiem myszy tę ikonę, a następnie kliknij polecenie Ustaw jako domyślną.
    • Jeżeli ikona sterownika drukarki Typowa nie istnieje, wykonaj następujące kroki:
      1. Otwórz okno Kreator dodawania drukarki.
      2. W Kreatorze dodawania drukarki kliknij przycisk Dalej.
      3. Zaznacz opcję Drukarka lokalna lub Drukarka sieciowa, a następnie kliknij przycisk Dalej.
      4. Jeżeli zostanie wyświetlony komunikat proponujący ręczną instalację drukarki, kliknij przycisk Dalej.
      5. Wybierz port, którego chcesz użyć, a następnie kliknij przycisk Dalej.
      6. Na liście Producenci kliknij pozycję Generic. Na liście Drukarki kliknij pozycję Generic / Text Only (Generic/Text Only). Kliknij przycisk Dalej.
      7. Wybierz żądane opcje i kliknij przycisk Dalej. Powtarzaj tę procedurę dla każdego panelu kreatora, aż do końca. Kliknij przycisk Zakończ.
UWAGA: Jeżeli sterownik drukarki Typowa/Tylko tekst jest skonfigurowany jako domyślny, czcionki TrueType są niedostępne w programie Word.

Aktualizacja sterownika wideo

Aby ustalić, który sterownik wideo jest używany, wykonaj następujące kroki.

UWAGA: Te kroki mogą być różne, zależnie od używanego systemu operacyjnego, a także zainstalowanego sterownika wideo.

W systemie Windows XP lub Windows 2000:
  1. Zamknij wszystkie wystąpienia programu Word. Jeżeli używasz programu Word jako edytora poczty e-mail, upewnij się, że program Microsoft Outlook również został zamknięty.
  2. Kliknij przycisk Start, wskaż polecenie Ustawienia, a następnie kliknij polecenie Panel sterowania.

    UWAGA: W systemie Windows XP kliknij polecenie Panel sterowania w menu Start.
  3. Kliknij dwukrotnie ikonę Ekran.
  4. Kliknij kartę Ustawienia.
  5. Kliknij przycisk Zaawansowane.
  6. Kliknij kartę Karta.
  7. Kliknij przycisk Właściwości.
  8. Zanotuj nazwę producenta.
  9. Kliknij kartę Sterownik.
  10. Zanotuj wersję sterownika, a następnie kliknij przycisk Anuluj trzy razy.
Skontaktuj się z producentem sterownika wideo i zamów najnowszą wersję. Aby zainstalować uaktualniony sterownik wideo, wykonaj instrukcje dostarczone razem ze sterownikiem wideo.

Aby uzyskać informacje dotyczące sposobu kontaktowania się z producentem sterownika wideo, kliknij odpowiedni numer artykułu na następującej liście w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z

Próba uruchomienia komputera w trybie awaryjnym

W systemie Windows XP lub Windows 2000:

Aby uzyskać więcej informacji dotyczących uruchamiania systemu Windows 2000 w trybie awaryjnym, kliknij następujące numery artykułów w celu wyświetlenia tych artykułów z bazy wiedzy Microsoft Knowledge Base:
202485 Opis rozruchu w trybie awaryjnym w systemie Windows 2000
239780 Safe-Mode boot switches for Windows Boot.ini file
199175 Situations in which Windows may not start in Safe Mode
W systemie Windows 98:

Aby uzyskać więcej informacji, kliknij następujące numery artykułów w celu wyświetlenia tych artykułów z bazy wiedzy Microsoft Knowledge Base:
192926 Jak rozwiązywać problemy za pomocą czystego rozruchu systemu Windows 98
180902 Jak uruchomić komputer z systemem Windows w trybie awaryjnym

Wykrywanie i naprawianie

Program Microsoft Word w pełni wykorzystuje funkcje samonaprawy, które są udostępniane przez Instalatora Windows. Instalator Windows wykrywa brak krytycznego zasobu, takiego jak plik lub klucz rejestru, niezbędnego do uruchomienia programu pakietu Office, i naprawia dany program. Aby uzyskać więcej informacji, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
235620 Description of the self-repairing features
822238 JAK: Opis funkcji naprawiania w pakiecie Microsoft Office 2003

Naprawianie programu Microsoft Word lub pakietu Microsoft Office

W niektórych sytuacjach pliki programu Word lub pakietu Office mogą zostać uszkodzone. Najłatwiejszy sposób naprawienia instalacji programu Word lub pakietu Office polega na uruchomieniu narzędzia Napraw produkt Office (lub Napraw produkt Word). Jest to metoda bardzo szybka i często umożliwia rozwiązanie problemu, jednak w niektórych sytuacjach jest nieskuteczna, dlatego konieczne może być całkowite usunięcie i ponowne zainstalowanie określonego produktu.

Aby skorzystać z narzędzia do naprawy programu Word lub pakietu Office, wykonaj następujące kroki:
  1. Zamknij wszystkie programy pakietu Microsoft Office i wyłącz wszystkie programy antywirusowe.
  2. Kliknij przycisk Start, wskaż polecenie Ustawienia, a następnie kliknij polecenie Panel sterowania. UWAGA: W systemie Windows XP kliknij polecenie Panel sterowania w menu Start.
  3. Kliknij dwukrotnie ikonę Dodaj lub usuń programy.
  4. Kliknij program Word należący do pakietu Office lub autonomiczną wersję programu Word, zainstalowaną na danym komputerze, a następnie kliknij przycisk Dodaj/Usuń.

    Na przykład kliknij skrót Microsoft Word 2000, Microsoft Office 2000 Standard, Microsoft Office 2000 Premium lub Microsoft Office 2000 Professional.
  5. Po uruchomieniu programu instalacyjnego kliknij przycisk Napraw produkt Office (lub Napraw produkt Word).
Program instalacyjny sprawdza zainstalowane pliki, a następnie zastępuje wszystkie pliki pochodzące ze starszych wersji, które mają nieprawidłowy rozmiar lub są uszkodzone, albo instaluje brakujące pliki. Po zakończeniu instalacji należy uruchomić program Word w normalny sposób (bez użycia przełącznika /a) i spróbować odtworzyć problem.

Jeżeli problem zostanie rozwiązany, być może przyczyną problemu był uszkodzony lub brakujący plik.

Usuwanie i ponowne instalowanie programu Microsoft Word lub pakietu Microsoft Office

Jeżeli naprawa programu Word lub pakietu Office nie umożliwia rozwiązania problemu, konieczne może być usunięcie, a następnie ponowne zainstalowanie programu Word lub pakietu Office. Następująca procedura umożliwia usunięcie maksymalnej liczby składników i elementów związanych z programem Word lub pakietem Office. Po usunięciu programu Word lub pakietu Office należy ponownie zainstalować dany produkt.

PRZESTROGA: Ta procedura może być przyczyną utraty danych. Przed wykonaniem tych kroków należy wykonać kopie zapasowe ważnych plików, z szablonami niestandardowymi, dokumentami i plikiem Normal.dot włącznie.

Uwaga: Ponieważ istnieje wiele wersji systemu Microsoft Windows, poniższe kroki mogą się różnić w zależności od komputera. W takim przypadku należy wykonać kroki opisane w dokumentacji produktu.
  1. Zamknij wszystkie programy pakietu Microsoft Office i wyłącz wszystkie programy antywirusowe.
  2. Jeżeli korzystasz z systemu Windows XP, kliknij przycisk Start, a następnie kliknij polecenie Panel sterowania. W systemie Windows 2000 kliknij przycisk Start, wskaż polecenie Ustawienia, a następnie kliknij polecenie Panel sterowania.
  3. W systemie Windows XP kliknij polecenie Dodaj lub usuń programy. W systemie Windows 2000 kliknij dwukrotnie ikonę Dodaj/Usuń programy.
  4. Kliknij przycisk Zmień lub usuń programy.
  5. Kliknij program Word należący do pakietu Office lub autonomiczną wersję programu Word zainstalowaną na danym komputerze, a następnie kliknij przycisk Usuń.
    Na przykład kliknij pozycję Microsoft Word 2000, Microsoft Office 2000 Standard, Microsoft Office 2000 Premium lub Microsoft Office 2000 Professional.
  6. Kliknij przycisk Tak, aby potwierdzić usunięcie.
  7. Po wyświetleniu monitu o potwierdzenie zamiaru usunięcia współużytkowanych składników kliknij przycisk Usuń wszystko.
  8. Po wyświetleniu monitu o ponowne uruchomienie systemu Windows kliknij przycisk Tak.
  9. Po ponownym uruchomieniu systemu Windows zamknij wszystkie programy ładowane podczas uruchamiania systemu, z programami antywirusowymi włącznie, a następnie ponownie zainstaluj program Word lub pakiet Office.

    UWAGA: Podczas ponownej instalacji programu Word lub pakietu Office należy wprowadzić klucz CD odczytany z kasety dysku CD lub uzyskany z Certyfikatu autentyczności.

Opcje Pomocy technicznej firmy Microsoft

Jeżeli nie można rozwiązać danego problemu, dostępnych jest kilka opcji pomocy technicznej.

Samodzielne szybkie znajdowanie odpowiedzi w trybie online

Za pomocą witryny Pomoc techniczna Microsoft w trybie online można przeszukiwać bazę wiedzy Microsoft Knowledge Base i inne zasoby techniczne w celu uzyskania szybkich i dokładnych odpowiedzi. Można również dostosować tę witrynę do własnych potrzeb.

Aby rozpocząć wyszukiwanie, przejdź do następującej witryny sieci Web:
http://support.microsoft.com/default.aspx?ln=PL

Pomoc techniczna firmy Microsoft

Można skontaktować się z pracownikiem pomocy technicznej firmy Microsoft, aby uzyskać pomoc w rozwiązaniu problemów.

Aby uzyskać więcej informacji o możliwościach otrzymania pomocy przy rozwiązywaniu problemów z systemem Microsoft Windows, kliknij polecenie Tematy Pomocy w menu Pomoc w Eksploratorze Windows. Na karcie Spis treści kliknij dwukrotnie, aby otworzyć książkę Rozwiązywanie problemów. Następnie kliknij dwukrotnie, aby otworzyć książkę Skontaktuj się z Pomocą techniczną firmy Microsoft, i przejrzyj dostępne opcje Pomocy technicznej.

Aby uzyskać więcej informacji dotyczących Pomocy technicznej firmy Microsoft, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
102344 Microsoft product support options Q&A

Właściwości

Numer ID artykułu: 259413 - Ostatnia weryfikacja: 27 lipca 2006 - Weryfikacja: 9.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
Słowa kluczowe: 
kbinfo kbtshoot KB259413

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com