Uninstalling Windows Media Center from Windows 7 Features may cause installation failures for drivers and other software

Article translations Article translations
Article ID: 2606237 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

When attempting to install drivers and other software on a Windows 7-based computer, the installation may fail if you have previously uninstalled Windows Media Center from the Control Panel under Uninstall a program / Turn Windows features on or off / Media Features / Windows Media Center.

CAUSE

This issue can occur because uninstalling Windows Media Center removes the following registry key: 
HKEY_LOCAL_Machine\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce

RESOLUTION

To resolve this issue, follow one of the methods below to add the registry key back into the registry.

Method 1: Re-enable Windows Media Center
  1. Click the Start button, click Control Panel, click Programs, and then click Turn Windows features on or off.
  2. In the Windows Features window, click Media Features to expand it, check the Windows Media Center box, click OK, and then restart your computer to complete the install. 
Method 2: Add the missing registry key back to the Windows Registry

Warning: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall Windows. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

Follow the steps below to to add the missing key to the registry:
  1. Click Start and type regedit, in the search box, then click Regedit from the returned list
  2. Locate the following registry subkey:

    HKEY_LOCAL_Machine\SOFTWARE\Microsoft\Windows\CurrentVersion
  3. Once you locate the registry subkey, right-click the CurrentVersion registry key , and click New and then click Key
  4. Type RunOnce in the text area and then press the Enter key on your keyboard
  5. Exit the Registry Editor

Properties

Article ID: 2606237 - Last Review: September 7, 2011 - Revision: 1.0
APPLIES TO
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
Keywords: 
KB2606237

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com