Unable to switch the input language from Korean to English in Windows 7 and Windows Vista [Step by Step]

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Article ID: 2606504 - View products that this article applies to.
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Symptoms

There is no reaction of language switch key in language bar, or the language bar disappears and unable to switch the input language from Korean to English in Windows 7 and Windows Vista.


Cause

Following issues can cause problems.
  • There is an error in registering the library module relating to language bar.
  • task scheduler service is stopped or MSCtfMonitordid not run.


How do I fix

Method 1: reregister the library module relating to language bar

  1. Click [Start]
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    and enter cmdIn the search window.

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  2. Right-click [cmd] in the list of program lists, and click [Run as Administrator].

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    When the user account control message appears, type the administrator password, or click [Yes].

  3. Type egsvr32.exe msimtf.dll at the command prompt screen, and then press Enter.

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    "When you receive the message "DllRegisterServer in msimtf.dll is successful.", click [OK].

  4. Type regsvr32.exe msctf.dll and then press Enter.

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    "When you receive the message "DllRegisterServer in the msctf.dll is successful." click [OK].

  5. Type exitand then press Enter to close the command prompt.

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  6. Restart your computer and check if the problem is solved.



Method 2: start the task scheduler service, and then run MSCtfMonitor.

Please see the following technical article to solve the problem.




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Properties

Article ID: 2606504 - Last Review: August 13, 2012 - Revision: 3.0
Applies to
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows 7 Enterprise
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
Keywords: 
kbstepbystep kbtshoot kbvideocontent kbmt KB2606504 KbMten

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