ID evento 9877 con codice di errore "0x80041606" quando si utilizza Outlook in modalitÓ in linea per la ricerca di una parola chiave in Exchange Server 2010

Traduzione articoli Traduzione articoli
Identificativo articolo: 2616127 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

Sintomi

Si consideri il seguente scenario. Per impostazione predefinita, la ricerca di Exchange Ŕ attivata per un database di cassette postali in un ambiente Microsoft Exchange Server 2010. ╚ possibile utilizzare Microsoft Outlook in modalitÓ in linea per la ricerca di una cassetta postale per una parola chiave o una frase che contiene una singola lettera o una sola cifra. In questo scenario, viene visualizzato il seguente messaggio di errore anche se vi sono corrispondenze per la parola chiave nella cassetta postale:
Nessuna corrispondenza trovata per"parola chiave".

Inoltre, il seguente evento viene registrato nel registro applicazione:
Nome registro: applicazione
Origine: MSExchangeIS Cassetta postale archivio
Data: Data
ID evento: 9877
Categoria di attivitÓ: Indicizzazione del contenuto
Livello: errore
Parole chiave: classico
Utente: n/d
Computer: Computer
Descrizione:
Funzione di indicizzazione di contenuto 'CISearch::EcGetRowsetAndAccessor' ha ricevuto un codice di errore anomalo e imprevisto da MSSearch.
Database delle cassette postali: Database delle cassette postali
Codice di errore: 0x80041606
NOTA: 0X80041606 = QUERY_E_TOOCOMPLEX

Cause

Questo problema si verifica perchÚ la ricerca di Exchange ha un limite di ricerca prefisso hardcoded di 200.000 nodi per la ricerca di un singolo carattere. Quando una ricerca prefisso supera questo limite, la ricerca restituisce QUERY_E_TOOCOMPLEX.Di conseguenza, 0x80041606 viene registrato come parte dell'evento ID 9877. Per impostazione predefinita, tutte le ricerche che utilizzano la modalitÓ in linea di Outlook in un ambiente di Exchange 2010 sono prefisso. Utilizzando le lettere o cifre singole, il sistema per la ricerca di tutte le parole o numeri che inizia con la cifra o la lettera nel database dell'intera cassetta postale. Se viene raggiunto il limite predefinito di 200.000 nodi, la ricerca restituisce l'errore.

Nota. ╚ il modo pi¨ comune per raggiungere il limite di 200.000 nodi per cercare una parola o frase che contiene una cifra o lettera. Esistono anche altre cause meno comuni, ad esempio ricerche molto complesse con molti e, Ors e NOTs. Inoltre, combinazioni complesse di intervalli di date e termini di ricerca, numero di voci nel campo a e da campi o una combinazione di queste operazioni pu˛ causare il limite essere raggiunto.

Risoluzione

Per risolvere questo problema, installare l'aggiornamento cumulativo seguente:
2608646 Descrizione dell'aggiornamento cumulativo 6 per Exchange Server 2010 Service Pack 1
Importante Questa sezione, metodo o attivitÓ contiene la procedura per modificare il Registro di sistema. Tuttavia, potrebbero verificarsi seri problemi se si modifica il Registro di sistema in modo errato. Pertanto, assicurarsi di seguire attentamente i passaggi. Per maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. In questo modo, Ŕ possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e ripristinare il Registro di sistema, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:
322756 Come eseguire il backup e il ripristino del Registro di sistema in Windows

Dopo aver installato l'aggiornamento cumulativo, per impostare il numero massimo di nodi di restrizione di query su 1.000.000, Vai al "Risolvere il problema per me"sezione. Se si preferisce impostare manualmente il numero massimo di nodi di restrizione di query, Vai al "Risolvere il problema manualmente"sezione.

Risolvere il problema per me



Per impostare automaticamente il numero massimo di nodi di restrizione di query, scegliere il Fix it pulsante o sul collegamento. Quindi fare clic su Esegui nella finestra di dialogo Download File e seguire i passaggi della procedura guidata di risolvere il problema.
Riduci l'immagineEspandi l'immagine
assets fixit1
Risolvere il problema
Microsoft Fix it 50810
Riduci l'immagineEspandi l'immagine
assets fixit2

Note
  • Questa procedura guidata potrebbe essere solo in lingua inglese. Tuttavia, la correzione automatica funziona anche per le versioni di Windows in altre lingue.
  • Se non si Ŕ nel computer in cui si verifica il problema, salvare la soluzione Fix it in un'unitÓ memoria flash o su un CD, quindi eseguirla sul computer che presenta il problema.

Quindi, visitare il "Il problema Ŕ stato risolto?"sezione.



Risolvere il problema manualmente

Dopo aver installato l'aggiornamento cumulativo, attenersi alla seguente procedura per impostare il numero massimo di nodi di restrizione di query su 1.000.000 (decimale):
  1. Verificare quanti evento ID 9877 con 0x80041606 eventi nel registro dell'applicazione ricevuti in un determinato server di cassette postali di Exchange Server 2010 nell'ultimo mese e di rendere un record del numero.
  2. Fare clic su Start
    Riduci l'immagineEspandi l'immagine
    pulsante Start
    digitare regedit nella casella Inizia ricerca e quindi premere INVIO
  3. Individuare e selezionare la seguente chiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14\ExSearch
  4. Fare clic su Modifica, scegliere Nuovo, quindi chiave.
  5. Tipo MaxRestrictionNodes, quindi premere INVIO.
  6. In MaxRestrictionNodes, fare clic su Modifica, scegliere Nuovoe quindi fare clic su Valore DWORD.
  7. Digitare servirere quindi premere INVIO.
  8. La voce del Registro di sistema dovrebbe essere simile al seguente:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14\ExSearch\MaxRestrictionNodes\Server
  9. Fare clic su Modificae quindi fare clic su Modifica.
  10. Nella casella dati valore digitare 1000000 (Decimale).
    Nota. Il valore predefinito della voce MaxRestrictionNodes Ŕ 200000 (decimale) prima di apportare qualsiasi modifica al Registro di sistema.
  11. Uscire dall'Editor del Registro di sistema.
Note
  • Dopo aver riavviato il servizio Indicizzatore ricerca di Microsoft Exchange, Ŕ necessario archiviare l'applicazione per i seguenti ID evento:
    • ID evento 130 non Ŕ riuscito a convertire il MailboxDB Guid leggere sotto la chiave del Registro di sistema MaxRestrictionNodes in un Guid
    • ID evento 131 Impossibile aprire la chiave del Registro di sistema MaxRestrictionNodes
    • ID evento 132 Impossibile impostare la proprietÓ MaxRestrictionNodes nell'indicizzatore
  • Se viene visualizzato uno di questi eventi, Ŕ possibile hanno immesso la chiave del Registro di sistema o il valore DWORD in modo non corretto. In alternativa, potrebbe non avere digitato la nuova chiave o valore DWORD correttamente. Apportare le correzioni necessarie e quindi riavviare il servizio Indicizzatore ricerca di Microsoft Exchange. La ricerca di nuove istanze di evento ID 130, 131 e 132.
  • Controllare il registro applicazione settimana e mensile che dipende dal numero di evento ID 9877 con errore 0x80041606 nel registro dell'applicazione.
  • Se viene ancora visualizzato un numero significativo di questi eventi, Ŕ possibile aumentare il valore in modo incrementale a 2000000 (decimale).
  • Non aumentare il valore oltre 2000000 (decimale), poichÚ questo potrebbe ridurre le prestazioni del server.
  • Se si hanno aumentato il valore a 2000000 (decimale) e continuano a essere visualizzati alcuni di questi eventi settimanali o mensili, questo Ŕ il comportamento previsto. Questo comportamento pu˛ essere causato da utenti che eseguono ricerche molto complesse (vedere la sezione "Sintomi" per ulteriori informazioni).

Il problema Ŕ stato risolto?

  • Controllare se il problema Ŕ stato risolto. Se il problema viene risolto, non Ŕ necessario continuare con questa sezione. Se il problema non viene risolto, Ŕ possibile contattare il supporto tecnico.
  • Ci piacerebbe ricevere commenti e suggerimenti. Per fornire commenti o segnalare problemi relativi a questa soluzione, lasciare un commento sul "Risolvere il problema per me"blog o inviare un messaggio di posta elettronica messaggio.

Status

Microsoft ha confermato che questo Ŕ un problema nei prodotti Microsoft elencati nella sezione "Si applica a".

Informazioni

Per ulteriori informazioni sulla ricerca di Exchange, visitare il seguente sito Web Microsoft:
Informazioni generali sulla ricerca di Exchange
Per ulteriori informazioni su come disattivare o attivare la ricerca di Exchange, visitare il seguente sito Web Microsoft:
Informazioni generali su come disattivare o attivare la ricerca di Exchange
Per ulteriori informazioni sulla voce del MaxRestrictionNodes , visitare il seguente sito Web Microsoft:
Informazioni generali relative al movimento di MaxRestrictionNodes

ProprietÓ

Identificativo articolo: 2616127 - Ultima modifica: lunedý 9 settembre 2013 - Revisione: 3.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Exchange Server 2010 Service Pack 1áalle seguenti piattaforme
    • Microsoft Exchange Server 2010 Enterprise
    • Microsoft Exchange Server 2010 Standard
Chiavi:á
kbqfe kbfix kbsurveynew kbexpertiseinter kbmt KB2616127 KbMtit
Traduzione automatica articoli
IMPORTANTE: il presente articolo Ŕ stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l?obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre Ŕ perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilitÓ per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualitÓ della traduzione.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 2616127
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com