E-mailové zprávy lze odesílat pouze z RoleTailored klienta v aplikaci Microsoft Dynamics NAV 2009 v prostředí pomocí anonymního ověřování třetí vrstvy

Překlady článku Překlady článku
ID článku: 2618652 - Produkty, které se vztahují k tomuto článku.
Tento článek se týká aplikace Microsoft Dynamics NAV ve všech zemích a ve všech národních jazykových prostředích.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Použijete-li klient RoleTailored (RTC) v aplikaci Microsoft Dynamics NAV 2009 v prostředí třetí vrstvy procedura poštu SMTP (400) e-mailové zprávy lze odesílat pouze při Anonymníje vybrána jako ověřování v nastavení pošty SMTP.
E-mailové zprávy však lze odeslat pomocí libovolného typu ověřování v klasické klienta.
Poznámka:Při spuštění RTC server hostící NAV služeb vrstvy (NSTR), procedura poštu SMTP (400) funguje správně s libovolného typu ověřování.
K tomuto problému dochází v následujících produktů:
  • Microsoft Dynamics NAV 2009 R2
  • Aktualizace Service Pack 1 (SP1) pro systém Microsoft Dynamics NAV 2009

Příčina

Tomuto problému dochází, protože identita klienta se liší v prostředích, tři vrstvy. Proto problémy ověřování dojít v Microsoft Exchange Server.

Řešení

Informace o opravě hotfix

Podporovaná oprava hotfix je k dispozici od společnosti Microsoft. Však je určena pouze k opravě problému popsaného v tomto článku. Použijte ji pouze u systémů, ve které dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Proto pokud jste závažně tento problém, doporučujeme počkat na další aktualizaci service pack aplikace Microsoft Dynamics NAV 2009 nebo další verze produktu Microsoft Dynamics NAV, která tuto opravu hotfix obsahovat.

Poznámka: Ve zvláštních případech poplatky, které jsou obvykle pro podporu, které mohou být účtovány, pokud pracovník technické podpory společnosti Microsoft Dynamics a souvisejících produktů potvrdí, že konkrétní aktualizace vyřeší váš problém. Výdaje na technickou podporu se bude u dalších otázek a problémů, které nelze vyřešit určitou konkrétní aktualizací.


Informace o instalaci

Společnost Microsoft poskytuje ukázky programování pouze pro ilustraci bez žádné záruky výslovně uvedené nebo předpokládané. Zahrnuje, ale neomezuje se pouze na předpokládaných záruk obchodovatelnosti nebo vhodnosti pro určitý účel. Tento článek předpokládá, že jste obeznámeni s programovacím jazykem, který je předmětem ukázky a s nástroji, které slouží k vytvoření a ladění skriptu. Pracovníci podpory společnosti Microsoft mohou vysvětlit funkce určitého postupu, ale nemohou tyto příklady rozšířit o další funkce nebo konstrukce podle konkrétních požadavků.

Poznámka: Před instalací této opravy hotfix ověřte, že všichni uživatelé klienta Microsoft Navision odhlášeni systému. Jedná se o Microsoft Navision Application Services (NAS) uživatelé klientského počítače. Je třeba klienta pouze uživatel přihlášený při implementaci opravy hotfix.

Chcete-li implementovat tuto opravu hotfix, musí mít licenci vývojáře.

Doporučujeme, aby uživatelský účet v okně přihlášení k systému Windows nebo v okně přihlášení databáze přidělí "SUPER" ID role. Pokud nelze uživatelskému účtu přiřadit ID role "SUPER", je třeba ověřit, zda má uživatelský účet následující oprávnění:
  • Změnit oprávnění pro objekt, který budete měnit.
  • Oprávnění spouštět System Object ID 5210 objekt a System Object ID 9015 objekt.


Poznámka: Nemáte práva k úložištím dat. Pokud nebudete provádět opravu dat.

Změny kódu

Poznámka: Vždy otestujte opravy kódu v kontrolovaném prostředí před instalací opravy v provozních počítačích.
Chcete-li tento problém vyřešit, změňte kód v procedura poštu SMTP (400). Po použití změny e-mailové zprávy vytvořené a odeslaná z klienta na server. Proto e-mailových zpráv zachová identitu vykonávajícího uživatele.
Chcete-li to provést, postupujte takto:
  1. Nasazení a zaregistrovat sestavení Microsoft.Navision.Mail.dll v klientovi. Chcete-li to provést, spusťte následující příkaz:
    regasm /tlb:Microsoft.Navision.Mail.tlb / codebase Microsoft.Navision.Mail.dll
  2. Změňte kód procedury poštu SMTP (400) takto:
    Existující kód
    ...
    PROCEDURE CreateMessage@.....
    BEGIN
    IF Recipients <> '' THEN
    CheckValidEmailAddresses(Recipients);
    CheckValidEmailAddresses(SenderAddress);
    SMTPMailSetup.GET;
    SMTPMailSetup.TESTFIELD("SMTP Server");
    IF ISCLEAR(Mail) THEN
    CREATE(Mail);
    Mail.FromName := SenderName;
    ...
    Změněný kód
    ...
    PROCEDURE CreateMessage@.....
    BEGIN
    IF Recipients <> '' THEN
    CheckValidEmailAddresses(Recipients);
    CheckValidEmailAddresses(SenderAddress);
    SMTPMailSetup.GET;
    SMTPMailSetup.TESTFIELD("SMTP Server");
    IF ISCLEAR(Mail) THEN
    CREATE(Mail,TRUE,TRUE);
    Mail.FromName := SenderName;
    ...

Požadavky

Musí mít jednu z následujících produktů nainstalovat tuto opravu hotfix:
  • Microsoft Dynamics NAV 2009 R2
  • Aktualizace Service Pack 1 pro systém Microsoft Dynamics NAV 2009
Musí mít následující opravy hotfix:
  • 2499881 You cannot configure the TLS settings for SMTP communication in Microsoft Dynamics NAV 2009
  • 2345735 You cannot change the default port for SMTP Communication in Microsoft Dynamics NAV
  • 2479702 The email message body is incorrect when you create an email message by using the AppendBody method in Microsoft Dynamics NAV 2009 Service Pack 1
  • 2280492 Attachments are not released until the Microsoft Dynamics NAV client is closed when you use the SMTP Mail codeunit (400) to send email messages that have attachments
  • 2516144 You receive malformed email messages if you use a specific version 7 release of the Microsoft.Navision.Mail.dll file in Microsoft Dynamics NAV 2009

Removal information

You cannot remove this hotfix.

Prohlášení

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Vlastnosti

ID článku: 2618652 - Poslední aktualizace: 29. září 2011 - Revize: 1.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Dynamics NAV 2009
Klíčová slova: 
kbqfe kbmbsmigrate kbsurveynew kbmbscodefix kbmt KB2618652 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:2618652

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com