E-mailberichten kunnen alleen worden verzonden vanaf de client RoleTailored in Microsoft Dynamics NAV 2009 in een drie-tier-omgevingen met anonieme verificatie

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 2618652 - Bekijk de producten waarop dit artikel van toepassing is.
Dit artikel is van toepassing op Microsoft Dynamics NAV voor alle landen en alle taalinstellingen.
Alles uitklappen | Alles samenvouwen

Op deze pagina

Symptomen

Wanneer u in de RoleTailored-client (RTC) in Microsoft Dynamics NAV 2009 in een omgeving met drie lagen de codeunit (400) van SMTP-Mail, kunnen e-mailberichten alleen worden verzonden als AnoniemeAls de verificatie in de SMTP-e-mailinstellingen is geselecteerd.
De e-mailberichten kunnen echter met elk type verificatie in de klassieke client worden verzonden.
OpmerkingWanneer u de RTC uitvoert op de server die als host fungeert voor de NAV Service Tier (NSTR), wordt de codeunit SMTP Mail (400) goed werkt met elk type verificatie.
Dit probleem treedt op in de volgende producten:
  • Microsoft Dynamics NAV 2009 R2
  • Microsoft Dynamics NAV 2009 servicepack 1 (SP1)

Oorzaak

Dit probleem treedt op omdat de identiteit van de client in drie-tier-omgevingen verschilt. Daarom worden de verificatieproblemen optreden in Microsoft Exchange Server.

Oplossing

Informatie over hotfixes

Een ondersteunde hotfix is nu beschikbaar bij Microsoft. Het is echter alleen bedoeld om het probleem dat in dit artikel wordt beschreven. Correctie alleen uit op systemen waarop dit specifieke probleem zich voordoet. Deze hotfix moet wellicht extra worden getest. Als u geen ernstige hinder van dit probleem ondervindt, is het daarom raadzaam te wachten op het volgende servicepack voor Microsoft Dynamics NAV 2009 of de volgende Microsoft Dynamics NAV-versie waarin deze hotfix is opgenomen.

Opmerking In speciale gevallen kunnen kosten die normaal verbonden zijn aan ondersteuningsoproepen, worden geannuleerd als een medewerker van Technical Support voor Microsoft Dynamics en verwante producten bepaalt dat een specifieke update de oplossing van uw probleem. De normale ondersteuningskosten blijven gelden voor extra ondersteuningsvragen die niet in aanmerking voor de specifieke update in kwestie komen.


Informatie over de installatie

Microsoft biedt programming voorbeelden ter illustratie alleen, zonder expliciete of impliciete garantie van. Dit omvat, maar is niet beperkt tot impliciete garanties van verkoopbaarheid of geschiktheid voor een bepaald doel. In dit artikel wordt ervan uitgegaan dat u bekend met de programmeertaal die wordt aangetoond en met de hulpprogramma's die worden gebruikt bent voor het maken en foutopsporing van procedures. Ondersteuningstechnici van Microsoft kunnen helpen verklaren van de functionaliteit van een bepaalde procedure, maar niet deze voorbeelden om extra functionaliteit of het bouwen van procedures om te voldoen aan uw specifieke behoeften passen.

Opmerking Voordat u deze hotfix installeert, moet u controleren dat alle gebruikers van Microsoft Navision-clients zijn afgemeld van het systeem. Dit omvat Microsoft Navision Application Services (NAS) clientgebruikers van de. U moet de alleen clientgebruiker die is aangemeld wanneer u deze hotfix gaat implementeren.

U moet een ontwikkelaarslicentie hebben voor het implementeren van deze hotfix.

Raadzaam dat de gebruikersaccount in het venster Windows-aanmelding of Databaseaanmeldingen de rol-id 'SUPER'. Als de gebruikersaccount niet worden toegewezen als de rol-ID 'SUPER', moet u controleren of de gebruikersaccount de volgende machtigingen heeft:
  • De machtiging wijzigen voor het object dat u wijzigt.
  • De machtiging uitvoeren voor de System Object ID 5210 object en voor de System Object ID 9015 object.


Opmerking U hebt geen rechten om de opgeslagen gegevens hebben, tenzij u gegevens herstellen.

Wijzigingen in de code

Opmerking Altijd corrigeert test code in een testomgeving voordat u de correcties in de productieomgeving.
Wijzig de code in de codeunit SMTP Mail (400) voor dit probleem. Nadat u de wijzigingen hebt toegepast, worden e-mailberichten gemaakt en verzonden door de client in plaats van de server. De e-mailberichten behoudt daarom de identiteit van de gebruiker uitvoeren.
Hiertoe de volgende stappen uit:
  1. Implementeren en registreren van de Microsoft.Navision.Mail.dll assemblage in de client. Voer hiertoe de volgende opdracht:
    RegAsm /tlb:Microsoft.Navision.Mail.tlb / Microsoft.Navision.Mail.dll codebase
  2. De code in de codeunit SMTP Mail (400) als volgt wijzigen:
    Bestaande code
    ...
    PROCEDURE CreateMessage@.....
    BEGIN
    IF Recipients <> '' THEN
    CheckValidEmailAddresses(Recipients);
    CheckValidEmailAddresses(SenderAddress);
    SMTPMailSetup.GET;
    SMTPMailSetup.TESTFIELD("SMTP Server");
    IF ISCLEAR(Mail) THEN
    CREATE(Mail);
    Mail.FromName := SenderName;
    ...
    Nieuwe code
    ...
    PROCEDURE CreateMessage@.....
    BEGIN
    IF Recipients <> '' THEN
    CheckValidEmailAddresses(Recipients);
    CheckValidEmailAddresses(SenderAddress);
    SMTPMailSetup.GET;
    SMTPMailSetup.TESTFIELD("SMTP Server");
    IF ISCLEAR(Mail) THEN
    CREATE(Mail,TRUE,TRUE);
    Mail.FromName := SenderName;
    ...

Voorwaarden

U moet een van de volgende producten geïnstalleerd om deze hotfix:
  • Microsoft Dynamics NAV 2009 R2
  • Microsoft Dynamics NAV 2009 servicepack 1
U moet de volgende hotfixes toegepast:
  • 2499881 U kunt de instellingen TLS voor SMTP-communicatie in Microsoft Dynamics NAV 2009 configureren
  • 2345735 U kunt de standaardpoort voor SMTP-communicatie in Microsoft Dynamics NAV niet wijzigen
  • 2479702 De berichttekst van het e-mailadres is onjuist wanneer u een e-mailbericht maken met behulp van de methode AppendBody in Service Pack 1 voor Microsoft Dynamics NAV 2009
  • 2280492 Bijlagen worden niet vrijgegeven tot de Microsoft Dynamics NAV-client wordt gesloten wanneer u e-mailberichten met bijlagen te verzenden met de SMTP-Mail codeunit (400)
  • 2516144 Foutbericht Ongeldige e-mail berichten als u een specifieke versie 7-versie van het bestand Microsoft.Navision.Mail.dll in Microsoft Dynamics NAV 2009

Informatie over verwijderen

U kunt deze hotfix niet verwijderen.

Status

Microsoft heeft bevestigd dat dit een probleem in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op' is.
Opmerking Dit is een 'Snel publiceren' artikel rechtstreeks vanuit gemaakt binnen de organisatie van de ondersteuning van Microsoft. De informatie in dit document wordt geleverd als-is in reactie op de opkomende problemen. Als gevolg van de snelheid in het beschikbaar te maken, de materialen kunnen typfouten bevatten en kunnen op elk gewenst moment zonder kennisgeving worden gewijzigd. Zie Gebruiksvoorwaarden voor andere overwegingen.

Eigenschappen

Artikel ID: 2618652 - Laatste beoordeling: donderdag 29 september 2011 - Wijziging: 1.0
De informatie in dit artikel is van toepassing op:
  • Microsoft Dynamics NAV 2009
Trefwoorden: 
kbqfe kbmbsmigrate kbsurveynew kbmbscodefix kbmt KB2618652 KbMtnl
Automatisch vertaald artikel
BELANGRIJK: Dit artikel is vertaald door de vertaalmachine software van Microsoft in plaats van door een professionele vertaler. Microsoft biedt u professioneel vertaalde artikelen en artikelen vertaald door de vertaalmachine, zodat u toegang heeft tot al onze knowledge base artikelen in uw eigen taal. Artikelen vertaald door de vertaalmachine zijn niet altijd perfect vertaald. Deze artikelen kunnen fouten bevatten in de vocabulaire, zinsopbouw en grammatica en kunnen lijken op hoe een anderstalige de taal spreekt en schrijft. Microsoft is niet verantwoordelijk voor onnauwkeurigheden, fouten en schade ontstaan door een incorrecte vertaling van de content of het gebruik ervan door onze klanten. Microsoft past continue de kwaliteit van de vertaalmachine software aan door deze te updaten.
De Engelstalige versie van dit artikel is de volgende:2618652

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com