Fehlermeldung "der Netzwerkpfad wurde nicht gefunden" beim Starten einer Anwendungs im Zusammenhang mit LDAP in Windows Server 2008 R2

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 2619880 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Betrachten Sie das folgende Szenario:
  • Installieren Sie den Remotedesktop-Sitzungshost-Rollendienst auf einem Computer, auf der Windows Server 2008 R2 ausgeführt wird.
  • Aktivieren Sie Remote-IP-Virtualisierung auf dem Computer.
  • Sie versuchen, eine Anwendung im Zusammenhang mit Lightweight Directory Access Protocol LDAP oder im Zusammenhang mit dem LDAP-Dienst auf dem Computer zu starten.
In diesem Szenario Sie können die Anwendung oder der Dienst nicht starten, und Sie erhalten die folgende Fehlermeldung angezeigt:

Der Netzwerkpfad wurde nicht gefunden.

Hier sind einige im Zusammenhang mit LDAP-Beispielanwendungen, die von diesem Problem betroffen sind:

Active Directory-Benutzer und Computer MMC-Snap-in
Active Directory-Domänen und Vertrauensstellungen MMC-Snap-in
Active Directory-Standorte und Dienste-MMC-Snap-in
MMC-ADSI-Bearbeitungs-Snap-in
Group Policy Management MMC-Snap-in
DHCP-MMC-Snap-in
"Ldp.exe"
Microsoft System Center Configuration Manager 2007-Verwaltungskonsole
Autorisierungs-Manager (AzMan)

Ursache

Das Problem tritt aufgrund eines ein Kompatibilitätsproblem zwischen LDAP- und Remote-IP-Virtualisierung.

Der LDAP-Modul hartcodierte Verhalten ist einen internen Socket zu verwenden, der an die IP-Adresse 127.0.0.1 gebunden ist. Allerdings bindet die Remotedesktop-IP-Virtualisierung das Socket an eine virtuelle IP-Adresse für die Sitzung oder das Programm erneut. Dieses Verhalten führt zu einem Scheitern der Verbindung in der LDAP-Komponente.

Lösung

Hotfix-Informationen

Nachdem Sie den folgenden Hotfix installieren und konfigurieren einen Registrierungsunterschlüssel, wird das LDAP-Modul binden und eine interne Buchse an eine beliebige Loopbackadresse, die in der Registrierung durch einen Benutzer bereitgestellt wird. Die Adresse eine Loopback-Adresse sein muss (die Adresse beginnt mit 127) bereitgestellt und sollte sich nicht auf 127.0.0.1. Ein unterstützter Hotfix ist von Microsoft erhältlich. Allerdings soll diesen Hotfix nur das Problem zu beheben, das in diesem Artikel beschrieben wird. Wenden Sie diesen Hotfix nur auf Systemen, bei die das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix wird möglicherweise zu einem Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, ist gibt es ein Abschnitt "Hotfixdownload available" (Hotfixdownload verfügbar"am oberen Rand dieser Knowledge Base-Artikel. Wenn dieser Abschnitt nicht angezeigt wird, wenden Sie sich an Microsoft Customer Service and Support, um den Hotfix zu erhalten.

Hinweis Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der Microsoft-Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf der folgenden Microsoft-Website:
http://support.Microsoft.com/contactus/?WS=Support
Hinweis Das Formular "Hotfixdownload available" (Hotfixdownload verfügbar"zeigt die Sprachen an, für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Um diesen Hotfix anwenden zu können, muss Windows Server 2008 R2 oder Windows Server 2008 R2 Service Pack 1 (SP1) ausgeführt werden. Weitere Informationen dazu, wie Sie einen Windows Server 2008 R2 Servicepack erhalten finden Sie in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
976932Informationen zum Servicepack 1 für Windows 7 und Windows Server 2008 R2

Registrierungsinformationen

Nachdem dieser Hotfix angewendet werden, müssen Sie einen Registrierungsschlüssel erstellen.

Um den Registrierungsschlüssel für Sie erstellen lassen möchten, gehen Sie zu den "Für mich zu beheben"Section. Wenn Sie den Registrierungsschlüssel selbst erstellen möchten, fahren Sie mit der "Lassen Sie mich manuell beheben"Section.

Für mich zu beheben



Um dieses Problem automatisch beheben möchten, klicken Sie auf der Fix it Schaltfläche bzw. Verknüpfung. Klicken Sie dann auf Führen Sie Klicken Sie im Dialogfeld Dateidownload Dialogfeld ein, und folgen Sie den Schritten in den Fix it Assistent.


Dieses Problem zu beheben.
Microsoft Fix it 50808


Notizen
  • Bitte downloaden und installieren Sie den Hotfix in über Artikel der Knowledge Base (KB), bevor Sie das Update ausführen es Lösung.
  • Sie müssen alle Anwendungen neu starten, die LDAP-Modul verwenden, nachdem Sie diesen Hotfix angewendet haben.
  • Dieser Assistent kann nur auf Englisch verfügbar sein. Die automatische Korrektur funktioniert jedoch auch für andere Sprachversionen von Windows.
  • Wenn Sie nicht auf dem Computer, auf dem das Problem, speichern Sie die Fehlerbehebung ist es Lösung auf ein Flashlaufwerk oder eine CD, und führen Sie es auf dem Computer, auf dem das Problem ist.

Fahren Sie dann, mit der "Wurde das Problem behoben?"Section.



Lassen Sie mich manuell beheben

Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start
    Bild minimierenBild vergrößern
    Schaltfläche "Start"
    , Typ Regedit Klicken Sie im Dialogfeld Programme / Dateien durchsuchen das Feld, und drücken Sie dann die EINGABETASTE.
    Bild minimierenBild vergrößern
    UAC
    Wenn Sie ein Administratorkennwort aufgefordert werden, geben Sie das Kennwort ein. Wenn Sie zur Bestätigung aufgefordert werden, geben Sie zur Bestätigung.
  2. Suchen Sie, und klicken Sie dann auf den folgenden Registrierungsunterschlüssel:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\ldap\
  3. Auf der Bearbeiten Menü, zeigen Sie auf Neue, und klicken Sie dann auf String-Wert.
  4. Typ IPv4LoopbackAlternative, und drücken Sie dann die EINGABETASTE.
  5. Mit der rechten Maustaste IPv4LoopbackAlternative, und klicken Sie dann auf Ändern.
  6. In der Wertdaten Geben Sie im Feld 127.0.0.2, und klicken Sie dann auf OK.
  7. Beenden Sie den Registrierungs-Editor.

Hinweis Es wird empfohlen, dass Sie 127.0.0.2 in das Feld Wert, aber nichts im Bereich von 127.0.0.2 bis 127.255.255.254 (inklusive) akzeptabel ist.

Neustart erforderlich ist.

Sie müssen alle Anwendungen neu starten, die LDAP-Modul verwenden, nachdem Sie diesen Hotfix angewendet haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine zuvor veröffentlichten Hotfix.

Dateiinformationen

Die internationale Version dieses Hotfixes installiert Dateien mit die Attributen, die in den folgenden Tabellen aufgeführt sind. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) aufgelistet. Die Datumsangaben und Uhrzeiten für diese Dateien auf Ihrem lokalen Computer werden in Ihrer lokalen Zeit zusammen mit der Berücksichtigung der aktuellen Daylight Saving Time (DST) angezeigt. Darüber hinaus können die Datums- und Uhrzeitangaben ändern, wenn Sie bestimmte Operationen auf die Dateien anwenden.
Hinweise zu den Dateiinformationen für Windows Server 2008 R2
Wichtig Windows 7-Updates und Windows Server 2008 R2-Updates sind in der gleichen Paketen enthalten. Allerdings sind Hotfixes, die auf der Seite Hotfix Anforderung unter beiden Betriebssystemen aufgeführt. Um das Hotfix-Paket anzufordern, das auf einem oder beiden Betriebssysteme angewendet wird, wählen Sie den Hotfix, der auf der Seite unter "Windows 7/Windows Server 2008 R2" aufgelistet ist. Bezieht sich immer auf den Abschnitt "Gilt für" im Artikel, um das aktuelle Betriebssystem zu bestimmen, dem für jeden Hotfix gilt.
  • Die Dateien, die gelten für bestimmte Produkte, Meilensteine (RTM, SPn) und Servicebereiche (LDR, GDR) können identifiziert werden, durch Untersuchen der Datei Versionsnummern wie in der folgenden Tabelle dargestellt:
    Tabelle minimierenTabelle vergrößern
    VersionProduktMeilensteinServicebereich
    6.1.760 0,21xxxWindowsServer 2008 R2RTMLDR
    6.1.760 1.21xxxWindowsServer 2008 R2SP1LDR
  • GDR-Servicebereiche enthalten nur die Updates, die weit verbreitete, kritische Probleme freigegeben werden. LDR-Servicebereiche enthalten zusätzlich zu den auf breiter Basis veröffentlichten Korrekturen Hotfixes.
  • Sind die MANIFESTEN-Dateien (. Manifest), die installiert werden für jede Umgebung separat aufgeführt im Abschnitt "Weitere Dateiinformationen für WindowsServer 2008 R2". MANIFEST-Dateien und die dazugehörigen Sicherheitsupdates (.cat) Katalogdateien, sind äußerst wichtig, den Status der aktualisierten Komponenten zu verwalten. Die Sicherheitskatalogdateien, deren Attribute nicht aufgeführt sind, sind mit einer digitalen Microsoft-Signatur signiert.
Für alle unterstützten x 64-basierten Versionen von Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameDateiversionGröße der DateiDatumZeitPlattform
Wldap32.dll6.1.7600.21057312,83218-Oct-201101: 45X 64
Wldap32.dll6.1.7601.21822312,83218-Oct-201103: 05X 64
Wldap32.dll6.1.7600.21057269,31218-Oct-201101: 07X 86
Wldap32.dll6.1.7601.21822270,33618-Oct-201102: 41

Wurde das Problem behoben?

  • Überprüfen Sie, ob das Problem behoben ist. Wenn das Problem behoben ist, sind Sie mit diesem Abschnitt fertig. Wenn das Problem nicht behoben ist, können Sie Kontakt zum support.
  • Wir schätzen Ihr Feedback. Um Feedback bereitzustellen oder Probleme mit dieser Lösung zu informieren, lassen Sie einen Kommentar über das "Für mich zu beheben"Blog oder senden Sie uns eine e-Mail.

Status

Microsoft hat bestätigt, dass dieses Problem auf die im Abschnitt "Gilt für" aufgeführten Microsoft-Produkte zutrifft.

Weitere Informationen

Weitere Informationen zum Konfigurieren von Einstellungen für die Remotedesktop-IP-Virtualisierung finden Sie auf die folgende Microsoft-Website:
Gewusst wie: Konfigurieren von Remotedesktop-IP-Virtualisierung
Weitere Informationen zur Terminologie für Softwareupdates finden Sie in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
824684Beschreibung der Standardterminologie, die zum Beschreiben von Microsoft-Softwareupdates verwendet wird

Weitere Dateiinformationen

Weitere Dateiinformationen für Windows Server 2008 R2

Weitere Dateien für alle unterstützten x 64-basierten Versionen von Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameAmd64_5305f7a1f95355c3ec741daec9cd5a2b_31bf3856ad364e35_6.1.7601.21822_none_8cb2d34be02cf135.Manifest
DateiversionNicht zutreffend
Größe der Datei703
Datum ab (UTC)18-Oct-2011
Zeit (UTC)06: 02
PlattformNicht zutreffend
DateinameAmd64_b60b5cbf24fec97a49d44e4683828ccd_31bf3856ad364e35_6.1.7601.21822_none_39b0d1b5e246b7e7.Manifest
DateiversionNicht zutreffend
Größe der Datei1.046
Datum ab (UTC)18-Oct-2011
Zeit (UTC)06: 02
PlattformNicht zutreffend
DateinameAmd64_c3d06b01daf73185259bfc94cdb45eef_31bf3856ad364e35_6.1.7600.21057_none_cd3d7ea01052b4cc.Manifest
DateiversionNicht zutreffend
Größe der Datei703
Datum ab (UTC)18-Oct-2011
Zeit (UTC)06: 02
PlattformNicht zutreffend
DateinameAmd64_c767e639018f581b698cd2c5693fbc0f_31bf3856ad364e35_6.1.7600.21057_none_2ad3a4985c7e1c4e.Manifest
DateiversionNicht zutreffend
Größe der Datei1.046
Datum ab (UTC)18-Oct-2011
Zeit (UTC)06: 02
PlattformNicht zutreffend
DateinameAmd64_microsoft-Windows-Ldap-client_31bf3856ad364e35_6.1.7600.21057_none_4fdd280189205e2c.manifest
DateiversionNicht zutreffend
Größe der Datei13,962
Datum ab (UTC)18-Oct-2011
Zeit (UTC)02: 16
PlattformNicht zutreffend
DateinameAmd64_microsoft-Windows-Ldap-client_31bf3856ad364e35_6.1.7601.21822_none_51df1d1d8632c177.manifest
DateiversionNicht zutreffend
Größe der Datei13,962
Datum ab (UTC)18-Oct-2011
Zeit (UTC)04: 22
PlattformNicht zutreffend
DateinameUpdate.mum
DateiversionNicht zutreffend
Größe der Datei3,215
Datum ab (UTC)18-Oct-2011
Zeit (UTC)06: 02
PlattformNicht zutreffend
DateinameX86_microsoft-Windows-Ldap-client_31bf3856ad364e35_6.1.7600.21057_none_f3be8c7dd0c2ecf6.manifest
DateiversionNicht zutreffend
Größe der Datei13,956
Datum ab (UTC)18-Oct-2011
Zeit (UTC)01: 42
PlattformNicht zutreffend
DateinameX86_microsoft-Windows-Ldap-client_31bf3856ad364e35_6.1.7601.21822_none_f5c08199cdd55041.manifest
DateiversionNicht zutreffend
Größe der Datei13,956
Datum ab (UTC)18-Oct-2011
Zeit (UTC)03: 12
PlattformNicht zutreffend

Eigenschaften

Artikel-ID: 2619880 - Geändert am: Mittwoch, 21. Dezember 2011 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbexpertiseadvanced kbsurveynew kbfixme kbmsifixme kbmt KB2619880 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 2619880
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com