Rdpshell.exe prosessen forårsaker minnelekkasje i Windows Server 2008 R2 når du flytter et publisert RemoteApp-programmets vindu på klientsiden

Artikkeloversettelser Artikkeloversettelser
Artikkel-ID: 2636613 - Vis produkter som denne artikkelen gjelder for.
Vis alt | Skjul alt

På denne siden

Symptom

Tenk deg følgende:
  • Du publiserer en RemoteApp-programmer på en ekstern skrivebord-server som kjører Windows Server 2008 R2.
  • En bruker starter publisert RemoteApp-program på en klientdatamaskin.
  • Brukeren flytter publiserte RemoteApp-programmets vindu til et annet på skjermen sted på klientdatamaskinen.
I dette tilfellet holder minnebruk av Rdpshell.exe i samme økt på den eksterne serveren for skrivebordet øker. Til slutt, er tilgjengelig minne helt utladet på den eksterne serveren for skrivebordet. Når dette skjer, slutter alle kjørende programmer og tjenester på den eksterne skrivebord serveren å virke. Brukeren har for å løse dette problemet, lukker du alle hans eller hennes RemoteApp-programmer på serveren og vent i minst ett minutt å avslutte økten.

Merk Hvis du overvåker minnebruk av Rdpshell.exe prosessen, vil du finne verdien for ytelsestelleren sin Privat arbeidssett stadig økende.

Årsak

Dette problemet oppstår fordi noen tildelte minnet ikke frigjøres riktig i Rdpshell.exe prosessen.

Løsning

Informasjon om hurtigreparasjon

En støttet hurtigreparasjon er tilgjengelig fra Microsoft. Denne hurtigreparasjonen er imidlertid ment å løse problemet som er beskrevet i denne artikkelen. Bruk denne hurtigreparasjonen bare på systemer som har problemet som er beskrevet i denne artikkelen. Denne hurtigreparasjonen kan gjennomgå ytterligere testing. Hvis du ikke er alvorlig påvirket av dette problemet, anbefaler vi derfor at du venter på neste programvareoppdatering som inneholder denne hurtigreparasjonen.

Hvis hurtigreparasjonen er tilgjengelig for nedlasting, finnes delen "Nedlasting av hurtigreparasjoner tilgjengelig" øverst i denne Knowledge Base-artikkel. Hvis denne delen ikke vises, kan du kontakte Microsofts kundeservice og kundestøtte for å få hurtigreparasjonen.

Merk Hvis det oppstår flere problemer, eller hvis du trenger feilsøkingstips, kan du kanskje opprette en separat forespørsel om. Vanlige kundestøttekostnader gjelder for ytterligere kundestøttespørsmål og problemer som ikke dekkes av denne oppdateringen. For en fullstendig liste over telefonnumre for Microsofts kundeservice og kundestøtte eller opprette en separat forespørsel om, kan du gå til følgende Microsoft-Website:
http://support.Microsoft.com/contactus/?ws=support
Merk "Nedlasting av hurtigreparasjoner tilgjengelig"-skjemaet viser språk hurtigreparasjonen er tilgjengelig. Hvis du ikke ser språket ditt, er det fordi hurtigreparasjonen ikke er tilgjengelig for dette språket.

Forutsetninger

Hvis du vil bruke denne hurtigreparasjonen, må du kjøre ett av følgende operativsystemer:
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
Hvis du vil ha mer informasjon om hvordan du skaffer en service pack for Windows 7 eller Windows Server 2008 R2, klikker du følgende artikkelnummer for å vise artikkelen i Microsoft Knowledge Base:
976932Informasjon om Service Pack 1 for Windows 7 og Windows Server 2008 R2

Informasjonen i registeret

Hvis du vil bruke denne hurtigreparasjonen i denne pakken, har du ikke foreta endringer i registret.

Krav om omstart

Du må starte datamaskinen på nytt etter at du har installert denne hurtigreparasjonen.

Informasjon om erstatning av hurtigreparasjoner

Denne hurtigreparasjonen erstatter ikke tidligere utgitte hurtigreparasjoner.

Filinformasjon

Den globale versjonen av denne hurtigreparasjonen installerer filer med attributtene som er oppført i tabellene nedenfor. Datoene og klokkeslettene for disse filene er oppført i Coordinated Universal Time (UTC). Datoene og klokkeslettene for disse filene på den lokale datamaskinen, vises i lokal tid sammen med din gjeldende tidsforskjell for sommertid (DST). I tillegg kan til datoene og klokkeslettene endres når du utfører bestemte operasjoner på filene.
Filinformasjonsmerknader for Windows Server 2008 R2
Viktig Hurtigreparasjoner for Windows 7 og hurtigreparasjoner for Windows Server 2008 R2 er inkludert i de samme pakkene. Hurtigreparasjoner er likevel listet opp individuelt for begge operativsystemene på siden for forespørsler om hurtigreparasjoner. Hvis du vil be om hurtigreparasjonspakken som gjelder ett eller begge operativsystemene, velg hurtigreparasjonen som er oppført under "Windows 7/Windows Server 2008 R2" på siden. Referer alltid til delen "Gjelder" i artiklene for å fastslå det faktiske operativsystemet som gjelder hver hurtigreparasjon.
  • Filene som gjelder for et bestemt produkt, SR_Level (RTM, SPn), og gren (LDR, GDR), kan identifiseres ved å kontrollere filversjonsnumrene, som vist i følgende tabell.
    Skjul denne tabellenVis denne tabellen
    VersjonProduktSR_LevelAvdeling
    6.1.760 0 . 16xxxWindows Server 2008 R2RTMGDR
    6.1.760 0 . 21xxxWindows Server 2008 R2RTMLDR
    6.1.760 1 . 17xxxWindows Server 2008 R2SP1GDR
    6.1.760 1 . 21xxxWindows Server 2008 R2SP1LDR
  • MANIFEST-filene (.manifest) og MUM-filene (.mum) som installeres for hvert miljø, er oppført separat i delen "mer filinformasjon for Windows Server 2008 R2". MUM- og MANIFEST-filer, og tilknyttede sikkerhetskatalogfiler (.cat)-filer, er det svært viktig å vedlikeholde statusen for de oppdaterte komponentene. Sikkerhetskatalogfilene, som attributtene ikke er oppført for, er signert med Microsofts digitale signatur.
For alle støttede x 64-baserte versjoner av Windows Server 2008 R2
Skjul denne tabellenVis denne tabellen
FilnavnFilversjonFilstørrelseDatoTidPlattform
Rdpinit.exe6.1.7601.21864178,68822-Nov 201106: 23x 64
Rdpinit.MOFIkke tilgjengelig1,19705-Nov-201002: 01Ikke tilgjengelig
Rdpshell.exe6.1.7601.21864300,03222-Nov 201106: 23x 64
Rdpshell.MOFIkke tilgjengelig1 20005-Nov-201002: 01Ikke tilgjengelig
Tserrredir.dll6.1.7601.1751413 31220-Nov-201013: 27x 64
Rdpinit.exe6.1.7601.21864178,68822-Nov 201106: 23x 64
Rdpinit.MOFIkke tilgjengelig1,19710-Jun-200920: 44Ikke tilgjengelig
Rdpshell.exe6.1.7601.21864300,03222-Nov 201106: 23x 64
Rdpshell.MOFIkke tilgjengelig1 20010-Jun-200920: 44Ikke tilgjengelig
TerminalServices-remoteapplications-clientsku-ppdlic.xrm-msIkke tilgjengelig3,06722-Nov 201106: 42Ikke tilgjengelig
Tserrredir.dll6.1.7600.1638513 31214-Jul-200901: 41x 64
Rdpinit.exe6.1.7601.21864162,30422-Nov 201105: 23x 86
Rdpinit.MOFIkke tilgjengelig1,19705-Nov-201002: 01Ikke tilgjengelig
Rdpshell.exe6.1.7601.21864261,63222-Nov 201105: 23x 86
Rdpshell.MOFIkke tilgjengelig1 20005-Nov-201002: 01Ikke tilgjengelig

Workaround

Du kan omgå dette problemet ved å logge av Remote Desktop Services-økten som bruker den berørte prosessen for Rdpshell.exe og deretter opprette en ny økt.

Merk Hvis du vil unngå rask tilkobling på nytt, kan du opprette en ny økt 20 sekunder etter at du logger deg av den berørte eksterne skrivebordstjenester-økt.

Status

Microsoft har bekreftet at dette er et problem i Microsoft-produktene som er oppført i delen "Gjelder for".

Mer informasjon

Hvis du vil ha mer informasjon om terminologi for programvareoppdatering, klikker du følgende artikkelnummer for å vise artikkelen i Microsoft Knowledge Base:
824684Beskrivelse av standardterminologien som brukes til å beskrive oppdateringer av Microsoft-programvare

Mer filinformasjon

Mer filinformasjon for Windows Server 2008 R2

Tilleggsfiler for alle støttede x 64-baserte versjoner av Windows Server 2008 R2
Skjul denne tabellenVis denne tabellen
FilnavnAmd64_7dcb346eab4e3614579d1272522b57d7_31bf3856ad364e35_6.1.7601.21864_none_1f6cd03f68634548.manifest
FilversjonIkke tilgjengelig
Filstørrelse737
Dato (UTC)22-Nov 2011
Tid (UTC)14: 57
PlattformIkke tilgjengelig
FilnavnAmd64_d0971b1fd44738244381203d873d941b_31bf3856ad364e35_6.1.7601.21864_none_e0e4cde48005f6ac.manifest
FilversjonIkke tilgjengelig
Filstørrelse727
Dato (UTC)22-Nov 2011
Tid (UTC)14: 57
PlattformIkke tilgjengelig
FilnavnAmd64_ef15c4712d9eefb827a368c46cac8fad_31bf3856ad364e35_6.1.7601.21864_none_29956bf1e7c2bb36.manifest
FilversjonIkke tilgjengelig
Filstørrelse727
Dato (UTC)22-Nov 2011
Tid (UTC)14: 57
PlattformIkke tilgjengelig
FilnavnAmd64_microsoft-windows-t...-remoteapplications_31bf3856ad364e35_6.1.7601.21864_none_a089d074cc474192.manifest
FilversjonIkke tilgjengelig
Filstørrelse9,324
Dato (UTC)22-Nov 2011
Tid (UTC)15: 40
PlattformIkke tilgjengelig
FilnavnAmd64_microsoft-windows-t...lications-clientsku_31bf3856ad364e35_6.1.7601.21864_none_7d54b6c3760942f7.manifest
FilversjonIkke tilgjengelig
Filstørrelse10,718
Dato (UTC)22-Nov 2011
Tid (UTC)15: 40
PlattformIkke tilgjengelig
FilnavnUpdate.mum
FilversjonIkke tilgjengelig
Filstørrelse2,503
Dato (UTC)22-Nov 2011
Tid (UTC)14: 57
PlattformIkke tilgjengelig
FilnavnWow64_microsoft-windows-t...-remoteapplications_31bf3856ad364e35_6.1.7601.21864_none_aade7ac700a8038d.manifest
FilversjonIkke tilgjengelig
Filstørrelse6,618
Dato (UTC)22-Nov 2011
Tid (UTC)05: 59
PlattformIkke tilgjengelig

Egenskaper

Artikkel-ID: 2636613 - Forrige gjennomgang: 4. januar 2013 - Gjennomgang: 1.0
Informasjonen i denne artikkelen gjelder:
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
Nøkkelord: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter kbmt KB2636613 KbMtno
Maskinoversatt
Viktig: Denne artikkelen har blitt maskinoversatt, og dermed ikke oversatt av en person. For at alle artikler i vår database skal være oversatt til ditt språk, vil Microsoft benytte både personoversatte og maskinoversatte artikler. Det er viktig å merke seg at en maskinoversatt artikkel ikke alltid er perfekt. Det kan forekomme stave, strukturelle eller grammatiske feil. Microsoft er ikke ansvarlig for unøyaktigheter, feil eller skade ved bruk av innhold i artikkel som måtte forårsakes av feiloversettelse. Microsoft vil jevnlig oppdatere sitt maskinoversettelses programvare.
Den engelske versjonen av denne artikkelen er den følgende: 2636613

Gi tilbakemelding

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com