Processo de Rdpshell.exe causa vazamento de memória no Windows Server 2008 R2 quando você move a janela do aplicativo RemoteApp publicado no lado do cliente

Traduções de Artigos Traduções de Artigos
Artigo: 2636613 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Considere o seguinte cenário:
  • Publicar um aplicativo do RemoteApp em um servidor remoto da área de trabalho que está executando o Windows Server 2008 R2.
  • Um usuário inicia o aplicativo do RemoteApp publicado em um computador cliente.
  • O usuário move janela do aplicativo RemoteApp publicado para outro na tela local no computador cliente.
Nesse cenário, o uso de memória do processo de Rdpshell.exe na mesma sessão no servidor remoto da área de trabalho continue crescendo. Eventualmente, a memória disponível seja completamente esgotada no servidor remoto da área de trabalho. Quando isso ocorre, todos os aplicativos e serviços no servidor remoto da área de trabalho em execução parar de funcionar. Para resolver esse problema, o usuário deve fechar todos os aplicativos RemoteApp no servidor e, em seguida, aguarde pelo menos um minuto para que a sessão se encerre.

Observação Se você monitorar o uso de memória do processo de Rdpshell.exe, você achar que o valor do contador de desempenho do seu Conjunto de trabalho particular continue crescendo.

Causa

Esse problema ocorre porque alguns memória alocada não é liberada corretamente no processo de Rdpshell.exe.

Resolução

Informações sobre hotfix

Um hotfix compatível está disponível na Microsoft. No entanto, esse hotfix destina-se apenas a corrigir o problema descrito neste artigo. Aplica esse hotfix somente aos sistemas que apresentarem o problema descrito neste artigo. Esse hotfix pode receber testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Dados de Conhecimento. Se esta seção não for exibido, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa dos números de telefone de suporte e atendimento ao cliente da Microsoft ou para criar uma solicitação de serviço, visite o seguinte Website da Microsoft:
http://support.microsoft.com/contactus/?WS=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, você deve estar executando um dos seguintes sistemas operacionais:
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
Para obter mais informações sobre como obter um service pack do Windows 7 ou Windows Server 2008 R2, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
976932Informações sobre o Service Pack 1 para Windows 7 e Windows Server 2008 R2

Informações do registro

Para usar o hotfix neste pacote, você não precisará fazer qualquer alteração no registro.

Requisito de reinicialização

Você deve reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix

Esse hotfix não substitui um hotfix lançado anteriormente.

Informações sobre o arquivo

A versão global deste hotfix instala arquivos que tenham os atributos listados nas tabelas a seguir. As datas e horários desses arquivos estão listados em formato Tempo Universal Coordenado (UTC). As datas e horários desses arquivos no computador local são exibidos em sua hora local com a diferença do horário de verão (DST) atual. Além disso, as datas e horas podem ser alteradas quando você executa certas operações nos arquivos.
Observações sobre o arquivo Windows Server 2008 R2
Importante Hotfixes do Windows 7 e hotfixes do Windows Server 2008 R2 estão incluídos nos mesmos pacotes. No entanto, os hotfixes na página solicitação Hotfix estão listados em ambos os sistemas operacionais. Para solicitar o pacote de hotfix que se aplica a um ou ambos os sistemas operacionais, selecione o hotfix listado em "Windows 7/Windows Server 2008 R2" na página. Consulte sempre a seção "Aplica-se a" nos artigos para determinar o sistema operacional real ao qual se aplica cada hotfix.
  • Os arquivos que se aplicam a um produto específico, SR_Level (RTM, SPn), e ramificação do serviço (LDR, GDR) pode ser identificada ao examinar os números de versão do arquivo conforme mostrado na tabela a seguir.
    Reduzir esta tabelaExpandir esta tabela
    VersãoProdutoSR_LevelRamificação do serviço
    6.1.760 0 . 16xxxWindows Server 2008 R2RTMGDR
    6.1.760 0 . 21xxxWindows Server 2008 R2RTMLDR
    6.1.760 1 . 17xxxWindows Server 2008 R2SP1GDR
    6.1.760 1 . 21xxxWindows Server 2008 R2SP1LDR
  • Os arquivos MANIFEST (. manifest) e os arquivos MUM (. mum) instalados para cada ambiente são listados separadamente na seção "informações de arquivo adicionais para o Windows Server 2008 R2". MUM e arquivos de manifesto e os arquivos de catálogo (. cat) de segurança associadas, são extremamente importantes para manter o estado dos componentes atualizados. Os arquivos de catálogo de segurança, para o qual os atributos não estiverem listados, são assinados com uma assinatura digital da Microsoft.
Para todas as versões baseadas em x64 com suporte do Windows Server 2008 R2
Reduzir esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHoraPlataforma
Rdpinit.exe6.1.7601.21864178,68822-Nov-201106: 23x64
Rdpinit.MOFNão aplicável1,19705-Nov-201002: 01Não aplicável
Rdpshell.exe6.1.7601.21864300,03222-Nov-201106: 23x64
Rdpshell.MOFNão aplicável1.20005-Nov-201002: 01Não aplicável
Tserrredir.dll6.1.7601.1751413,31220-Nov-201013: 27x64
Rdpinit.exe6.1.7601.21864178,68822-Nov-201106: 23x64
Rdpinit.MOFNão aplicável1,19710-Jun-200920: 44Não aplicável
Rdpshell.exe6.1.7601.21864300,03222-Nov-201106: 23x64
Rdpshell.MOFNão aplicável1.20010-Jun-200920: 44Não aplicável
TerminalServices-remoteapplications-clientsku-ppdlic.xrm-msNão aplicável3,06722-Nov-201106: 42Não aplicável
Tserrredir.dll6.1.7600.1638513,31214-Jul-200901: 41x64
Rdpinit.exe6.1.7601.21864162,30422-Nov-201105: 23x86
Rdpinit.MOFNão aplicável1,19705-Nov-201002: 01Não aplicável
Rdpshell.exe6.1.7601.21864261,63222-Nov-201105: 23x86
Rdpshell.MOFNão aplicável1.20005-Nov-201002: 01Não aplicável

Como contornar

Para contornar esse problema, faça logoff da sessão de serviços de área de trabalho remota que está usando o processo Rdpshell.exe afetado e, em seguida, criar uma nova sessão.

Observação Para evitar a reconexão rápida, você pode criar uma nova sessão de 20 segundos depois de fazer logoff da sessão de serviços de área de trabalho remota afetada.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos Microsoft que estão listados na seção "Aplica-se a".

Mais Informação

Para obter mais informações sobre a terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft

Informações adicionais sobre arquivos

Informações adicionais sobre arquivos para Windows Server 2008 R2

Arquivos adicionais para todas as versões baseadas em x64 com suporte do Windows Server 2008 R2
Reduzir esta tabelaExpandir esta tabela
Nome do arquivoAmd64_7dcb346eab4e3614579d1272522b57d7_31bf3856ad364e35_6.1.7601.21864_none_1f6cd03f68634548.manifest
Versão do arquivoNão aplicável
Tamanho do arquivo737
Data (UTC)22-Nov-2011
Hora (UTC)14: 57
PlataformaNão aplicável
Nome do arquivoAmd64_d0971b1fd44738244381203d873d941b_31bf3856ad364e35_6.1.7601.21864_none_e0e4cde48005f6ac.manifest
Versão do arquivoNão aplicável
Tamanho do arquivo727
Data (UTC)22-Nov-2011
Hora (UTC)14: 57
PlataformaNão aplicável
Nome do arquivoAmd64_ef15c4712d9eefb827a368c46cac8fad_31bf3856ad364e35_6.1.7601.21864_none_29956bf1e7c2bb36.manifest
Versão do arquivoNão aplicável
Tamanho do arquivo727
Data (UTC)22-Nov-2011
Hora (UTC)14: 57
PlataformaNão aplicável
Nome do arquivoAmd64_microsoft-windows-t...-remoteapplications_31bf3856ad364e35_6.1.7601.21864_none_a089d074cc474192.manifest
Versão do arquivoNão aplicável
Tamanho do arquivo9,324
Data (UTC)22-Nov-2011
Hora (UTC)15: 40
PlataformaNão aplicável
Nome do arquivoAmd64_microsoft-windows-t...lications-clientsku_31bf3856ad364e35_6.1.7601.21864_none_7d54b6c3760942f7.manifest
Versão do arquivoNão aplicável
Tamanho do arquivo10,718
Data (UTC)22-Nov-2011
Hora (UTC)15: 40
PlataformaNão aplicável
Nome do arquivoUpdate.mum
Versão do arquivoNão aplicável
Tamanho do arquivo2,503
Data (UTC)22-Nov-2011
Hora (UTC)14: 57
PlataformaNão aplicável
Nome do arquivoWow64_microsoft-windows-t...-remoteapplications_31bf3856ad364e35_6.1.7601.21864_none_aade7ac700a8038d.manifest
Versão do arquivoNão aplicável
Tamanho do arquivo6,618
Data (UTC)22-Nov-2011
Hora (UTC)05: 59
PlataformaNão aplicável

Propriedades

Artigo: 2636613 - Última revisão: 4 de janeiro de 2013 - Revisão: 2.0
A informação contida neste artigo aplica-se a:
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
Palavras-chave: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter kbmt KB2636613 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 2636613

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com