Article ID: 2642495 - Last Review: March 30, 2012 - Revision: 4.0

Error “The Windows Installer Service Could Not Be Accessed” when installing or updating programs on Windows 7 or Windows Vista

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SYMPTOMS

When attempting to install applications you may receive the following error:
"The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed. Contact your support personnel for assistance."
For this issue on Windows XP or Windows Server 2003 see the following article:

315346 (http://support.microsoft.com/kb/315346) Error message when you try to add or remove a program on a computer that is running Windows XP or Windows Server 2003: "The Windows Installer service could not be accessed"

CAUSE

This problem may occur if one or more of the following conditions is true:
  • You install or remove a program that uses the Microsoft Installer Service to install a program on your computer.
  • The Windows Installer Service is not running.
  • The Windows Installer registry settings may be corrupted or set incorrectly.

RESOLUTION

To resolve this issue, follow the steps in the methods below starting with Method 1, if the steps in that method do not resolve the issue, go to the next method.

Method 1: Reset the Windows Installer Service Registry settings

Click here to view or hide detailed information

Method 2: Start the Windows Installer Service

Click here to view or hide detailed information

Method 3: Check the status of the Windows Installer Service

Click here to view or hide detailed information

Method 4: uninstall any previous versions of applications that you may be trying to update

Click here to view or hide detailed information

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support (http://support.microsoft.com/contactus) .
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me (http://blogs.technet.com/fixit4me/) " blog or send us an email (mailto:fixit4me@microsoft.com?Subject=KB) .

APPLIES TO
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
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